Subject: Robust Header Compression BOF agenda

From: Mikael Degermark <[email-masked]>
Date: Tue, 09 Nov 1999 14:47:40 +0100

This is a revised agenda for the robust header compression 
BOF to be held today Tuesday. As this is the night of the
social event, we will ignore the break and instead aim to
finish 17.45 at the latest. 

-------------
Robust Header compression BOF (robhc)

Tuesday, November 9 at 1545-1800
==========

CHAIRS: 
Mikael Degermark <[email-masked]>
Stephen Pink <[email-masked]>

DESCRIPTION:
The cellular community is now standardizing the next generation cellular
systems. These systems will use IP to deliver telephony to coming mobile
phones, to allow end-to-end IP telephony. As cellular bandwith is expensive,
radio spectrum efficiency is of outmost importance and thus the IP/UDP/RTP
headers must be compressed over the air. 3GPP has specified the requirements
for the needed header compression scheme and it has been shown that no current
header compression scheme in the IETF can satisfy these requirements. CRTP
[RFC-2508] is the closest candidate but is not sufficiently robust against
errors on the link, i.e., CRTP cannot deliver acceptable performance at the
anticipated error rates. It is likely that the number of users of cellular
IP telephony will be larger than the current number of people using TCP/IP,
therefore it is important that a suitable header compression scheme is 
developed.

The BOF will outline the relevant properties of the cellular links, the
requirements, and will explain why CRTP fails. One or more proposals for
a suitable header compression scheme will be presented, and finally we 
will discuss if and how the IETF will work on standardizing a suitable
header compression scheme.

AGENDA

    0. Introduction
        Mikael Degermark

    1. 3GPP timeline
        Mats Nilsson

    2. 3GPP requirements on robust header compression.
        Khiem Le, Nokia
        draft-degermark-hc-requirements-00.txt

    3. Why CRTP is not good enough
        Mikael Degermark
        draft-degermark-crtp-eval-00.{ps,txt}

    4. Cellular link properties affecting header compression - 
                delays, error rates & error distributions for
                EDGE, WCDMA, GSM, etc. 
        Krister Svanbro, Ericsson
          
    5. RObust Checksum-based header COmpression - ROCCO
        Lars-Erik Jonsson, Ericsson
        draft-jonsson-robust-hc-02.{ps,txt}

    6. Should we propose that a WG is formed? Outline of charter presented.
        Mikael Degermark

---------
This message came from the IETF IPTEL Working Group Mailing List.

---

From: [email-masked]
Date: Tue, 9 Nov 1999 16:18:36 +0200

Mikael,

I think you forgot an item on the agenda. As we discussed and agreed, we are
going to present a robust RTP header compression scheme. This is separate
from the 3GPP requirements item. Also, due to my schedule constraints, as
discussed last week, would it be possible to reshuffle the items on the
agenda as follows (items 1 and 2 back-to-back will save some time, i.e.
together they should take less than 30 min):

AGENDA

    0. Introduction
        Mikael Degermark

    1. 3GPP requirements on robust header compression.
        Chris Clanton, Nokia
        draft-degermark-hc-requirements-00.txt

    2. A robust and efficient RTP header compression scheme
	Khiem Le, Nokia

	4. 3GPP timeline
        Mats Nilsson

    5. Cellular link properties affecting header compression - 
                delays, error rates & error distributions for
                EDGE, WCDMA, GSM, etc. 
        Krister Svanbro, Ericsson
          
    6. RObust Checksum-based header COmpression - ROCCO
        Lars-Erik Jonsson, Ericsson
        draft-jonsson-robust-hc-02.{ps,txt}

    7. Should we propose that a WG is formed? Outline of charter presented.
        Mikael Degermark

Thanks

Khiem

-----Original Message-----
From: EXT Mikael Degermark [mailto:[email-masked]]
Sent: Tuesday, November 09, 1999 7:48 AM
To: [email-masked]; [email-masked]; [email-masked];
[email-masked]
Cc: [email-masked]
Subject: Robust Header Compression BOF agenda

-------------

CHAIRS: 

DESCRIPTION:
for the needed header compression scheme and it has been shown that no
current

AGENDA

    0. Introduction
        Mikael Degermark

    1. 3GPP timeline
        Mats Nilsson

          

---------