Subject: RTP measuring

From: "Bogdan Ghita" <[email-masked]>
Date: Wed, 24 Nov 1999 17:30:09 -0000

Hello all,

I have three questions related to RTP/RTCP.
1. Are there any  tools for monitoring RTP/RTCP (free or commercial)? I am interested especially in RTP analysis, and not RTCP parsing. And, if there are, which are their capabilities?
In order to restrict the range of replies, I must mention that I've already found:
- Hammer VoIP Test System - analysing all the parameters (drop packets, jitter, delay) within a VoIP call
- HP Internet Advisor - similar
(for these two commercial packages, I couldn't get more information about what actually is monitored)
- rtpmon, which is free, but, in spite of its name, it is an RTCP monitor.

2. Can anybody explain me what is the structure of a compound RTCP packet? I know, from the RTP specification, that it looks like this:

if encrypted: random 32-bit integer
|
|[------- packet -------][----------- packet -----------][-packet-]
|
| receiver reports chunk chunk
V item item item item
--------------------------------------------------------------------
|R[SR|# sender #site#site][SDES|# CNAME PHONE |#CNAME LOC][BYE##why]
|R[  |# report #  1 #  2 ][    |#             |#         ][   ##   ]
|R[  |#        #    #    ][    |#             |#         ][   ##   ]
|R[  |#        #    #    ][    |#             |#         ][   ##   ]
--------------------------------------------------------------------
|<------------------ UDP packet (compound packet) --------------->|
#: SSRC/CSRC

The question is, as I couldn't understand the figure: how is the above figure packetised in UDP packets (is it 'line-by-line') ? 

3. Are there any standards for encrypting RTP/RTCP (in relation with H.323) ? Besides inserting the 32-bit integer in the RTCP packet and using DES there is nothing else specified.

Thank you very much
Best regards
Bogdan Ghita

---

From: Colin Perkins <[email-masked]>
Date: Wed, 24 Nov 1999 16:20:47 +0000

>I have three questions related to RTP/RTCP.

RTP related questions should be asked on the AVT working group's list
[email-masked].

>1. Are there any  tools for monitoring RTP/RTCP (free or commercial)? I 
>am interested especially in RTP analysis, and not RTCP parsing. And, if 
>there are, which are their capabilities?
>2. Can anybody explain me what is the structure of a compound RTCP 
>packet? I know, from the RTP specification, that it looks like this:
>
>The question is, as I couldn't understand the figure: how is the above 
>figure packetised in UDP packets (is it 'line-by-line') ?

The random prefix (if any) is put at the start of the UDP packet, then 
the RTCP packets comprising the compound are concatenated into a single 
UDP packet.

>3. Are there any standards for encrypting RTP/RTCP (in relation with 
>H.323) ? Besides inserting the 32-bit integer in the RTCP packet and 
>using DES there is nothing else specified.

The a/v profile (RFC1890) allows for any encryption algorithm to be used,
with the algorithm identifier being prefixed onto the encryption key
followed by a "/" character. One can also use IPsec.

Colin

---------
This message came from the IETF IPTEL Working Group Mailing List.