Subject: Re: [Iptel] [Sipping] draft-mahy-iptel-cpc

From: "Lee, Yiu" <[email-masked]>
Date: Tue, 1 Apr 2008 20:39:37 -0400

After reading all the mails in the list, I think we agree:

1. OLI-CPC should be carried in one parameter. Exact syntax yet to be
defined.
2. This parameter should be inserted by originating network but not the
UAC (From vs. PAI).
3. This parameter is useful for both SIP-URI and TEL-URI.

We haven't agreed if we allow the parameter carries multiple values (due
to SIP->ISUP interop)

Now my question is what is next step?

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Ian Elz
Sent: Tuesday, April 01, 2008 8:21 AM
To: DOLLY, MARTIN C, ATTLABS; [email-masked]; [email-masked]
Subject: Re: [Sipping] draft-mahy-iptel-cpc

Martin,

Sorry my choice of words. 'back to ISUP' was not meant to imply a
backward direction message but where the interworking from SIP -> ISUP.

ISUP -> SIP working is easy as ISUP will only contain one value but if
SIP contains multiple values as Paul has suggested then we need to be
able to map these to a single value in ISUP.

Ian Elz

System Manager
DUCI LDC UK
(Lucid Duck)

Office: + 44 24 764 35256
gsm: +44 7801723668
[email-masked]

-----Original Message-----
From: DOLLY, MARTIN C, ATTLABS [mailto:[email-masked]]
Sent: 01 April 2008 13:16
To: Ian Elz; [email-masked]; [email-masked]
Subject: RE: [Sipping] draft-mahy-iptel-cpc

Ian,

CPC: Information sent in the forward direction indicating the category
of the calling party and, in case of semiautomatic calls, the service
language to be spoken by the incoming, delay and assistance operators.
The format of the calling party's category is shown below.

OLI:  Information sent in the forward direction indicating toll class of
service. Identification of the originating line.

Martin

-----Original Message-----
From: Ian Elz [mailto:[email-masked]]
Sent: Tuesday, April 01, 2008 4:58 AM
To: Paul Kyzivat
Cc: [email-masked]; DOLLY, MARTIN C, ATTLABS; [email-masked]
Subject: RE: [Sipping] draft-mahy-iptel-cpc

Paul,

My comments are made based upon the content of the latest draft (06).

The introduction begins:

   "SS7 ISUP [4] defines a Calling Party's Category (CPC) parameter that
   characterizes the station used to originate a call and carries other
   important state that can describe the originating party.  When
   telephone numbers are contained in URIs, such as the tel URI [2], it
   may be desirable to communicate any CPC associated with that
   telephone number or, in the context of a call, the party calling from
   it."

Based upon this the current requirement appears to be to support the
ISUP CPC/OLI.

If the requirement is greater than this then that is a discussion that
we should have before the draft is finalized.

The issue with mutual exclusivity exists in the current ISUP
implementations. If that limitation is to be overcome then that
requirement also needs to be discussed. If we are to move from mutual
exclusivity of values then we need to ensure that interworking back to
ISUP is supported. The resolution of the overlapping cases as you have
indicated may have to be at the discretion of the network operator.

Ian Elz

_______________________________________________
Sipping mailing list  https://www.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP Use
[email-masked] for questions on current sip Use
[email-masked] for new developments of core SIP
_______________________________________________
Iptel mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/iptel

---

From: "DOLLY, MARTIN C, ATTLABS" <[email-masked]>
Date: Tue, 1 Apr 2008 19:53:40 -0500

How could you come to that conclusion for a North American deployment?

CPC and OLI have separate meanings.

Agreed, they are never seen by an end point (walled garden only), as
they both will be asserted, therefore needed to be associated with the
PAI. 

-----Original Message-----

Martin,

Ian Elz

System Manager
DUCI LDC UK
(Lucid Duck)

-----Original Message-----
From: DOLLY, MARTIN C, ATTLABS [mailto:[email-masked]]
Sent: 01 April 2008 13:16
To: Ian Elz; [email-masked]; [email-masked]
Subject: RE: [Sipping] draft-mahy-iptel-cpc

Ian,

Martin

-----Original Message-----
From: Ian Elz [mailto:[email-masked]]
Sent: Tuesday, April 01, 2008 4:58 AM
To: Paul Kyzivat
Cc: [email-masked]; DOLLY, MARTIN C, ATTLABS; [email-masked]
Subject: RE: [Sipping] draft-mahy-iptel-cpc

Paul,

The introduction begins:

Ian Elz

---

From: "Lee, Yiu" <[email-masked]>
Date: Tue, 1 Apr 2008 21:01:16 -0400

Hi Martin,

Forgive me that I am not an expert for SS7. So, you support to separate
OLI and CPC into two parameters. I have no objection for it, I just want
to see how we move forward.

Thanks,
Yiu

-----Original Message-----
From: DOLLY, MARTIN C, ATTLABS [mailto:[email-masked]] 
Sent: Tuesday, April 01, 2008 8:54 PM
To: Lee, Yiu; Ian Elz; [email-masked]; [email-masked]; Jean-Francois
Mule; Daryl Malas

-----Original Message-----

Martin,

Ian Elz

System Manager
DUCI LDC UK
(Lucid Duck)

-----Original Message-----
From: DOLLY, MARTIN C, ATTLABS [mailto:[email-masked]]
Sent: 01 April 2008 13:16
To: Ian Elz; [email-masked]; [email-masked]
Subject: RE: [Sipping] draft-mahy-iptel-cpc

Ian,

Martin

-----Original Message-----
From: Ian Elz [mailto:[email-masked]]
Sent: Tuesday, April 01, 2008 4:58 AM
To: Paul Kyzivat
Cc: [email-masked]; DOLLY, MARTIN C, ATTLABS; [email-masked]
Subject: RE: [Sipping] draft-mahy-iptel-cpc

Paul,

The introduction begins:

Ian Elz

---

From: "DOLLY, MARTIN C, ATTLABS" <[email-masked]>
Date: Tue, 1 Apr 2008 20:07:49 -0500

I think 2 separate PAI parameters.  

-----Original Message-----
From: Lee, Yiu [mailto:[email-masked]] 
Sent: Tuesday, April 01, 2008 9:01 PM
To: DOLLY, MARTIN C, ATTLABS; Ian Elz; [email-masked]; [email-masked];
Jean-Francois Mule; Daryl Malas
Subject: RE: [Sipping] draft-mahy-iptel-cpc

Hi Martin,

Thanks,
Yiu

-----Original Message-----
From: DOLLY, MARTIN C, ATTLABS [mailto:[email-masked]] 
Sent: Tuesday, April 01, 2008 8:54 PM
To: Lee, Yiu; Ian Elz; [email-masked]; [email-masked]; Jean-Francois
Mule; Daryl Malas

-----Original Message-----

Martin,

Ian Elz

System Manager
DUCI LDC UK
(Lucid Duck)

-----Original Message-----
From: DOLLY, MARTIN C, ATTLABS [mailto:[email-masked]]
Sent: 01 April 2008 13:16
To: Ian Elz; [email-masked]; [email-masked]
Subject: RE: [Sipping] draft-mahy-iptel-cpc

Ian,

Martin

-----Original Message-----
From: Ian Elz [mailto:[email-masked]]
Sent: Tuesday, April 01, 2008 4:58 AM
To: Paul Kyzivat
Cc: [email-masked]; DOLLY, MARTIN C, ATTLABS; [email-masked]
Subject: RE: [Sipping] draft-mahy-iptel-cpc

Paul,

The introduction begins:

Ian Elz

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 01 Apr 2008 21:54:12 -0400

If the semantics are to be defined by SS7 then it makes sense to have 
the same two parameters that it has. But is that the right thing?

If you dig thru the stuff in there, some of the values indeed fall into 
mutually exclusive sets. Others seem to be orthogonal. (E.g. police vs 
celular, or test vs lots of things.) Why not decompose these things into 
orthogonal dimensions and have a parameter for each? If not all 
combinations are conveyable in SS7 it won't be a problem going from SS7 
to SIP, and when going the other way it can simply be a policy about 
which attributes trump which other attributes.

	Paul

DOLLY, MARTIN C, ATTLABS wrote:
> This list is for NEW development of the application of SIP
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments of core SIP
>