Subject: Re: DHCPv6 vs ND strikes again (was: New version available)

From: james woodyatt <[email-masked]>
Date: Tue, 19 Oct 2010 11:21:36 -0700

On Sep 22, 2010, at 02:24, Mikael Abrahamsson wrote:
> On Wed, 22 Sep 2010, Rémi Després wrote:
>> 
>> Of course, if MS and Apple announce an upgrade of all their IPv6 stacks, to the effect that they use DHCPv6 requests to obtain what they no longer get in RAs, that would mitigate the need for backward compatibility. But is this realistic?
> 
> As far as I know Apple doesn't support DHCPv6 at all.

I know I'm responding to an old message here, but in case anyone finds this by searching the archive, I'd like to point out that Apple supports DHCPv6 in current AirPort, Time Capsule, Apple TV, iPhone, iPod Touch and iPad products.  (As a policy matter, I can't say whether or when a release of Mac OS X will appear that supports DHCPv6, because engineering doesn't comment publicly about future products. Though, one expects that a pattern is readily apparent to anyone who wants to find one.)

--
james woodyatt <[email-masked]>
member of technical staff, communications engineering

---

From: Thomas Narten <[email-masked]>
Date: Wed, 20 Oct 2010 08:25:09 -0400

Thanks for this info. Clarification question:

> I know I'm responding to an old message here, but in case anyone
> finds this by searching the archive, I'd like to point out that
> Apple supports DHCPv6 in current AirPort, Time Capsule, Apple TV,
> iPhone, iPod Touch and iPad products.  (As a policy matter, I can't
> say whether or when a release of Mac OS X will appear that supports
> DHCPv6, because engineering doesn't comment publicly about future
> products. Though, one expects that a pattern is readily apparent to
> anyone who wants to find one.)

Does this include DHCPv6 support for address assignment? I.e, are we
talking full DHCPv6, or just for "other" information?

Thomas

---

From: james woodyatt <[email-masked]>
Date: Wed, 20 Oct 2010 09:08:00 -0700

On Oct 20, 2010, at 05:25, Thomas Narten wrote:

> [I wrote:]
>> [...] I'd like to point out that Apple supports DHCPv6 in current AirPort, Time Capsule, Apple TV, iPhone, iPod Touch and iPad products. [...]
> 
> Does this include DHCPv6 support for address assignment? I.e, are we talking full DHCPv6, or just for "other" information?

The IA_NA option is supported in DHCPv6 clients.  It's always used when the M=1 bit is set in RA messages received by AirPort and Time Capsule.  Pretty sure it's the same for the other products with DHCPv6 clients.

The AirPort and Time Capsule have a DHCPv6 server, but it's stateless and the RA messages sent on the LAN bridge have M=0 and O=1.

---

From: "Lee, Yiu" <[email-masked]>
Date: Thu, 21 Oct 2010 01:57:39 +0000

James,

Thanks for the information. I also assume it will support IA_PD. If the
AirPort and Time Capsule receive a PD shorter than /64, what is the
behavior?

Yiu

On 10/20/10 12:08 PM, "james woodyatt" <[email-masked]> wrote:

>>> [...] I'd like to point out that Apple supports DHCPv6 in current
>>>AirPort, Time Capsule, Apple TV, iPhone, iPod Touch and iPad products.
>>>[...]
>> 
>The IA_NA option is supported in DHCPv6 clients.  It's always used when
>the M=1 bit is set in RA messages received by AirPort and Time Capsule.
>Pretty sure it's the same for the other products with DHCPv6 clients.
>
>The AirPort and Time Capsule have a DHCPv6 server, but it's stateless and
>the RA messages sent on the LAN bridge have M=0 and O=1.
>
>
>--
>--------------------------------------------------------------------
>IETF IPv6 working group mailing list
>[email-masked]
>Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
>--------------------------------------------------------------------