Subject: ipv4 and ipv6 a different protocol

From: Mahesh Govindappa <[email-masked]>
Date: Sat, 23 Oct 2010 15:00:51 -0700

Hi,

I was thinking that why can't we have a 2 different protocol types.

1.       Where src address is ipv4 and dst as ipv6 address.

2.       Where src is ipv6 and dst as ipv4 address.

We name a different protocol number for each of them and have a different
treatment when it comes to application level and in routers.

Let me know if that is a good idea.

Thanks

Mahesh G

---

From: Turchanyi Geza <[email-masked]>
Date: Sun, 24 Oct 2010 11:18:47 +0200

Hi Mahesh,

Let's imagine that we introduce these two new protocols. Would it be easier
to implement them as IP4/IP6 dual stack? The complet socket interface should
be rewriten at least....

We have already enough pains - probably it is less work to implement IPv6
"as it is" than to intruduce two "mixed solutions",

Géza

On Sun, Oct 24, 2010 at 12:00 AM, Mahesh Govindappa <[email-masked]
> wrote:

>  Hi,
>
>
>
> I was thinking that why can’t we have a 2 different protocol types.
>
>
>
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
>
>

---

From: "Mahesh Govindappa" <[email-masked]>
Date: Sun, 24 Oct 2010 11:15:37 -0700

Hi Turchanyi,

Thanks, it was just an idea which I got on weekend ;-) when I was reading
IPv6 RFC 2460.

Everyone has time to write all type of tunneling protocols b/w ipv4 and
ipv6.

The idea which I gave makes ipv4 to live for few more decades without much
hassle.

The header format and packet handling can be decided the ipv6 way for ipv4
way.

Anyways it goes with the people’s choice whether it can be designed or not.

Thanks & Best regards

Mahesh G

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Turchanyi Geza
Sent: Sunday, October 24, 2010 2:19 AM
To: [email-masked]
Cc: IPv6 WG Mailing List
Subject: Re: ipv4 and ipv6 a different protocol

Hi Mahesh,

Géza

On Sun, Oct 24, 2010 at 12:00 AM, Mahesh Govindappa
<[email-masked]> wrote:

Hi,

Thanks

Mahesh G