Subject: OMNI Interface - the OMNI Address

From: "Templin (US), Fred L" <[email-masked]>
Date: Tue, 18 Feb 2020 16:58:01 +0000

As an IPv6-over-(foo) document, the OMNI interface spec naturally discusses the formation of
IPv6 link-local addresses. Care must be taken to form link-local addresses that are assured to be
unique among all nodes on the OMNI link, but without requiring Duplicate Address Detection
(since link-scoped multicast on the OMNI link may be intractable, and since the extra traffic
required for DAD on some OMNI links may be undesirable). For this reason, the OMNI spec
defines a simple link-local address format and construction algorithm. Namely, a Mobile Node
(MN) that has been assigned a Mobile Network Prefix (e.g., 2001:db8:1:2::/64) constructs its
OMNI address by writing the most significant 64 bits o the MNP into the least significant 64
bits of the IPv6 link-local prefix, i.e., as fe80::2001:db8:1:2. The uniqueness properties of the
link local address are therefore the same as the uniqueness properties of the MNPs assigned
to the MNs. Please bring any discussion points regarding the OMNI address under this thread.

Fred

> -----Original Message-----
> From: ipv6 [mailto:[email-masked]] On Behalf Of Templin (US), Fred L
> Sent: Tuesday, February 18, 2020 8:07 AM
> To: [email-masked]; [email-masked]
> Subject: FW: I-D Action: draft-templin-6man-omni-interface-00.txt
> 
> 6man and atn list members,
> 
> We have received direction to rename the OMNI interface draft to more closely match the
> document title and to indicate the target working group. This submission therefore replaces
> the former draft name thread, and should be used as the basis for further discussion.
> 
> The OMNI interface spec introduces many important constructs that would be very difficult
> to track in a single discussion thread. I will initiate multiple sub-threads to invite discussion
> on specific aspects of the document in subsequent messages.
> 
> Thanks - Fred
> 
> -----Original Message-----
> From: I-D-Announce [mailto:[email-masked]] On Behalf Of [email-masked]
> Sent: Tuesday, February 18, 2020 7:35 AM
> To: [email-masked]
> Subject: I-D Action: draft-templin-6man-omni-interface-00.txt
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
>         Title           : Transmission of IPv6 Packets over Overlay Multilink Network (OMNI) Interfaces
>         Authors         : Fred L. Templin
>                           Tony Whyman
> 	Filename        : draft-templin-6man-omni-interface-00.txt
> 	Pages           : 36
> 	Date            : 2020-02-18
> 
> Abstract:
>    Mobile nodes (e.g., aircraft of various configurations, terrestrial
>    vehicles, seagoing vessels, mobile enterprise devices, etc.)
>    communicate with networked correspondents over multiple access
>    network data links and configure mobile routers to connect end user
>    networks.  A multilink interface specification is therefore needed
>    for coordination with the network-based mobility service.  This
>    document specifies the transmission of IPv6 packets over Overlay
>    Multilink Network (OMNI) Interfaces.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-templin-6man-omni-interface/
> 
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-templin-6man-omni-interface-00
> https://datatracker.ietf.org/doc/html/draft-templin-6man-omni-interface-00
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

---

From: Simon Hobson <[email-masked]>
Date: Wed, 19 Feb 2020 21:49:30 +0000

Templin (US), Fred L <[email-masked]> wrote:

> Care must be taken to form link-local addresses that are assured to be
> to the MNs.

Is it guaranteed that the MNP is unique to each device - e.g., is it 100% guaranteed that there will never be two nodes sharing a network ?

I can see that on a typical mobile phone network, each device will have it's own /64 - but is it guaranteed that all nodes will always be located on networks with similar characteristics ? Could mobile nodes find themselves (even if only during development or testing) on (for example) an ethernet network sharing a /64 ?

Simon

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Thu, 20 Feb 2020 18:18:44 +0000

Hi Simon, the expectation is the same as for IPv6 prefix delegation in that the prefix delegation
service (e.g., DHCPv6) uniquely delegates a prefix to a requesting client, and does not delegate
the same prefix to multiple clients. RFC 7084 is an example where this expectation is assumed.

Can there be a case of the same prefix being delegated to multiple clients? I don't know, but
we would not intend to support that case.

Thanks - Fred

> From: ipv6 [mailto:[email-masked]] On Behalf Of Simon Hobson
> Sent: Wednesday, February 19, 2020 1:50 PM
> To: [email-masked]
> Subject: Re: OMNI Interface - the OMNI Address
> 
> I can see that on a typical mobile phone network, each device will have it's own /64 - but is it guaranteed that all nodes will always be
> located on networks with similar characteristics ? Could mobile nodes find themselves (even if only during development or testing) on
> (for example) an ethernet network sharing a /64 ?
> 
> Simon
>