Subject: FW: New Version Notification for draft-bonica-6man-vpn-dest-opt-09.txt

From: Ron Bonica <[email-masked]>
Date: Wed, 19 Feb 2020 23:15:58 +0000

Folks,

Please review.
 
                      Ron

Juniper Business Use Only

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: Wednesday, February 19, 2020 6:12 PM
To: Ron Bonica <[email-masked]>; Ning So <[email-masked]>; Gang Chen <[email-masked]>; Ning So <[email-masked]>; Luay Jalil <[email-masked]>; Yuji Kamite <[email-masked]>
Subject: New Version Notification for draft-bonica-6man-vpn-dest-opt-09.txt

A new version of I-D, draft-bonica-6man-vpn-dest-opt-09.txt
has been successfully submitted by Ron Bonica and posted to the IETF repository.

Name:		draft-bonica-6man-vpn-dest-opt
Revision:	09
Title:		The IPv6 Tunnel Payload Forwarding (TPF) Option
Document date:	2020-02-19
Group:		Individual Submission
Pages:		9
URL:            https://www.ietf.org/id/draft-bonica-6man-vpn-dest-opt-09.txt 
Status:         https://datatracker.ietf.org/doc/draft-bonica-6man-vpn-dest-opt/
Htmlized:      https://tools.ietf.org/html/draft-bonica-6man-vpn-dest-opt-09 

Abstract:
   This document explains how IPv6 options can be used in IPv6 tunnels.
   It also defines the IPv6 Tunnel Payload Forwarding (TPF) option.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Melchior Aelmans <[email-masked]>
Date: Sun, 23 Feb 2020 21:28:43 +0100

Hi Ron,

Thanks for this draft which seems to solve customers challenges hence my
support for this work.

Some minor comments:

Section:

The original packet can be any layer-2 or layer-3 protocol (e.g.,
   Ethernet, IPv4, IPv6).  The Tunnel IPv6 Header is an IPv6 header
   followed by zero or more extension headers.  The resulting packet is
   a Tunnel IPv6 Packet.

Could be:
The original packet can be any  layer-2 or layer-3 packet (e.g., Ethernet,
IPv4, IPv6).
The Tunnel Header is an IPv6 header followed by zero or more extension
headers.
The resulting packet is a Tunnel IPv6 Packet.

"The entry-point sends the Tunnel IPv6 Packet to the exit-point and the
exit-point executes the following procedure" --> "The entry-point sends the
Tunnel IPv6 Packet to the exit-point which then executes the following
procedure"

Cheers,
Melchior

On Thu, Feb 20, 2020 at 12:16 AM Ron Bonica <rbonica=
[email-masked]> wrote:

> To: Ron Bonica <[email-masked]>; Ning So <[email-masked]>; Gang
> Chen <[email-masked]>; Ning So <[email-masked]>; Luay Jalil <
> [email-masked]>; Yuji Kamite <[email-masked]>
> URL:
> https://www.ietf.org/id/draft-bonica-6man-vpn-dest-opt-09.txt
> Status:
> https://datatracker.ietf.org/doc/draft-bonica-6man-vpn-dest-opt/
> Htmlized:
> https://tools.ietf.org/html/draft-bonica-6man-vpn-dest-opt-09
>
>
> Abstract:
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
>
> The IETF Secretariat
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
>

---

From: Krzysztof Grzegorz Szarkowicz <[email-masked]>
Date: Mon, 24 Feb 2020 10:34:35 +0100

+1 support

> On 2020 -Feb-23, at 21:28, Melchior Aelmans <[email-masked]> wrote:
> 
> Hi Ron,
> 
> Thanks for this draft which seems to solve customers challenges hence my support for this work.
> 
> Some minor comments:
> 
> Section:
> The original packet can be any  layer-2 or layer-3 packet (e.g., Ethernet, IPv4, IPv6).
> The Tunnel Header is an IPv6 header followed by zero or more extension headers.
> "The entry-point sends the Tunnel IPv6 Packet to the exit-point and the exit-point executes the following procedure" --> "The entry-point sends the Tunnel IPv6 Packet to the exit-point which then executes the following procedure"
> 
> Cheers,
> Melchior
> 
> 
> On Thu, Feb 20, 2020 at 12:16 AM Ron Bonica <rbonica=[email-masked] <mailto:[email-masked]>> wrote:
> Folks,
> 
> Please review.
> 
>                       Ron
> 
> 
> 
> From: [email-masked] <mailto:[email-masked]> <[email-masked] <mailto:[email-masked]>> 
> To: Ron Bonica <[email-masked] <mailto:[email-masked]>>; Ning So <[email-masked] <mailto:[email-masked]>>; Gang Chen <[email-masked] <mailto:[email-masked]>>; Ning So <[email-masked] <mailto:[email-masked]>>; Luay Jalil <[email-masked] <mailto:[email-masked]>>; Yuji Kamite <[email-masked] <mailto:[email-masked]>>
> URL:            https://www.ietf.org/id/draft-bonica-6man-vpn-dest-opt-09.txt <https://www.ietf.org/id/draft-bonica-6man-vpn-dest-opt-09.txt> 
> Status:         https://datatracker.ietf.org/doc/draft-bonica-6man-vpn-dest-opt/ <https://datatracker.ietf.org/doc/draft-bonica-6man-vpn-dest-opt/>
> Htmlized:      https://tools.ietf.org/html/draft-bonica-6man-vpn-dest-opt-09 <https://tools.ietf.org/html/draft-bonica-6man-vpn-dest-opt-09> 
> 
> 
> Abstract:
> Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org <http://tools.ietf.org/>.
> 
> The IETF Secretariat
> [email-masked] <mailto:[email-masked]>
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6 <https://www.ietf.org/mailman/listinfo/ipv6>

---

From: Julian Lucek <[email-masked]>
Date: Mon, 24 Feb 2020 09:38:04 +0000

+1, I support the draft

Julian

From: ipv6 <[email-masked]> on behalf of Krzysztof Grzegorz Szarkowicz <[email-masked]>
Date: Monday, 24 February 2020 at 09:34
To: 6man WG <[email-masked]>
Cc: Ron Bonica <rbonica=[email-masked]>
Subject: Re: New Version Notification for draft-bonica-6man-vpn-dest-opt-09.txt

+1 support

On 2020 -Feb-23, at 21:28, Melchior Aelmans <[email-masked]<mailto:[email-masked]>> wrote:

Hi Ron,

Some minor comments:

Section:

   a Tunnel IPv6 Packet.
Could be:

Cheers,
Melchior

On Thu, Feb 20, 2020 at 12:16 AM Ron Bonica <rbonica=[email-masked]<mailto:[email-masked]>> wrote:
Folks,

Please review.

                      Ron

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Sent: Wednesday, February 19, 2020 6:12 PM
To: Ron Bonica <[email-masked]<mailto:[email-masked]>>; Ning So <[email-masked]<mailto:[email-masked]>>; Gang Chen <[email-masked]<mailto:[email-masked]>>; Ning So <[email-masked]<mailto:[email-masked]>>; Luay Jalil <[email-masked]<mailto:[email-masked]>>; Yuji Kamite <[email-masked]<mailto:[email-masked]>>
Subject: New Version Notification for draft-bonica-6man-vpn-dest-opt-09.txt

Name:           draft-bonica-6man-vpn-dest-opt
Revision:       09
Title:          The IPv6 Tunnel Payload Forwarding (TPF) Option
Document date:  2020-02-19
Group:          Individual Submission
Pages:          9
URL:            https://www.ietf.org/id/draft-bonica-6man-vpn-dest-opt-09.txt<https://urldefense.com/v3/__https:/www.ietf.org/id/draft-bonica-6man-vpn-dest-opt-09.txt__;!!NEt6yMaO-gk!WwPdcfcMWVZfF1_s_sE4x3_0712KHoMrPGvtjaAaAD2FVnr86j29-uZJJoNBifQ9$>
Status:         https://datatracker.ietf.org/doc/draft-bonica-6man-vpn-dest-opt/<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-bonica-6man-vpn-dest-opt/__;!!NEt6yMaO-gk!WwPdcfcMWVZfF1_s_sE4x3_0712KHoMrPGvtjaAaAD2FVnr86j29-uZJJhLDFJtt$>
Htmlized:      https://tools.ietf.org/html/draft-bonica-6man-vpn-dest-opt-09<https://urldefense.com/v3/__https:/tools.ietf.org/html/draft-bonica-6man-vpn-dest-opt-09__;!!NEt6yMaO-gk!WwPdcfcMWVZfF1_s_sE4x3_0712KHoMrPGvtjaAaAD2FVnr86j29-uZJJmSfUqsu$>

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org<https://urldefense.com/v3/__http:/tools.ietf.org/__;!!NEt6yMaO-gk!WwPdcfcMWVZfF1_s_sE4x3_0712KHoMrPGvtjaAaAD2FVnr86j29-uZJJkvL7Pcw$>.

The IETF Secretariat
--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]<mailto:[email-masked]>
Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/ipv6__;!!NEt6yMaO-gk!WwPdcfcMWVZfF1_s_sE4x3_0712KHoMrPGvtjaAaAD2FVnr86j29-uZJJjSsTaNT$>
--------------------------------------------------------------------
--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]<mailto:[email-masked]>
Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Parag Kaneriya <[email-masked]>
Date: Mon, 24 Feb 2020 09:52:06 +0000

+1,  I support this draft.

Parag

Juniper Business Use Only
From: ipv6 <[email-masked]> On Behalf Of Julian Lucek
Sent: Monday, February 24, 2020 3:08 PM
To: 6man WG <[email-masked]>
Cc: Ron Bonica <rbonica=[email-masked]>
Subject: Re: New Version Notification for draft-bonica-6man-vpn-dest-opt-09.txt

+1, I support the draft

Julian

From: ipv6 <[email-masked]<mailto:[email-masked]>> on behalf of Krzysztof Grzegorz Szarkowicz <[email-masked]<mailto:[email-masked]>>
Date: Monday, 24 February 2020 at 09:34
To: 6man WG <[email-masked]<mailto:[email-masked]>>
Cc: Ron Bonica <rbonica=[email-masked]<mailto:rbonica=[email-masked]>>
Subject: Re: New Version Notification for draft-bonica-6man-vpn-dest-opt-09.txt

+1 support

Hi Ron,

Some minor comments:

Section:

   a Tunnel IPv6 Packet.
Could be:

Cheers,
Melchior

Please review.

                      Ron

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Sent: Wednesday, February 19, 2020 6:12 PM
To: Ron Bonica <[email-masked]<mailto:[email-masked]>>; Ning So <[email-masked]<mailto:[email-masked]>>; Gang Chen <[email-masked]<mailto:[email-masked]>>; Ning So <[email-masked]<mailto:[email-masked]>>; Luay Jalil <[email-masked]<mailto:[email-masked]>>; Yuji Kamite <[email-masked]<mailto:[email-masked]>>
Subject: New Version Notification for draft-bonica-6man-vpn-dest-opt-09.txt

Abstract:

The IETF Secretariat

---

From: Srihari Sangli <[email-masked]>
Date: Mon, 24 Feb 2020 10:00:18 +0000

+1

This relies on IPv6 architecture by leveraging the DO header in simplistic manner. I support this draft.

srihari…

On 24/02/20, 3:22 PM ipv6 on behalf of Parag Kaneriya from [email-masked]<mailto:[email-masked]> on behalf of pkaneria=[email-masked]<mailto:pkaneria=[email-masked]> said >

Parag

+1, I support the draft

Julian

+1 support

Hi Ron,

Some minor comments:

Section:

   a Tunnel IPv6 Packet.
Could be:

Cheers,
Melchior

Please review.

                      Ron

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Sent: Wednesday, February 19, 2020 6:12 PM
To: Ron Bonica <[email-masked]<mailto:[email-masked]>>; Ning So <[email-masked]<mailto:[email-masked]>>; Gang Chen <[email-masked]<mailto:[email-masked]>>; Ning So <[email-masked]<mailto:[email-masked]>>; Luay Jalil <[email-masked]<mailto:[email-masked]>>; Yuji Kamite <[email-masked]<mailto:[email-masked]>>
Subject: New Version Notification for draft-bonica-6man-vpn-dest-opt-09.txt

URL:            https://www.ietf.org/id/draft-bonica-6man-vpn-dest-opt-09.txt<https://urldefense.com/v3/__https:/urldefense..com/v3/__https:/www.ietf.org/id/draft-bonica-6man-vpn-dest-opt-09.txt__;!!NEt6yMaO-gk!WwPdcfcMWVZfF1_s_sE4x3_0712KHoMrPGvtjaAaAD2FVnr86j29-uZJJoNBifQ9$__;!!NEt6yMaO-gk!WnWygSz-e3Nrzv1m78sX4IVaVueRA0_ZoUZ2cA1XJLEqP8cPe5803bkKzFkx9A4$>

Abstract:

The IETF Secretariat
Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/ipv6__;!!NEt6yMaO-gk!WnWygSz-e3Nrzv1m78sX4IVaVueRA0_ZoUZ2cA1XJLEqP8cPe5803bkKUTt2MUE$>

---

From: Ron Bonica <[email-masked]>
Date: Thu, 27 Feb 2020 15:06:37 +0000

Melchior,

Thanks for the review. I have just posted a new version with both of your proposed changes.

                                              Ron

From: Melchior Aelmans <[email-masked]>
Sent: Sunday, February 23, 2020 3:29 PM
To: Ron Bonica <[email-masked]>
Cc: 6man WG <[email-masked]>
Subject: Re: FW: New Version Notification for draft-bonica-6man-vpn-dest-opt-09.txt

Hi Ron,

Some minor comments:

Section:

   a Tunnel IPv6 Packet.
Could be:

Cheers,
Melchior

Please review.

                      Ron

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Sent: Wednesday, February 19, 2020 6:12 PM
To: Ron Bonica <[email-masked]<mailto:[email-masked]>>; Ning So <[email-masked]<mailto:[email-masked]>>; Gang Chen <[email-masked]<mailto:[email-masked]>>; Ning So <[email-masked]<mailto:[email-masked]>>; Luay Jalil <[email-masked]<mailto:[email-masked]>>; Yuji Kamite <[email-masked]<mailto:[email-masked]>>
Subject: New Version Notification for draft-bonica-6man-vpn-dest-opt-09.txt

Name:           draft-bonica-6man-vpn-dest-opt
Revision:       09
Title:          The IPv6 Tunnel Payload Forwarding (TPF) Option
Document date:  2020-02-19
Group:          Individual Submission
Pages:          9
URL:            https://www.ietf.org/id/draft-bonica-6man-vpn-dest-opt-09.txt<https://urldefense.com/v3/__https:/www.ietf.org/id/draft-bonica-6man-vpn-dest-opt-09.txt__;!!NEt6yMaO-gk!QQ9REvlQmafezD9iBCV9ymFLMrEMEK8yKX4JiXtcGStlMdcDpGlahIgA8acefNBx$>
Status:         https://datatracker.ietf.org/doc/draft-bonica-6man-vpn-dest-opt/<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-bonica-6man-vpn-dest-opt/__;!!NEt6yMaO-gk!QQ9REvlQmafezD9iBCV9ymFLMrEMEK8yKX4JiXtcGStlMdcDpGlahIgA8UeeR9D9$>
Htmlized:      https://tools.ietf.org/html/draft-bonica-6man-vpn-dest-opt-09<https://urldefense.com/v3/__https:/tools.ietf.org/html/draft-bonica-6man-vpn-dest-opt-09__;!!NEt6yMaO-gk!QQ9REvlQmafezD9iBCV9ymFLMrEMEK8yKX4JiXtcGStlMdcDpGlahIgA8SYAadQ7$>

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org<https://urldefense.com/v3/__http:/tools.ietf.org__;!!NEt6yMaO-gk!QQ9REvlQmafezD9iBCV9ymFLMrEMEK8yKX4JiXtcGStlMdcDpGlahIgA8SmeRZZ8$>.

The IETF Secretariat
--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]<mailto:[email-masked]>
Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/ipv6__;!!NEt6yMaO-gk!QQ9REvlQmafezD9iBCV9ymFLMrEMEK8yKX4JiXtcGStlMdcDpGlahIgA8eyi68UX$>
--------------------------------------------------------------------