Subject: Where to continue work on the Unified Identifier?

From: Greg Mirsky <[email-masked]>
Date: Mon, 10 Feb 2020 14:15:46 -0800

Dear Chairs of SPRING and 6man WGs,
on behalf of the authors of the Unified Identifier in SRH draft, I'm asking
for your consideration and suggestion. We're looking for your decision on
which WG may, at the time, become the adopter of this work. One the one
hand, as the draft proposes an update to SRH by allocating the new field,
6man WG seems as logical as it was the group that has led the work on SRH
specification. On the other hand, a significant part of the draft is on
using the Unified Identifier to realize the Segment Routing with SRH in an
IPv6 network.
Please let us know if you have any further questions or concerns.
Thank you for your consideration.

Regards,
Greg

---

From: <[email-masked]>
Date: Mon, 10 Feb 2020 22:56:47 +0000

Dear Greg,

As you know, there are a number of proposals in the so called ‘Beyond SRv6’ topic.
Unifier Identifier is one, but there are others.

Given that we are not seeing some natural convergence on a solution, I think that the WG needs to refine the technical issue(s) that we want to address and the requirements for the new solution(s)/extension(s).
Cf slide 9 of latest chair’s slides https://datatracker.ietf.org/meeting/106/materials/slides-106-spring-sessa-chairs-slides-01 more specifically
> Several solutions on the table. Need to be explicit about the goals and the costs of each proposal.
> ■ Authors are invited to explicit both in their document (short text)

Then we can look at merits and costs of each solution, possibly refine them, possibly converge on a single one, probably drop multiples.

This first step is to be done in the SPRING WG. I’m assuming that this part be the hardest part.
Once SPRING has figured out what we want to do on this topic, I would expect the header format and processing be done in the 6MAN WG. (This may eventually depends on the outcome of this first step; in particular this is assuming that both spring & 6man  want & need something new)

In order to prepare this first step, do you think that for the next meeting, the document could be updated to spell out:

a)      The goals/requirements that this proposal wants to address. Aka, why do we need a fourth SR data plane.

b)      Which goals/requirements are addressed by this proposal, and what are the costs.

I would encourage to carefully think about “a” as it would be good to avoid discovering, in 3 years from now, that we missed something (again) and that a new team asks for a N+1 SR dataplane.
On a personal note, I’d be also interested in any feedback about the reasons why we missed those requirements/goals when SRv6 has been originally proposed, discussed and specified, in order to avoid repeating the same mistakes.

Thank you,
Regards,
--Bruno

From: Greg Mirsky [mailto:[email-masked]]
Sent: Monday, February 10, 2020 11:16 PM
To: 6man WG; [email-masked]
Cc: [email-masked]
Subject: Where to continue work on the Unified Identifier?

Dear Chairs of SPRING and 6man WGs,
on behalf of the authors of the Unified Identifier in SRH draft, I'm asking for your consideration and suggestion. We're looking for your decision on which WG may, at the time, become the adopter of this work. One the one hand, as the draft proposes an update to SRH by allocating the new field, 6man WG seems as logical as it was the group that has led the work on SRH specification. On the other hand, a significant part of the draft is on using the Unified Identifier to realize the Segment Routing with SRH in an IPv6 network.
Please let us know if you have any further questions or concerns.
Thank you for your consideration.

Regards,
Greg

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.