Subject: Learning from mistakes (was Re: [Errata Held for Document Update] RFC8200 (5933))

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Tue, 3 Mar 2020 23:21:19 +0000

Fernando, my friend, 

Look below for Eric> [Original email thread elided to keep it short]

Best regards,

-éric-hoping-to-keep-learning-from-my-mistakeS

-----Original Message-----
From: ipv6 <[email-masked]> on behalf of Fernando Gont <[email-masked]>
Date: Tuesday, 3 March 2020 at 23:56

    On 3/3/20 18:43, Brian E Carpenter wrote:
    [....]
    >> It seems to me that the bigger question is whether there would be
    >> consensus to update RFC8200 to allow whatever SPRING wants to do.
    > 
    > SPRING is not asking for an update to 8200; their claim is that it
    > already allows the PSP action. You might disagree, of course.
    
    FWIW, segment-routing-header also argued that en-route insertion was 
    allowed.

Eric> when authors change their mind based on the community feedback, then I ***respect*** them.
Eric> As we all know, the approved / to-be-published SRH does not mention header insertion anymore for a long time ... (your sentence was indeed in the past tense ;-) ).

    ....%<....%<....

---

From: Ron Bonica <[email-masked]>
Date: Wed, 4 Mar 2020 21:20:03 +0000

Eric,

What is the status of EH insertion in SRv6? Will it be reintroduced at some later date? Do the authors intend to let draft-voyer-6man-extension-header-insertion expire?

                                             Ron

Juniper Business Use Only

-----Original Message-----
From: ipv6 <[email-masked]> On Behalf Of Eric Vyncke (evyncke)
Sent: Tuesday, March 3, 2020 6:21 PM
To: [email-masked]
Subject: Learning from mistakes (was Re: [Errata Held for Document Update] RFC8200 (5933))

Fernando, my friend, 

Best regards,

-----Original Message-----
From: ipv6 <[email-masked]> on behalf of Fernando Gont <[email-masked]>
Date: Tuesday, 3 March 2020 at 23:56

    ....%<....%<....

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/ipv6__;!!NEt6yMaO-gk!SY4PNFctSNaebYAiuLh_wNsveXLN49HbgyQurhz-muVFaeAQTwuEJMMRyWoYtxHb$ 
--------------------------------------------------------------------

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Wed, 4 Mar 2020 23:16:50 +0000

Hello Ron,

I am not an author of any SRv6-related document. So, I have not a single clue. Sorry.

Regards

-éric

-----Original Message-----
From: Ron Bonica <rbonica=[email-masked]>
Date: Wednesday, 4 March 2020 at 22:20
To: Eric Vyncke <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: Learning from mistakes (was Re: [Errata Held for Document Update] RFC8200 (5933))

    Eric,

                                                 Ron

    
    -----Original Message-----
    From: ipv6 <[email-masked]> On Behalf Of Eric Vyncke (evyncke)
    Sent: Tuesday, March 3, 2020 6:21 PM
    To: [email-masked]
    Subject: Learning from mistakes (was Re: [Errata Held for Document Update] RFC8200 (5933))
    
    Fernando, my friend, 

    Best regards,

    -----Original Message-----
    From: ipv6 <[email-masked]> on behalf of Fernando Gont <[email-masked]>
    Date: Tuesday, 3 March 2020 at 23:56

    
    
        ....%<....%<....

---

From: Ron Bonica <[email-masked]>
Date: Thu, 5 Mar 2020 16:05:30 +0000

Eric,

Maybe Dan can tell us?

                       Ron

-----Original Message-----
From: Eric Vyncke (evyncke) <evyncke=[email-masked]> 
Sent: Wednesday, March 4, 2020 6:17 PM
To: Ron Bonica <[email-masked]>; [email-masked]
Subject: Re: Learning from mistakes (was Re: [Errata Held for Document Update] RFC8200 (5933))

Hello Ron,

Regards

-éric

-----Original Message-----
From: Ron Bonica <rbonica=[email-masked]>
Date: Wednesday, 4 March 2020 at 22:20
To: Eric Vyncke <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: Learning from mistakes (was Re: [Errata Held for Document Update] RFC8200 (5933))

    Eric,

                                                 Ron

    
    -----Original Message-----
    From: ipv6 <[email-masked]> On Behalf Of Eric Vyncke (evyncke)
    Sent: Tuesday, March 3, 2020 6:21 PM
    To: [email-masked]
    Subject: Learning from mistakes (was Re: [Errata Held for Document Update] RFC8200 (5933))
    
    Fernando, my friend, 

    Best regards,

    -----Original Message-----
    From: ipv6 <[email-masked]> on behalf of Fernando Gont <[email-masked]>
    Date: Tuesday, 3 March 2020 at 23:56

    
    
        ....%<....%<....