Subject: draft-fz-6man-ipv6-alt-mark

From: Ron Bonica <[email-masked]>
Date: Mon, 30 Mar 2020 16:19:49 +0000

Authors,

Draft-fz-6man-ipv6-alt-mark is based upon draft-ietf-ippm-multipoint-alt-mark, which is intended for publication as EXPERIMENTAL.

Does it make sense to progress draft-fz-6man-ipv6-alt-mark as EXPERIMENTAL, too?

Does it make sense to use an RFC3692-style code point for the option type?

                                             Ron

Juniper Business Use Only

---

From: Giuseppe Fioccola <[email-masked]>
Date: Tue, 31 Mar 2020 08:16:59 +0000

Hi Ron,
Thanks for raising this point!
RFC 8321 and related draft-ietf-ippm-multipoint-alt-mark are Experimental because they describe the methodology in general as protocol agnostic technique. Actually, both RFC 8321 and draft-ietf-ippm-multipoint-alt-mark are considered borderline between Informational and Experimental, indeed we had some discussion on that during the AD review.
Anyway, to make the methodology applicable and standard for a specific protocol, we need the marking field in the header and this is what we aim to do with IPv6. Note that we are following the same approach of draft-ietf-bier-pmmm-oam that was also submitted as Standards Track.
Our idea is to go beyond the general scope of RFC8321 and implement this OAM method in IPv6, so this is why the proposed status is Standards Track.

Regards,

Giuseppe

From: ipv6 [mailto:[email-masked]] On Behalf Of Ron Bonica
Sent: Monday, March 30, 2020 6:20 PM
To: 6man WG <[email-masked]>
Subject: draft-fz-6man-ipv6-alt-mark

Authors,

                                             Ron