Subject: Comments on draft-ietf-6man-spring-srv6-oam-03

From: <[email-masked]>
Date: Mon, 23 Mar 2020 13:52:37 +0800 (CST)

Hi Zafar,

I have several comments on draft-ietf-6man-spring-srv6-oam-03 as below.

In section 4.1.1 and 4.2.2.1, several descriptions of node behavior on "performs the standard SRH processing" and "executes the END.X function" can be improved.

For example, in section 4.1.1, I propose to change the description of Node N2 behavior.

OLD

Node N2, which is an SRv6 capable node, performs the standard SRH processing.  Specifically, it executes the END.X function (B:2:C31) and forwards the packet on link3 to N3.

NEW

Node N2, which is an SRv6 capable node, performs the standard SRv6 SID and SRH processing.  Specifically, it executes the END.X function (B:2:C31) and forwards the packet on link3 to N3.

As I understand, the behavior of executing the END.X function is not part of SRH processing, but part of SRv6 SID (IPv6 DA) processing, right?

In section 4.1.1, I propose to insert one more sentence clarifyiing the behavior of the egress SRv6 capable node.

OLD

Similarly, the egress node (IPv6 classic or SRv6 capable) does not require any change to process the ICMPv6 echo request.

NEW

Similarly, the egress node (IPv6 classic or SRv6 capable) does not require any change to process the ICMPv6 echo request, and there is no difference in processing of the ICMPv6 echo request at an IPv6 classic node and an SRv6 capable node.

This inserted sentence is almost the same with thatBes is present in section 4.2.1 as "There is no difference in processing of the traceroute probe at an IPv6 classic node and an SRv6 capable node." The reason is that I was asked whether the ICMPv6 echo reply would carry SRH when the egress node is SRv6 capable, as I understand , the answer is NO, but I couldn't find explicit text in the current draft.

In section 4.2.2.1, s/hop count/hop limit/g, s/hop-count/hop-limit/g

In section 4.2.2.1, s/2001:DB8:3:4::41/2001:DB8:3:4:41; In section 4.2.1, s/2001:DB8:4:5::52::/2001:DB8:4:5:52::/g, s/2001:DB8:3:4::41/2001:DB8:3:4:41. In addition, the displayed interface IPv6 addresses in Figure 3 have the last ::, but that in Figure 4 have no the last ::, shouldn't they be the same?

Best Regards,

Xiao Min

---

From: "Zafar Ali (zali)" <[email-masked]>
Date: Mon, 30 Mar 2020 18:02:02 +0000

Hi Xiao Min,

Many thanks for your review and serval comments.
Your comments have been addressed in the revision 4 of the draft,

Please see [ZA] in-line for the specifics.

Thanks

Regards … Zafar

From: ipv6 <[email-masked]> on behalf of "[email-masked]" <[email-masked]>
Date: Monday, March 23, 2020 at 1:52 AM
To: "Zafar Ali (zali)" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Comments on draft-ietf-6man-spring-srv6-oam-03

Hi Zafar,

  1.  In section 4.1.1 and 4.2.2.1, several descriptions of node behavior on "performs the standard SRH processing" and "executes the END.X function" can be improved.

OLD

NEW

[ZA] Yes, the suggested change has been made in rev-4.

  1.  In section 4.1.1, I propose to insert one more sentence clarifyiing the behavior of the egress SRv6 capable node.

OLD

NEW

[ZA] The suggested change has been made in rev-4. You are right, the responder does not include SRH in the ICMP echo reply.

  1.  In section 4.2.2.1, s/hop count/hop limit/g, s/hop-count/hop-limit/g
  2.  In section 4.2.2.1, s/2001:DB8:3:4::41/2001:DB8:3:4:41; In section 4.2.1, s/2001:DB8:4:5::52::/2001:DB8:4:5:52::/g, s/2001:DB8:3:4::41/2001:DB8:3:4:41. In addition, the displayed interface IPv6 addresses in Figure 3 have the last ::, but that in Figure 4 have no the last ::, shouldn't they be the same?

[ZA] The suggested change has been made in rev-4. You are right, the responder does not include SRH in the ICMP echo reply.

Best Regards,

Xiao Min

---

From: <[email-masked]>
Date: Tue, 31 Mar 2020 14:28:58 +0800 (CST)

Hi Zafar,

Thanks for addressing my comments.

For the comment #1, in the rev-4 I still find three places that can be improved, as follows.

Section 6.1.1, behavior of Node N2 and Node N4.

Section 6.1.2, behavior of Node N2.

For all the three places, s/performs the standard SRH processing/performs the standard SRv6 SID and SRH processing.

Best Regards,

Xiao Min

原始邮件

发件人：ZafarAli(zali) <[email-masked]>
收件人：肖敏10093570;
抄送人：[email-masked] <[email-masked]>;Zafar Ali (zali) <[email-masked]>;
日 期 ：2020年03月31日 02:02
主 题 ：Re: Comments on draft-ietf-6man-spring-srv6-oam-03

Hi Xiao Min,

 

 

Thanks

Regards … Zafar

 

Hi Zafar,

OLD

NEW

OLD

NEW

Similarly, the egress node (IPv6 classic or SRv6 capable) does not require any change to process the ICMPv6 echo request, and there is no difference in processing of the ICMPv6 echo request at an IPv6 classic node and an SRv6 capable
 node.

This inserted sentence is almost the same with thatBes is present in section 4.2.1 as "There is no difference in processing of the traceroute probe at an IPv6 classic node and an SRv6 capable node." The reason is that I was asked
 whether the ICMPv6 echo reply would carry SRH when the egress node is SRv6 capable, as I understand , the answer is NO, but I couldn't find explicit text in the current draft.

In section 4.2.2.1, s/2001:DB8:3:4::41/2001:DB8:3:4:41; In section 4.2.1, s/2001:DB8:4:5::52::/2001:DB8:4:5:52::/g, s/2001:DB8:3:4::41/2001:DB8:3:4:41. In addition, the displayed interface IPv6 addresses in Figure 3 have
 the last ::, but that in Figure 4 have no the last ::, shouldn't they be the same?

Best Regards,

Xiao Min