Subject: RE: So where have all these new 6man WG people come from?

From: "Voyer, Daniel" <[email-masked]>
Date: Thu, 28 May 2020 14:11:48 +0000

Hello Fred,

I too, come from the real-world, the operator side which implies wireline & wireless network. It's pretty awesome that you have an aviation hat though, I can't claim that I have a "drone hat" .. just yet.

But with this new ecosystem where we try to have an end-to-end type architecture, from access network, to metro and core network and try to adapt to a 5G/MEC, I believe we are redefining boundaries between domains. What's happening in 6man AND SPRING working group just reflect those new changes. New contributors coming in is not just happening to those 2 working group, there's also new contributors showing at DMM wg, and there's wireline folks attending 3GPP (not just related to segment routing). Proposing to "reject" or "treat" new contributors separately makes an "us and them" type of relationship and it's not good for reaching a form of consensus. 

Regards,
dan

On 2020-05-28, 9:54 AM, "ipv6 on behalf of Templin (US), Fred L" <[email-masked] on behalf of [email-masked]> wrote:

    Ole,

    > It seems that a proxy war is being fought out in the working group.
    > With both opponents and proponents of proposals closely aligned along company borders.

    I am representing real-world use cases (planes, trains and automobiles) with my
    aviation hat on. I do not work for a network equipment vendor and do not have
    company influences driving my decisions. I think this flood of people coming into
    6man many for the first time is bad for the 6man technical process and may
    interfere with the timely need for solutions to real world problems. I trust that
    the chairs will recognize what is going on and make the right decisions.

    Thanks - Fred

    > -----Original Message-----
    > From: ipv6 [mailto:[email-masked]] On Behalf Of [email-masked]
    > Sent: Thursday, May 28, 2020 5:12 AM
    > To: Mark Smith <[email-masked]>
    > Cc: 6MAN <[email-masked]>
    > Subject: Re: So where have all these new 6man WG people come from?
    > 
    > Segment Routing (CRH, SRH and friends) isn't something 6man has traditionally dealt with.
    > We have been more concerned about IPv6 in the open Internet, end to end, and not so much of technologies only applicable within a
    > controlled domain.
    > 
    > From that perspective, it is not surprising that this work attracts a different participant-set than before.
    > 
    > It seems that a proxy war is being fought out in the working group.
    > With both opponents and proponents of proposals closely aligned along company borders.
    > 
    > Best regards,
    > Ole, with the dystopian hat on.
    > 
    > 
    > > On 28 May 2020, at 13:23, Mark Smith <[email-masked]> wrote:
    > >
    > > I've been an active participant in the ipng, 6man and v6ops IETF working groups since 2002.
    > >
    > > While I've only been to one IETF meeting in person since then (106, sponsored by the Internet Society), over that time I've come to
    > recognise the names of many of the regular and active participants in these IPv6 working groups.
    > >
    > > I do not recognise many of the names of people who are objecting to the 6man working group adopting the CRH draft.
    > >
    > > Those who have been active 6man participants in recent years would know that even an ID adopted by 6man, written by Bob and
    > Brian, that had a number of revisions, didn't survive WG last call, and that occurred while Bob was (as he still is) one of the 6man WG
    > chairs.
    > >
    > >
    > > Regards,
    > > Mark.
    > > --------------------------------------------------------------------
    > > IETF IPv6 working group mailing list
    > > [email-masked]
    > > Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
    > > --------------------------------------------------------------------
    > 
    > --------------------------------------------------------------------
    > IETF IPv6 working group mailing list
    > [email-masked]
    > Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
    > --------------------------------------------------------------------

    --------------------------------------------------------------------
    IETF IPv6 working group mailing list
    [email-masked]
    Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
    --------------------------------------------------------------------
    ------------------------------------------------------------------------------
    External Email: Please use caution when opening links and attachments / Courriel externe: Soyez prudent avec les liens et documents joints

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Thu, 28 May 2020 14:17:13 +0000

Hi Daniel, I do also have a drone hat:

https://ieeexplore.ieee.org/document/8742246

Thanks - Fred

> From: Voyer, Daniel [mailto:[email-masked]]
> Sent: Thursday, May 28, 2020 7:12 AM
> To: Templin (US), Fred L <[email-masked]>; [email-masked]; Mark Smith <[email-masked]>
> Cc: 6MAN <[email-masked]>
> Subject: RE: So where have all these new 6man WG people come from?
> 
> Hello Fred,
> 
> I too, come from the real-world, the operator side which implies wireline & wireless network. It's pretty awesome that you have an
> aviation hat though, I can't claim that I have a "drone hat" .. just yet.
> 
> But with this new ecosystem where we try to have an end-to-end type architecture, from access network, to metro and core network
> and try to adapt to a 5G/MEC, I believe we are redefining boundaries between domains. What's happening in 6man AND SPRING
> working group just reflect those new changes. New contributors coming in is not just happening to those 2 working group, there's also
> new contributors showing at DMM wg, and there's wireline folks attending 3GPP (not just related to segment routing). Proposing to
> "reject" or "treat" new contributors separately makes an "us and them" type of relationship and it's not good for reaching a form of
> consensus.
> 
> Regards,
> dan
>

---

From: "Bernier, Daniel" <[email-masked]>
Date: Thu, 28 May 2020 14:23:04 +0000

+1 to my colleagues comment

Moreover, every open community thrives at trying to grow and add new active participants, committers (just look at the IETF Hackathons attendees growth).
It would be counter-intuitive if WG were actually proposing the opposite.

Thanks,
Dan B

On 2020-05-28, 10:11 AM, "ipv6 on behalf of Voyer, Daniel" <[email-masked] on behalf of [email-masked]> wrote:

    Hello Fred,

    Regards,
    dan

        Ole,

        Thanks - Fred

---

From: Andrew Alston <[email-masked]>
Date: Thu, 28 May 2020 14:25:49 +0000

Not proposing any such thing.

Am questioning if we are seeing a growth in participation – or a blatant stacking of the floor with people who have never set foot on the lists and will never will again.

Similar to the floor of +1’s we saw on something else a while back – where – once I took the list of all of them – and ran through an analytics script – had never posted to any archive I could find – and have never posted since.

Encourage participation – yes – encourage blatant floor stacking for the purpose of saying “I support this” and disappearing into the woodwork – no – there is a big difference

Andrew

From: ipv6 <[email-masked]> On Behalf Of Bernier, Daniel
Sent: Thursday, 28 May 2020 17:23
To: Voyer, Daniel <[email-masked]>; Templin (US), Fred L <[email-masked]>; [email-masked]; Mark Smith <[email-masked]>
Cc: 6MAN <[email-masked]>
Subject: RE: So where have all these new 6man WG people come from?

Thanks,
Dan B

Hello Fred,

Regards,
dan

Ole,

Thanks - Fred

> > Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6<https://www.ietf.org/mailman/listinfo/ipv6>
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6<https://www.ietf.org/mailman/listinfo/ipv6>

Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6<https://www.ietf.org/mailman/listinfo/ipv6>

Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6<https://www.ietf.org/mailman/listinfo/ipv6>

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6<https://www.ietf.org/mailman/listinfo/ipv6>
--------------------------------------------------------------------

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Thu, 28 May 2020 14:29:46 +0000

Well said.

From: Andrew Alston [mailto:[email-masked]]
Sent: Thursday, May 28, 2020 7:26 AM
To: Bernier, Daniel <[email-masked]>; Voyer, Daniel <[email-masked]>; Templin (US), Fred L <[email-masked]>; [email-masked]; Mark Smith <[email-masked]>
Cc: 6MAN <[email-masked]>
Subject: RE: So where have all these new 6man WG people come from?

Andrew

From: ipv6 <[email-masked]<mailto:[email-masked]>> On Behalf Of Bernier, Daniel
Sent: Thursday, 28 May 2020 17:23
To: Voyer, Daniel <[email-masked]<mailto:[email-masked]>>; Templin (US), Fred L <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Mark Smith <[email-masked]<mailto:[email-masked]>>
Cc: 6MAN <[email-masked]<mailto:[email-masked]>>
Subject: RE: So where have all these new 6man WG people come from?

Thanks,
Dan B

On 2020-05-28, 10:11 AM, "ipv6 on behalf of Voyer, Daniel" <[email-masked] on behalf of [email-masked]<mailto:[email-masked][email-masked]>> wrote:

Hello Fred,

Regards,
dan

On 2020-05-28, 9:54 AM, "ipv6 on behalf of Templin (US), Fred L" <[email-masked] on behalf of [email-masked]<mailto:[email-masked][email-masked]>> wrote:

Ole,

Thanks - Fred

> From: ipv6 [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>
> To: Mark Smith <[email-masked]<mailto:[email-masked]>>
> Cc: 6MAN <[email-masked]<mailto:[email-masked]>>
> > On 28 May 2020, at 13:23, Mark Smith <[email-masked]<mailto:[email-masked]>> wrote:
> >
> > [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>

[email-masked]<mailto:[email-masked]>

[email-masked]<mailto:[email-masked]>

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]<mailto:[email-masked]>
Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Nick Hilliard <[email-masked]>
Date: Thu, 28 May 2020 15:56:09 +0100

+1 on this.  Also, hats off to Ole for explicitly acknowledging that 
this is a vendor proxy war.

As an independent operator of services, I find it disappointing and 
thoroughly distasteful to see representatives from otherwise reputable 
vendors engage in a protocol assassination attempt for what are very 
obviously political reasons.

This is abusive and damaging to the IETF,  to the development of useful 
building-block technologies, and serves to act directly against the 
interests of technology consumers.  It needs to stop.

Nick

Templin (US), Fred L wrote on 28/05/2020 15:29:
>
> Well said.
>
> *From:* Andrew Alston [mailto:[email-masked]]
> *Sent:* Thursday, May 28, 2020 7:26 AM
> *To:* Bernier, Daniel <[email-masked]>; Voyer, Daniel 
> <[email-masked]>; Templin (US), Fred L 
> <[email-masked]>; [email-masked]; Mark Smith 
> <[email-masked]>
> *Cc:* 6MAN <[email-masked]>
> *Subject:* RE: So where have all these new 6man WG people come from?
>
> Am questioning if we are seeing a growth in participation – or a 
> blatant stacking of the floor with people who have never set foot on 
> the lists and will never will again.
>
> Similar to the floor of +1’s we saw on something else a while back – 
> where – once I took the list of all of them – and ran through an 
> analytics script – had never posted to any archive I could find – and 
> have never posted since.
>
> Encourage participation – yes – encourage blatant floor stacking for 
> the purpose of saying “I support this” and disappearing into the 
> woodwork – no – there is a big difference
>
> Andrew
>
>

---

From: Xing Li <[email-masked]>
Date: Thu, 28 May 2020 23:09:40 +0800

> obviously political reasons.
+1,xing
>
> This is abusive and damaging to the IETF,  to the development of 
> useful building-block technologies, and serves to act directly against 
> the interests of technology consumers.  It needs to stop.
>
> Nick
>
> ------------------------------------------------------------------------
>

---

From: Sander Steffann <[email-masked]>
Date: Thu, 28 May 2020 17:24:52 +0200

Hi Nick,

Well written:

> +1 on this.  Also, hats off to Ole for explicitly acknowledging that this is a vendor proxy war.
> 
> As an independent operator of services, I find it disappointing and thoroughly distasteful to see representatives from otherwise reputable vendors engage in a protocol assassination attempt for what are very obviously political reasons.
> 
> This is abusive and damaging to the IETF,  to the development of useful building-block technologies, and serves to act directly against the interests of technology consumers.  It needs to stop.

Yes, it definitely needs to stop.
Sander

---

From: [email-masked]
Date: Thu, 28 May 2020 17:36:53 +0200

> +1 on this.  Also, hats off to Ole for explicitly acknowledging that this is a vendor proxy war.

As far as I can tell this behaviour started with the adoption of the SRH document and has continued ever since.
The SR-PGM appeal is another example of collateral damage.

It's the Karpman drama triangle playing out.

> This is abusive and damaging to the IETF,  to the development of useful building-block technologies, and serves to act directly against the interests of technology consumers.  It needs to stop.

Indeed.
How though, is the difficult part. Trying to mediate leads to being dragged into the conflict, accused of taking sides and losing credibility.

Best regards,
Ole

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 28 May 2020 16:59:05 +0100

Two ways to de-escalate this, Ole, would be:

1. Don't imply that everyone stating an opinion is doing so because they are
following a company line. If you make such statements then you discourage
people from expressing their independent opinions.

2. Don't say anything that could be taken to be an opinion on an appeal that
is in progress and implies that the appellants are doing anything other than
a true and honest appeal.

Sometimes being a WG chair is a no-win situation, and I think everyone
respects the job you do. But you can avoid shooting yourself if you're
careful.

Best,
Adrian

-----Original Message-----
From: ipv6 <[email-masked]> On Behalf Of [email-masked]
Sent: 28 May 2020 16:37
To: Nick Hilliard <[email-masked]>
Cc: 6MAN <[email-masked]>
Subject: Re: So where have all these new 6man WG people come from?

> +1 on this.  Also, hats off to Ole for explicitly acknowledging that this
is a vendor proxy war.

As far as I can tell this behaviour started with the adoption of the SRH
document and has continued ever since.
The SR-PGM appeal is another example of collateral damage.

Indeed.
How though, is the difficult part. Trying to mediate leads to being dragged
into the conflict, accused of taking sides and losing credibility.

Best regards,
Ole

---

From: 神明達哉 <[email-masked]>
Date: Thu, 28 May 2020 08:59:58 -0700

> How though, is the difficult part. Trying to mediate leads to being dragged into the conflict, accused of taking sides and losing credibility.

I think we could at least discount the "blatant" +1's in adoption or
last calls in terms of assessing rough consensus.  Even if a simple
"+1" is really all one can say in response to the call, they should at
least be able to provide a short summary of their understanding on
what's proposed and why they support or don't support it *in their own
words*.  Chairs could clarify at each call that blatant responses that
don't even meet the minimum due diligence will be rather considered as
a "-1" for the chair's consensus assessment.

Maybe we'll then just see a flood of some marketing or company agenda,
but hopefully this will result in having more constructive technical
discussions, while discouraging those (if any) just fighting a proxy
war to post the blatant reply.

--
JINMEI, Tatuya

---

From: Fernando Gont <[email-masked]>
Date: Thu, 28 May 2020 13:37:14 -0300

On 28/5/20 12:36, [email-masked] wrote:
> As far as I can tell this behaviour started with the adoption of the
> SRH document and has continued ever since. The SR-PGM appeal is
> another example of collateral damage.

The SR-PGM appeal is the result of folks like myself becoming fed up
about processes not being followed, and rules being apparently bent in
favor of companies with an agenda.

The "process" started more or less at RFC2460bis-time (see: [1]),
continued with subsequent efforts to punch a hole in RFC8200 (see: [2]), 
and ended with the SR-PGM document dismissing comments at will.  After 
trying numerous times to get the relevant chairs and ADs involved
(see: [3]) and still being ignored, we proceeded with Appealing the 
decision, as we had promised.

FWIW, SRH itself (like other Spring stuff) had been portrayed more or 
less as a document we simply had to rubber-stamp because there were 
several companies with big pockets willing to pay for it, and because 
the document contained a full page worth of authors from multiple big 
companies. The document was also pushed with very twisted 
interpretations of RFC2460 claiming "ambiguities" that the same people 
later opposed to clarify in RFC8200 (as per [1])

Some of us simply want that:

1) Relevant WGs get to take the decisions they are meant to take 
(including wg adoption of documents) -- i.e., that the rights of the wg 
and wg participants be respected -- , and that,

2) Rules apply to all of us in the same way, no matter who sponsors 
proposals, or how much money there is to be made with them.

(which can be summarized as "be fair, and follow the due processes", or 
simply as "follow the due processes")

If anybody has benefited from the Appeal in what seems to be this fight 
over Routing Headers, that has simply been an unintended side effect. In 
fact, some of us tried so many times to get the Spring and RTG ADs 
involved (both off-list and on-list), that it would be quite difficult 
for anybody to infer that we were willing to do a formal Appeal (as 
opposed to resorting to it because there was no other option left to us).

What happened, already happened (let's just hope that there's no need to 
fight for 1) and 2) to be applied/take place).

But let's call the lemon a lemon: The Appellants have no blame for the 
disaster described in 
https://mailarchive.ietf.org/arch/msg/ipv6/I1rChA9NrN91knc12h5y9zA5iTQ/ 
. And it worries that in that light, you somehow suggest that we 
appellants have played a role in the alleged "Karpman drama triangle".

References:

[1] https://mailarchive.ietf.org/arch/msg/ietf/j1O11x4ICMUWGJmzlJfCx0y0-c8/

[2] https://mailarchive.ietf.org/arch/msg/ipv6/ql8V9MegVkXjlB7P-eTeLW6BhjI/

[3] https://mailarchive.ietf.org/arch/msg/ipv6/6gw13SyIAnQlp9-NCpEyXaozQYg/

Thanks,
-- 
Fernando Gont
SI6 Networks
e-mail: [email-masked]
PGP Fingerprint: 6666 31C6 D484 63B2 8FB1 E3C4 AE25 0D55 1D4E 7492

---

From: Jared Mauch <[email-masked]>
Date: Fri, 29 May 2020 11:08:15 -0400

> On May 28, 2020, at 10:25 AM, Andrew Alston <[email-masked]> wrote:
> 

(No hat)

I’m concerned about how welcoming this might be to new participants who perhaps have a legitimate problem to be solved that they discover in the operations of a network.  This above text doesn’t reflect a welcoming environment, nor one where perhaps someone has something valuable to contribute in a single area of expertise of operations.

I’m going to bookmark this thread for a reminder next time someone asks me about if the IETF is welcoming to newcomers.

- Jared

---

From: Mark Smith <[email-masked]>
Date: Sat, 30 May 2020 12:48:18 +1000

Do you think somebody who spent many hours of their own time preparing
and presenting this at the AusNOG 2015 conference wants to discourage
IETF participation, unless it is trying to influence group consensus
via membership stacking and using ring-ins (Australian for non-genuine
members)?

"Why you should read RFCs and Internet Drafts (and what you need to
know to do so)"
https://www.ausnog.net/sites/default/files/ausnog-2015/presentations/1.4_Mark_Smith_AusNOG2015.pdf

---

From: Robert Raszuk <[email-masked]>
Date: Sat, 30 May 2020 11:25:57 +0200

HI Mark,

So what is your recommendation ?

What should make an individual eligible by your standards to express an
opinion on adoption or last call of any proposal in 6man or any WG?

If someone is following SPRING and 6MAN just by reading list archives and
he sees an adoption call - by your standards he can not one time voice his
opinion ? Very interesting ...

In fact 6man is open also for non subscribers making it very welcoming to
anyone to send an email even without joining the WG list.

Sure - in the past I personally experienced folks from a vendor subscribing
and voting with an artificial name yet silly enough to use their company
internal mailer domain - pretending he is an operator, but those would be
rather ugly exceptions then a rule.

Thx a lot,
R.

On Sat, May 30, 2020 at 4:48 AM Mark Smith <[email-masked]> wrote:

> blatant stacking of the floor with people who have never set foot on the
> lists and will never will again.
> > >
> >
> > (No hat)
> >
> > I’m concerned about how welcoming this might be to new participants who
> perhaps have a legitimate problem to be solved that they discover in the
> operations of a network.  This above text doesn’t reflect a welcoming
> environment, nor one where perhaps someone has something valuable to
> contribute in a single area of expertise of operations.
> >
> > I’m going to bookmark this thread for a reminder next time someone asks
> me about if the IETF is welcoming to newcomers.
> >
> > - Jared
>

---

From: Mark Smith <[email-masked]>
Date: Sat, 30 May 2020 22:44:39 +1000

On Sat, 30 May 2020 at 19:26, Robert Raszuk <[email-masked]> wrote:
> What should make an individual eligible by your standards to express an opinion on adoption or last call of any proposal in 6man or any WG?
>

Since this is a group that does work ("working group"), I think it is
fair to expect some evidence of contribution to the work the group
does, such as active involvement in previous working group mailing
list discussions, authored or co-authored Internet Drafts relevant to
the working group's purpose, or mentions in working group relevant ID
acknowledgement sections indicating off-line communication and
contribution with the author(s) regarding the ID.

It doesn't seem fair to me that people who haven't contributed work to
the group get a say in what work the group does or does not do.

Regards,
Mark.

> If someone is following SPRING and 6MAN just by reading list archives and he sees an adoption call - by your standards he can not one time voice his opinion ? Very interesting ...
>
> In fact 6man is open also for non subscribers making it very welcoming to anyone to send an email even without joining the WG list.
>
> Sure - in the past I personally experienced folks from a vendor subscribing and voting with an artificial name yet silly enough to use their company internal mailer domain - pretending he is an operator, but those would be rather ugly exceptions then a rule.
>
> Thx a lot,
> R.
>
>

---

From: Robert Raszuk <[email-masked]>
Date: Sat, 30 May 2020 14:53:25 +0200

> I think it is fair to expect some evidence of contribution to the work
the group does

Well I am not so sure if this is "fair". But I am lucky that I am not the
one to decide that :)

Just so you are aware in other WGs say GROW or IDR we often see one timers
- say ISP, IXP operators who often voice support for an idea in spite of a
fact that they just do not have time for any IETF activities, but just hear
about such discussions on *NOGs or RIPE discussions.

I hope that you do not mean that it is ok to "support", but not ok to
indicate "no support" for any idea.

Thx,
Robert.

On Sat, May 30, 2020 at 2:45 PM Mark Smith <[email-masked]> wrote:

> > If someone is following SPRING and 6MAN just by reading list archives
> and he sees an adoption call - by your standards he can not one time voice
> his opinion ? Very interesting ...
> >
> > In fact 6man is open also for non subscribers making it very welcoming
> to anyone to send an email even without joining the WG list.
> >
> > Sure - in the past I personally experienced folks from a vendor
> subscribing and voting with an artificial name yet silly enough to use
> their company internal mailer domain - pretending he is an operator, but
> those would be rather ugly exceptions then a rule.
> >
> > Thx a lot,
> > R.
> >
> >
> >> > I’m concerned about how welcoming this might be to new participants
> who perhaps have a legitimate problem to be solved that they discover in
> the operations of a network.  This above text doesn’t reflect a welcoming
> >> > I’m going to bookmark this thread for a reminder next time someone
> asks me about if the IETF is welcoming to newcomers.
> >> >
> >> > - Jared
> >>

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Sat, 30 May 2020 18:08:35 +0000

Mark I think you’ve inadvertently described an old boys club in 6man.  After meeting you in person in Singapore, I can say with some certainty that was not your intent.

Let’s end this thread and welcome the diversity and new ideas that new posters to the list can bring. We need not agree with everything we read on the list but it is better than silence.

To those new posters to 6man, keep it up!  The ietf needs the diversity of experience culture and thought that you bring.

https://www.rfc-editor.org/rfc/rfc7704.html#section-2.1

Sincerely
  Darren
________________________________
From: ipv6 <[email-masked]> on behalf of Mark Smith <[email-masked]>
Sent: Saturday, May 30, 2020 8:46 AM
To: Robert Raszuk
Cc: 6MAN
Subject: Re: So where have all these new 6man WG people come from?

Regards,
Mark.

---

From: Ole Troan <[email-masked]>
Date: Sat, 30 May 2020 23:23:59 +0200

Mark,

With 6man taking on new work, that is outside of where 6man traditionally has worked new participants are both expected and necessary. 

Be that the alt-mark work, bier or segment routing. 
6man has evolved into the intarea wg for IPv6 related work. 
Cheers 
Ole

> On 30 May 2020, at 14:45, Mark Smith <[email-masked]> wrote:
>

---

From: Stewart Bryant <[email-masked]>
Date: Sun, 31 May 2020 09:17:46 +0100

Hi Ole,

There are lots of changes to the IP dataplane that are gradually surfacing and need to be addressed if IP is not to suffer premature obsolescence.

Perhaps it is time we set up an IP development working group?

- Stewart

> On 30 May 2020, at 22:23, Ole Troan <[email-masked]> wrote:
> 
> Mark,
>

---

From: Stewart Bryant <[email-masked]>
Date: Sun, 31 May 2020 09:20:44 +0100

Hi Ole,

- Stewart

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 31 May 2020 10:27:28 +0200

> Perhaps it is time we set up an IP development working group?

That would be an IRTF research group, no?

Grüße, Carsten

---

From: Toerless Eckert <[email-masked]>
Date: Mon, 1 Jun 2020 00:35:38 +0200

Carsten,

Not sure if you have followed the ongoing backpressure from IRTF
and IESG leadership to bless any form of forum/WG for discussions
about longer term network layer architecture. We did discuss this
a bit on architecture-discuss around the IETF leaderhip response
to some liaison with ITU-T, if you remember. And direct responses
from IRTF chair re evolution of network protocols where even more
rejecting: "That is not research ... or after chopping it up into
sub-problems it should fit into some set of WG/RGs".

And that thinking of chopping larger architectural discussions into
smaller pieces fitting into existing RG/WGs is IMHO the root of
our (IETF/IRTF) problems to do anything strategic.

For example: We have two WGs (6man, Spring), that argue how many hundreds
of bytes in header space can be spent on primarily steering, and
at the same time, we did not increase the header space for path
QoS for more than 40 years from its original 8 bit. Just look at the pain
with ECT(1) for L4S. How ridiculous is that. And thats just the latest
of frustration about QoS being handled in network headers like,
oh, i don't know, a leper? for lack of better term.

In QoS you can run around multiple TSV groups to argue functionality
and then multiple RTG groups to argue encoding of such functionality
in network headers whose groups mostly do not care or know about QoS.
That is IETF friendlyness for newcomers. Or should i say newipcomers ?

And whatever we do, if we wanted it to be efficient, we would have
to do it for MPLS, IPv4 and IPv6, unless we really had a version of
a network layer protocol that could really superceed MPLS and IPv4
without taking away their benefits, which unfortunately is what
current IPv6 does, at least in the eyes of those who will continue
to use IPv4 and MPLS, and we know what those markets are.

I think an evolution of IPv6 could be built to be backward compatible
and interoperable with IPv4/MPLS and then we would only have to bother
about defining new functionality like better QoS once.
Did i say variable lengh addresses ?

IMHO the next generation network layer really should be a "Unified IP".

Cheers
    Toerless

-- 
---
[email-masked]