Subject: Interested in wireless ?

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Sat, 30 May 2020 11:46:12 +0000

Dear all

Since there’s so much energy on the list these days, could we consider the adoption of
https://tools.ietf.org/html/draft-thubert-6man-ipv6-over-wireless-05
?

I got only positive feedback, there’s no politics, there no label, it’s all about IPv6 models for wireless. This may appear useful in a world where the vast majority of devices are connected that way.

Keep safe,

Pascal

---

From: Loganaden Velvindron <[email-masked]>
Date: Sat, 30 May 2020 17:24:18 +0400

> I got only positive feedback, there’s no politics, there no label, it’s all about IPv6 models for wireless. This may appear useful in a world where the vast majority of devices are connected that w…

I hope that work continues on this.

> Keep safe,
>
> Pascal
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 31 May 2020 08:47:37 +1200

Hi,

I believe that this is an important topic that 6MAN should take up. The draft is a good basis.

At the moment I find the draft a bit confusing in one way. It's aimed at standards track, but it mainly doesn't read like a standard. There's a lot of discussion but not much specification. If I was a coder, I wouldn't really know where to start. For example, the end of the Introduction says:

"This document discusses the applicability of IPv6 ND
 over wireless links, as compared with routing-based alternatives such
 as prefix-per node and multi-link subnets (MLSN), and with Wireless
 ND (WiND), that is similar to the Wi-Fi association and reduces the
 need for Network-Layer multicast."

If it's a standard, IMHO it shouldn't do that. It should specify what WiND is, with normative references as needed. Section 5 is the important part. It's fine to have a descriptive section about why WiND is needed, but that is almost better as an appendix. The main text should be essentially the instructions for a kernel programmer.

Regards
   Brian Carpenter

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 31 May 2020 04:00:16 +0200

> Since there’s so much energy on the list these days,

Hah.

> could we consider the adoption of

I think that rebranding 6lowpan-ND/RFC8505 as WiND and using that in more wireless networks than just the 6lo ones is a good idea.

I think we need a better coexistence/transition strategy before we can use it alongside ND-Classic, as will continue to be the normal case for WiFi.

(I have sent some editorial comments on the document to Pascal, and plan to send more.)

Grüße, Carsten

---

From: Michael Richardson <[email-masked]>
Date: Sun, 31 May 2020 12:31:10 -0400

> I think that rebranding 6lowpan-ND/RFC8505 as WiND and using that in
    > more wireless networks than just the 6lo ones is a good idea.

I agree.
Does this get us any closer to routing /128s rather than bridging
wired/wireless?  I feel it ought to, but I'm not sure how.

    > I think we need a better coexistence/transition strategy before we can
    > use it alongside ND-Classic, as will continue to be the normal case for
    > WiFi.

I think that we get a lot of traction by setting L=0.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Sun, 31 May 2020 16:40:45 +0000

Hello Brian

We may have to split the doc but for the most part I agree it is an informational. 

For now I suggest to just change the intended status accordingly and aim at BCP or something.

Let’s discuss in parallel the coexistence and if there’s a need for an std track somewhere. There’s at least the use of a 6LBR for address looking up in unicast.

Take care,
Pascal

> Le 30 mai 2020 à 22:47, Brian E Carpenter <[email-masked]> a écrit :
> 
> Hi,
>

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 1 Jun 2020 11:20:36 +1200

Pascal,

There is a category of standards track documents foreseen in RFC2026 called "applicability statements", described at https://tools.ietf.org/html/rfc2026#section-3.2

I think that is perhaps where your draft could fit. A little bit stronger than Informational and little bit different than Best *Current* Practice.

Regards
   Brian