Subject: Adoption Call for "IPv6 Application of the Alternate Marking Method"

From: Bob Hinden <[email-masked]>
Date: Fri, 15 May 2020 15:10:17 -0700

This message starts a two week 6MAN call on adopting:

  Title:	   IPv6 Application of the Alternate Marking Method
  Authors:         G. Fioccola, T. Zhou, M. Cociglio, F. Qin
  File Name	   draft-fz-6man-ipv6-alt-mark-09
  Document date:   2020-05-04

  https://tools.ietf.org/html/draft-fz-6man-ipv6-alt-mark-09

as a working group item. Substantive comments regarding adopting this document should be directed to the mailing list. Editorial suggestions can be sent to the authors.  This adoption call will end on 29 May 2020.

There has been a lot of discussion on this draft, the chairs believe that the major issues raised on the list are resolved in this version of draft and it is ready for the working group to consider adopting as working group draft.

Could those who are willing to work on this document, either as contributors, authors or reviewers please notify the list.   That gives us an indication of the energy level in the working group
to work on this.

Regards,
Bob and Ole

---

From: "Xiejingrong (Jingrong)" <[email-masked]>
Date: Sat, 16 May 2020 01:10:42 +0000

Hi WG,
I support the adoption of this I-D.
It is a straight-forward method of performance measurement and is useful for the network operation.

Thanks
Jingrong

-----Original Message-----
From: ipv6 [mailto:[email-masked]] On Behalf Of Bob Hinden
Sent: Saturday, May 16, 2020 6:10 AM
To: IPv6 List <[email-masked]>
Cc: Bob Hinden <[email-masked]>
Subject: Adoption Call for "IPv6 Application of the Alternate Marking Method" 

Regards,
Bob and Ole

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 16 May 2020 13:25:15 +1200

I have reviewed several versions of this work, and I think this version is quite mature and is ready for adoption. I will continue to review future updates.

Regards
   Brian Carpenter

On 16-May-20 10:10, Bob Hinden wrote:
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
>

---

From: stefano previdi <[email-masked]>
Date: Sat, 16 May 2020 13:07:12 +0200

Hi,

I support the adoption of this document as WG item.

Thanks.
s.

> On May 16, 2020, at 12:10 AM, Bob Hinden <[email-masked]> wrote:
>

---

From: "Pengshuping (Peng Shuping)" <[email-masked]>
Date: Sun, 17 May 2020 13:57:49 +0000

Hi, 

I support the adoption of this work, which takes advantage of IPv6 extension headers for implementing Alternate Marking Method in an IPv6 domain for performance measurement.

Best regards,
Shuping

-----Original Message-----
From: ipv6 [mailto:[email-masked]] On Behalf Of Bob Hinden
Sent: Saturday, May 16, 2020 6:10 AM
To: IPv6 List <[email-masked]>
Cc: Bob Hinden <[email-masked]>
Subject: Adoption Call for "IPv6 Application of the Alternate Marking Method" 

Regards,
Bob and Ole

---

From: Gyan Mishra <[email-masked]>
Date: Sun, 17 May 2020 20:40:00 -0400

I support WG adoption of this draft as it is in a mature state for
adoption.  This draft from an operations perspective provides much needed
performance measurement characteristics via available extension headers.

Thanks

Gyan

On Sun, May 17, 2020 at 9:58 AM Pengshuping (Peng Shuping) <
[email-masked]> wrote:

> Hi,
>
> I support the adoption of this work, which takes advantage of IPv6
> extension headers for implementing Alternate Marking Method in an IPv6
> domain for performance measurement.
>
> Best regards,
> Shuping
>
>
> as a working group item. Substantive comments regarding adopting this
> document should be directed to the mailing list. Editorial suggestions can
> be sent to the authors.  This adoption call will end on 29 May 2020.
>
> There has been a lot of discussion on this draft, the chairs believe that
> the major issues raised on the list are resolved in this version of draft
> and it is ready for the working group to consider adopting as working group
> draft.
>
> Could those who are willing to work on this document, either as
> contributors, authors or reviewers please notify the list.   That gives us
> an indication of the energy level in the working group
> to work on this.
>
> Regards,
> Bob and Ole
>
>
-- 

Gyan  Mishra

Network Engineering & Technology

Verizon

Silver Spring, MD 20904

Phone: 301 502-1347

Email: [email-masked]

---

From: Uma Chunduri <[email-masked]>
Date: Sun, 17 May 2020 20:49:36 -0700

Very useful work. I support adoption of this draft by WG.

--
Uma C.

---

From: "Weiqiang Cheng" <[email-masked]>
Date: Mon, 18 May 2020 11:57:42 +0800

Support the adoption.

The draft provided an effective way for performance measurement in an IPv6 domain.

B.R.

Weiqiang Cheng

-----Original Message-----
From: ipv6 [mailto:[email-masked]] On Behalf Of Bob Hinden
Sent: Saturday, May 16, 2020 6:10 AM
To: IPv6 List <[email-masked]>
Cc: Bob Hinden <[email-masked]>
Subject: Adoption Call for "IPv6 Application of the Alternate Marking Method" 

Regards,
Bob and Ole

-- 

Gyan  Mishra

Verizon 

Silver Spring, MD 20904

Phone: 301 502-1347

---

From: Giuseppe Fioccola <[email-masked]>
Date: Mon, 18 May 2020 06:35:52 +0000

Hi Bob, All,
I support its adoption as co-author.

Thanks,

Giuseppe

-----Original Message-----
From: ipv6 [mailto:[email-masked]] On Behalf Of Bob Hinden
Sent: Saturday, May 16, 2020 12:10 AM
To: IPv6 List <[email-masked]>
Cc: Bob Hinden <[email-masked]>
Subject: Adoption Call for "IPv6 Application of the Alternate Marking Method" 

Regards,
Bob and Ole

---

From: Lizhenbin <[email-masked]>
Date: Mon, 18 May 2020 14:49:37 +0000

I support the adoption of the draft. It provides an effective method for performance measurement
for IPv6 and the draft is well written after updates and ready for adoption.

Best Regards,
Zhenbin (Robin)

-----Original Message-----
From: ipv6 [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Bob Hinden
Sent: Saturday, May 16, 2020 6:10 AM
To: IPv6 List <[email-masked]<mailto:[email-masked]>>
Cc: Bob Hinden <[email-masked]<mailto:[email-masked]>>
Subject: Adoption Call for "IPv6 Application of the Alternate Marking Method"

Regards,
Bob and Ole

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]<mailto:[email-masked]>
Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------
--
Gyan  Mishra
Network Engineering & Technology
Verizon
Silver Spring, MD 20904
Phone: 301 502-1347
Email: [email-masked]<mailto:[email-masked]>

---

From: Greg Mirsky <[email-masked]>
Date: Mon, 18 May 2020 12:59:09 -0700

Hi Bob,
I support the adoption of this draft by 6man WG. The proposed solution is
reasonable and a good addition to the PM OAM toolbox for IPv6 networks.

Regards,
Greg

---

From: Haoyu Song <[email-masked]>
Date: Mon, 18 May 2020 20:25:27 +0000

I have reviewed the revisions of this draft and support the wg adoption. 

Haoyu

-----Original Message-----
From: ipv6 <[email-masked]> On Behalf Of Bob Hinden
Sent: Friday, May 15, 2020 3:10 PM
To: IPv6 List <[email-masked]>
Cc: Bob Hinden <[email-masked]>
Subject: Adoption Call for "IPv6 Application of the Alternate Marking Method" 

  https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-fz-6man-ipv6-alt-mark-09&amp;data=02%7C01%7Chaoyu.song%40futurewei.com%7Cbad9597d038f47b7750d08d7f91ce1fe%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637251774759223710&amp;sdata=3OX%2Fl4NP2VfpigE%2FSwVur4pZ2Bzot9Zlqoh4HbzK2Lg%3D&amp;reserved=0

Regards,
Bob and Ole

---

From: Tom Herbert <[email-masked]>
Date: Mon, 18 May 2020 13:56:40 -0700

I support adoption of this draft.

Tom

---

From: "qinfengwei" <[email-masked]>
Date: Tue, 19 May 2020 16:21:20 +0800

Hi,
 I support the adoption of this document as ao-editor.

Thanks,
Fengwei Qin

-----邮件原件-----
发件人: ipv6 [mailto:[email-masked]] 代表 Bob Hinden
发送时间: 2020年5月16日 06:10
收件人: IPv6 List
抄送: Bob Hinden
主题: Adoption Call for "IPv6 Application of the Alternate Marking Method" 

Regards,
Bob and Ole

---

From: Jeff Tantsura <[email-masked]>
Date: Tue, 19 May 2020 14:37:15 -0700

yes, support

Cheers,
Jeff

---

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Wed, 20 May 2020 08:15:19 +0000

Hi 6man,

I support the adoption. The document is useful. 
It seems like the mechanism can work together with SRv6 Path Segment, which identifies an SRv6 Path Segment[1][2]. I think a better IPFPM solution can be provided by combining this two mechanisms.

Thanks,
Cheng

[1]. https://tools.ietf.org/html/draft-li-spring-srv6-path-segment-00
[2]. https://tools.ietf.org/html/draft-li-6man-srv6-path-segment-encap-00

-----Original Message-----
From: ipv6 [mailto:[email-masked]] On Behalf Of Bob Hinden
Sent: Saturday, May 16, 2020 6:10 AM
To: IPv6 List <[email-masked]>
Cc: Bob Hinden <[email-masked]>
Subject: Adoption Call for "IPv6 Application of the Alternate Marking Method" 

Regards,
Bob and Ole

---

From: Tim Chown <[email-masked]>
Date: Thu, 21 May 2020 13:40:56 +0100

Hi,

I support adoption of this draft as a WG item.

There is some ongoing work in the WLCG (the CERN experiment collaboration network) on packet marking to which the principles of this draft may be applicable, and about which I have emailed the authors.   

I note there is also the PDM RFC 8250 that defines a destination option, which is standards track rather than experimental.

Tim

> On 15 May 2020, at 23:10, Bob Hinden <[email-masked]> wrote:
>

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Fri, 22 May 2020 12:41:27 +0000

[Removing my internet area director hat for this post]

While this document is linked to other RFC and WG active documents, I would have appreciated a little more justification for this document. Especially, around the statement in section 2 " The only correct and robust choice that can actually be standardized". At least there is a informative reference to IPPM active documents :-) The security section is also pretty weak.

With the above lack of justification, I cannot "throw my voice" for WG adoption yet even if I like the idea and that I am sure that the document will be adopted later once the above issue is really fixed. (A simple email from the IPPM chairs will be enough -- if not yet done).

I cannot refrain to re-state my previous comment: the hop-by-hop is not really required here, what is actually needed is the ability to mark a packet and up to the routers in the path to do deep packet inspection to find this value. The only benefit of HbH is that it is required to be the first extension header (= less deep in the packet). Or another way to express my point: the extension header is not used in this case to change the forwarding/receiving function just as a placeholder for a 'FlowMonID' marker. Also, the lifetime of HbH in the Internet is pretty limited :-(

And with my AD hat back on: please use the right template for BCP 14 __

-éric

-----Original Message-----
From: ipv6 <[email-masked]> on behalf of Bob Hinden <[email-masked]>
Date: Saturday, 16 May 2020 at 00:10
To: IPv6 List <[email-masked]>
Cc: Bob Hinden <[email-masked]>
Subject: Adoption Call for "IPv6 Application of the Alternate Marking Method" 

    Regards,
    Bob and Ole

---

From: Giuseppe Fioccola <[email-masked]>
Date: Fri, 22 May 2020 15:09:46 +0000

Hi Eric,
Thanks for your comments.
My answers inline tagged as [GF]

Regards,

Giuseppe

-----Original Message-----
From: ipv6 [mailto:[email-masked]] On Behalf Of Eric Vyncke (evyncke)
Sent: Friday, May 22, 2020 2:41 PM
To: Bob Hinden <[email-masked]>; IPv6 List <[email-masked]>
Subject: Re: Adoption Call for "IPv6 Application of the Alternate Marking Method"

[GF]: In the next revision, we could emphasize the motivation for that sentence, in particular both the discussion about the earlier document (https://datatracker.ietf.org/doc/draft-fioccola-v6ops-ipv6-alt-mark/) and the mailing list threads regarding the different alternatives we have investigated (e.g. SRH TLV).

[GF]: Consider that we already had a discussion with IPPM Chairs, 6MAN Chairs and TSV AD Magnus Westerlund about the Intended Status of the document. The outcome was shared on the mailing list.

[GF]: We have agreed with the WG to describe all the possibilities for now (HbH, DOH, DOH + RH). Note that in the draft, it is reported the issue of HbH support and it is also mentioned this "non-conventional" use of DOH for hop by hop usage (as you suggest) but this is not recommended and many people are against this proposal, indeed it was also suggested to omit this consideration in the next revision. 

[GF]: Sure, we can revise the template for the next revision.

-éric

-----Original Message-----
From: ipv6 <[email-masked]> on behalf of Bob Hinden <[email-masked]>
Date: Saturday, 16 May 2020 at 00:10
To: IPv6 List <[email-masked]>
Cc: Bob Hinden <[email-masked]>
Subject: Adoption Call for "IPv6 Application of the Alternate Marking Method" 

    Regards,
    Bob and Ole

---

From: Ran Pang(联通集团联通网络技术研究院本部) <[email-masked]>
Date: Wed, 27 May 2020 06:20:41 +0000

Hi WG,

I support the adoption of this draft.
It’s very useful work for performance measurement.

Thanks,
Ran

From: Bob Hinden<mailto:[email-masked]>
Date: 2020-05-16 06:10
To: IPv6 List<mailto:[email-masked]>
CC: Bob Hinden<mailto:[email-masked]>
Subject: Adoption Call for "IPv6 Application of the Alternate Marking Method"
This message starts a two week 6MAN call on adopting:

Regards,
Bob and Ole

如果您错误接收了该邮件，请通过电子邮件立即通知我们。请回复邮件到 [email-masked]，即可以退订此邮件。我们将立即将您的信息从我们的发送目录中删除。 If you have received this email in error please notify us immediately by e-mail. Please reply to [email-masked] ,you can unsubscribe from this mail. We will immediately remove your information from send catalogue of our.

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Wed, 27 May 2020 07:04:57 +0000

Hi, 

I support the adoption of this document. It provides a useful feature for performance measurement in IPv6 network. 

Best regards,
Jie

> document should be directed to the mailing list. Editorial suggestions can be
> sent to the authors.  This adoption call will end on 29 May 2020.
> 
> There has been a lot of discussion on this draft, the chairs believe that the
> major issues raised on the list are resolved in this version of draft and it is
> ready for the working group to consider adopting as working group draft.
> 
> Could those who are willing to work on this document, either as contributors,
> authors or reviewers please notify the list.   That gives us an indication of
> the energy level in the working group
> to work on this.
> 
> Regards,
> Bob and Ole
>

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 27 May 2020 16:06:09 +0800

Hi,
I support the adoption of this document. It is useful for network operation and management.
Chongfeng

---

From: "Aijun Wang" <[email-masked]>
Date: Wed, 27 May 2020 16:07:07 +0800

Hi, Bob and Ole:

I support its adoption. The method is one straightforward method to measure
the network performance.

Best Regards.

Aijun Wang
China Telecom

-----邮件原件-----
发件人: ipv6 [mailto:[email-masked]] 代表 Bob Hinden
发送时间: 2020年5月16日 6:10
收件人: IPv6 List
抄送: Bob Hinden
主题: Adoption Call for "IPv6 Application of the Alternate Marking Method" 

Regards,
Bob and Ole

---

From: "[email-masked]" <[email-masked]>
Date: Thu, 28 May 2020 12:05:54 +0800

Hi 6man,
 
I do not support the adoption.
CRH is not compatible with SRv6 and SRH.CRH has many associated control plane and data plane drafts. However, it is unclear on how these various pieces of work fit together. The working group need the proper understanding on the overall architecture before adoption this draft.
 
In my option,SRv6 compression should be done based on SRv6. Regarding SRv6 compression, I prefer G-SRv6 instead of CRH.
 
Therefore, right now is not a good timing to adopt CRH or even any other solution.
 
Best regards,

Zhao Feng

China Academy of Information and Communication Technology

---

From: "[email-masked]" <[email-masked]>
Date: Thu, 28 May 2020 16:11:46 +0800

Hi, 6man

I do not support the adoption of this work.CRH defines a new data plane which is not compatible with SHR and SRv6. In addition, I think the use cases and security considerations are not clear enough.I think it's not the right timing to adopt CRH. Until now，there are other SRv6 and SRH compatible solutions, we should  compare the advantages and disadvantages of different solutions and choose the best one.

Best regards
Cong Li

-----Original Message-----
From: ipv6 [mailto:[email-masked]] On Behalf Of Bob Hinden
Sent: Saturday, May 16, 2020 6:10 AM
To: IPv6 List <[email-masked]>
Cc: Bob Hinden <[email-masked]>
Subject: Adoption Call for "IPv6 Application of the Alternate Marking Method"

 

 
 
Regards,
Bob and Ole

---

From: "qinfengwei" <[email-masked]>
Date: Thu, 28 May 2020 18:15:15 +0800

Hi,

There are too many issues required resolved. 
First is that CRH is a mapping table based solution, which means in a
large-scale multi-domain interconnect, like MPLS, the CRH suffers from the
large label stack and protection/ convergence challenges.
Second is that CRH and SRv6 are incompatible, which affects the existed
network deployment. 
Third is the security considerations are really not clear, meanwhile it is
very important for a operator.
The most important one is there are couple of similar solutions that need
discuss together.

I hope the WG could consider this point in the adoption call.

Thanks，
Fengwei Qin

-----邮件原件-----
发件人: ipv6 [mailto:[email-masked]] 代表 Bob Hinden
发送时间: 2020年5月16日 06:10
收件人: IPv6 List
抄送: Bob Hinden
主题: Adoption Call for "IPv6 Application of the Alternate Marking Method" 

Regards,
Bob and Ole

---

From: "qinfengwei" <[email-masked]>
Date: Thu, 28 May 2020 18:54:14 +0800

Hi,

I'm sorry to click on the wrong email accidentally, I made a half-hearted
mistake in the meeting just now, please ignore the last email. 
I have supported the adoption of this draft as co-editor.
The attachment is the supported email sent before.

Thanks,
Fegnwei Qin

-----邮件原件-----
发件人: ipv6 [mailto:[email-masked]] 代表 qinfengwei
发送时间: 2020年5月28日 18:15
收件人: 'Bob Hinden'; 'IPv6 List'
主题: 答复: Adoption Call for "IPv6 Application of the Alternate Marking
Method" 

Hi,

Thanks，
Fengwei Qin

-----邮件原件-----
发件人: ipv6 [mailto:[email-masked]] 代表 Bob Hinden
发送时间: 2020年5月16日 06:10
收件人: IPv6 List
抄送: Bob Hinden
主题: Adoption Call for "IPv6 Application of the Alternate Marking Method" 

Regards,
Bob and Ole

Subject: 答复: Adoption Call for "IPv6 Application of the Alternate Marking Method"
From: "qinfengwei" <[email-masked]>
To: "'Bob Hinden'" <[email-masked]>, "'IPv6 List'" <[email-masked]>
Date: Tue, 19 May 2020 16:21:20 +0800

Hi,

Thanks,
Fengwei Qin

-----邮件原件-----
发件人: ipv6 [mailto:[email-masked]] 代表 Bob Hinden
发送时间: 2020年5月16日 06:10
收件人: IPv6 List
抄送: Bob Hinden
主题: Adoption Call for "IPv6 Application of the Alternate Marking Method" 

Regards,
Bob and Ole

---

From: Bob Hinden <[email-masked]>
Date: Fri, 29 May 2020 13:32:55 -0700

This email concludes the Adoption Call for "IPv6 Application of the Alternate Marking Method”.

The 6man chairs determine that this document is adopted as a 6MAN working group document.

The authors should submit the next revision as an 6MAN document: draft-ietf-6man-ipv6-alt-mark-00 .

Bob & Ole

> On May 15, 2020, at 3:10 PM, Bob Hinden <[email-masked]> wrote:
>

---

From: Giuseppe Fioccola <[email-masked]>
Date: Sat, 30 May 2020 07:42:47 +0000

Dear Bob and Ole,
Thanks! We have just submitted draft-ietf-6man-ipv6-alt-mark-00 for your approval.
We took the opportunity to apply some minor changes and to include a new section about the Uniqueness of FlowMonID as outcome of the discussion with Tom and Brian.

Regards,

Giuseppe 

-----Original Message-----
From: ipv6 [mailto:[email-masked]] On Behalf Of Bob Hinden
Sent: Friday, May 29, 2020 10:33 PM
To: Bob Hinden <[email-masked]>
Cc: IPv6 List <[email-masked]>
Subject: Conclusion of the Adoption Call for "IPv6 Application of the Alternate Marking Method" 

Bob & Ole