Subject: Re: Adoption Call for "The IPv6 Compact Routing Header (CRH)"

From: 刘毅松 <[email-masked]>
Date: Tue, 26 May 2020 12:51:20 +0800

Hi 6man WG,

I do not support the adoption.

For CRH based solution, the VPN context is encoded in a Destination Option
header located after the CRH. At the egress PE, the packet arrives with both
CRH and Destination Option headers. The egress PE will need to process TLVs
in DOH, which is not hardware efficient. The same applies to Ingress PE that
need to encapsulate topological instructions in CRH and service instructions
in DOH.

I think there is no need for defining a new data-plane (CRH) apparently more
complicated.

I hope the WG could consider this point in the adoption call.

Thanks
Yisong

-----邮件原件-----
发件人: ipv6 <[email-masked]> 代表 Bob Hinden
发送时间: 2020年5月16日 06:14
收件人: IPv6 List <[email-masked]>
抄送: Bob Hinden <[email-masked]>
主题: Adoption Call for "The IPv6 Compact Routing Header (CRH)"

This message starts a two-week 6MAN call on adopting:

 Title:          The IPv6 Compact Routing Header (CRH)
 Authors:        R. Bonica, Y. Kamite, T. Niwa, A. Alston, L. Jalil
 File Name:      draft-bonica-6man-comp-rtg-hdr-21
 Document date:  2020-05-14

 https://tools.ietf.org/html/draft-bonica-6man-comp-rtg-hdr

as a working group item. Substantive comments regarding adopting this
document should be directed to the mailing list.  Editorial suggestions can
be sent to the authors.

Please note that this is an adoption call, it is not a w.g. last call for
advancement, adoption means that it will become a w.g. draft.  As the
working group document, the w.g. will decide how the document should change
going forward.

This adoption call will end on 29 May 2020.

The chairs note there has been a lot of discussions on the list about this
draft.   After discussing with our area directors, we think it is
appropriate to start a working group adoption call.  The authors have been
active in resolving issues raised on the list.

Could those who are willing to work on this document, either as
contributors, authors or reviewers please notify the list.   That gives us
an indication of the energy level in the working group
to work on this.

Regards,
Bob and Ole

---

From: "[email-masked]" <[email-masked]>
Date: Tue, 26 May 2020 13:12:16 +0800

Hi ,

IMO, more negiciations are needed for the document, as it is related to other working groups as well, and many diffrent ideas exit.
 
Best Regards
Zongpeng Du

[email-masked]
 
发件人： 刘毅松
发送时间： 2020-05-26 12:51
收件人： 'Bob Hinden'; 'IPv6 List'
主题： Re: Adoption Call for "The IPv6 Compact Routing Header (CRH)"
Hi 6man WG,

 

Thanks
Yisong
 
-----邮件原件-----
发件人: ipv6 <[email-masked]> 代表 Bob Hinden
发送时间: 2020年5月16日 06:14
收件人: IPv6 List <[email-masked]>
抄送: Bob Hinden <[email-masked]>
主题: Adoption Call for "The IPv6 Compact Routing Header (CRH)"

 

 

 
Regards,
Bob and Ole

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Srihari Sangli <[email-masked]>
Date: Tue, 26 May 2020 05:58:25 +0000

Leveraging the IPv6 headers to achieve a functionality - I won't treat this as complicated. There is a reason Destination Options header was introduced in base IPv6 architecture. The proposal leverages just that. CRH is a generic routing header.

I don't agree with your assessment that its complicated. Thanks.

srihari…

On 26/05/20, 10:22 AM, "ipv6 on behalf of 刘毅松" <[email-masked] on behalf of [email-masked]> wrote:

    [External Email. Be cautious of content]

    Hi 6man WG,

    Thanks
    Yisong

    -----邮件原件-----
    发件人: ipv6 <[email-masked]> 代表 Bob Hinden
    发送时间: 2020年5月16日 06:14
    收件人: IPv6 List <[email-masked]>
    抄送: Bob Hinden <[email-masked]>
    主题: Adoption Call for "The IPv6 Compact Routing Header (CRH)"

     https://urldefense.com/v3/__https://tools.ietf.org/html/draft-bonica-6man-comp-rtg-hdr__;!!NEt6yMaO-gk!T3DQGGwlj2rBGOCC0VGYHrukx9elCyFBoc8HzNdgm98N20dLsTIQ13hRzOUyUB8$

    Regards,
    Bob and Ole

    --------------------------------------------------------------------
    IETF IPv6 working group mailing list
    [email-masked]
    Administrative Requests: https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/ipv6__;!!NEt6yMaO-gk!T3DQGGwlj2rBGOCC0VGYHrukx9elCyFBoc8HzNdgm98N20dLsTIQ13hRFttl0SA$
    --------------------------------------------------------------------

Juniper Business Use Only

---

From: "Peng Liu" <[email-masked]>
Date: Tue, 26 May 2020 14:30:37 +0800

Hi,

+1 with Du. I do not support the adoption.

It needs more discussion among several ideas at this stage and some of them may be deployed already.

Regards,
Peng Liu

[email-masked]
 
发件人： [email-masked]
发送时间： 2020-05-26 13:12
收件人： 'Bob Hinden'; 'IPv6 List'
主题： 回复: Re: Adoption Call for "The IPv6 Compact Routing Header (CRH)"
Hi ,

 
Best Regards
Zongpeng Du

[email-masked]
 
发件人： 刘毅松
发送时间： 2020-05-26 12:51

 

Thanks
Yisong
 
-----邮件原件-----
发件人: ipv6 <[email-masked]> 代表 Bob Hinden
发送时间: 2020年5月16日 06:14
收件人: IPv6 List <[email-masked]>
抄送: Bob Hinden <[email-masked]>
主题: Adoption Call for "The IPv6 Compact Routing Header (CRH)"

 

 

 
Regards,
Bob and Ole