Subject: Reply: Re: New Version Notification for draft-fz-6man-ipv6-alt-mark-08.txt

From: Giuseppe Fioccola <[email-masked]>
Date: Fri, 1 May 2020 17:04:45 +0000

Hi Bob,
Thanks a lot for your review and feedback.

You are right, there are still few considerations about SRH TLV just to mention this possibility, but we state clearly that Hop-By-Hop Options and Destination Options are the best and only ways.

Anyway, I agree with you, this may create confusion. I will produce a new version soon and will remove any mention of using SRH TLV.

Best Regards,

Giuseppe

________________________________

Giuseppe Fioccola
Mobile: +49-15222812418<tel:+49-15222812418>
Email: [email-masked]<mailto:[email-masked]>

From: Bob Hinden<[email-masked]<mailto:[email-masked]>>
To: Giuseppe Fioccola<[email-masked]<mailto:[email-masked]>>
Cc: Bob Hinden<[email-masked]<mailto:[email-masked]>>;IPv6 List<[email-masked]<mailto:[email-masked]>>
Subject: Re: New Version Notification for draft-fz-6man-ipv6-alt-mark-08.txt
Time: 2020-04-30 20:52:49

Giuseppe and Tianran,

Good to see most of the issues discussed on the list accounted for in this version.

I continue to think it’s inappropriate to include any mention of using this option in SRH TLVs.   The draft is proposing to standardize its use as a SRH TLV and includes an IANA request to allocate a code point.  This was not the intended use for TLVs when SRH was standardized in 6MAN.

I think all mention of its use as a SRH TLV should be removed from the document.

Bob

> On Apr 30, 2020, at 1:36 AM, Giuseppe Fioccola <[email-masked]> wrote:
>
> Dear All,
> We published this new revision of the draft and it includes the changes that have been agreed with Bob, Ole and Magnus after the interim meeting.
> In particular we have now described in detail how the alternate marking method can work for IPv6, in order to move RFC 8321 from normative to informative reference. A new Section "Alternate Marking Method Operation" has been introduced for this purpose.
> In addition we have added more considerations about the use of HBH to address the outcome of the discussion with Eric, Ole and Tom on the mailing list.
>
> We would really appreciate hearing your thoughts and inputs.
>
> Best Regards,
>
> Giuseppe and Tianran
>
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Thursday, April 30, 2020 9:19 AM
> To: Fengwei Qin <[email-masked]>; Giuseppe Fioccola <[email-masked]>; Tianran Zhou <[email-masked]>; Mauro Cociglio <[email-masked]>
> Subject: New Version Notification for draft-fz-6man-ipv6-alt-mark-08.txt
>
>
> A new version of I-D, draft-fz-6man-ipv6-alt-mark-08.txt
> has been successfully submitted by Giuseppe Fioccola and posted to the IETF repository.
>
> Name:         draft-fz-6man-ipv6-alt-mark
> Revision:     08
> Title:                IPv6 Application of the Alternate Marking Method
> Document date:        2020-04-30
> Group:                Individual Submission
> Pages:                13
> URL:            https://www.ietf.org/internet-drafts/draft-fz-6man-ipv6-alt-mark-08.txt
> Status:         https://datatracker.ietf.org/doc/draft-fz-6man-ipv6-alt-mark/
> Htmlized:       https://tools.ietf.org/html/draft-fz-6man-ipv6-alt-mark-08
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-fz-6man-ipv6-alt-mark
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-fz-6man-ipv6-alt-mark-08
>
> Abstract:
>   This document describes how the Alternate Marking Method can be used
>   as the passive performance measurement tool in an IPv6 domain and
>   reports implementation considerations.  It proposes how to define a
>   new Extension Header Option to encode alternate marking technique and
>   also the Segment Routing case is discussed.
>
>
>
>
>
> Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.
>
> The IETF Secretariat
>
>
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

---

From: Bob Hinden <[email-masked]>
Date: Fri, 1 May 2020 12:23:09 -0700

Giuseppe,

> On May 1, 2020, at 10:04 AM, Giuseppe Fioccola <[email-masked]> wrote:
> 
> Hi Bob,

Great!

Thanks,
Bob

> 
> Best Regards,
> 
> Giuseppe
> 
> 
> 
> Giuseppe Fioccola
> Mobile: +49-15222812418
> Email: [email-masked]
> 
> 
> From: Bob Hinden<[email-masked]>
> To: Giuseppe Fioccola<[email-masked]>
> Cc: Bob Hinden<[email-masked]>;IPv6 List<[email-masked]>

---

From: Giuseppe Fioccola <[email-masked]>
Date: Mon, 4 May 2020 08:56:20 +0000

Hi Bob,
We have just published the -09 version with the agreed modifications.

Regards,

Giuseppe

-----Original Message-----
From: Bob Hinden [mailto:[email-masked]] 
Sent: Friday, May 1, 2020 9:23 PM
To: Giuseppe Fioccola <[email-masked]>
Cc: Bob Hinden <[email-masked]>; IPv6 List <[email-masked]>
Subject: Re: Reply: Re: New Version Notification for draft-fz-6man-ipv6-alt-mark-08.txt

Giuseppe,

Great!

Thanks,
Bob

> > To: Fengwei Qin <[email-masked]>; Giuseppe Fioccola 
> > <[email-masked]>; Tianran Zhou 
> > <[email-masked]>; Mauro Cociglio 
> > <[email-masked]>
> > IETF IPv6 working group mailing list [email-masked] Administrative 
> > Requests: https://www.ietf.org/mailman/listinfo/ipv6