Subject: wget patch for RFC6874(bis)

From: Brian E Carpenter <[email-masked]>
Date: Sat, 2 Oct 2021 17:16:19 +1300

I decided it was worth looking into one of the URL parsers to find out how hard it is to implement zone IDs for link-local addresses. I picked wget on Linux as being self-contained and acessible, and the answer is: not very hard. Actually, two lines of C.

More at https://github.com/becarpenter/wget6 (accessible only using an obsolete IP version). Read the wget-6874bis file first.

Regards
    Brian

---

From: Lorenzo Colitti <[email-masked]>
Date: Mon, 4 Oct 2021 09:43:00 +0900

Did you send it upstream for review?

On Sat, Oct 2, 2021 at 1:16 PM Brian E Carpenter <
[email-masked]> wrote:

> I decided it was worth looking into one of the URL parsers to find out how
> hard it is to implement zone IDs for link-local addresses. I picked wget on
> Linux as being self-contained and acessible, and the answer is: not very
> hard. Actually, two lines of C.
>
> More at https://github.com/becarpenter/wget6 (accessible only using an
> obsolete IP version). Read the wget-6874bis file first.
>
> Regards
>     Brian
>
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
>

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 4 Oct 2021 14:13:19 +1300

> Did you send it upstream for review?

No. I would certainly do that if the WG decides to pursue this work.
But it really should be checked for Windows first, and converting
zone ids to zone indexes is definitely different in Windows.

Of course, if you want it for Android, feel free, it's GPL.

I noticed ifdefs for VMS in the wget code too ;-). If anybody wants
zone id support in wget on VMS, they're on their own.

(Technically speaking, it also implements RFC6874, so I might submit
it anyway, depending on where we end up.)

   Brian

> 
> On Sat, Oct 2, 2021 at 1:16 PM Brian E Carpenter <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     More at https://github.com/becarpenter/wget6 <https://github.com/becarpenter/wget6> (accessible only using an obsolete IP version). Read the 
wget-6874bis file first.
>     [email-masked] <mailto:[email-masked]>
<https://www.ietf.org/mailman/listinfo/ipv6>

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 5 Oct 2021 17:44:57 +1300

Then I thought I'd see whether I could fix curl, but a quick glance at the source code and a quick test on cygwin shows that it already supports zone ids (but not using %25):

brian@DESKTOP-3TKH2O8 ~
$ curl http://[fe80::3e2a:fdff:fea4:dde7%7]
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0<!DOCTYPE html>
<html lang="en">
<head>
<meta http-equiv=content-type content="text/html; charset=utf-8" />
<meta http-equiv="Cache-Control" content="private, no-transform" />

etc etc.

I'm looking at Firefox, but that's a bigger job...

Regards
   Brian Carpenter