Subject: [ire] Protocol or format?

From: Stephane Bortzmeyer <[email-masked]>
Date: Fri, 22 Jan 2010 11:33:17 +0100

Ed Lewis, in his first message, mentioned a protocol. I thought the
idea was to devise a format? I don't think a common protocol is
realistic.

---

From: James Gould <[email-masked]>
Date: Fri, 22 Jan 2010 08:36:55 -0500

I concur.  I believe that it would be a common file format and also a common
transport for the file.  Is this the case?

-- 

JG 

-------------------------------------------------------
James F. Gould
Principal Software Engineer
VeriSign Naming Services
[email-masked]
Direct: 703.948.3271
Mobile: 703.628.7063

21345 Ridgetop Circle
LS2-2-1
Dulles, VA 20166

Notice to Recipient:  This e-mail contains confidential, proprietary and/or
Registry  Sensitive information intended solely for the recipient and, thus
may not be  retransmitted, reproduced or disclosed without the prior written
consent of  VeriSign Naming and Directory Services.  If you have received
this e-mail message in error, please notify the sender immediately by
telephone or reply e-mail and destroy the original message without making a
copy.  Thank you.

From: Stephane Bortzmeyer <[email-masked]>
Organization: NIC France
Date: Fri, 22 Jan 2010 05:33:17 -0500
To: <[email-masked]>
Subject: [ire] Protocol or format?

Ed Lewis, in his first message, mentioned a protocol. I thought the
idea was to devise a format? I don't think a common protocol is
realistic.
_______________________________________________
ire mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ire

---

From: James M Galvin <[email-masked]>
Date: Fri, 22 Jan 2010 08:45:16 -0500

It's about the data itself more so than the format.  What is it that 
needs to be escrowed?  Then it's the format and the transport.

Jim

-- On January 22, 2010 11:33:17 AM +0100 Stephane Bortzmeyer 
<[email-masked]> wrote regarding [ire] Protocol or format? --

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Fri, 22 Jan 2010 14:59:38 +0100

On Fri, Jan 22, 2010 at 08:36:55AM -0500,
 James Gould <[email-masked]> wrote 
 a message of 127 lines which said:

> I believe that it would be a common file format and also a common
> transport for the file.

That's not my vision. We need to specify the data (as said by James M
Galvin) then the format but we may leave the transport unspecified,
escrowing is typically not a real-time process and does not require an
official transport (rsync or DVD are fine for me).

---

From: James Gould <[email-masked]>
Date: Fri, 22 Jan 2010 09:31:37 -0500

Yes, I agree that the data comes first (what and how much).  The format of
the data is also important to ensure that software can be written that can
easily process any escrow data deposited.    The transport is less of an
issue, but it would be good if there was an agreed upon secure transport for
the escrow data.  Are the files encrypted, are they unencrypted and passed
across an encrypted transport, or a combination.  My concern is related to
the encryption of the data itself to again ensure that software can easily
process escrowed data in a standard and ³secure² manor.

-- 

JG 

21345 Ridgetop Circle
LS2-2-1
Dulles, VA 20166

From: James M Galvin <[email-masked]>
Date: Fri, 22 Jan 2010 08:45:16 -0500
To: <[email-masked]>
Subject: Re: [ire] Protocol or format?

Jim

---

From: John Curran <[email-masked]>
Date: Fri, 22 Jan 2010 09:37:18 -0500

Some IRE Charter Questions - 

Scope 

- Internet resource registry data in general, or 
 just registry data needed for escrow purposes?

 i.e.  Presently the RIR's publish 'daily files',
 containing summaries of number resource changes
 for each day, these files are used for statistics 
 and for informing the operational/security community 
 about resource allocations.  The RIR's have worked
 to bring about more commonality on publication 
 format; would this also be a potential use for 
 the format being considered by the working group, 
 or it is specifically targeted at escrow purposes?

- Public Internet resource registry data, or also 
 private/NDA data and/or metadata?  

 While we all know what shows up in WHOIS, there's 
 actually quite a bit of data behind the scenes
 regarding allocation and change history which is
 not visible but still important to have, and then
 there's related private information which is part
 of the resource request history.  How much of this
 is being considered in the data format?

- Incremental updates in scope of format or not?

 If we're focusing on formats and have protocol 
 out of scope, it may be necessary to determine 
 if incremental escrow updates are in scope (and
 hence require us to include necessary sync data)
 or whether this is purely a protocol matter.

Many of the above issues might be clarified by 
elaborating a problem statement or use cases...

Thanks,
/John

---

From: James Gould <[email-masked]>
Date: Fri, 22 Jan 2010 10:13:42 -0500

John,

I would see the data as being full and partial registry data that represents
all of the registered data (domains, hosts, etc.), the relationships, the
sponsorship information (Registrar information) of the objects, and finally
any additional meta-data needed to reconstitute the data.  I don¹t see the
summary data as being in scope.  I¹m assuming data like private keys held in
HSM¹s for DNSSEC signing is not included.  The full deposit could be done
less frequently (i.e. Weekly) and the partial deposits would include the
delta changes more frequently (i.e. Daily).  I see the deposits as files
following a pre-defined file format and hopefully secured in a standard way.

-- 

JG 

21345 Ridgetop Circle
LS2-2-1
Dulles, VA 20166

From: John Curran <[email-masked]>
Date: Fri, 22 Jan 2010 09:37:18 -0500
To: <[email-masked]>
Subject: Re: [ire] Protocol or format?

Scope

Thanks,
/John

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Fri, 22 Jan 2010 16:21:43 +0100

On Fri, Jan 22, 2010 at 09:37:18AM -0500,
 John Curran <[email-masked]> wrote 
 a message of 47 lines which said:

> - Public Internet resource registry data, or also private/NDA data
>  and/or metadata?

Certainly private data also. Use case: AFNIC does not, by default,
distribute personal data of .FR registrants who are physical
persons. But we have this data and a real escrow of course needs it
(otherwise it would not be possible to restart the registry.)

---

From: James M Galvin <[email-masked]>
Date: Fri, 22 Jan 2010 10:29:23 -0500

I agree with you that these are important topics for discussion.

Jim

-- On January 22, 2010 9:31:37 AM -0500 James Gould 
<[email-masked]> wrote regarding Re: [ire] Protocol or format? --

> Yes, I agree that the data comes first (what and how much).  The
> format of the data is also important to ensure that software can be
> written that can easily process any escrow data deposited.    The
> transport is less of an issue, but it would be good if there was an
> agreed upon secure transport for the escrow data.  Are the files
> encrypted, are they unencrypted and passed across an encrypted
> transport, or a combination.  My concern is related to the encryption
> of the data itself to again ensure that software can easily process
> escrowed data in a standard and “secure” manor.

---

From: James M Galvin <[email-masked]>
Date: Fri, 22 Jan 2010 10:31:51 -0500

Good questions John.  I think they should be in scope for the working 
group but we'll have to see what comes from the BOF discussion.

Jim

-- On January 22, 2010 9:37:18 AM -0500 John Curran <[email-masked]> 
wrote regarding Re: [ire] Protocol or format? --