Subject: Re: [ire] XML or not

From: "Michael Young" <[email-masked]>
Date: Tue, 23 Nov 2010 21:44:22 -0500

From: Michael Young [mailto:[email-masked]] 
Sent: November-23-10 8:31 PM
To: [email-masked]
Subject: XML or not

Hi all,

I've been thinking more about the XML issue, in general the verbosity makes
me cringe, however there remains the issue of dealing with non-ascii data in
our new IDN.IDN registries.  There's more than one way of solving for that,
but it all involves some form of encoding.  James I was wondering if you
have any thoughts there,.....

Best Regards,

Michael Young

Vice President, Product Development

Afilias

O:416-673-4109

M:+1-647-289-1220

---

From: Chris Wright <[email-masked]>
Date: Wed, 24 Nov 2010 16:42:18 +1100

All,

I believe using XML is the most sensible approach for a number of reasons:

*         Most Domain Name Registries use EPP as their primary provisioning protocol. EPP is based on XML and allows for many 'localised' fields, especially in contact data, that will contain non-ASCII information. Combine this with some new Registries needing to deal with IDNs it just makes sense. XML provides an easy to use, well understood way of dealing with encodings other than ASCII;

*         Dealing with XML in implementation is fairly easy, standards compliant, validating parsers exist in most programming languages, no need to write parsers from scratch;

*         Given that most Registries / Registrars needed 'XML expertise' to construct EPP interfaces, it shouldn't be a big step for them;

*         The 'bloat' or verbosity that has been referred to isn't really a significant issue these days, and this downside is far outweighed by the ease of use, rapid implementation time and other benefits we get from using XML. There are ways to reduce the size overhead of XML by declaring default namespaces and so forth. Besides XML compresses extremely well;

*         XML already has ways (example using schemas) to ensure data is in required formats / valid according to rules, the EPP schemas are a great starting point / input to use when creating the required schemas.

Thanks

Chris Wright
Chief Technology Officer
AusRegistry Pty Ltd

From: [email-masked] [mailto:[email-masked]] On Behalf Of Michael Young
Sent: Wednesday, 24 November 2010 1:44 PM
To: [email-masked]
Subject: Re: [ire] XML or not

Hi all,

I've been thinking more about the XML issue, in general the verbosity makes me cringe, however there remains the issue of dealing with non-ascii data in our new IDN.IDN registries.  There's more than one way of solving for that, but it all involves some form of encoding.  James I was wondering if you have any thoughts there,...........

Best Regards,

Michael Young