Subject: [ire] About Host Data Issue

From: "liushuo@knet" <[email-masked]>
Date: Wed, 15 May 2013 16:57:14 +0800

Hi All,

We are puzzled with the host data in deposit, we used to think that the host data should be the name servers associated with domain in the deposit, in this case some other gTLD's NSes may be  included in deposits such as ns1.google.com,etc. 
But now we tend to believe that the hosts under the same registry should be the answer, that is only the hosts under new gTLD 'xn--fiq64b' should be included in xn--fiq64b's deposit file. 

Are we right? Or both of the hosts under the registry and the NSes which may not under the registry should be included?

Regards,
Stuart

---

From: "Gould, James" <[email-masked]>
Date: Wed, 15 May 2013 12:41:56 +0000

Stuart,

I believe that both internal and external hosts need to be included in the deposit, since the goal of the deposit is to capture the information contained in the registry database.  Both internal and external hosts are first-class objects in the registry database, so they must be included in the deposit.  The name server links between the domain names and the hosts should result in an objects at both ends of the links, meaning external hosts cannot be excluded from the deposit to make the links complete.

--

JG

James Gould
Principal Software Engineer
[email-masked]

703-948-3271 (Office)
12061 Bluemont Way
Reston, VA 20190
VerisignInc.com

From: "liushuo@knet" <[email-masked]<mailto:[email-masked]>>
Reply-To: liushuo <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, May 15, 2013 4:57 AM
To: ire <[email-masked]<mailto:[email-masked]>>
Subject: [ire] About Host Data Issue

Hi All,

Regards,
Stuart

---

From: James Mitchell <[email-masked]>
Date: Thu, 16 May 2013 00:18:18 +1000

I see no need for a deposit to include external hosts, however their omission may complicate the process of restoring a registry. Furthermore, I'd expect escrow agents check that all name-server associations have corresponding host objects, where host objects are used.

Regards,
James

From: <Gould>, James <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, 15 May 2013 10:41 PM
To: liushuo <[email-masked]<mailto:[email-masked]>>, ire <[email-masked]<mailto:[email-masked]>>
Subject: Re: [ire] About Host Data Issue

Stuart,

--

JG

James Gould
Principal Software Engineer
[email-masked]<mailto:[email-masked]>

703-948-3271 (Office)
12061 Bluemont Way
Reston, VA 20190
VerisignInc.com

Hi All,

Regards,
Stuart

---

From: Francisco Obispo <[email-masked]>
Date: Wed, 15 May 2013 08:35:54 -0700

Hi James,

On May 15, 2013, at 7:18 AM, James Mitchell <[email-masked]> wrote:

> I see no need for a deposit to include external hosts, however their omission may complicate the process of restoring a registry.

I believe they both need to be included, because the sponsorship component is very important. 

>  Furthermore, I'd expect escrow agents check that all name-server associations have corresponding host objects, where host objects are used.
> 

It would be ideal if we could get some clarity with regards of what type of checks Escrow agents are supposed to be doing.

They could technically:

A) Verify just the signature
B) Verify the signature + schema
C) Verify the signature + schema + object relationships
D) Do none of the above

> James

Francisco Obispo 
Director of Applications and Services - ISC
email: [email-masked]
Phone: +1 650 423 1374 || INOC-DBA *3557* NOC
PGP KeyID = B38DB1BE

---

From: Gustavo Lozano <[email-masked]>
Date: Wed, 15 May 2013 08:44:35 -0700

Hi All,

Comments in line.

Regards,
Gustavo

On 5/15/13 8:35 AM, "Francisco Obispo" <[email-masked]> wrote:

>Hi James,
>
>
>
>On May 15, 2013, at 7:18 AM, James Mitchell
><[email-masked]> wrote:
>
>> I see no need for a deposit to include external hosts, however their
>>omission may complicate the process of restoring a registry.
>
>
>>  Furthermore, I'd expect escrow agents check that all name-server
>>associations have corresponding host objects, where host objects are
>>used.
>> 
>
>It would be ideal if we could get some clarity with regards of what type
>of checks Escrow agents are supposed to be doing.

The answer is C + other validations (e.g. NNDN comparison with Domain Name)

>_______________________________________________
>ire mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/ire

---

From: "liushuo@knet" <[email-masked]>
Date: Thu, 16 May 2013 17:28:35 +0800

Hi All,

So it is recommended that the external hosts could not be included, right?

Regards,
Stuart

From: Gustavo Lozano
Date: 2013-05-15 23:44
To: Francisco Obispo; James Mitchell
CC: liushuo; ire
Subject: Re: [ire] About Host Data Issue
Hi All,

Comments in line.

Regards,
Gustavo