Subject: [irs-discuss] if-map example

From: Pedro Roque Marques <[email-masked]>
Date: Thu, 2 Aug 2012 11:07:40 -0700

As i pointed out in the RT area meeting, i believe that IF-MAP is a successful example of what can be achieved by network-wide schemas (vs network element schemas).

The current spec is at:
http://www.trustedcomputinggroup.org/files/resource_files/2888CAD9-1A4B-B294-D0ED95712B121FEF/TNC_IFMAP_v2_1r15.pdf

if-map.org has lots of material on the use cases.

As per my comment on the mic, i'd like to encourage the IRS to focus on data schemas that describe network state.

thank you,
  Pedro.

---

From: Ping Pan <[email-masked]>
Date: Thu, 2 Aug 2012 14:32:59 -0700

After playing around with a bunch of other schemes, this indeed is one of
the better ones to use as the base.

Ping

On Thu, Aug 2, 2012 at 11:07 AM, Pedro Roque Marques <
[email-masked]> wrote:

> As i pointed out in the RT area meeting, i believe that IF-MAP is a
> successful example of what can be achieved by network-wide schemas (vs
> network element schemas).
>
> The current spec is at:
>
> As per my comment on the mic, i'd like to encourage the IRS to focus on
> data schemas that describe network state.
>
> thank you,
>   Pedro.
> _______________________________________________
> irs-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/irs-discuss
>

---

From: Pedro Roque Marques <[email-masked]>
Date: Thu, 2 Aug 2012 15:18:48 -0700

As an additional example, the following document describes a schema that can be used to provision a VPN (which is implemented by many PEs as individual VRFs).
http://datatracker.ietf.org/doc/draft-marques-l3vpn-schema

The document is still in its early stages.

The problems that can be solved by such a schema is to be able to, for instance:
1) Query the MAP database for all PEs where a specific VPN is present.
2) Ensure that the VRFs associated with a specific VPN consistently implement the same policy.

These are both examples of functionality that spans the network rather than be localized to a specific router/switch/appliance.

On Aug 2, 2012, at 2:32 PM, Ping Pan wrote:

> After playing around with a bunch of other schemes, this indeed is one of the better ones to use as the base.
> 
> Ping
> 
> On Thu, Aug 2, 2012 at 11:07 AM, Pedro Roque Marques <[email-masked]> wrote:

---

From: Ping Pan <[email-masked]>
Date: Thu, 2 Aug 2012 15:35:19 -0700

And this can be extended to apply more than L3VPN...

On Thu, Aug 2, 2012 at 3:18 PM, Pedro Roque Marques <
[email-masked]> wrote:

> As an additional example, the following document describes a schema that
> can be used to provision a VPN (which is implemented by many PEs as
> individual VRFs).
> These are both examples of functionality that spans the network rather
> than be localized to a specific router/switch/appliance.
>
>

---

From: Alia Atlas <[email-masked]>
Date: Thu, 2 Aug 2012 19:29:37 -0400

Pedro,

Thanks for sending out the references.  I'll definitely take a look.

Alia

---

From: Susan Hares <[email-masked]>
Date: Thu, 2 Aug 2012 23:39:01 +0000

Ping and pedro:

What’s nice here is this is an interesting provisioning schema.  Did you have production code or rough code that you tried this with?

Sue

From: [email-masked] [mailto:[email-masked]] On Behalf Of Ping Pan
Sent: Thursday, August 02, 2012 3:35 PM
To: Pedro Roque Marques
Cc: [email-masked]
Subject: Re: [irs-discuss] if-map example

And this can be extended to apply more than L3VPN...
On Thu, Aug 2, 2012 at 3:18 PM, Pedro Roque Marques <[email-masked]<mailto:[email-masked]>> wrote:
As an additional example, the following document describes a schema that can be used to provision a VPN (which is implemented by many PEs as individual VRFs).
http://datatracker.ietf.org/doc/draft-marques-l3vpn-schema

Ping
On Thu, Aug 2, 2012 at 11:07 AM, Pedro Roque Marques <[email-masked]<mailto:[email-masked]>> wrote:
As i pointed out in the RT area meeting, i believe that IF-MAP is a successful example of what can be achieved by network-wide schemas (vs network element schemas).

The current spec is at:

if-map.org<http://if-map.org/> has lots of material on the use cases.

thank you,
  Pedro.
_______________________________________________
irs-discuss mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/irs-discuss