Subject: Re: [irs-discuss] I-D Action: draft-ward-irs-framework-00.txt

From: Susan Hares <[email-masked]>
Date: Wed, 1 Aug 2012 17:58:09 +0000

Alia:

The hierarchical of interfaces (To routing system) is one of the areas that requires prioritization. The prioritization must be able to handle "preempt me", "after you", and "after me".  

It is also key to understand that irs system must handle multi-interfaces struggles at the lowest layer.  You need to look at the MIF WG (+/-) for some of the struggles of mobility. 

-----Original Message-----
From: Alia Atlas [mailto:[email-masked]] 
Sent: Monday, July 30, 2012 6:33 PM
To: Susan Hares
Cc: Joel M. Halpern; [email-masked]
Subject: Re: [irs-discuss] I-D Action: draft-ward-irs-framework-00.txt

Hi Sue,

On Mon, Jul 30, 2012 at 9:16 PM, Susan Hares <[email-masked]> wrote:
> Joel and irs-folks:
>
> +1 on Joel.
>
>  Beyond your comments, the requirement prioritization of the interworking of these interfaces is not clearly delineated in this work. This type of prioritization and sequencing is key to multi-interfaces operation on the monitoring, configuration or insertion of information into the depth.

[Alia] Can you further clarify, maybe with an example, which aspect
you are thinking of?   Do you mean the ability of an application to
access multiple sub-interfaces?  The interaction of operations
requested by differerent applications?

> In addition, if you are going to do configuration with roll-forward/roll-back - you need a transaction based processing.

[Alia] I'm pretty sure that I avoided the word "transaction" in both
drafts.  That was deliberate.  Of course, we can have a discussion
about whether or not some form of transactions might be desirable.  I
am concerned about their potentially heavy-weight nature.

> Therefore, you've skipped even requiring the hard problems.

[Alia] Can I optimistically pretend that means that the requirements
we do have don't seem too hard?  For the responsiveness and throughput
goals, I've put a stake in the ground to avoid transaction-based
semantics.  Naturally, the hordes can run over that stake, if
necessary.

[Sue]: The requirements are necessary even if they are hard.  

[Alia] For the interaction between different layers of sub-interfaces,
I've been assuming that we'll define the interactions between the
layers based on how they are generally done.  For instance, perhaps we
standardize the idea of preference value - and then the RIB can pick
the best route based upon those preferences.  For interaction between
different applications, I think there's a mixture of
authorization/authentication to get right plus a good set of events
that an application could register for.

[Sue]: As someone who has lived with "local pref" in BGP for a long time, there is a bit more to unwrap in the statement.  However, it breaks down to prioritization that is pre-set by preferences.

The policy issues behind the local-pref setting have been studied by the BGP policy community. This is substantial good work on this from the academic researchers, vendors, and operator. Griffins, Rexford, Bush, Feamster, ..... and lots others are much better on the theory than I am.  

> Is this just the -00.draft?

[Alia] Certainly, I expect that we'll uncover more requirements as we
go along.  As I said, some of this is initially setting parts  out of
scope.

---> Scope == good.  Setting scope allows us to pick a piece of this work and standardize it for interoperability.

Alia

> Sue
>
>
>
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Joel M. Halpern
> Sent: Monday, July 30, 2012 3:15 PM
> To: [email-masked]
> Subject: Re: [irs-discuss] I-D Action: draft-ward-irs-framework-00.txt
>
> I am finding this document quite confusing.
>
> The primary confusion is that the document first says that it is about
> information that can not be manipulated with existing systems, and then
> proceeds to give a list of use cases all of which can be manipulated
> with existing systems at a suitable degree of abstraction.
>
> As a lesser confusion, the document says that "streaming" is important,
> but then describes "streaming" as "fast, interactive access."  That is
> not streaming.  And depending upon what one means by interactive, plenty
> of systems provide "fest, interactive access."  I realize the document
> later goes on tot talk about speed and frequency of state updates.   But
> that section simply reasserts the earlier terms withotu better
> description or justification.
>
> Yours,
> Joel
>
> On 7/30/2012 2:08 PM, [email-masked] wrote:
>>
>> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>>
>>
>>       Title           : Interface to the Routing System Framework
>>       Author(s)       : Alia Atlas
>>                            Thomas Nadeau
>>                            Dave Ward
>>       Filename        : draft-ward-irs-framework-00.txt
>>       Pages           : 21
>>       Date            : 2012-07-30
>>
>> Abstract:
>>     This document describes a framework for a standard, programmatic
>>     interface for full-duplex, streaming state transfer in and out of the
>>     Internet's routing system.  It lists the information that might be
>>     exchanged over the interface, and describes the uses of an interface
>>     to the Internet routing system.
>>
> _______________________________________________
> irs-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/irs-discuss
> _______________________________________________
> irs-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/irs-discuss

---

From: Alia Atlas <[email-masked]>
Date: Wed, 1 Aug 2012 18:51:14 -0400

Sue,

I look forward to talking with you more off-line on the policy and
local-pref research and issues.  If you have suggestions on good
background research to read, by all means send it to the list so
others can get up to speed as well.

On the atomic transaction semantics question, let's get a bit further
into the use-cases and framework - and then have a focused discussion.
 I'm not opposed to it forever or if it is necessary - just would like
to thoroughly analyze if it is a real requirement.

Do others have opinions and perspective on this?

Alia

---

From: Susan Hares <[email-masked]>
Date: Wed, 1 Aug 2012 22:54:54 +0000

Alia:

I'll try to create a bibliography of things people should read.  It will be mid-next week since I'm away from my home library on the SDN topic.

Sue 

-----Original Message-----
From: Alia Atlas [mailto:[email-masked]] 
Sent: Wednesday, August 01, 2012 3:51 PM
To: Susan Hares
Cc: Joel M. Halpern; [email-masked]
Subject: Re: [irs-discuss] I-D Action: draft-ward-irs-framework-00.txt

Sue,

Alia

---

From: Alia Atlas <[email-masked]>
Date: Wed, 1 Aug 2012 18:58:54 -0400

Thanks!

---

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 01 Aug 2012 19:01:07 -0400

With regard to transaction issues, we discussed this extensively when 
doing ForCES.  We concluded that the answer we needed was "yes and no". 
  That is, the protocol has mechanisms which can be used for 
transactional integrity, including integrity across interactions with 
multiple FEs.  However, the protocol does not require the CE to use 
those mechanisms.  In fact, if it does not even want explicit acks (the 
messages go over TCP), it can defer that until it gets to a good "please 
confirm" point.
And in the efforts to use this later, having this range of options has 
been useful.

Yours,
Joel