Subject: [irs-discuss] Fwd: New Version Notification for draft-amante-irs-topology-use-cases-00.txt

From: Thomas Nadeau <[email-masked]>
Date: Tue, 2 Oct 2012 22:39:35 +0000

Begin forwarded message:

From: <[email-masked]<mailto:[email-masked]>>
Date: October 2, 2012, 6:18:35 PM EDT
To: <[email-masked]<mailto:[email-masked]>>
Cc: <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>
Subject: New Version Notification for draft-amante-irs-topology-use-cases-00.txt

A new version of I-D, draft-amante-irs-topology-use-cases-00.txt
has been successfully submitted by Jan Medved and posted to the
IETF repository.

Filename:     draft-amante-irs-topology-use-cases
Revision:     00
Title:         Topology API Use Cases
Creation date:     2012-10-02
WG ID:         Individual Submission
Number of pages: 21
URL:             http://www.ietf.org/internet-drafts/draft-amante-irs-topology-use-cases-00.txt
Status:          http://datatracker.ietf.org/doc/draft-amante-irs-topology-use-cases
Htmlized:        http://tools.ietf.org/html/draft-amante-irs-topology-use-cases-00

Abstract:
  This document describes use cases for gathering routing, forwarding
  and policy information, (hereafter referred to as topology
  information), about the network and reflecting changes to the
  topology back into the network and related systems.  It describes
  several applications that need to view or change the topology of the
  underlying physical or logical network.  This document further
  demonstrates a need for a "Topology Manager" and related functions
  that collects topology data from network elements and other data
  sources, coalesces the collected data into a coherent view of the
  overall network topology, and normalizes the network topology view
  for use by clients -- namely, applications that consume or want to
  change topology information.

The IETF Secretariat

---

From: Iftekhar Hussain <[email-masked]>
Date: Sun, 7 Oct 2012 22:00:14 +0000

Hi Authors,
"...and visible within the Link State Database (LSDB) of an active IGP, but also network elements who are active, but invisible to a LSDB (e.g.: L2 Ethernet switches, ROADM's, etc.)"
Shouldn't ROADMs topology be visible to IGP? Perhaps you intend to say optical line amplifier (OLA).
Regards,
Iftekhar

---

From: Thomas Nadeau <[email-masked]>
Date: Mon, 8 Oct 2012 21:10:33 +0000

Hi!

The IRS topology effort is not about what is visible to what devices per se; its about revealing different topological components in a normalized topology database. So in this example, capturing the active information (which is visible via LSDB/IGP routing protocols), is complimented with other inactive (or passive) topological components.

--Tom

From: Iftekhar Hussain <[email-masked]<mailto:[email-masked]>>
Date: Sunday, October 7, 2012 6:00 PM
To: "<[email-masked]<mailto:[email-masked]>>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [irs-discuss] Fwd: New Version Notification for draft-amante-irs-topology-use-cases-00.txt

Hi Authors,
“…and visible within the Link State Database (LSDB) of an active IGP, but also network elements who are active, but invisible to a LSDB (e.g.: L2 Ethernet switches, ROADM's, etc.)”
Shouldn’t ROADMs topology be visible to IGP? Perhaps you intend to say optical line amplifier (OLA).
Regards,
Iftekhar

---

From: Iftekhar Hussain <[email-masked]>
Date: Mon, 8 Oct 2012 22:21:01 +0000

Hi Tom,

Okay, I see.  I think, it would be helpful to:

*         Clarify the context of this example as currently it is a little unclear. For example, ROADM layer 'active' topology would normally be 'visible' to the IGP's LSDB (i.e., IGPs with GMPLS extensions).

*         Add few multi-layer topology examples and their use by network applications (e.g., what type of info one would like to reveal etc.).
Thanks,
Iftekhar
From: Thomas Nadeau [mailto:[email-masked]]
Sent: Monday, October 08, 2012 2:11 PM
To: Iftekhar Hussain; <[email-masked]>
Subject: Re: [irs-discuss] Fwd: New Version Notification for draft-amante-irs-topology-use-cases-00.txt

Hi!

--Tom

Hi Authors,

---

From: Thomas Nadeau <[email-masked]>
Date: Mon, 8 Oct 2012 22:31:22 +0000

Will do.

Also, hopefully the forthcoming requirements draft that Jan is publishing tomorrow morning, should help too.

--Tom

From: Iftekhar Hussain <[email-masked]<mailto:[email-masked]>>
Date: Monday, October 8, 2012 6:21 PM
To: Thomas Nadeau <[email-masked]<mailto:[email-masked]>>, "<[email-masked]<mailto:[email-masked]>>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [irs-discuss] Fwd: New Version Notification for draft-amante-irs-topology-use-cases-00.txt

Hi Tom,

·         Clarify the context of this example as currently it is a little unclear. For example, ROADM layer ‘active’ topology would normally be ‘visible’ to the IGP’s LSDB (i.e., IGPs with GMPLS extensions).

·         Add few multi-layer topology examples and their use by network applications (e.g., what type of info one would like to reveal etc.).
Thanks,
Iftekhar
From: Thomas Nadeau [mailto:[email-masked]]
Sent: Monday, October 08, 2012 2:11 PM
To: Iftekhar Hussain; <[email-masked]<mailto:[email-masked]>>
Subject: Re: [irs-discuss] Fwd: New Version Notification for draft-amante-irs-topology-use-cases-00.txt

Hi!

--Tom

Hi Authors,