Subject: Re: [irs-discuss] Rough Draft IRS Charter

From: Ross Callon <[email-masked]>
Date: Sun, 4 Nov 2012 18:40:19 +0000

Speaking only for myself as an individual: 

I agree that this paragraph of the draft WG charter is a problem. For one thing the definition of "Slow Path" and "Fast Path" are not clear, and overlap with implementation issues as well as other issues. 

One option would be to just drop this paragraph. To me the charter hangs together fine without it. 

One alternative: Do we want to say something along the lines of "whatever solutions are selected by the WG will not preclude "fast path" low-overhead access to the routing system"? This would encourage the WG to think about what is needed to allow low-overhead access to data in the routers (both setting and reading), but would not in the charter specify what actually needs to be done to allow this. 

Ross

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Russ White
Sent: Monday, October 22, 2012 1:50 PM
To: [email-masked]
Subject: Re: [irs-discuss] Rough Draft IRS Charter

I think this has already been brought up on the list once before, but
I'd just like to repeat my concerns on it:

==
Thus, the IRS is a "fast path" that can be used to program routing and
policy state in a router using operational paradigms familiar to
operators of traditional distributed devices. This differs from the
programmatic "slow state" that is commonly a device's configuration
interface because those mechanisms impose many transactional mechanisms
and requirements, that may slow down the interaction.
==

Describing the CLI or other existing interfaces as the "slow path," and
the proposed as the "fast path," is problematic. First, it implies that
there is a specific path already available into all control plane
devices, and that single path is "too slow," for some meaning of "too
slow." Second, it implies, from the start, that we need new path, rather
than a possible structure around existing paths that we can use to make
sense of the routing system as a whole.

I think 2a needs to be better defined so it doesn't overlap with 2c, or
2c needs to be made a part of 2a in some way (?).

Thanks!

Russ

-- 
<><
[email-masked]
[email-masked]
_______________________________________________
irs-discuss mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/irs-discuss

---

From: Ross Callon <[email-masked]>
Date: Sun, 4 Nov 2012 18:43:11 +0000

The draft charter says "at least". Thus in my reading of this, the current proposed text does not preclude other use cases.

On the other hand, I think that initially, after the WG is chartered and starts operating as a WG (assuming that this happens), we need to be careful to avoid trying to take on so much work that we don't succeed in finishing any of it.

Ross
(speaking only as an interested individual, giving my personal opinion)

From: Maglione Roberta [mailto:[email-masked]]
Sent: Friday, October 19, 2012 8:43 AM
To: Ross Callon; [email-masked]
Cc: [email-masked]; Capello Alessandro
Subject: RE: Rough Draft IRS Charter

Hello,
 I have a question on working item 2:

"The working group is chartered to work on the following items:

2.     Tightly scoped key use cases for operational use of IRS. These use cases will include at least:

a.    Interactions with the RIB

b.    Association of routing policies with routing state

c.    The ability to extract information about topology from the network
"
Does this bullet exclude the possibility to use IRS to gather information about network measurements such as available bandwidth on a link, information related to jitter delay for specific flows etc. ?

Thanks,
Roberta
________________________________
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Ross Callon
Sent: Thursday, October 18, 2012 5:55 PM
To: [email-masked]<mailto:[email-masked]>
Cc: Ross Callon; [email-masked]<mailto:[email-masked]>
Subject: [irs-discuss] Rough Draft IRS Charter

Attached (in Word format) is a very rough initial draft charter (for a potential IRS WG) that the BOF chairs have been discussing with our friendly sponsoring routing area AD.

Comments are welcome. We will be discussing the draft IRS WG charter in Atlanta.

Thanks, Ross
(with input from Dave and Adrian)

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie.

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks.
[rispetta l'ambiente]Rispetta l'ambiente. Non stampare questa mail se non è necessario.

---

From: Thomas Nadeau <[email-masked]>
Date: Sun, 4 Nov 2012 13:53:13 -0500

> One option would be to just drop this paragraph. To me the charter hangs together fine without it. 

I personally do not find it offensive, but if it clears things up, let's loose it.

> One alternative: Do we want to say something along the lines of "whatever solutions are selected by the WG will not preclude "fast path" low-overhead access to the routing system"? This would encou…

I don't like the language of "will not preclude".  it's a bit of a double negative to me. something like "will seek to reuse or develop a protocol that achieves the requirements of low-overhead, etc...  seems more flexible and precise to me at the same time.

Tom

---

From: Thomas Nadeau <[email-masked]>
Date: Sun, 4 Nov 2012 13:54:39 -0500

On Nov 4, 2012, at 1:43 PM, Ross Callon <[email-masked]> wrote:

> The draft charter says “at least”. Thus in my reading of this, the current proposed text does not preclude other use cases.

agreed. I think that was the spirit of hat was proposed.

>  
> On the other hand, I think that initially, after the WG is chartered and starts operating as a WG (assuming that this happens), we need to be careful to avoid trying to take on so much work that we don’t succeed in finishing any of it.

agreed.

Tom 

> “The working group is chartered to work on the following items:
>  
> “
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Ross Callon
> Cc: Ross Callon; [email-masked]
> Rispetta l'ambiente. Non stampare questa mail se non è necessario.
>

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 5 Nov 2012 13:21:25 -0000

The intention of the draft charter is to seed the list of use cases.
The charter that you all put forward to the IESG (if you have consensus to form
a WG) needs to have an agreed list of use cases that the WG will work on.
 
IMHO, this needs to be a closed list for initial work, with a way to add further
use cases if needed. I also think that the list in the charter needs to be a
fairly short list, and that will require the group to determine where its wants
to focus.
 
A
 
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Ross Callon
Sent: 04 November 2012 18:43
To: Maglione Roberta; [email-masked]
Cc: [email-masked]; Capello Alessandro
Subject: Re: [irs-discuss] Rough Draft IRS Charter
 
The draft charter says “at least”. Thus in my reading of this, the current
proposed text does not preclude other use cases. 
 
On the other hand, I think that initially, after the WG is chartered and starts
operating as a WG (assuming that this happens), we need to be careful to avoid
trying to take on so much work that we don’t succeed in finishing any of it. 
 
Ross

Hello, 

2.       Tightly scoped key use cases for operational use of IRS. These use
cases will include at least:
a.       Interactions with the RIB
b.      Association of routing policies with routing state
c.       The ability to extract information about topology from the network
“
Does this bullet exclude the possibility to use IRS to gather information about
network measurements such as available bandwidth on a link, information related
to jitter delay for specific flows etc. ?
 
Thanks,
Roberta 
  _____  

From: [email-masked] [mailto:[email-masked]] On
Behalf Of Ross Callon
Sent: Thursday, October 18, 2012 5:55 PM
To: [email-masked]
Cc: Ross Callon; [email-masked]
Subject: [irs-discuss] Rough Draft IRS Charter
 
Attached (in Word format) is a very rough initial draft charter (for a potential
IRS WG) that the BOF chairs have been discussing with our friendly sponsoring
routing area AD. 

Thanks, Ross

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone
indicate. La diffusione, copia o qualsiasi altra azione derivante dalla
conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate
ricevuto questo documento per errore siete cortesemente pregati di darne
immediata comunicazione al mittente e di provvedere alla sua distruzione,
Grazie. 
This e-mail and any attachments is confidential and may contain privileged
information intended for the addressee(s) only. Dissemination, copying, printing
or use by anybody else is unauthorised. If you are not the intended recipient,
please delete this message and any attachments and advise the sender by return
e-mail, Thanks. 
rispetta l'ambienteRispetta l'ambiente. Non stampare questa mail se non è
necessario.

---

From: Christopher LILJENSTOLPE <[email-masked]>
Date: Mon, 5 Nov 2012 11:43:08 -0800

Greetings all,

On 05Nov2012, at 05.21, "Adrian Farrel" <[email-masked]> wrote:

<snip>
> Does this bullet exclude the possibility to use IRS to gather information about network measurements such as available bandwidth on a link, information related to jitter delay for specific flows et…

<snip>

However, I would want to test those use cases against existing capabilities BEFORE adding more use cases.  I'm not sure I'm in favor of replicating work and capabilities already done elsewhere (i.e. bandwidth available on a link, etc).

	Chris