Subject: Re: [irtf-discuss] Interested in Learning capable communication networks ?

From: Aaron Falk <[email-masked]>
Date: Mon, 08 Nov 2010 06:18:23 +0800

Hi Dimitri-

Finally getting around to reading your draft.  Thank you for putting your thoughts into a document so your proposal of an IRTF actitvity can be appreciated in some detail.  The proposal is quite interesting.  Are you reflecting existing or planned work in a research project?  Have you identified any other projects that you think might participate?

One thought I had in reading the draft: Do you think the move from the less diverse behaviors (I'm avoiding 'simple') of current routers to adaptive behavior will in fact make it harder to diagnose the network as current diagnostics may no longer work?  Put another way, will 'correct' behavior will be harder to predict?

Anyway, I'm interested in seeing other comments

--aaron

On 10/30/10 8:13 PM, Papadimitriou, Dimitri (Dimitri) wrote:
> Hi all,
>
>
> If you are interested in the application of learning paradigms/techniques to the control of communication networks, please take a look at the following document<http://tools.ietf.org/html//draft-tavernier-irtf-lccn-problem-statement-00>  and let us know if you think this research topic would be worth investigating in the IRTF context.
>
> Depending on the level of interest, we will organize an informal meeting in Beijing during IETF 79 (and provide means to enable remote participation for people that can't be physically present). Details would follow on this list.
>
>
> Thanks,
> -dimitri.
> _______________________________________________
> irtf-discuss mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/irtf-discuss
>

---

From: Arturo Servin <[email-masked]>
Date: Mon, 8 Nov 2010 00:23:22 -0200

Dimitri,

	I couldn't  go to the IETF meeting in Beijing but I am very interested in the topic. 

	I think that the adaptive behaviour of networks is an interesting and challenging topic (not only technically but in other domains too). I would be really happy to see some IETF efforts in this direction and to contribute on them.

	If you are planning a meeting during the IETF 79 with support for remote participation, please let me know.

Best wishes,
-as

On 30 Oct 2010, at 10:13, Papadimitriou, Dimitri (Dimitri) wrote:

> 
> Hi all,
> 
> 
> If you are interested in the application of learning paradigms/techniques to the control of communication networks, please take a look at the following document <http://tools.ietf.org/html//draft-tavernier-irtf-lccn-problem-statement-00> and let us know if you think this research topic would be worth investigating in the IRTF context.
>

---

From: "Papadimitriou, Dimitri (Dimitri)" <[email-masked]>
Date: Mon, 8 Nov 2010 22:20:25 +0100

Hi Aaron,

> -----Original Message-----
> From: Aaron Falk [mailto:[email-masked]] 
> Sent: Sunday, November 07, 2010 11:18 PM
> To: Papadimitriou, Dimitri (Dimitri)
> Cc: [email-masked]; Wouter Tavernier; Didier Colle
> Subject: Re: [irtf-discuss] Interested in Learning capable 
> communication networks ?
> 
> Hi Dimitri-
> 
> Finally getting around to reading your draft.  Thank you for 
> putting your thoughts into a document so your proposal of an 
> IRTF actitvity can be appreciated in some detail.  The 
> proposal is quite interesting.  

Thanks for the feedback.

> Are you reflecting existing or planned work in a research project?  

Yes, this is existing work as part of a research project started more than 2 years ago (not counting the initial investigation phase).

> Have you identified any other projects that you think might participate?

We have identified and are in contact with other projects/researchers having similar interests. We hope they will participate to this effort.

> One thought I had in reading the draft: Do you think the move 
> from the less diverse behaviors (I'm avoiding 'simple') of 
> current routers to adaptive behavior will in fact make it 
> harder to diagnose the network as current diagnostics may no 
> longer work?  Put another way, will 'correct' behavior will 
> be harder to predict?

Current diagnostics can still be performed as of today; indeed, the learning cycle may still be ommitted or bypassed (produce analysis/decision without taking them into account for subsequent execution).  

Note that part of the research consists in determining which behavior would benefit of "adaptivity" (without mandating usage).

Thanks,
-dimitri.

> > If you are interested in the application of learning 
> paradigms/techniques to the control of communication 
> networks, please take a look at the following 
> document<http://tools.ietf.org/html//draft-tavernier-irtf-lccn
> -problem-statement-00>  and let us know if you think this 
> research topic would be worth investigating in the IRTF context.
> >
> > Depending on the level of interest, we will organize an 
> informal meeting in Beijing during IETF 79 (and provide means 
> to enable remote participation for people that can't be 
> physically present). Details would follow on this list.
> >
> >
> > Thanks,
> > -dimitri.

---

From: John Wroclawski <[email-masked]>
Date: Mon, 8 Nov 2010 14:00:50 -0800

It's the Knowledge Plane, back for another swing!

-- sigcomm vision paper
http://groups.csail.mit.edu/ana/Publications/PubPDFs/A%20knowlege%20plane%20for%20the%20internet.pdf
-- slides from DARPA seedling program
http://www.isi.edu/know-plane/DOCS/ramming.cognitivenetworksbriefforweb.pdf
(all from around 2003)

This whole line of work seems to have tantalizing broad potential, particularly when you look at it through the lens of advancing "network management" or "fault diagnosis and management" - the case for thinking of it as replacing low-level control isn't as strong yet IMO - but it's also run up against some very hard problems and difficult pragmatic issues in the past. The effect of that seems to be that people backed off from the big-picture objective a little and went off to work on smaller chunks of the problem for a while, or just hid in the corner to see what would happen. It'd be really interesting to see whether things have advanced enough that we could pull a coherent next-round research agenda out of the collective community's thinking at this point.

--john

---

From: Aaron Falk <[email-masked]>
Date: Tue, 09 Nov 2010 16:05:51 +0800

> Yes, this is existing work as part of a research project started more than 2 years ago (not counting the initial investigation phase).

Can you provide a pointer with more info?

--aaron

---

From: "Papadimitriou, Dimitri (Dimitri)" <[email-masked]>
Date: Tue, 9 Nov 2010 12:12:02 +0100

Hi Aaron, all,

I invite interested IRTF'ers to take a look at the following pointers:
<http://www.ecode-project.eu/pmwiki/pmwiki.php/Ecode/Ecode>
<http://www.ecode-project.eu/pmwiki/pmwiki.php/Ecode/Publications>
we keep the latter updated with published/presented papers.
 
Thanks,
-dimitri.
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Aaron Falk
> Sent: Tuesday, November 09, 2010 9:06 AM
> > Yes, this is existing work as part of a research project 
> started more than 2 years ago (not counting the initial 
> investigation phase).
> >
>