Subject: Re: [irtf-discuss] a new research proposal

From: "Steiner, Moritz (Moritz)" <[email-masked]>
Date: Mon, 21 Mar 2011 15:17:27 -0500

Hello Young,

I read your proposal with a lot of interest. It certainly makes a lot of sense to tie all type of resources together: computing, storage and network resources. 
You raise a couple of very interesting questions: How to enhance the quality of application experience? How to enhance the resilience of the running applications? What implications is the load balancing on the application level going to have on the network engineering happening at a lower level at different time scales? 
Besides those points I think it is important to justify how a tighter integration provides also benefits to the network operators, not only to the applications. Why isn't today's load balancing not good enough?
As you have stated the scope of ALTO is much more limited than what you're proposing, but wouldn't it make sense to reutilize some concepts introduced by ALTO, such as the network map and cost map? 

Best
Moritz

-- 
  Moritz Steiner                     Bell Labs / Alcatel-Lucent
  Email: [email-masked]           600-700 Mountain Avenue
  Phone: +1-908-582-1911             Murray Hill, NJ 07974, USA

-------- Original Message --------
Subject: 	[irtf-discuss] a new research proposal
Date: 	Thu, 17 Mar 2011 16:04:32 -0500
From: 	Leeyoung <[email-masked]>
To: 	[email-masked] <[email-masked]>

Hi all,

We are exploring a new IRTF research proposal which focuses on the interaction between data centers and the underlying carrier networks, which is referred to as cross stratum optimization (cso). If you're interested in this topic, please take a look at the draft published:

http://datatracker.ietf.org/doc/draft-lee-cross-stratum-optimization-datacenter/

If you're interested in this research and/or would like to comment, please feel free to do so in the discussion mailing list.

Thanks and best regards,

Young

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Abstract

Data Centers offer various application services to end-users such as video gaming, cloud computing and others. Since the data centers used to provide application services are distributed geographically around a network, many decisions made in the control and management of application services, such as where to instantiate another service instance or to which data center out of several a new client is assigned, can have a significant impact on the state of the network.
Conversely the capabilities and state of the network can have a major impact on application performance.

Currently application decisions are made with very little or no information concerning the underlying network used to deliver those services. Hence such decisions may be sub-optimal from both application and network resource utilization and quality of service objectives. This document proposes a research program into cross stratum application/network optimization focusing on the challenges and opportunities presented by data center based applications and carriers networks.

Tentative Research Deliverables

a) Baseline network/application model - general enough to include most cases of interest but no more.

b) Survey the various "trust or lack of" in the relationships between various key players in both the application and network stratum. Include a survey of various "summarization", "abstraction", or other techniques that can reduce the level of "trust" needed at an interface.

c) Survey of the data center/cloud based applications - investigate the commonality and differences with respect to their impact on network infrastructure.

d) Define key interfaces and their functionality and relate these to current standards and potential future standards.

e) Investigation and report on the role of TE based network infrastructure (MPLS, GMPLS) in providing support to dynamic application loads, scaling and QoE enhancement.

f) Report on mechanisms for application level support for network recovery and network support for application recovery.

g) Investigate the time frames and responsiveness of interest to application/network interaction. For example what do various applications need, what can the network provide, can other techniques such as time based "load shifting" be utilized.

---

From: Leeyoung <[email-masked]>
Date: Mon, 21 Mar 2011 21:40:02 +0000

Hi Moritz,

Thanks for your review of and interest in the draft and providing a set of excellent discussion points and questions. 

As you indicated, the benefit of cross application/network optimization applied to network operators as well as application providers. One of the key problems today is the lack of application-awareness by the networks and vice versa. So I believe the proposal would benefit both application and network and ultimately the end-users, especially for the mission-critical application users. 

In regard to the question why today's load balancing is not good enough, I think the question depends on the kind of application we are dealing with. For web-based applications including streaming video, etc, I think today's load balancing works well in most of cases. On the other hands, for mission-critical applications, today's load balancing may not be good enough to meet the requirement of critical end-user applications such as remote medical surgery, real-time interactive 3D video applications, mission critical financial transaction services, etc. All these application should be provided with some level of resource guarantee above and beyond "best effort." 

For your question on why not reusing ALTO mechanisms, I am for it actually if the ALTO mechanisms can provide solutions to the requirements. One thing ALTO may be lacking is the exchange of network abstraction information --- no network operators want to reveal detail network topology and resource (e.g., available bandwidth) information. So we need to investigate network abstraction mechanism and "virtual" network topology exchange, etc., as part of the research. But I agree with you that, we can reuse existing mechanisms where possible. 

Thanks,
Young   

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Steiner, Moritz (Moritz)
Sent: Monday, March 21, 2011 3:17 PM
To: [email-masked]
Subject: Re: [irtf-discuss] a new research proposal

Hello Young,

Best
Moritz

-------- Original Message --------
Subject: 	[irtf-discuss] a new research proposal
Date: 	Thu, 17 Mar 2011 16:04:32 -0500
From: 	Leeyoung <[email-masked]>
To: 	[email-masked] <[email-masked]>

Hi all,

Thanks and best regards,

Young

Abstract

_______________________________________________
irtf-discuss mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/irtf-discuss

---

From: Kathy McEwen <[email-masked]>
Date: Mon, 21 Mar 2011 20:46:39 -0500

Some interesting activity with net and video going on now at Time Warner...
Perhaps good data points for market
Need by network providers....
http://macdailynews.com/2011/03/16/time-warner-cuts-back-live-tv-ipad-app-due-to-overwhelming-demand/

And note Comcast plans similar app 
http://www.foxnews.com/scitech/2011/03/17/time-warner-cables-new-live-tv-ipad-app-cable-networks/

via mobile ... 

On Mar 21, 2011, at 4:40 PM, Leeyoung <[email-masked]> wrote:

> cso mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cso

---

From: Greg Bernstein <[email-masked]>
Date: Tue, 22 Mar 2011 08:29:30 -0700

Hi all,
as to "Why isn't today's load balancing not good enough?", there are 
several types of load balancing: those that take place within data 
centers and those that take place between data centers. Within data 
centers we are seeing more "network aware" capabilities, e.g., virtual 
switches are now offering flow statistics [OpenVSwitch 
<http://openvswitch.org/>], and work on VM placements within data 
centers [1].  Between data centers the network capabilities tend not to 
be known, this is particularly true for technologies below the IP 
layer.  Without some type of interaction between application and network 
layer, one could never know, for example, that additional wavelengths 
(10Gbps or 40Gbps) may be available between two locations.
Note that in general there have been many theoretical optimization 
results reported in this area [2-4].

"I think it is important to justify how a tighter integration provides 
also benefits to the network operators, not only to the applications."  
This is key, if it doesn't benefit network operators it will not be 
implemented, if it doesn't benefit the application providers (and end 
users) it will not be used!

Best Regards

Greg B.

References:
[1] X. Meng, V. Pappas, and L. Zhang, "Improving the Scalability of Data Center Networks with Traffic-aware Virtual Machine Placement," in 2010 Proceedings IEEE INFOCOM, San Diego, CA, USA, 2010, pp. 1-9.
[2] S. Das and J. Kangasharju, "Evaluation of network impact of content distribution mechanisms," in Proceedings of the 1st international conference on Scalable information systems, Hong Kong, 2006, p. 35.
[3] S. Ratnasamy, M. Handley, R. Karp, and S. Shenker, "Topologically-aware overlay construction and server selection," in INFOCOM 2002. Twenty-First Annual Joint Conference of the IEEE Computer and Communications Societies. Proceedings. IEEE, 2002, vol. 3, pp. 1190-1199 vol.3.
[4] V. N. Padmanabhan and G. M. Voelker, with Lili Qiu, "On the placement of Web server replicas," in INFOCOM 2001. Twentieth Annual Joint Conference of the IEEE Computer and Communications Societies. Proceedings. IEEE, 2001, vol. 3, pp. 1587-1596 vol.3.

-- 
===================================================
Dr Greg Bernstein, Grotto Networking (510) 573-2237