Subject: [irtf-discuss] Draft ICN RG Charter

From: Börje Ohlman <[email-masked]>
Date: Mon, 23 May 2011 13:27:30 +0200

Here is a proposal for a charter for an ICN RG. In producing this draft we have had great help from Volker Hilt, Lixia Zhang, Martin Vigoureux, Joerg Ott, Stephen Farrell and Bengt Ahlgren who has commented and made proposals for improvements. We also got some first positive feedback from the IRTF chair Lars Eggert.
But this does not mean that this charter is ready. There is still room for improvement, e.g. good research issues to be added. Please feel free to contribute to the discussion on this mailing list(s).
At the next IETF meeting we will present the proposal at the IRTF Open Meeting and an RG-to-be side meeting. 
The side meeting could either be held in the week before the IETF meeting, with the problem that interested people might not yet be there, or during the IETF week, with the problem that interested people might have other conflicting meetings. Any feedback on this dilemma is very much appreciated.

	Börje & Dirk

---

From: Martin Vigoureux <[email-masked]>
Date: Tue, 24 May 2011 14:33:07 +0200

Hello Paulo,

Le 24/05/2011 13:55, Paulo Mendes a écrit :
> Hi Borje and Dirk
>
> I would be careful with the word "architecture" since IETF/IRTF does not standardize architectures. Hence I would propose to use the following sentence...
>
> "The ICNRG will investigate components of a common protocol framework for information-centric networking, aiming to: i) identify protocols for standardization, which may or may not re; ii) support an ICN architecture with large applicability."
>
> ... to replace the following two sentences:
>
> "The ICNRG will identify key ICN architecture invariants across different specific approaches which could form the basis of a future ICN architecture."
>
> "The intention is that one result from this work could be a common protocol framework that can be used to identify protocols for standardization. These protocols may or may not re-use existing IETF protocols."

In turn, I would be careful with the statement "IETF/IRTF does not 
standardize architectures" :-)
It all depends on what one reads in "architecture".
Note also that the charter does not say that an architecture will be 
standardized.
I think the text is fine.

best regards,
martin

---

From: Paulo Mendes <[email-masked]>
Date: Tue, 24 May 2011 12:55:35 +0100

Hi Borje and Dirk

I would like to provide the following comments in what concerns the ICNRG objectives and milestones:

A) ICNRG objectives

Since the list of research areas is not fully analyzed (work proposed to be done as first milestone) I suggest to change the first objective to "The main objective of the ICNRG is to advance the state of ICN research in AT LEAST the mentioned areas, focusing on solutions that are relevant for evolving the Internet at large."

As for the expression "Internet at large" I would be a little more precise, including some examples in order to avoid misunderstandings.. I would suggest "... Internet at large, including the support for new services and operation into disruptive scenarios based for instance in the present of a considerable number of low-capacity (computational, storage) devices". The idea is to keep as an objective the analysis of the interaction of information-centric networking with Internet-of-services and Internet-of-connected-objects.

I would put more emphasis to work based on implementations than simulations.. Simulations should be pointed out as acceptable to prove the feasibility of proposed solutions in large-scale scenarios. Given more importance to implementations is inline with the other mentioned objective of ICNRG "The ICNRG will foster the development of ICN testbeds for performing experiments with running code."

B) ICNRG Milestones

The charter has milestones to describe the main concepts and research challenges, to provide a survey of different approaches and to describe an ICN architecture.

What is missing here is the common protocol framework mentioned before. So I'll add the following milestone as third one: "Based on the identified main research challenges and the analysis of different approaches, ICNRG will devise a common protocol framework for ICN, aiming to have high applicability".

I would re-write the third ICNRG milestone, since saying that "... long-term goals would be documents describing an ICN architecture.. " since a little strange to see within IETF/IRTF work. Instead of saying that the goal will describe an architecture, I would suggest to say that the group will described guidelines to device an ICN architecture based on the common protocol framework to be devised within the ICNRG.

Somewhere in this process we should have a milestone to check the applicability of ICN, aiming to check our inline with potential standardization effort is the work to be devised in the ICNRG

Cheers
Paulo

On May 23, 2011, at 12:27 PM, Börje Ohlman wrote:

> <Draft-ICN-RG-Charter.txt>_______________________________________________
> Icn-interest mailing list
> [email-masked]
> https://listserv.netlab.nec.de/mailman/listinfo/icn-interest

-------------------------------------------------------------
Paulo Mendes, Ph.D
Scientific Director for Innovation of the Research Unit in Informatics Systems and Technologies (SITI)
Coordinator of the Internet Architecture and Networking Lab (IAN Lab)
University Lusofona, Portugal
[email-masked]
http://siti.ulusofona.pt
Tel.: 217 515 500 Fax: 21 757 7006

---

From: Dirk Kutscher <[email-masked]>
Date: Tue, 24 May 2011 12:41:35 +0000

Hi Paulo,

Thanks for the suggestions. Please my some comments inline.

> Since the list of research areas is not fully analyzed (work proposed
> to be done as first milestone) I suggest to change the first objective
> to "The main objective of the ICNRG is to advance the state of ICN
> research in AT LEAST the mentioned areas, focusing on solutions that
> are relevant for evolving the Internet at large."

OK, I agree.

> As for the expression "Internet at large" I would be a little more
> precise, including some examples in order to avoid misunderstandings..
> I would suggest "... Internet at large, including the support for new
> services and operation into disruptive scenarios based for instance in
> the present of a considerable number of low-capacity (computational,
> storage) devices". The idea is to keep as an objective the analysis of
> the interaction of information-centric networking with Internet-of-
> services and Internet-of-connected-objects.

Here, I really disagree. We did not want to create the notion of different "Internets", i.e., Information-Centric, Internet-of-Services, Internet-of-Things etc. The message is that we want to assess ICN's applicability as a general Internet technology ("Internet at large").
 
> I would put more emphasis to work based on implementations than
> simulations.. Simulations should be pointed out as acceptable to prove
> the feasibility of proposed solutions in large-scale scenarios. Given
> more importance to implementations is inline with the other mentioned
> objective of ICNRG "The ICNRG will foster the development of ICN
> testbeds for performing experiments with running code."

Right, so IMO that aspect is already covered. We also said "work that is based on implementation and simulation experiences will be given preference.".
 
> I would be careful with the word "architecture" since IETF/IRTF does
> not standardize architectures. Hence I would propose to use the
> following sentence...
> 
> "The ICNRG will investigate components of a common protocol framework
> for information-centric networking, aiming to: i) identify protocols
> for standardization, which may or may not re; ii) support an ICN
> architecture with large applicability."
> 
> "The ICNRG will identify key ICN architecture invariants across
> different specific approaches which could form the basis of a future
> ICN architecture."
> "The intention is that one result from this work could be a common
> protocol framework that can be used to identify protocols for
> standardization. These protocols may or may not re-use existing IETF
> protocols."

OK, got your point. It's true that "form the basis of a future ICN architecture" can be misinterpreted.

Here, we wanted to strike a balance: it's true that *system architecture* work is not the IETF's core business. However, for an IRTF research group, we expect some architecture work to be required, e.g., to find out about common core elements that you need to agree on (for later protocol specifications etc.). For example, RFC 4838 is a good example of architecture work that describes fundamental architecture concepts for DTN, which has been a good basis for subsequent DTNRG work on the Bundle Protocol spec.

Will think of a better formulation.

> 
> 
> B) ICNRG Milestones
> 
> The charter has milestones to describe the main concepts and research
> challenges, to provide a survey of different approaches and to describe
> an ICN architecture.
> 
> What is missing here is the common protocol framework mentioned before.
> So I'll add the following milestone as third one: "Based on the
> identified main research challenges and the analysis of different
> approaches, ICNRG will devise a common protocol framework for ICN,
> aiming to have high applicability".
> 
> I would re-write the third ICNRG milestone, since saying that "...
> long-term goals would be documents describing an ICN architecture.. "
> since a little strange to see within IETF/IRTF work. Instead of saying
> that the goal will describe an architecture, I would suggest to say
> that the group will described guidelines to device an ICN architecture
> based on the common protocol framework to be devised within the ICNRG.

OK, we have to remember that this is not an IETF WG charter. For a research group, that is really highly contribution-driven, we should allow some flexibility. From that perspective, I think it would be better not promise delivering guidelines to devise an architecture. If course, that would not keep the WG from doing that, if people are interested.

> Somewhere in this process we should have a milestone to check the
> applicability of ICN, aiming to check our inline with potential
> standardization effort is the work to be devised in the ICNRG

Again, normally "yes" for a tightly controlled activity, but for a research group, I rather see our contribution in advancing ICN and offering the result to the community. I would not like to have a milestone on that.

Thanks again for the comments!

Best regards,

Dirk

> > Here is a proposal for a charter for an ICN RG. In producing this
> draft we have had great help from Volker Hilt, Lixia Zhang, Martin
> Vigoureux, Joerg Ott, Stephen Farrell and Bengt Ahlgren who has
> commented and made proposals for improvements. We also got some first
> positive feedback from the IRTF chair Lars Eggert.
> > But this does not mean that this charter is ready. There is still
> room for improvement, e.g. good research issues to be added. Please
> feel free to contribute to the discussion on this mailing list(s).
> > At the next IETF meeting we will present the proposal at the IRTF
> Open Meeting and an RG-to-be side meeting.
> > The side meeting could either be held in the week before the IETF
> meeting, with the problem that interested people might not yet be there,
> or during the IETF week, with the problem that interested people might
> have other conflicting meetings. Any feedback on this dilemma is very
> much appreciated.
> >
> > 	Börje & Dirk
> >
> > <Draft-ICN-RG-
> Charter.txt>_______________________________________________
> _______________________________________________

---

From: Markus Hofmann <[email-masked]>
Date: Tue, 24 May 2011 09:21:27 -0400

On 5/23/2011 7:27 AM, Börje Ohlman wrote:
> Milestones
>
> ----------
>
> The ICNRG will not work along a complete list of milestones, but
> will be set to meet the following starting point, intermediate and
> potential long-term goals:
>
> 1. As a starting point the ICNRG will produce a document that
> describes the main concepts and research challenges in depth.

What about including a summary of the expected benefits of ICN, i.e. 
first describe the *problem* to be solved in *quantifiable* terms, then 
describe the main concepts and continue on to the research challenges.

Far too often do we in research work on solutions just to struggle later 
on with the justification of the problem they solve. Or is the problem 
ICN will solve not yet quantifiable?

If sufficient work on the problem statement has already been done, then 
a brief summary with references might suffice. But a clearly defined and 
convincing problem statement will go a long way, IMHO.

Cheers,
   Markus

---

From: Paulo Mendes <[email-masked]>
Date: Wed, 25 May 2011 10:35:54 +0100

Hi Martin

Just to clarify. It is clear that the charter does not say that an architecture will be standardized. It couldn't in any case - IRTF does not aim to devise standards. I was commenting on the fact that one goal described in the charter seems to be to write "...documents describing an ICN architecture", and IETF/IRTF is focus on working on protocols and not architectures. 3GPP, ITU-T are more looking at architectures, most of the time making use of IETF protocols. So, we do not want to create misunderstandings :).

Paulo

On May 24, 2011, at 1:33 PM, Martin Vigoureux wrote:

> In turn, I would be careful with the statement "IETF/IRTF does not standardize architectures" :-)
> Note also that the charter does not say that an architecture will be standardized.

---

From: Paulo Mendes <[email-masked]>
Date: Wed, 25 May 2011 11:42:17 +0100

Hi Dirk

see my comments inline...

> Here, I really disagree. We did not want to create the notion of different "Internets", i.e., Information-Centric, Internet-of-Services, Internet-of-Things etc. The message is that we want to asses…

I was not suggestion the creation of the notion of different "Internets", Just to say something in the charter about the applicability scenario at large... For instance, is ICNRG going to look at ICN solutions for the Internet as is it, or for the "expected" Internet which may be extended to different types of portable devices. But is all of us have this perspective in mind, than "Internet at large" is fine :)

> Right, so IMO that aspect is already covered. We also said "work that is based on implementation and simulation experiences will be given preference.".

RIght.. The question is that this sentence givens equal preference to simulations and testbed experiences. I was suggesting to give higher preference to testbed experiences.

> Will think of a better formulation.

Good.. If we are talking about RFC4838 type of work, and not a 3GPP type of description this is expectable.

> OK, we have to remember that this is not an IETF WG charter. For a research group, that is really highly contribution-driven, we should allow some flexibility. From that perspective, I think it wou…

OK

> Again, normally "yes" for a tightly controlled activity, but for a research group, I rather see our contribution in advancing ICN and offering the result to the community. I would not like to have…

I was not proposing a very tight activity, but just a reality-check milestone to analyze what is exactly the probability of having ICNRG research work being ported to IETF... I like to see this reality check in any research work, from PhD thesis to EU projects :-)

Cheers

Paulo

---

From: Giacomo Morabito <[email-masked]>
Date: Wed, 25 May 2011 23:37:29 +0200

Dear Börje and Dirk, dear all

it looks like there is not a consensus on the weight to assign to  
different experimental methodologies (implementation in physical  
testbeds vs. simulations).
As you know methodologies exist that can combine the two approaches so  
you can run simulations where some of the nodes are "physical" nodes,  
or create testbeds where part of the network is "simulated/emulated".
In any case I believe that this discussion confirms what I already  
heard from Börje some time ago: the community needs to reach an  
agreement on the experimental approach so that different solutions can  
be compared in a consistent way.

Accordingly, I would suggest to add another milestone about this issue.
It could be something like:

"The ICNRG will produce a document that provides guidelines for  
experimental activities in the area of ICN so that different,  
alternative solutions can be compared consistently."

Best regards
Giacomo

Il giorno 25/mag/11, alle ore 12:42, Paulo Mendes ha scritto:

>> Here, I really disagree. We did not want to create the notion of  
>> different "Internets", i.e., Information-Centric, Internet-of- 
>> Services, Internet-of-Things etc. The message is that we want to  
>> assess ICN's applicability as a general Internet technology  
>> ("Internet at large").
>
> I was not suggestion the creation of the notion of different  
> "Internets", Just to say something in the charter about the  
> applicability scenario at large... For instance, is ICNRG going to  
> look at ICN solutions for the Internet as is it, or for the  
> "expected" Internet which may be extended to different types of  
> portable devices. But is all of us have this perspective in mind,  
> than "Internet at large" is fine :)
>
>
>>
>> Right, so IMO that aspect is already covered. We also said "work  
>> that is based on implementation and simulation experiences will be  
>> given preference.".
>
> RIght.. The question is that this sentence givens equal preference  
> to simulations and testbed experiences. I was suggesting to give  
> higher preference to testbed experiences.
>
>>
>> Here, we wanted to strike a balance: it's true that *system  
>> architecture* work is not the IETF's core business. However, for an  
>> IRTF research group, we expect some architecture work to be  
>> required, e.g., to find out about common core elements that you  
>> need to agree on (for later protocol specifications etc.). For  
>> example, RFC 4838 is a good example of architecture work that  
>> describes fundamental architecture concepts for DTN, which has been  
>> a good basis for subsequent DTNRG work on the Bundle Protocol spec.
>>
>> OK, we have to remember that this is not an IETF WG charter. For a  
>> research group, that is really highly contribution-driven, we  
>> should allow some flexibility. From that perspective, I think it  
>> would be better not promise delivering guidelines to devise an  
>> architecture. If course, that would not keep the WG from doing  
>> that, if people are interested.
>
> OK
>
>>
>> Again, normally "yes" for a tightly controlled activity, but for a  
>> research group, I rather see our contribution in advancing ICN and  
>> offering the result to the community. I would not like to have a  
>> milestone on that.
>
> I was not proposing a very tight activity, but just a reality-check  
> milestone to analyze what is exactly the probability of having ICNRG  
> research work being ported to IETF... I like to see this reality  
> check in any research work, from PhD thesis to EU projects :-)
>
> Cheers
>
> Paulo
>
>
>>
>>> Scientific Director for Innovation of the Research Unit in  
>>> Informatics
>>> Systems and Technologies (SITI)
> Scientific Director for Innovation of the Research Unit in  
> Informatics Systems and Technologies (SITI)

---

From: Giacomo Morabito <[email-masked]>
Date: Wed, 25 May 2011 23:46:23 +0200

Best regards
Giacomo

---

From: Börje Ohlman <[email-masked]>
Date: Thu, 26 May 2011 10:03:17 +0200

Hi Giacomo,

I think this is a good proposal which I do support. If people agree I will add this to the charter when I do the next update (probably this weekend).
I will also go through all the mails and do all uncontroversial updates, e.g. improved formulations, special thanks to Holger on that account.
BTW, from then on the charter for the proposed ICN RG will be available at the Wiki page
http://trac.tools.ietf.org/group/irtf/trac/wiki/icnrg

	Börje

---

From: Dirk Kutscher <[email-masked]>
Date: Thu, 26 May 2011 08:16:48 +0000

Markus,

> describe the main concepts and continue on to the research challenges.

Thanks, good point.

I'd preferably do that in more detail, in a problem statement draft, but I agree that the charter should ideally provide at least a summary for that.

Best regards,

Dirk

---

From: Markus Hofmann <[email-masked]>
Date: Thu, 26 May 2011 06:59:52 -0400

Dirk,

That's what I meant - include in the charter the preparation of a problem statement draft as a deliverable. Not to include the summary itself in the charter.

Thanks,
  Markus