Subject: [irtf-discuss] NSRG Archives

From: Andrew Babakian <[email-masked]>
Date: Thu, 15 Jul 2021 03:44:44 +0000

Hi,

I am a research student in namespaces. I found your website but can see that the NSRG is concluded.

Inquiring to see if there is an archive of the discussions from this group?

Many thanks,

Andrew

---

From: Colin Perkins <[email-masked]>
Date: Thu, 15 Jul 2021 13:53:51 +0100

Hi,

> On 15 Jul 2021, at 04:44, Andrew Babakian <[email-masked]> wrote:
> 

That was a group with closed membership, and I don’t think there was a public mailing list.  Eliot (cc’d) can probably say more about the output of the group. 

Colin

-- 
Colin Perkins
https://csperkins.org/

---

From: Lars Eggert <[email-masked]>
Date: Thu, 15 Jul 2021 15:54:59 +0300

Hi,

> Inquiring to see if there is an archive of the discussions from this group?

https://mailarchive.ietf.org/arch/ doesn't seem to have list archives for NSRG. I am CC'ing the former RG chairs to see if any of them have a private repo that they could make available (to you, and to mailarchive.)

Thanks,
Lars

---

From: Mirja Kuehlewind <[email-masked]>
Date: Thu, 15 Jul 2021 13:10:40 +0000

The webpage says that the discussion listed was closed as well. However, there is a report (that was never published as RFC but probably still captures most if it?):

https://datatracker.ietf.org/doc/html/draft-irtf-nsrg-report-10

On 15.07.21, 14:55, "irtf-discuss on behalf of Lars Eggert" <[email-masked] on behalf of [email-masked]> wrote:

    Hi,

    Thanks,
    Lars

---

From: Steve Crocker <[email-masked]>
Date: Thu, 15 Jul 2021 09:31:10 -0400

I do not have a private repo of that work.

Steve

Sent from my iPhone

> On Jul 15, 2021, at 9:10 AM, Mirja Kuehlewind <[email-masked]> wrote:
>

---

From: Andrew Babakian <[email-masked]>
Date: Thu, 15 Jul 2021 16:11:52 +0000

Thanks for the link! If there is any more published work like this, I would love to read it!

regards,
Andrew
________________________________
From: Mirja Kuehlewind <[email-masked]>
Sent: Thursday, 15 July 2021 11:10 PM
To: Lars Eggert <[email-masked]>; Andrew Babakian <[email-masked]>
Cc: [email-masked] <[email-masked]>; [email-masked] <[email-masked]>; [email-masked] <[email-masked]>
Subject: Re: [irtf-discuss] NSRG Archives

https://datatracker.ietf.org/doc/html/draft-irtf-nsrg-report-10<https://protect-au.mimecast.com/s/YOWVCNLJ2NTv2ZjGijtAdR?domain=datatracker.ietf.org>

Hi,

> Inquiring to see if there is an archive of the discussions from this group?

https://mailarchive.ietf.org/arch/<https://protect-au.mimecast.com/s/r8MYCOMK2OTq6NvyIr5rek?domain=mailarchive.ietf.org> doesn't seem to have list archives for NSRG. I am CC'ing the former RG chairs to see if any of them have a private repo that they could make available (to you, and to mailarchive.)

Thanks,
Lars

---

From: Eliot Lear <[email-masked]>
Date: Thu, 15 Jul 2021 15:45:12 -0400

The archives aren’t available but if you have specific questions I can find answers. 

Eliot

> On Jul 15, 2021, at 08:55, Lars Eggert <[email-masked]> wrote:
> 
> Hi,
>

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 16 Jul 2021 09:01:52 +1200

> https://mailarchive.ietf.org/arch/ doesn't seem to have list archives for NSRG. I am CC'ing the former RG chairs to see if any of them have a private repo that they could make available (to you, an…

A couple of points:

1. This was an invitational IRTF research group, i.e. a closed group, which was not unusual at the time. It was set up at the IAB's request after the workshop that led to RFC2956 (see https://www.rfc-editor.org/rfc/rfc2956.html#section-3.1). Its mailing list was hosted "elsewhere", so no public archive.

2. As is always possible for a research group, it didn't reach consensus. Not everybody agreed with the draft and some people strongly disagreed, but didn't write up their own conclusions. In other words, draft-irtf-nsrg-report-10 is *a* result of the work, not *the* result.

I have 122 messages that were sent to [email-masked] in 1999-2004. Since it was an invitational group, I'm not sure what the ethics are of releasing them.

   Brian

---

From: "Steven M. Bellovin" <[email-masked]>
Date: Thu, 15 Jul 2021 17:03:56 -0400

On 15 Jul 2021, at 17:01, Brian E Carpenter wrote:

>> On 2021-7-15, at 6:44, Andrew Babakian 
>> <[email-masked]> wrote:
>>>
>> https://mailarchive.ietf.org/arch/ doesn't seem to have list archives 
>> for NSRG. I am CC'ing the former RG chairs to see if any of them have 
>> a private repo that they could make available (to you, and to 
>> mailarchive.)
>>
>> Thanks,
>> Lars
>
> A couple of points:
>
> 1. This was an invitational IRTF research group, i.e. a closed group, 
> which was not unusual at the time. It was set up at the IAB's request 
> after the workshop that led to RFC2956 (see 
> https://www.rfc-editor.org/rfc/rfc2956.html#section-3.1). Its mailing 
> list was hosted "elsewhere", so no public archive.
>
> 2. As is always possible for a research group, it didn't reach 
> consensus. Not everybody agreed with the draft and some people 
> strongly disagreed, but didn't write up their own conclusions. In 
> other words, draft-irtf-nsrg-report-10 is *a* result of the work, not 
> *the* result.
>
> I have 122 messages that were sent to [email-masked] in 
> 1999-2004. Since it was an invitational group, I'm not sure what the 
> ethics are of releasing them.
>
Yes, that's my issue, too.

         —Steve Bellovin, https://www.cs.columbia.edu/~smb

---

From: Lars Eggert <[email-masked]>
Date: Fri, 16 Jul 2021 11:08:20 +0300

Hi,

apologies that I missed this having been a closed RG.

> I have 122 messages that were sent to [email-masked] in 1999-2004. Since it was an invitational group, I'm not sure what the ethics are of releasing them.

How many member did the NSRG have? I wonder if it would be feasible to contact them to ask about making the archives public?

(More generally, I think it would be useful if the records of such historic closed groups could be made available for posterity in some form.)

Thanks,
Lars

---

From: Eliot Lear <[email-masked]>
Date: Fri, 16 Jul 2021 05:47:55 -0400

My recollection is approximately 25.

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 17 Jul 2021 09:05:02 +1200

I agree with Lars that lost archives are a problem, but a whole lot of work to solve.

For this particular case where we have an interested customer, it would be sufficient to ask the people who *sent* any archived emails to the list if they are OK with releasing them, so we don't need to reconstruct the whole membership list. I can see 16 distinct senders in my personal (very incomplete) archive.

Regards
   Brian Carpenter

---

From: Andrew Babakian <[email-masked]>
Date: Fri, 16 Jul 2021 21:38:08 +0000

That would be very much appreciated!!

________________________________
From: Brian E Carpenter <[email-masked]>
Sent: Saturday, 17 July 2021 7:05 AM
To: Eliot Lear <[email-masked]>; Lars Eggert <[email-masked]>
Cc: Andrew Babakian <[email-masked]>; [email-masked] <[email-masked]>; [email-masked] <[email-masked]>; [email-masked] <[email-masked]>
Subject: Re: [irtf-discuss] NSRG Archives

Regards
   Brian Carpenter

---

From: Lixia Zhang <[email-masked]>
Date: Wed, 21 Jul 2021 13:41:39 -0700

> On Jul 16, 2021, at 2:47 AM, Eliot Lear <[email-masked]> wrote:
> 

there is a list of names at the end of that draft report
https://datatracker.ietf.org/doc/html/draft-irtf-nsrg-report-10

This document is a description of a review done by the Name Space
Research Group of the Internet Research Task Force.  The members of
that group include:
  J.  Noel Chiappa,   Scott Bradner,      Henning Schulzrinne,
  Brian Carpenter,    Rob Austien,        Karen Sollins, 
  John Wroclawski,    Steve Bellovin,     Steve Crocker,
  Keith Moore,        Steve Deering,      Matt Holdrege,
  Randy Stewart,      Leslie Daigle,      John Ioannidis,
  John Day,           Thomas Narten,      Bob Moskowitz, 
  Ran Atkinson,       Gabriel Montenegro, Lixia Xiang.

(Eliot typed my name wrong:)
I recall that, after the group's progress stagnated, Eliot was called in to help the group finish up.  But the opinions and understandings at the time just too diversified to make the job feasible.
It seems to me that the understanding on naming has much progressed over the last 20-some years, though the diversity of views seems remaining if not further enlarged.

Lixia

---

From: Dave Crocker <[email-masked]>
Date: Wed, 21 Jul 2021 13:44:05 -0700

> It seems to me that the understanding on naming has much progressed over the last 20-some years, though the diversity of views seems remaining if not further enlarged.

It could be enlightening to try to characterize the differences in that 
understanding, between then and now.

d/

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 22 Jul 2021 11:12:37 +1200

Thanks Lixia, well spotted.

Does anyone have a full private archive of the list?
If so it might be worth the effort of getting permission
to make it public from that list. It doesn't seem worth
it for the small fraction of traffic that I captured.

Regards
   Brian Carpenter

On 22-Jul-21 08:41, Lixia Zhang wrote:
> .

---

From: "Steven M. Bellovin" <[email-masked]>
Date: Wed, 21 Jul 2021 20:11:36 -0400

Full? I have no idea. I have 155 messages that have the
proper List-Archive header line, and 266 that have nsrg
in some address line. Some of those are definitely duplicates,
e.g., messages I sent in which case they'd be in a 'Sent'
folder as well. I also have 288 messages in the folder I used
for that mailing list, but from a quick scan it has some pre-RG
messages as well. From a random check, at least one of those
might be considered personal.

On 21 Jul 2021, at 19:12, Brian E Carpenter wrote:

>> I recall that, after the group's progress stagnated, Eliot was called 
>> in to help the group finish up.  But the opinions and understandings 
>> at the time just too diversified to make the job feasible.
>> It seems to me that the understanding on naming has much progressed 
>> over the last 20-some years, though the diversity of views seems 
>> remaining if not further enlarged.
>>
>> Lixia
>>
>>>>> 1999-2004. Since it was an invitational group, I'm not sure what 
>>>>> the ethics are of releasing them.
>>>> How many member did the NSRG have? I wonder if it would be feasible 
>>>> to contact them to ask about making the archives public?
>>>>
>>>> (More generally, I think it would be useful if the records of such 
>>>> historic closed groups could be made available for posterity in 
>>>> some form.)
>>>>
>>>> Thanks,
>>>> Lars
>>>>
>>>
>>
>> .
>>