Subject: [irtf-discuss] Is there a home for Semantic Routing in the IRTF?

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 10 Mar 2022 15:57:04 -0000

Hi,

On a recent thread that I was cc'ed on, you said:

> The IRSG reviewed the proposal for a semantic routing research 
> group, and concluded that it did not meet the bar for chartering
> as a new IRTF group.

This came as a real surprise to me as one of the main proponents of the
Semantic Routing work. No one ever made a formal request or proposal to you,
and the furthest we got was an early draft of a charter to scope what we
wanted to work on and to gather feedback from friends and researchers.

Indeed, the IRSG minutes (by the way, very many thanks for making IRSG
meeting minutes public) don't show any evidence of detailed discussion, no
consideration of the draft charter, and no discussion with any of the
proponents. I did have a chat with you in early November to give you a heads
up that we were thinking about this, and you were pretty certain at that
point that there was a considerable overlap with COIN.

>From the minutes of the 2021-10-26, I see:

| Lars Eggert mentioned a group wanting to meet. 
|
| Colin mentioned he thought it was one specific company asking for a 
| research group, but unless they can bring a verified community he 
| wasn't going to approve a group.

It's not clear from the minutes whether this was Semantic Routing or not.
There was, I think, a lot of debate about research into Satellite Networks
at around the same time. At the time of this IRSG meeting, you and I hadn't
talked about the proposal, so I suppose this was an early view without any
deep dive.

>From the minutes of the 2021-11-30 meeting I see:

| Colin also spoke about the IETF 112 side meetings, one on 
| semantic routing that proposed a research group charter that was 
| narrower than expected. He noted he would likely not charter a 
| new group at this time, as it looked like the work would overlap 
| with both COINRG and also possibly PANRG. The contractual 
| routing, semantic routing, and internet addressing that seem 
| closely related. He suggested the proponents start with COINRG 
| to develop the ideas further.

I like that you were surprised by the narrowness of the proposed charter
since it was not substantially changed from what we talked about when we met
on 2021-11-05.

I'm not worried that you recommended us to air the ideas in COIN, and this
has helped us a lot to formulate the concepts and to attract a number of
people to discuss their work. That it turns out that "routing is out of
scope of COIN" (to quote all three of the co-chairs in separate emails) is
not a surprise, although it leaves us with not a lot left to discuss in
COIN. Perhaps the mechanisms used to programme the forwarding plane in
support of Semantic Routing can be discussed there, and perhaps there will
be room for work on the applicability of Semantic Routing in support of
specific compute in the network requirements if someone is interested in
that work. Of course, this has used up some time and energy, and arguably
clogged up the otherwise empty COIN mailing list, but so long as we are
gaining understanding, that is not a problem.

But I would note that you were not approached with a formal request for a
new RG. Rather, we put together a talking point for discussion to see what
reaction we would get and what would be needed to take it further. This
seems consistent with the level of debate recorded in the IRSG minutes, and
it doesn't seem that there was discussion about a proposal to form an RG for
Semantic Routing, an opinion expressed by the IRSG, or any exploration with
the proponents of what they wanted to do. But it does all seems a bit
pre-emptive and closed.

So, just as a matter of getting the record straight, can you clarify a few
points:

- Was the discussion from the 2021-10-26 meeting quoted above about Semantic
Routing?
- If the 2021-10-26 discussion was about Semantic Routing, what specific
company were you implying I was associated with?
- Did you at any time suggest to any of the proponents of Semantic Routing
that unless they can bring a verified community you were not going to
approve a group?
- What discussion of the Semantic Routing proposal did the IRSG have, what
input did they seek from the proponents to clarify the proposal, and how was
the conclusion that the bar had not been met communicated to the proponents?

Lastly, now that it is clear that a substantial part of Semantic Routing is
related to routing, and reiterating that we are looking at packet routing
within "limited domains" as well as for wider connectivity, do you have any
further advice about where our work sits within the IRTF/IETF?

Many thanks,
Adrian

---

From: Colin Perkins <[email-masked]>
Date: Thu, 10 Mar 2022 23:01:41 +0000

Adrian,

You sent me a proposed research group charter, along with an extensive motivation document, to review in November 2021. I discussed this with relevant members of the IRSG, and we had a call – at your request – where I gave you feedback. That feedback was that it was not appropriate to charter a semantic routing group because, to the extent that there was research being proposed, it seemed to overlap with existing IRTF groups, primarily COINRG. Much of the work also seemed to be outside the scope of IRTF or better suited to other venues.

After further discussion with members of the IRSG, and with others in the community, during IETF 112, I repeated that feedback by email on 15 November, in response to discussion you initiated on the COINRG list.

Colin

> On 10 Mar 2022, at 15:57, Adrian Farrel <[email-masked]> wrote:
> 
> Hi,
>

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 11 Mar 2022 11:35:22 -0000

Dear Colin,

Oh dear. Clearly some communication problems. I am very sorry to have to write this email, but I find it necessary to set out a fuller record of the exchanges about Semantic Routing.

I would be glad if you could recognise that this is an accurate representation of our interactions on this topic.

I would also appreciate it if you could address the questions at the end of my previous email. It is incumbent on leaders in our community to answer questions about process and their activities.

In February and March last year you and I discussed draft-king-irtf-semantic-routing-survey. I asked for a short presentation slot at IRTF Open at IETF-110. You said you had discussed with "the IRSG members" and that you did not think it was suitable to present at the meeting. You commented that the range of topics covered was broad and overlapped with other RGs. You suggested I discuss the work within existing RGs and hold a side meeting to assess community interest.

On November 2nd last year I sent you a courtesy email. The email recognised that we had been discussing a proposal to work on research for Semantic Routing with "friends" in the community and had a slot in the forthcoming HotRFC. I explained that our intent was to spend time at IETF 112 sounding out the community. Given the visibility, I felt it polite to let you know what was going on and to point you at our latest thoughts (a "motivation" and a "scope", the latter in the form of a draft charter). I did not ask you for an opinion or a review.

At Hot RFCs for IETF 112 (that took place on November 3rd, before IETF 112). There was a slot to float the idea for working on Semantic Routing research. I wasn't there, but the reports I heard suggested that there was some confusion between this idea and previous efforts under the banner "FIPE." In order to make sure this confusion didn't persist, I asked for a meeting with you. At HotRFC, you also said that you thought the work fitted within COIN, but you suggested that this had already been explained to the proponents, something that could not have happened at that time because the idea was still in its infancy.

You and I had our meeting at 4pm (UK) on November 5th. At that meeting you re-asserted your view that the Semantic Routing idea overlapped substantially with what COIN is working on. We took that as "direction" and acted accordingly by bringing our thoughts to the COIN list and to the recent COIN interim. At our meeting you also re-asserted that this work was part of the "FIPE effort" and repeatedly told me that I was a supporter of the FIPE work. You did not appear to hear my contradictions, and I felt the need to send you an email the same day to clarify the content of my talk at the FIPE side meeting at IETF 109 which:
- Only mentioned Semantic Routing as a passing comment 
- Spent most of its time telling people how previous attempts to
  make changes to the routing and addressing scheme had faired
- Advised people how best to bring work to the IETF and IRTF
In that email I also indicated that I had heard you and that we would direct our work to existing RGs.

In mid-November there was a series of emails on the COIN list trying to work out which bits of Semantic Routing fitted within the COIN scope, and how. You summed up that thread and gave your opinions on November 15th noting that your feedback was that "Some aspects of the semantic routing work fell into the scope of COINRG, and some parts overlapped with other IRTF groups. It seemed that there was no need for a new group, since IRTF had existing venues that covered key aspects of the proposed work. Parts of the work also seemed to be outside the scope of IRTF or better suited to other venues." You also said that having, "Discussed with a number of people, with a range of views on the issue, attended the side meeting, and read the email discussion, I remain of that opinion." You reasserted that, "It does not seem appropriate to charter a semantic routing group," In addition to saying that the work overlaps strongly with the scope of COINRG, and somewhat with several other IRTF groups, you added that, "Not all of the work is in scope, but should the proponents want to discuss their ideas in IRTF, there are venues for it."

Colin, I am not debating that you decided not to charter a research effort at that time. I am concerned that your representation of events was incomplete and conflated "discussions with some members of the IRSG" with decisions made by the IRSG.

In the light of the recent decision that routing is out of scope for COIN, I am also asking whether you have any further recommendations about where Semantic Routing should be discussed within the IRTF.

Looking forward to your response,
Adrian

-----Original Message-----
From: Colin Perkins <[email-masked]> 
Sent: 10 March 2022 23:02
To: Adrian Farrel <[email-masked]>
Cc: [email-masked]
Subject: Re: Is there a home for Semantic Routing in the IRTF?

Adrian,

Colin

---

From: Lars Eggert <[email-masked]>
Date: Fri, 11 Mar 2022 14:06:26 +0200

Hi,

> In the light of the recent decision that routing is out of scope for COIN, I am also asking whether you have any further recommendations about where Semantic Routing should be discussed within the…

I'm not Colin - and I'm wearing no hats here.

There are *many* research topics related to networking that have no discussion venue in the IRTF.

I don't think the IRTF or its chair is under any obligation to create or even identify such discussion venues, especially when they and/or the IRSG believe a given research topic is unlikely to become a topic for the IRTF.

Over on the IETF side, non-working-group lists exist and can be created if an AD approves, or the interested research community could create a discussion forum in any number of ways (Slack, Google-hosted list, GitHub discussions, etc.)

Thanks,
Lars

---

From: Colin Perkins <[email-masked]>
Date: Fri, 11 Mar 2022 17:27:14 +0000

Adrian,

I’m not going to trade selective quotes from email exchanges and personal notes about Zoom calls. 

Decisions around chartering IRTF research groups are made by the IRTF Chair with input from the IRSG, and subject to approval by the IAB; they are not made by the IRSG.

My email yesterday reminded you of the feedback I gave about your semantic routing proposal, and outlined some discussions I had with the IRSG on which I based that feedback. I have given similar feedback, also based on discussions with the IRSG, to others making similar proposals.

To answer your specific questions:

> - Was the discussion from the 2021-10-26 meeting quoted above about Semantic Routing?

No.

> company were you implying I was associated with?

Not applicable (see above).

> that unless they can bring a verified community you were not going to

Not that I recall. I do note, though, that the community is one aspect to consider when evaluating a proposal for a research group so it would be a reasonable thing to ask about.

> - What discussion of the Semantic Routing proposal did the IRSG have, what input did they seek from the proponents to clarify the proposal, and how was the conclusion that the bar had not been met communicated to the proponents?

This was answered in my email yesterday.

I believe I have made my position clear. Continuing this discussion no longer seems productive. 

Colin

> On 11 Mar 2022, at 11:35, Adrian Farrel <[email-masked]> wrote:
> 
> Dear Colin,
>

---

From: Mirja Kuehlewind <[email-masked]>
Date: Fri, 11 Mar 2022 17:27:41 +0000

Hi Adrian,

I'm also not Colin, however, I'm replying because the repurpose of rehashing past comments and discussion on this mailing list is really not clear to me.

I would say that Colin's statements are pretty clear and consistent. The charter text you proposed is not appropriate for chartering an RG given a) overlap with other RGs and b) potential non-research aspects that are not in scope for the IRTF in general. I think it's on you now to further work on refining the scope.

Mirja

On 11.03.22, 13:07, "irtf-discuss on behalf of Lars Eggert" <[email-masked] on behalf of [email-masked]> wrote:

    Hi,

    Thanks,
    Lars