Subject: RE: [Isis-wg] Unknown Version/ Protocol ID Extension

From: Jeff Parker <[email-masked]>
Date: Mon, 22 Jul 2002 12:11:26 -0400

> 	One of such errors is unknown version number.

I am surprised that we didn't add this to the list of
things to check in draft-ietf-isis-interoperable-01.txt.
I will add to my to-do list.

- jeff parker

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Jeff Parker <[email-masked]>
Date: Mon, 22 Jul 2002 12:34:33 -0400

> Since the current Version/Protocol ID Extension and Version 
> fields in the
> ISIS PDU fixed headers are set to one (1), 
> so if an ISIS implementation receive a PDU with different 
> values, how should
> the receiving ISIS router handle the PDU?

Looking a bit further...

The current mib includes a notification to be sent
when getting such an error.  It assumes that we would 
see this only in a hello packet, which is a valid 
assumption if
	1) the implementation uses the same version throughout
	2) the field isn't smashed in transit in, say, an LSP

No distinction is made between the two different version
fields.  Since the PDU header is included, any difference
in values is visible to the recipient of the trap.

- jeff parker
- axiowave networks

    isisVersionSkew NOTIFICATION-TYPE
        OBJECTS {
            isisProtocolVersion,
            isisSystemLevel,
                isisPDUFragment,
            isisCircIfIndex
        }
        STATUS current
        DESCRIPTION
            "A notification sent when we receive a Hello
             PDU from an IS running a different version
             of the protocol. This notification includes
             the header of the packet, which may help a
             network manager identify the source of the
             confusion.

             This should be an edge-triggered notification.
             We should not send a second notification about
             PDUs received from what seem to be the same source.
             This decision is up to the agent to make, and may
             be based on the circuit or on some MAC level
             information."

    ::= { isisTrapPrefix 11 }