Subject: [Isis-wg] Hello PDU sequence numbers

From: Jeff Parker <[email-masked]>
Date: Tue, 13 Aug 2002 17:53:50 -0400

Subject changed to more relevant name.  

> >   This would be a good troubleshooting tool for large ISIS networks
> >   and specifically for point-2-multipoint networks as I( and Naiming)
> >   worked on in our previous lives.
>
> If you can get a statistical approximation of the drop rate per
> neighbor without changing the protocol, would that suffice?
> Presumably, knowing that one or two hellos disappeared into the void
> is not interesting, but 5 or 10 percent would be.  This should be easy
> to do without torquing the protocol spec.
> 
> [Dave Katz]
 
The PDU counters in the MIB today provide what Dave is 
describing.  It would be easy to compare the counts from 
the two sides of a connection.  The 09 version of the table 
follows.

This level of detail is much less fine that the sequence counters 
permits.  But how could we convey such detail to the outside world? 
I suppose we could send a sequence like the following, but this
reminds me of an IQ test rather than a measurement suitable for 
recording.  

	{1, 4, 6, 8, 9, 10, 12, 14, 15, 16, 18, 20 ...}  

- jeff parker

    isisPacketCounterTable OBJECT-TYPE
        SYNTAX SEQUENCE OF IsisPacketCounterEntry
        MAX-ACCESS not-accessible
        STATUS current
        DESCRIPTION
            "Information about IS-IS protocol traffic at one level
             on one circuit in one direction"
    ::= { isisCounters 3 }

    isisPacketCounterEntry OBJECT-TYPE
        SYNTAX IsisPacketCounterEntry
        MAX-ACCESS not-accessible
        STATUS current
        DESCRIPTION
            "Information about IS-IS protocol traffic at one level
             on one circuit in one direction"
        INDEX { isisSysInstance,
                isisCircIndex,
                isisPacketCountLevel,
                isisPacketCountDirection }
    ::= { isisPacketCounterTable 1 }

    IsisPacketCounterEntry ::=
        SEQUENCE {
            isisPacketCountLevel
                INTEGER,
            isisPacketCountDirection
                INTEGER,
            isisPacketCountHello
                Counter32,
            isisPacketCountLSP
                Counter32,
            isisPacketCountCSNP
                Counter32,
            isisPacketCountPSNP
                Counter32
    }

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Naiming Shen <[email-masked]>
Date: Tue, 13 Aug 2002 15:18:30 -0700

Jeff,

 ] Subject changed to more relevant name.  
 ] 

thanks. if i follow the below logic correctly, can i say that MIB is
not needed, since telnet has offered the exact information ?-(

Cheers.

 ] 
 ] > >   This would be a good troubleshooting tool for large ISIS networks
 ] > >   and specifically for point-2-multipoint networks as I( and Naiming)
 ] > >   worked on in our previous lives.
 ] >
 ] > If you can get a statistical approximation of the drop rate per
 ] > neighbor without changing the protocol, would that suffice?
 ] > Presumably, knowing that one or two hellos disappeared into the void
 ] > is not interesting, but 5 or 10 percent would be.  This should be easy
 ] > to do without torquing the protocol spec.
 ] > 
 ] > [Dave Katz]
 ]  
 ] The PDU counters in the MIB today provide what Dave is 
 ] describing.  It would be easy to compare the counts from 
 ] the two sides of a connection.  The 09 version of the table 
 ] follows.
 ] 
 ] This level of detail is much less fine that the sequence counters 
 ] permits.  But how could we convey such detail to the outside world? 
 ] I suppose we could send a sequence like the following, but this
 ] reminds me of an IQ test rather than a measurement suitable for 
 ] recording.  
 ] 
 ] 	{1, 4, 6, 8, 9, 10, 12, 14, 15, 16, 18, 20 ...}  
 ] 
 ] - jeff parker
 ] 
 ]     isisPacketCounterTable OBJECT-TYPE
 ]         SYNTAX SEQUENCE OF IsisPacketCounterEntry
 ]         MAX-ACCESS not-accessible
 ]         STATUS current
 ]         DESCRIPTION
 ]             "Information about IS-IS protocol traffic at one level
 ]              on one circuit in one direction"
 ]     ::= { isisCounters 3 }
 ] 
 ]     isisPacketCounterEntry OBJECT-TYPE
 ]         SYNTAX IsisPacketCounterEntry
 ]         MAX-ACCESS not-accessible
 ]         STATUS current
 ]         DESCRIPTION
 ]             "Information about IS-IS protocol traffic at one level
 ]              on one circuit in one direction"
 ]         INDEX { isisSysInstance,
 ]                 isisCircIndex,
 ]                 isisPacketCountLevel,
 ]                 isisPacketCountDirection }
 ]     ::= { isisPacketCounterTable 1 }
 ] 
 ]     IsisPacketCounterEntry ::=
 ]         SEQUENCE {
 ]             isisPacketCountLevel
 ]                 INTEGER,
 ]             isisPacketCountDirection
 ]                 INTEGER,
 ]             isisPacketCountHello
 ]                 Counter32,
 ]             isisPacketCountLSP
 ]                 Counter32,
 ]             isisPacketCountCSNP
 ]                 Counter32,
 ]             isisPacketCountPSNP
 ]                 Counter32
 ]     }
 ] 
 ] _______________________________________________
 ] Isis-wg mailing list
 ] [email-masked]
 ] https://www1.ietf.org/mailman/listinfo/isis-wg

- Naiming