Subject: RE: [Isis-wg] Protocols Supported TLV

From: Jeff Learman <[email-masked]>
Date: Wed, 18 Sep 2002 11:45:54 -0400

At 11:08 AM 9/18/2002, Jeff Parker wrote:
>> I would like to know what people think should be done with the
>> information received in the Protocols Supported TLV of an IIH, in the
>> way of compatibility checking.
>
>Ruth -
>        We hashed this out a few months ago when writing
>http://ietf.org/internet-drafts/draft-ietf-isis-interoperable-01.txt
>
>The document is still under revision, but this portion 
>has settled down, and hasn't changed much recently.
>The section from my current version is reproduced
>below.  
>
>One of the sticky points is what happens
>with DIS election on a LAN - you can get into 
>situations where not everyone can talk to the DIS,
>or where you have dueling DISs.  It seems that 
>discussion of this issue was left on the 
>cutting room floor.  

I'm surprised I let that happen, since this was my mantra for a while.
I'll see if I can come up with a paragraph to fit in context.

Regards,
Jeff

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Les Ginsberg <[email-masked]>
Date: Wed, 18 Sep 2002 10:07:18 -0700

>I'll see if I can come up with a paragraph to fit in context.

Actually I believe we deliberately left out discussion of this issue 
because we knew that the ITU work and the associated auto-encapsulation 
draft work being done by Philip were addressing this issue and we didn't 
want to do a disservice by having either an incomplete discussion or a 
solution which differed from what was eventually settled on by the other 
work. Hence the statement in the section from 
http://ietf.org/internet-drafts/draft-ietf-isis-interoperable-01.txt which 
Jeff P quoted:

     "However, the behavior of mixed networks that do not fol-
      low these guidelines is not well defined."

  Section 5.1 of Philip's latest draft  (draft-ietf-isis-auto-encap-02.txt) 
addresses this issue quite well.

    Les

---

From: Jeff Learman <[email-masked]>
Date: Wed, 18 Sep 2002 13:31:52 -0400

Good point, Les, but we should at least warn folks that this is
not a plug-and-play situation.  I agree we shouldn't attempt to
solve it, just point out the problem and mention that it can be
worked around by configuring DR priorities.

At 01:07 PM 9/18/2002, Les Ginsberg wrote:
>Actually I believe we deliberately left out discussion of this issue because we knew that the ITU work and the associated auto-encapsulation draft work being done by Philip were addressing this issue and we didn't want to do a disservice by having either an incomplete discussion or a solution which differed from what was eventually settled on by the other work. Hence the statement in the section from http://ietf.org/internet-drafts/draft-ietf-isis-interoperable-01.txt which Jeff P quoted:
>
> Section 5.1 of Philip's latest draft  (draft-ietf-isis-auto-encap-02.txt) addresses this issue quite well.
>
>   Les