Subject: [Isis-wg] MTU lowering in IS-IS

From: <[email-masked]>
Date: Mon, 26 Aug 2002 12:44:42 -0000

Hello Everyone,

I have a question regarding how IS-IS should handle MTU changes in the System. If i decrease the MTU size on a interface to a value which will lower the current LSP buffer size, then how should IS-IS handle this case ?

 Also how do we inform the IS's neighbours that the Buffer Size in the Local IS has been lowered ? Does the padding of the IIH packets help in this case?

Thanks,
Sarav

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Jeff Parker <[email-masked]>
Date: Tue, 10 Sep 2002 10:38:00 -0400

> Hi Jeff,
> 
> After looking into the draft, i've got one basic question, should'nt
> ReceiveLSPBufferSize be less than ( or equal to ) the minimum 
> of the Link
> MTUs of all the circuitsin the router ?  Otherwise how will the router
> receive LSPs through a circuit whose MTU is smaller than the LSP size.
> 
> Thanks,
> Sarav

Sarav -
	Did you mean the maximum rather than the minimum?  

	Do you mean the maximum of your current interfaces/  How
do you deal with migrating a configuration to deal with new 
interfaces that support a larger MTU?

	The area is rich with possibilities of missconfiguration,
leading to odd behavior and generalized frustration.  I think
the steps outlined in the draft provide one algorithm to deal
with this.  Please let me know if you see a flaw.

- jeff parker

---

From: Jeff Parker <[email-masked]>
Date: Mon, 16 Sep 2002 10:24:13 -0400

> Hi Mike, Jeff,
> 
> Sorry for my late reply.. as i've been away form my mail for a while.
> 
> I see both your points here. But my concern is with the 
> definition of the ReceiveLSPBufferSize, .... the  
> "size of the largest LSP we can receive". Is'nt
> it given that a router which receives a LSP on one 
> of its interface should flood it out through all 
> its other interfaces.
 
> > Are we bit fiddling with  something that works or trying to fix
> > something that does not work?
> >
> > Mike
 
Saravana -
	Three different answers to your question. 

	1) This doesn't break anything, so we don't need to fix it.
	An integer can be used to store an Enum that never gets close
	to MAXINT.  

	2) Be liberal in what you recieve ....

	3) If you are trying to change the MTU in a running network, 
	you will find that you need something like this variable as
	part of your transition.  

But what is your concern about this value?  Are you worried about
wasting fixed-size buffers?  Or that everything doesn't line up
perfectly?

- jeff parker