Subject: Re: [Isis-wg] Paper comparing OSPF and ISIS

From: "Philip Christian" <[email-masked]>
Date: Fri, 06 Sep 2002 09:07:36 +0000

I would be glad to help and would like to be on the list.

In a single protocol environment the differences between OSPF and IS-IS are small, although the extensibility of IS-IS is one notable exception (they had to do opaque LSAs to get this in OSPF, and not all implementations support it).

The differences in a multiprotocol environment are enormous though.  With the demise of CLNP everyone has forgot about the "Integrated" part of Integrated IS-IS, but with IPv6 coming onto the scene it will get important again.

You cannot do this with OSPF
http://www.ietf.org/internet-drafts/draft-ietf-isis-auto-encap-01.txt (shameless plug for my own work :)

On the other hand OSPF is probably more idiot proof.  You don't have to worry about topological restrictions so much.  Also IS-IS doesn't have a virtual link capability, although the forgotten IS-IS over IP draft would allow virtual links.

Philip
----- Original Message -----
From: "Manral, Vishwas" <[email-masked]>
Date: Wed, 4 Sep 2002 06:58:56 -0400 
To: "[email-masked]''" <[email-masked]>
Subject: [Isis-wg] Paper comparing OSPF and ISIS

> Hi folks,
> 
> The topic of differences between OSPF and ISIS has been raised more than
> once. The topic has been covered in a few presentations before as well as a
> lot of internal documents. It would however be helpful to "compare both
> specs and put down the differences and pros and cons of the differences" for
> the benefit of people.
> 
> I intend to make a group of people who would be interested in the effort. So
> anyone willing to help can mail me and I will add them to the group, from
> where we can take this further on.
> 
> I do have a preliminary list of things to start off.
> 
> Thanks,
> Vishwas
> 
> _______________________________________________
> Isis-wg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/isis-wg
> 

-- 
__________________________________________________________
Sign-up for your own FREE Personalized E-mail at Mail.com
http://www.mail.com/?sr=signup

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: "Manral, Vishwas" <[email-masked]>
Date: Fri, 6 Sep 2002 05:26:06 -0400

Hi Philip,

We have the points you mentioned on our radar already,;-) besides many more.

I will add you to the list.

Thanks,
Vishwas

-----Original Message-----
From: Philip Christian [mailto:[email-masked]]
Sent: Friday, September 06, 2002 2:38 PM
To: Manral, Vishwas
Cc: [email-masked]
Subject: Re: [Isis-wg] Paper comparing OSPF and ISIS

In a single protocol environment the differences between OSPF and IS-IS are
small, although the extensibility of IS-IS is one notable exception (they
had to do opaque LSAs to get this in OSPF, and not all implementations
support it).

The differences in a multiprotocol environment are enormous though.  With
the demise of CLNP everyone has forgot about the "Integrated" part of
Integrated IS-IS, but with IPv6 coming onto the scene it will get important
again.

You cannot do this with OSPF
http://www.ietf.org/internet-drafts/draft-ietf-isis-auto-encap-01.txt
(shameless plug for my own work :)

On the other hand OSPF is probably more idiot proof.  You don't have to
worry about topological restrictions so much.  Also IS-IS doesn't have a
virtual link capability, although the forgotten IS-IS over IP draft would
allow virtual links.

Philip