Subject: [Isis-wg] isisISAdjState

From: Noguchi Kay <[email-masked]>
Date: Mon, 09 Sep 2002 16:13:52 -0700

Hi Jeff,

One question about isisISAdjState.

What is the intention of '0' as 'up' state like below in -09 draft.

    isisISAdjState OBJECT-TYPE
        SYNTAX INTEGER
            {
                 up (0),
                 initializing (1),
                 down (2),
                 failed (3)
            }
        MAX-ACCESS read-only
        STATUS current
        DESCRIPTION
            "The state of the adjacency"
        REFERENCE "{ISIS.aoi adjacencyState (78)}"
    ::= { isisISAdjEntry 2 }

For me, '0' as down is reasonable because usually the state is changing
from down(0), initializing(1) and then up(2).

    isisISAdjState OBJECT-TYPE
        SYNTAX INTEGER
            {
                 down (0),
                 initializing (1),
                 up (2),
                 failed (3)
            }
        MAX-ACCESS read-only
        STATUS current
        DESCRIPTION
            "The state of the adjacency"
        REFERENCE "{ISIS.aoi adjacencyState (78)}"
    ::= { isisISAdjEntry 2 }

Thank you,

								kay
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Hannes Gredler <[email-masked]>
Date: Tue, 10 Sep 2002 02:26:51 +0200

noguchi,

the MIB reflects the adjacency states that are
conveyed in TLV #240; [see 3-way handshaking draft]

/hannes

On Mon, Sep 09, 2002 at 04:13:52PM -0700, Noguchi Kay wrote:
| Hi Jeff,
| 
| One question about isisISAdjState.
| 
| What is the intention of '0' as 'up' state like below in -09 draft.
| 
|     isisISAdjState OBJECT-TYPE
|         SYNTAX INTEGER
|             {
|                  up (0),
|                  initializing (1),
|                  down (2),
|                  failed (3)
|             }
|         MAX-ACCESS read-only
|         STATUS current
|         DESCRIPTION
|             "The state of the adjacency"
|         REFERENCE "{ISIS.aoi adjacencyState (78)}"
|     ::= { isisISAdjEntry 2 }
| 
| For me, '0' as down is reasonable because usually the state is changing
| from down(0), initializing(1) and then up(2).
| 
|     isisISAdjState OBJECT-TYPE
|         SYNTAX INTEGER
|             {
|                  down (0),
|                  initializing (1),
|                  up (2),
|                  failed (3)
|             }
|         MAX-ACCESS read-only
|         STATUS current
|         DESCRIPTION
|             "The state of the adjacency"
|         REFERENCE "{ISIS.aoi adjacencyState (78)}"
|     ::= { isisISAdjEntry 2 }
| 
| Thank you,