Subject: [Isis-wg] RE: index of isisISAdjIPAddrEntry

From: Jeff Parker <[email-masked]>
Date: Mon, 26 Aug 2002 18:43:39 -0400

Kay -
	Could you take a look at the current version of
the MIB and rephrase your question?  The 09 version
has a different index, which may alter your request.  

- jeff parker

> Hi Jeff,
> 
> This time is the index of isisISAdjIPAddrEntry.
> 
> Like other entries, isisSummAddrEntry and isisRedistributeEntry, let's
> use isisISAdjIPAddressType and isisISAdjIPAddress instead of
> isisISAdjIPAddrIndex as the index of isisISAdjIPAddrEntry.
> 
> And let's omit isisISAdjIPAddrIndex itself like below.
> 
>     isisISAdjIPAddrEntry OBJECT-TYPE
>         SYNTAX IsisISAdjIPAddrEntry
>         MAX-ACCESS not-accessible
>         STATUS current
>         DESCRIPTION
>             "Each entry contains one IP Address reported by a
>              neighboring Intermediate System in its IIH PDUs."
>         INDEX { isisSysInstance,
>                 isisCircIndex,
>                 isisISAdjIndex,
>                 isisISAdjIPAddressType
>                 isisISAdjIPAddress }
>     ::= { isisISAdjIPAddrTable 1 }
> 
>     IsisISAdjIPAddrEntry ::=
>         SEQUENCE {
>             isisISAdjIPAddressType
>                  InetAddressType,
>             isisISAdjIPAddress
>                 InetAddress
>         }
> 
> Thank you,
> 
> 								kay
> 
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Noguchi Kay <[email-masked]>
Date: Mon, 26 Aug 2002 16:42:27 -0700

Hi Jeff,

> has a different index, which may alter your request.  

	I only referencing -09 draft. I totaly forgat about -08 version. :p
	If you have -10 draft, please send it to me. ;P

	And I sent another mail that corrected my point regarding
	isisISAdjIPAddrEntry. I've attached that mail.

	My point is the consistency between those three.

	- isisSummAddrEntry
	- isisRedistributeEntry
	- isisISAdjIPAddrEntry

	The Upper two use *AddressType, *Address and *AddrPrefixlen as an
	index and the last one uses *IPAddrIndex.

	So then I sent a mail to sync isisISAdjIPAddrEntry back again
	to the other two.

Thank you,

								kay

> >     ::= { isisISAdjIPAddrTable 1 }

Subject: Re: index of isisISAdjIPAddrEntry
From: Noguchi Kay <[email-masked]>
To: [email-masked], [email-masked]
Cc: [email-masked]
Date: Wed, 21 Aug 2002 18:41:46 -0700

Hi Jeff,

# I didn't receive previous mail and those mail is not in the archive itself.
# Do you know what's going on in the mailing list itself? ;P

> isisISAdjIPAddrIndex as the index of isisISAdjIPAddrEntry.

	I saw the mailing list archive and I'm the guy who suggested to
	remove the isisISAdjIPAddress itself. Sorry for the back and
	forth comments.

	But the point is the consistency between those three entries.

	- isisSummAddrEntry
	- isisRedistributeEntry
	- isisISAdjIPAddrEntry

	Top two have the InetAddress type index and the bottom one doesn't.
	This makes a confusion to me.

	Could you clarify that point, Jeff?

    isisSummAddrEntry OBJECT-TYPE
        SYNTAX IsisSummAddrEntry
        MAX-ACCESS not-accessible
        STATUS current
        DESCRIPTION
            "Each entry contains one IP summary address."

        INDEX { isisSysInstance,
                isisSummAddressType,
                isisSummAddress,
                isisSummAddrPrefixLen }
    ::= { isisSummAddrTable 1 }

    isisRedistributeAddrEntry OBJECT-TYPE
        SYNTAX IsisRedistributeAddrEntry
        MAX-ACCESS not-accessible
        STATUS current
        DESCRIPTION
            "Each entry contains one IP summary address to
             manage leaking L2 addresses into L1."
        INDEX { isisSysInstance,
                isisRedistributeAddrType,
                isisRedistributeAddrAddress,
                isisRedistributeAddrPrefixLen }
    ::= { isisRedistributeAddrTable 1 }

                isisISAdjIPAddrIndex