Subject: RE: [Isis-wg] Fwd: Last Call: Draft of agreement between ISOC/IET F and SO/IEC JTC1/SC6 on IS-IS protocol development to Informational

From: Chris Hopps <[email-masked]>
Date: Wed, 30 Oct 2002 07:31:13 -0800

Nah, it's

ISISIDREPCPPCNS

Chris.

-----Original Message-----
From: Jeff Parker [mailto:[email-masked]] 
Sent: Wednesday, October 30, 2002 7:23 AM
To: 'Alex Zinin'; [email-masked]'
Subject: RE: [Isis-wg] Fwd: Last Call: Draft of agreement between ISOC/IET F
and SO/IEC JTC1/SC6 on IS-IS protocol development to Informational

One of the first things I hope will come out of this
new accord is a ruling on the spelling of the protocol.
Is it ISIS or IS-IS?   

- jeff parker
- axiowave networks
- All those who believe in psychokinesis, raise my hand.
    
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: mike shand <[email-masked]>
Date: Wed, 30 Oct 2002 15:44:21 +0000

>ISISIDREPCPPCNS

But does R stand for Routing or Routeing? :-)

and it's IS-IS definitely.

         Mike

---

From: Jeff Parker <[email-masked]>
Date: Thu, 31 Oct 2002 15:19:41 -0500

First, let me say that I think this is a great step forward.
Having said that, it is something we should consider pretty
carefully in the very limited time a Last Call allows.  
I re-read this last night, and started going down the list
of current Drafts, and tried to figure out where each would
fall.  I would be interested to see how others would sort
the documents.  Granted that we can still publish anything
we like: the issue is simply the status of the document.
But it is an interesting exercise.  For example, where
does the M-IS-IS work fall?

Comments below marked with leading >>.

> 
>     This Internet-Draft documents proposes text of an 
> agreement between
>     ISOC/IETF and ISO/IEC JTC1/SC6 regarding cooperative 
> development of
>     the IS-IS routing protocol extensions.
 
> Files can be obtained via
> http://www.ietf.org/internet-drafts/draft-zinin-ietf-jtc1-aggr-00.txt

>> So thinking out loud about the split

2. Definitions

 2.1 Core IS-IS Mechanisms

   Core IS-S Mechanisms are subsystems with associated algorithms, data
   structures, and PDU formats as specified in (ISO/IEC 10589),
   constituting the core of the IS-IS protocol and including the
   following elements:

     a)   Framework of PDU formats, including standard TLVs

>> Standard means?  Things defined in 10589, plus anything that
JTCL adds?  I'm a bit leary about this term, if only because
it suggests that TLV 0x81 isn't 'standard'.  Perhaps we could
clarify, or call this something like "JTCL Standard". 

     b)   Encapsulation of PDUs

>> Tony has spoken to this.  

     c)   Adjacency state machine and formation logic

>> We have recently played in these waters
when adding the clause about matching IP interface
addresses on either side.

     d)   DIS election algorithm

     e)   Initial LSP synchronization via CSNP exchange

     f)   Asynchronous LSP flooding (including DIS flooding behavior)

>> The recent draft on flooding over multiple links applies

     g)   LSP database maintenance including LSP origination, aging, and
          purging

     h)   Standard topology abstraction

>> What about "P2P over LANs"?

 2.2 Internet-specific IS-IS Extensions:

   Internet-specific IS-IS Extensions are extensions to the IS-IS proto-
   col that are within the work scope of the IETF (including, but not
   limited to IPv4 or IPv6 unicast and multicast routing, MPLS, MPLS TE,
   GMPLS, or any other routing technology that the IETF decides to work
   on in future), and:

>> That last clause "or any other routing technology that the IETF 
decides to work on in future)" is very vague.  Would it apply to
MPLS, where it not already grandfathered in?  (I could argue that
MPLS is a switching rather than routing technology) 

- jeff parker