Subject: RE: [Isis-wg] MIB: re-index isisIPRATable to be in line with othe r IP tables

From: Laura Liu <[email-masked]>
Date: Tue, 8 Oct 2002 10:03:33 -0500

> -----Original Message-----
> From: Don Goodspeed [mailto:[email-masked]]
> Sent: Monday, October 07, 2002 9:38 PM
> To: [email-masked]
> Subject: [Isis-wg] MIB: re-index isisIPRATable to be in line 
> with other
> IP tables
> 
> 
> 
> Found on page 61 of the mib-09 draft, the isisIPRATable is currently
> index'ed by isisSysInstance, isisIPRAIndex, and isisIPRAType.
> 
> First, the type is not needed in the index since there cannot be
> both a manual and an automatic version of the route in the route
> table at the same time.
> 
I totally agree. Instead of using type (manual or automatic) as index, it
can be an attribute of each prefix.

> Second, in keeping with the re-indexing of the other IP tables
> on the list recently, this table should be indexed by:
> isisSysInstance, isisIPRADest, isisIPRADestPrefixLen, and 
> either the isisIPRASNPAAddress or a new attribute for
> isisIPRADestNextHop.

And a new attribute for isisIPRASourceType, which indicate where the prefix
learned from: static, directly connected, OSPF, BGP or ISIS.

Laura

> 
> -don
> 
> ------------------------------------------------
> Changed your e-mail?  Keep your contacts!  Use this free 
> e-mail change of address service from Return Path.  Register now!
> _______________________________________________
> Isis-wg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/isis-wg
> 

----------------------------------------- (on rchss001)

This e-mail and any files transmitted with it are the property
of Chiaro Networks, Ltd., and may contain confidential and 
privileged material for the sole use of the intended recipient(s)
to whom this e-mail is addressed. If you are not one of the named
recipient(s), or otherwise have reason to believe that you have 
received this message in error, please notify the sender and 
delete all copies from your system.  Any other use, retention, 
dissemination, forwarding, printing or copying of this e-mail is 
strictly prohibited.

---------------------------------------------------------

---

From: Jeff Parker <[email-masked]>
Date: Tue, 8 Oct 2002 14:23:33 -0400

> isisIPRADestNextHop

Reworked to use different index.  I included DestType to 
distinguish ipv4 from ipv6.  The usual changes in MAX-ACCESS
needed to make smicng happy.  

I'd love to find a way to reach Don directly with a copy
before submitting a new version.  Don?

- jdp

    isisIPRAEntry OBJECT-TYPE
        SYNTAX IsisIPRAEntry
        MAX-ACCESS not-accessible
        STATUS current
        DESCRIPTION
            "Each entry defines an IP Reachable Address to a network,
             subnetwork or host."
        INDEX {  isisSysInstance,
                 isisIPRAIndex,
                 isisIPRADestType,
                 isisIPRADest,
                 isisIPRADestPrefixLen,
                 isisIPRASNPAAddress }
    ::= { isisIPRATable 1 }
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Laura Liu <[email-masked]>
Date: Tue, 8 Oct 2002 14:19:48 -0500

> From: Jeff Parker [mailto:[email-masked]]
> Sent: Tuesday, October 08, 2002 1:24 PM
> To: [email-masked]
> Subject: RE: [Isis-wg] MIB: re-index isisIPRATable to be in line with
> othe r IP tables
> 
> 

I think it would make more sense to use isisIPRADestNextHop as attribute
instead of isisIPRASNPAAddress as index. 

My 2 cents,

Laura

---

From: Jeff Parker <[email-masked]>
Date: Tue, 8 Oct 2002 15:29:09 -0400

> > > isisIPRATable ... should be indexed by:....
> > Reworked to use [isisIPRASNPAAddress]  
> > 
> > - jdp
>

Comments?  I don't need to rev this in real time.
Current table below

- jeff parker

isisIPRASNPAAddress 

    isisIPRATable OBJECT-TYPE
        SYNTAX SEQUENCE OF IsisIPRAEntry
        MAX-ACCESS not-accessible
        STATUS current
        DESCRIPTION
            "The table of IP Reachable Addresses to networks,
             subnetworks or hosts either manually configured or
             learned from another protocol."
    ::= { isisIPReachAddr 1 }
	....
    IsisIPRAEntry ::=
        SEQUENCE {
            isisIPRAIndex
                Integer32,
            isisIPRADestType
                InetAddressType,
            isisIPRADest
                InetAddress,
            isisIPRADestPrefixLen
                InetAddressPrefixLength,
            isisIPRASNPAAddress
                OSINSAddress,
            isisIPRAType
                INTEGER,
            isisIPRAExistState
                RowStatus,
            isisIPRAAdminState
                AdminState,
            isisIPRAMetric
                DefaultMetric,
            isisIPRAMetricType
                MetricType,
            isisIPRAFullMetric
                FullMetric
        }
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Jeff Parker <[email-masked]>
Date: Wed, 9 Oct 2002 11:47:29 -0400

> learned from: static, directly connected, OSPF, BGP or ISIS.

Laura -

	I have added the following.

All -
	Are other protocols called for?  Two version of ISIS - L1 and L2?

- jdp

    isisIPRASourceType OBJECT-TYPE
        SYNTAX INTEGER
            {
                static (1),
                direct (2),
                ospf   (3),
                isis   (4),
                bgp    (5),
                other  (6)
            }
        MAX-ACCESS read-only
        STATUS current
        DESCRIPTION
            "The origin of this route."
    ::= { isisIPRAEntry 14 }
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: "Don Goodspeed" <[email-masked]>
Date: Wed, 9 Oct 2002 16:04:46 -0400 (EDT)

Don't forget RIP!  -don

 --- On Wed 10/09, Jeff Parker  wrote:
From: Jeff Parker [mailto: [email-masked]]
To: [email-masked]
     Cc: [email-masked]
Date: Wed, 9 Oct 2002 11:47:29 -0400
Subject: RE: [Isis-wg] MIB: re-index isisIPRATable to be in line with othe  r IP tables

------------------------------------------------
Join Excite! - http://www.excite.com
The most personalized portal on the Web!
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg