Subject: RE: [Isis-wg] OperStatus in System and Circ

From: Jeff Parker <[email-masked]>
Date: Wed, 9 Oct 2002 12:18:40 -0400

We are closing in on Don's list: updates below.  

However, this mail is really about OperState

> 1) isisLSPTable - On the todo list.   
> 2) isisSysOverloadTimeLeft - I think I had this once, and I'm
> trying to remember why it disappeared.   

> 3) OperStatus is in the isisSys table and isisCircTable.
> ...we had this once, and I wonder why it isn't there... 

> > At the system level, the OperStatus might still be up for a few seconds
> > when the protocol has been disabled to clean up some internal entities.

> > At the circuit level, a lower-level link status of down would cause
> > the OperStatus of the circuit to be down as opposed to up.
> > 
> > Don Goodspeed

[Looking back, we replace OperState with AdminState]

If you have enabled a circuit, when do you think it
is operational?

	1) When you hear from the kernel that you have 
		carrier [Don's choice, above]
	2) When you send a packet out without error
	3) When you see your info in the far side's 
		Hello Pkt
	4) Some other measure

I'm not sure I know what ISIS OperState represents,
or how much credit to put into anything but #3.
The first is already in the Interface MIB, the second
is in the PacketCount area, and the third is in the 
Adjacency area.    You could make the case that 
"isisCircOperational" means 1) and that the circuit 
is enabled for ISO, however that is defined on your 
system - PPP negotiation is complete, or right mcast 
addresses are enabled on Ethernet, etc.

I'm not adverse to putting this in if it has value.
I do wonder what we gain.

> 4)  isisRedistributeAddrTable 
Don - are we in agreement on this yet?

> 5) Add 3WayAdjState 
Revised, in review.  

- jeff parker
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: "Don Goodspeed" <[email-masked]>
Date: Wed, 9 Oct 2002 16:10:01 -0400 (EDT)

Jeff,

On issue #3 (oper state), I guess the isisCircOperStatus is a 
one-stop place to see if the circuit is up or down.  As for
the isisOperStatus, some protocols (BGP, for one) need some
time to come down operationally when administratively disabled.
I guess it's not much of an issue for ISIS since we don't 
have much to clean up, and do it sub-second usually.

So, I'd still like to see the isisCircOperStatus, but not the
isisOperStatus.

As for #4, I just sent some replies to the list separately.

Thanks,
Don

 --- On Wed 10/09, Jeff Parker  wrote:
From: Jeff Parker [mailto: [email-masked]]
To: [email-masked]
Date: Wed, 9 Oct 2002 12:18:40 -0400
Subject: RE: [Isis-wg] OperStatus in System and Circ

> Don - are we in agreement on this yet?

------------------------------------------------
Join Excite! - http://www.excite.com
The most personalized portal on the Web!
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg