Subject: [Isis-wg] MIB: should we include Auth settings?

From: "Don Goodspeed" <[email-masked]>
Date: Mon, 7 Oct 2002 20:41:34 -0400 (EDT)

All,

Should we include any MIB attributes for Authentication settings
in the ISIS MIB?  Possible attributes would include at each of
{system, level, circuit, circuit-level} attributes for:
auth-type (none, password, or MD5)
auth-password (or auth-key): would be write-only
auth-check

Possible additional attributes might include settings for:
hello-auth-type
hello-auth-password (or key)
hello-auth-check

I know some vendors also allow control of security on other types
(psnp's, etc.) as well.  This could be a can of worms, but I thought
I'd raise the issue.

-don

------------------------------------------------
Changed your e-mail?  Keep your contacts!  Use this free e-mail change of address service from Return Path.  Register now!
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: RJ Atkinson <[email-masked]>
Date: Mon, 7 Oct 2002 21:59:22 -0400

On Monday, Oct 7, 2002, at 20:41 America/Montreal, Don Goodspeed wrote:

> in the ISIS MIB?

No.  That would create operational security problems.  We discussed the
topic at some length a while back.  The current absence of 
authentication
related data is quite deliberate.

Ran
[email-masked]

---

From: "Antoni B. Przygienda" <[email-masked]>
Date: Tue, 08 Oct 2002 02:01:15 -0700

RJ Atkinson wrote:

> topic at some length a while back.  The current absence of authentication

yes, my experience was taht any passwords/security keys in MIBs were
a simple backdoor into the system so far

    -- tony