Subject: RE: [Isis-wg] FW: IS-IS MIB (metric comments)

From: "Don Goodspeed" <[email-masked]>
Date: Tue, 15 Oct 2002 14:49:09 -0400 (EDT)

Satish,

The metric can still be zero in isisIPRATable for the subnet
that the passive interface belongs to.  The attribute isisIPRAMetric
is also mapped to the textual convention DefaultMetric.  So
even if the configured value is maintained (for when the interface
is made non-passive), the cost to that interface in the isisIPRA
Table would still be zero in some implementations.

Whether the software zeroes the isisCircLevelMetric is up to the
implementation.

-don

 --- On Mon 10/14, Satish Dattatri  wrote:
From: Satish Dattatri [mailto: [email-masked]]
To: [email-masked], [email-masked], [email-masked]
     Cc: [email-masked]
Date: Mon, 14 Oct 2002 19:39:14 -0700 (PDT)
Subject: RE: [Isis-wg] FW: IS-IS MIB (metric comments)

> The metric configured does not matter when an interface is passive,
> IP prefix advertisement will always be with zero cost. At a later
> point if the interface is made non-passive, the IP prefix advertisement
> will have the metric of the interface. Since, the configured value is
> not considered anyways for the advertisement of the IP prefix when
> passive, I think MIB range need not start with 0.
> 
> Satish
> 
>  ]  ] >        We don't split passive interfaces from other interfaces
>  ]  ] >in the MIB.  Thus, given the current design, if we allow a 0 
>  ]  ] >metric on a passive circuit, we are allowing a 0 metric on
>  ]  ] >any circuit, and thus allowing a 0-cost path to a neighbor.  
>  ] 
>  ] I think we should allow 0 to be inside the range. It's up to the
>  ] implementation to block certain MIB settings. The MIB can give a
>  ] union of all the possible configures exist/possible-to-have, if it
>  ] does not want to specify the each specific cases. It's a local
>  ] implementation issue to honor such a MIB request. The reverse
> approach,
>  ] take a common dominate, does not sound right.
>                 ^^^^^^^^^ denominator.
>  ] 
>  ]  ] >        We can add a warning that 0 should only be used when
> the
>  ]  ] >interface is passive, but it is not enforceable.  
>  ]  ] 
>  ]  ] 
>  ]  ] but what are you going to do with implementations that 
>  ]  ] already assign 0-metric to (passive)interfaces ? I think 
>  ]  ] you should accept them.
>  ]  ] 
>  ]  ] Again, I don't believe it's the role of a MIB/SNMP agent 
>  ]  ] to handle these issues.
>  ]  ] 
>  ]  ] s.
>  ]  ] 
>  ]  ] _______________________________________________
>  ]  ] Isis-wg mailing list
>  ]  ] [email-masked]
>  ]  ] https://www1.ietf.org/mailman/listinfo/isis-wg
>  ] 
>  ] - Naiming
> 
> - Naiming
> _______________________________________________
> Isis-wg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/isis-wg
> 
> 
> 
> __________________________________________________
> Do you Yahoo!?
> Faith Hill - Exclusive Performances, Videos & More
> http://faith.yahoo.com
> _______________________________________________
> Isis-wg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/isis-wg
> 

_______________________________________________
Join Excite! - http://www.excite.com
The most personalized portal on the Web!
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Satish Dattatri <[email-masked]>
Date: Tue, 15 Oct 2002 15:19:08 -0700 (PDT)

Hi Don,

> is also mapped to the textual convention DefaultMetric.  So

Currently it is like that but if the ranges are different ...

> Whether the software zeroes the isisCircLevelMetric is up to the

By making a circuit passive, a get on that circuit must give the
configured metric. I agree that internally an implementation can
achieve this in many ways.

Naiming corrected my logic that people do want passive circuits 
to have non-zero cost (configurable). What I am a bit concerned 
is allowing a cost of zero to be configured on the circuit. Of
course the implementation can take care of *changing* (behind
the back) the metric to a default value when a ciruit with metric
of 0 and passive is made non-passive. MIB tools will not like this.

Thanks,
Satish