Subject: [Isis-wg] Queries for ISIS-MIB draft9

From: "Ganguly, Shamik" <[email-masked]>
Date: Tue, 15 Oct 2002 15:07:10 -0400

Jeff,

I have a few queries regarding the newly released Draft 9 of ISIS-MIB.

1. Is there any special reason that the MIB has no table to read the LSP
database? I mean, tables to see LSPs in the database and some information
relating to them.

2. Why do you have separate tables for Reachable Addresses, namely
isisRATable and isisIPRATable? Can they be clubbed together? Also if we do
not have any plans for deploying our implementations in OSI networks, can
the isisRATable be removed? Expanding the scope of the question, what value
are you adding by both of these tables?

3. This query is regarding the table isisRedistributeAddrTable. In our ISIS
implementation, if the global L2toL1Leaking flag is enabled, all L2 routes
are leaked into L1. We can configure summary-filters to prevent certain
prefixes to get into L1. But isisRedistributeAddrTable in draft9 works
differently. Only those routes that match entries in this table are leaked
into L1 by L2 routers. Could you explain the reasoning behind the design of
this table?

-Shamik
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: "Don Goodspeed" <[email-masked]>
Date: Tue, 15 Oct 2002 15:43:16 -0400 (EDT)

Answering #1 and #2 ...

Shamik,

1) The syntax for the LSP Table is being reviewed by Jeff, myself,
and a few others and will probably be included in version -11
of the MIB.
2) If you do not support OSI reachability (as some newer implemen-
tations are going), you just do not return anything for the
isisRATable.  Supporting a table does not mean you HAVE to 
polulate a table.  It just means you recognize it when a get,
get-next, etc. is done on that table (don't crash, return proper
error codes, etc.).

As for #3, I second your question.  We "may" need another
attribute to handle this.  At the very least, your implementation
should install a 0.0.0.0/0 entry in the table indicating
you are leaking all L2 routes into L1 by default.

Cheers,
-don

--- On Tue 10/15, Ganguly, Shamik  wrote:
From: Ganguly, Shamik [mailto: [email-masked]]
To: [email-masked]
Date: Tue, 15 Oct 2002 15:07:10 -0400
Subject: [Isis-wg] Queries for ISIS-MIB draft9

_______________________________________________
Join Excite! - http://www.excite.com
The most personalized portal on the Web!
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Jeff Parker <[email-masked]>
Date: Tue, 15 Oct 2002 15:42:51 -0400

> 1. Is there any special reason that the MIB has no table to 
> read the LSP database? I mean, tables to see LSPs in the 
> database and some information relating to them.

Shamik -
	Excellent point.  I don't know what I was thinking of.
I will add the LSP table and send you a review copy by 
private mail. 

> isisRATable and isisIPRATable? Can they be clubbed together? 

The RATable is for OSI addresses and the IPRA table is 
for IP addresses.  I could club them together, but
you wouldn't like the result.  

> .. if we do not have any plans for deploying our 
> implementations in OSI networks, can
> the isisRATable be removed? 

Well, it is pretty easy to reply to a get on
an empty table.  

> Expanding the scope of the question, what value

Support Dual Protocol Routers

> into L1 by L2 routers. Could you explain the reasoning behind 

Please review the version in the table I send you 
and I'll be happy to take your review comments.

- jeff parker

---

From: "Ganguly, Shamik" <[email-masked]>
Date: Tue, 15 Oct 2002 15:58:44 -0400

Don and Jeff,

Thanx for the quick responses.

For your response to #3. We can change the interpretation of the
isisRedistributeTable. The entries in this table are the ones that are NOT
leaked to L1. Are there ISIS implementations that have a behaviour as in
draft9 of this table?

Another question related to the same point. Draft9 does not seem to have
something to regulate leaking of routes to L2 from L1. We can either add a
new field to isisRedistributeTable to differentiate between the two or
create a separate table.

-Shamik

-----Original Message-----
From: Don Goodspeed [mailto:[email-masked]]
Sent: Tuesday, October 15, 2002 3:43 PM
To: [email-masked]; [email-masked]
Subject: RE: [Isis-wg] Queries for ISIS-MIB draft9

Answering #1 and #2 ...

Shamik,

Cheers,
-don

---

From: Jeff Parker <[email-masked]>
Date: Tue, 15 Oct 2002 16:05:26 -0400

> leaked to L1. Are there ISIS implementations that have a 

Take a look at draft 10.

> new field to isisRedistributeTable to differentiate between the two or

Shamik -
	draft 9 is dead: long live draft 10.  I have sent you a copy.
If you didn't get it, we can work out an off-line transport mechanism.
I'll buy you a beer and slip you a paper copy.

- jeff parker