Subject: [Isis-wg] MIB: split isisISAdjNeighSysID into 2 attributes

From: "Don Goodspeed" <[email-masked]>
Date: Mon, 7 Oct 2002 22:30:48 -0400 (EDT)

This attribute is found on page 59 of the mib-09 draft, and
serves 2 purposes.  One is to indicate the neighbor system
ID (which is seven octets) and the other is to indicate
an extended circuit ID only if the circuit is p2p and 3way
handshaking is enabled.

I propose that we split this attribute into two.  Keep the name
of the existing attribute, but contrain it's size to seven octets.
The new attribute "isisISAdjNeighExtendedCircID" would contain
either a zero octet string or a four octet string.

-don

------------------------------------------------
Changed your e-mail?  Keep your contacts!  Use this free e-mail change of address service from Return Path.  Register now!
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Jeff Parker <[email-masked]>
Date: Tue, 8 Oct 2002 14:56:59 -0400

> either a zero octet string or a four octet string.

I have added a "3WayEnabled" bit to the CircEntry (this is
per circ, not per circ/level) and a 4 byte Extended Circ ID.
I am using 0 to mean "not valid"

- jeff parker

    isisCirc3WayEnabled OBJECT-TYPE
        SYNTAX TruthValue
        MAX-ACCESS read-create
        STATUS current
        DESCRIPTION
            "Is this circuit enabled to run 3Way handshake?"
    ::= { isisCircEntry 14 }

    isisISAdjExtendedCircID OBJECT-TYPE
        SYNTAX Integer32
        MAX-ACCESS read-only
        STATUS current
        DESCRIPTION
            "The 4 byte Extended Circuit ID learned from the
             Neighbor during 3-way handshake, or 0."
    ::= { isisISAdjEntry 4 }

---

From: "Don Goodspeed" <[email-masked]>
Date: Tue, 8 Oct 2002 18:41:19 -0400 (EDT)

Jeff,

I forgot to mention it should be numeric, but we probably want to
make it an Unsigned32, not Integer32 since this # will not be
negative.

Also, in the MIB update you sent me, you list the ExtendedCircID
after NeighSysID, but you put it just after SNPAAddress (oid 4
in the table).

-don

 --- On Tue 10/08, Jeff Parker  wrote:
From: Jeff Parker [mailto: [email-masked]]
To: [email-masked]
Date: Tue, 8 Oct 2002 14:56:59 -0400
Subject: RE: [Isis-wg] MIB: split isisISAdjNeighSysID into 2 attributes

------------------------------------------------
Join Excite! - http://www.excite.com
The most personalized portal on the Web!
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Jeff Parker <[email-masked]>
Date: Wed, 9 Oct 2002 10:09:22 -0400

> after NeighSysID, but you put it just after SNPAAddress (oid 4
 
Thanks.  Fixed.  

- jdp