Subject: RE: [Isis-wg] isisAreaAddrTable index

From: "Jonnala, Nagi" <[email-masked]>
Date: Fri, 1 Nov 2002 00:27:23 -0500

Laura,

I agree with you that area address will keep index permanent during neighbor
configuration. But I have an alternative view point. 

For the current isisAreaAddrTable definition, we have only one object
isisAreaAddr
which is also used in indexing the table. Because it is read-only object, we
can
do only GET and GET-NEXT operations on the table. In other words, we are
only interested in seeing the contents of the table, least bothering about
the order
of the table.

I'm concerned about providing the isisAreaAddr(because it also acts as the
index)
to GET the same object. i.e., There is nothing much GET can do here, we give
something
to check if it is there or not.  Ofcourse GET-NEXT does the job well(no need
of supplying the index initially).

So my question remains -- When we are least bothered about keeping the index
permanent, why can't we just have a simple index like isisAreaAddrIndex?

Thanks
Nagi.

    |    -----Original Message-----
    |    From: Laura Liu [mailto:[email-masked]]
    |    Sent: Thursday, October 31, 2002 7:08 PM
    |    To: Jonnala, Nagi; 'Jeff Parker'
    |    Cc: ISIS-WG (E-mail)
    |    Subject: RE: [Isis-wg] isisAreaAddrTable index
    |    
    |    
    |    
    |    
    |    > -----Original Message-----
    |    > From: Jonnala, Nagi [mailto:[email-masked]]
    |    > Sent: Wednesday, October 30, 2002 10:33 PM
    |    > To: 'Jeff Parker'
    |    > Cc: ISIS-WG (E-mail)
    |    > Subject: [Isis-wg] isisAreaAddrTable index
    |    > 
    |    > 
    |    > 
    |    > Jeff,
    |    > 
    |    > Thanks for the clarification on isisISAdjAreaAddrTable.
    |    > 
    |    > I have another question on isisAreaAddrTable(The 
    |    union of the 
    |    > sets of area
    |    > addresses reported in all Level 1 LSPs). I noticed 
    |    > isisAreaAddr is one of
    |    > the index into the table. Being the read-only object, Can't 
    |    > we consider
    |    > having an isisAreaAddrIndex instead
    |    > of direct object as the index. 
    |    > 
    |    
    |    There was a discussion on using IP address or area 
    |    address as part of index,
    |    using area address will keep index permanent during 
    |    neighbor configuration.
    |    The order of manual/union addresses could change when 
    |    a new area address
    |    being added/deleted by a neighbor. I would like to see 
    |    area address as part
    |    of index in isisAreaAddrTable and isisManAreaAddrTable.
    |    isisISAdjAreaAddrTable is ok to use 
    |    isisISAdjAreaAddrIndex, since
    |    isisISAdjIndex is before isisISAdjAreaAddrIndex to 
    |    point out which neighbor
    |    it refers to.
    |    
    |    regrads,
    |    
    |    Laura
    |    
    |    > Notes: 
    |    > 
    |    > 1) We have the same kind of isisISAdjAreaAddrIndex for
    |    > isisISAdjAreaAddrTable.
    |    > 
    |    > 2) For isisManAreaAddrTable, it does make sense to have
    |    > isisManAreaAddr as the index because we use it for SET 
    |    > operations also.
    |    > 
    |    > Thanks
    |    > Nagi.
    |    > 
    |    > 
    |    > 
    |    > 
    |    >     
    |    > _______________________________________________
    |    > Isis-wg mailing list
    |    > [email-masked]
    |    > https://www1.ietf.org/mailman/listinfo/isis-wg
    |    > 
    |    
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Laura Liu <[email-masked]>
Date: Fri, 1 Nov 2002 07:48:06 -0600

Nagi,

If we use isisAreaAddrIndex, when there is a configuration changes of
adding/deleting an area address, the same index could refer to a different
area address value. It will confuse me. It seems you would like to make area
address a read-write object, then area address should not be part of index.

regards,

Laura

> -----Original Message-----
> From: Jonnala, Nagi [mailto:[email-masked]]
> Sent: Thursday, October 31, 2002 11:27 PM
> To: 'Laura Liu'
> Cc: 'Jeff Parker'; [email-masked]'
> Subject: RE: [Isis-wg] isisAreaAddrTable index
> 
> 
> 
> Laura,
> 

----------------------------------------- (on rchss001)

This e-mail and any files transmitted with it are the property
of Chiaro Networks, Ltd., and may contain confidential and 
privileged material for the sole use of the intended recipient(s)
to whom this e-mail is addressed. If you are not one of the named
recipient(s), or otherwise have reason to believe that you have 
received this message in error, please notify the sender and 
delete all copies from your system.  Any other use, retention, 
dissemination, forwarding, printing or copying of this e-mail is 
strictly prohibited.

---------------------------------------------------------