Subject: [Isis-wg] RE: OSPF MIB support for multiple OSPF processes

From: Jeff Parker <[email-masked]>
Date: Mon, 20 Jan 2003 14:14:08 -0500

> Jeff,
> 
>  Given the comments below, where did you get the
> requirement to explicitly support multiple IS-IS
> instances in the IS-IS MIB?
> 
> -Dan

Dan -
	You are refering to the SysInstance index in
the IS-IS MIB.  Use of this was not a requirement: 
it came with the original version of the MIB I inherited.  

	I would be interested to hear from any users 
that find this useful.  While it seems to offer 
a solution, I don't know of any other MIB that supports
this, so people will have to design an alternative 
anyway. 

	It isn't too late to rip this out if it has
no utility.

- jeff parker
 
> -----Original Message-----
> From: Tom Petch [mailto:[email-masked]]
> Sent: Monday, January 20, 2003 1:16 PM
> To: [email-masked]
> Subject: Re: OSPF MIB support for multiple OSPF processes
> 
> 
> Yes.
> In SNMPv1, this can be done by having multiple 'agents' identified by
> different community names or different IP addresses, each accessing a
> distinct incarnation of MIB II and its subordinate branches.
> In SNMPv3, there is a more sophisticated mechanism of contexts which
> formalises the techniques given above.
> I do not think you should ever return more than one instance of a
> given object in GET or GETNEXT.
> 
> Tom Petch
> [email-masked]
> 
> -----Original Message-----
> From: Roy Jose <[email-masked]>
> To: [email-masked] <[email-masked]>
> Date: 20 January 2003 16:04
> Subject: OSPF MIB support for multiple OSPF processes
> 
> 
> >Hi,
> >
> >Rfc1850 doesn't talk about what to be done regarding the
> retrieval(GET) of
> >MIB values when multiple OSPF processes exist on a router. Out first
> >impression is to return details about all the processes. The problem
> is
> >while selecting values for MIB objects like
> >ospfRouterId,ospfAreaBdrRtrStatus, ospfASBdrRtrStatus etc. They may
> differ
> >in separate processes. The Qn is, can we really support multiple
> processes
> >with rfc1850?
> >
> >Thanks,
> >Roy
> 
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Jeff Parker <[email-masked]>
Date: Tue, 28 Jan 2003 09:25:51 -0500

All -
	One user of the SysIndex in the MIB.

Jonathan -
	Did you need similar functionality for some other
mib - perhaps the interface mib?  How did you deal with
other mibs?

- jeff parker

> From: Jonathan Sadler [mailto:[email-masked]]
> Sent: Tuesday, January 28, 2003 5:06 AM
> To: Jeff Parker
> Subject: Re: [Isis-wg] RE: OSPF MIB support for multiple OSPF 
> processes
> 
> 
> Jeff -
> 
> I do have use for this in SONET/SDH environments -- 
> specifically this index
> allows for support of multiple logical IS-IS instances on one physical
> platform.  This is needed for:
>  - more than one Area per physical platform
>  - separation of IS-IS routing for the DCN from separate IS-IS
>    routing for other layer networks (i.e. GMPLS)
> 
> Jeff Parker wrote:
> 
> >
> > > Jeff,
> > >

---

From: Jonathan Sadler <[email-masked]>
Date: Wed, 29 Jan 2003 02:54:41 -0600

Jeff -

Acutally, we used a common ifIndex space so no issue existed with respect to
the interface mib.  And since we were not dealing with multiple instances
of  IP forwarding, we didn't have any problems with the IP MIBs.

Of course, if someone would like to add multi-instance support in the
interface or IP Forwarding-related MIBs, we would actively support it :^)

Jonathan Sadler

> > >         It isn't too late to rip this out if it has

============================================================
The information contained in this message may be privileged 
and confidential and protected from disclosure.  If the 
reader of this message is not the intended recipient, or an 
employee or agent responsible for delivering this message to 
the intended recipient, you are hereby notified that any 
reproduction, dissemination or distribution of this 
communication is strictly prohibited. If you have received 
this communication in error, please notify us immediately by 
replying to the message and deleting it from your computer.

Thank you.
Tellabs
============================================================
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg