Subject: [Isis-wg] SystemID Type definition.

From: "Jonnala, Nagi" <[email-masked]>
Date: Thu, 9 Jan 2003 06:05:17 -0500

Jeff,

Current Type definition  of System ID is

SystemID ::= TEXTUAL-CONVENTION
        STATUS current
        DESCRIPTION
            "A system ID."
        SYNTAX OCTET STRING (SIZE(0..6))

May be, you would want to change the size to 6 because
the WG has agreed on System-ID length earlier.

-Nagi.

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Jeff Parker <[email-masked]>
Date: Thu, 9 Jan 2003 10:22:27 -0500

> the WG has agreed on System-ID length earlier.

Nagi -
	Yup, it used to read 0..8, and I cranked it down to 6
when that discussion happened.  
	There is one spot where we have an object of type SystemID
which might be null.  If there was a syntax for it, I would say

	OCTET STRING (SIZE(0 or 6))

but there isn't.  

- jeff parker

---

From: "Don Goodspeed" <[email-masked]>
Date: Thu, 9 Jan 2003 14:58:14 -0500 (EST)

Jeff,

I thought I've seen the following syntax before:
SYNTAX OCTET STRING (SIZE(0|6))

-don

Nagi -

but there isn't.

- jeff parker

_______________________________________________
Join Excite! - http://www.excite.com
The most personalized portal on the Web!
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Jeff Parker <[email-masked]>
Date: Fri, 10 Jan 2003 10:01:58 -0500

> >
> how can 0 make any sense ? That would per definition make all
> routers crash into each others' IDs ? Just wondering ?
> 
>     -- tony

Tony -
	At one time we were using SystemID in some place where
a NULL was appropriate.  I can no longer find such a spot, and
I will remove the 0.  
	In hindsight, I should have used some other type for that
value anyway.  

- jeff parker