Subject: [Isis-wg] FW: WideMetric, FullMetric Type definitions

From: Jeff Parker <[email-masked]>
Date: Fri, 10 Jan 2003 10:09:55 -0500

> > Jeff,
> > 
> > Can we change the types from Integer32 to Unsigned32?
> > 
> > -Nagi.
> 
>     WideMetric ::= TEXTUAL-CONVENTION
>         STATUS current
>         DESCRIPTION
>             "Wide Metric for IS Neighbors.  ISO 10589 
> provides a 6 bit metric.
>              Traffic Engineering extensions provide 24 bit metrics."
>         SYNTAX Unsigned32 (0..16777215)
> 
>     FullMetric ::= TEXTUAL-CONVENTION
>         STATUS current
>         DESCRIPTION
>             "Full Metric for IP Routes.  Traffic Engineering 
> extensions
>              provide 32 bit metrics."
>         SYNTAX Unsigned32 (0..16777215)
> 
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: "Don Goodspeed" <[email-masked]>
Date: Fri, 10 Jan 2003 17:41:55 -0500 (EST)

Jeff and all,

In draft-ietf-isis-traffic-04.txt, section 4 contains:
Thus, MAX_PATH_METRIC is 4,261,412,864 (0xFE000000, 2^32 - 2^25).

FullMetric's range should be (0..4261412864) then.

-don

_______________________________________________
Join Excite! - http://www.excite.com
The most personalized portal on the Web!
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg