Subject: [Isis-wg] RE: IPRA Table Comments

From: Jeff Parker <[email-masked]>
Date: Fri, 10 Jan 2003 10:42:24 -0500

> I've a couple of comments on IPRA table of mib-10.
> 
> a) IPRA indices:
> ================
> 
> I'm just wondering why do we need isisIPRAIndex in
> the indices list? 
> 
> We can index into the table by using:
> 
> Sys-Instance, Dest-Type, Dest-Address, Prefix-Len.
> 
> Right? (or) Am I missing something?

There are many people who feel that complex indexing schemes
are hard to deal with.  This is intended to address that issue.
I agree that there seems to be an excess of indicies here.

> b) isisIPRANextHopType:
> =======================
> 
> Having DestType already in the table(Infact as one of the index),
> does isisIPRANextHopType carry any extra information?
> 
> It MAY be the case, if the node is at the boarder of IPv4 
> and IPv6 or vice versa. Is this meant for that? 
> 
> or can we remove this field?

All IP addresses have been changed to tuples (type, value).
I don't see any need to drop the generality here.  

> c) isisIPRASNPAAddress:
> =======================
> 
> First of all, I'm not sure if using MAC address in IPRA table
> is okay. Where do we get this -  from operator? or from other 
> protocols? 
> 
> Please note that we already have isisIPRANextHop in the table.
> Shouldn't that be sufficient?
> 
> Please correct me if I misinterpreted anything.
> 
> Thanks
> Nagi.
 
On a broadcast network, you learn the MAC address from the
hello packets.  I agree that it isn't very useful on P2P.  

While you can depend on IP's ARP table for this, I think 
this goes back to IS-IS's niche near the link layer in
support of CLNS.  

Result: I don't see a pressing reason to change any of this.  

- jeff parker
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Jeff Parker <[email-masked]>
Date: Thu, 16 Jan 2003 09:57:54 -0500

>  | > a) IPRA indices:
>  | > ================
>  | > 
>  | > I'm just wondering why do we need isisIPRAIndex in
>  | > the indices list? 
>  | > 
>  | > We can index into the table by using:
>  | > 
>  | > Sys-Instance, Dest-Type, Dest-Address, Prefix-Len.
>  |    
>  | There are many people who feel that complex indexing 
>  | schemesare hard to deal with.  This is intended to 
>  | address that issue.  I agree that there 
>  | seems to be an excess of indicies here.
> 
> Nagi>> 
> 
> The reason I see is that "If something is not needed, why should it be
> there". The presence of isisIPRAIndex made sense when "Dest-Type,
> Dest-Address, Prefix-Len" were not there. Once these three 
> new indices are
> introduced, isisIPRAIndex should have gone.
> 
> I agree that it MAY be there, but with the expense of:
> 
> i) Every now and then people come up with the same question.
> ii)Complex indexing scheme will be deployed.
> 
> Thanks
> Nagi.

Nagi -
	I agree that the index needs to be cleaned up.  However,
we will wind up with multiple routes, either due to ECMP
or to routes appearing at L1 and L2.  We can rename things
and move them around, but if you want a simple index, it
would have to be by dropping the Dest information.  We
will need some index to distinguish routes with the same
destination. 
	I suspect that people will want to search this table
by Destination, and I will try a versio that reorders that,
and puts another index later in the sequence.  

- jeff parker