Subject: Re: [Isis-wg] advertising P2P neighbors address in LSPs and IPv6

From: Saravana Kumar <[email-masked]>
Date: Tue, 28 Jan 2003 22:47:44 -0700

sorry about the last empty post..

Well, if its not mandatory to advertise the neighbors IP address in the LSPs, 
then perhaps this infomation should be added to the ip-interoperability draft, 
for future references. 

Thanks,
Sarav

On Tue, 28 Jan 2003 12:29 , Hannes Gredler <[email-masked]> sent:

>On Tue, Jan 28, 2003 at 03:46:26AM -0700, Saravana Kumar wrote:
>| Hi,
>| 
>| Once an adjacency is extablished over a P2P link, we advertise the neighbors 
IP 
>| address in our LSP's as internal reachability info. Is it mandatory and if 
so, is 
>| there any specific reason for doing so ?
>
>its not mandatory, the major implementations do not advertise it 
>and i would be curious if it was somebody with an OSPF background
>who did implement this ?
>
>/hannes
>
>| Because currently in IPv6 it is not possible to advertise the P2P's neighbors 
>| address in the LSP's, since the neighbor sends us only the link-local 
addresses 
>| for the circuit in its hello PDU's. 
>
>
>_______________________________________________
>Isis-wg mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/isis-wg
>

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Jeff Learman <[email-masked]>
Date: Wed, 29 Jan 2003 13:18:51 -0500

I'm not sure I understand what's being said here.

1195 defines what 128 TLVs can contain and what it means, but it does
not state that a router must include IP addresses of IS neighbors.
Since this information is redundant, it makes sense that it isn't
required.

Why would this be an interoperability issue?  What might a router
legally do that would depend on whether another router in the
area included the redundant information or not?

There's no harm in documenting it, but I don't see how it would be
an interoperability issue.  This is more of a conformance issue --
and I don't see anyone clamoring for conformance testing ;)

Regards,
Jeff