Subject: RE: [Isis-wg] Another draft-ietf-isis-restart-02 question

From: "Ravindra Sunkad" <[email-masked]>
Date: Thu, 9 Jan 2003 16:41:29 -0800

Paragraph 4 of section 4.2 in draft-ietf-isis-restart-02 reads:

"As LSPs are received (by the normal operation of the update process) 
 over any interface, the corresponding LSPID entry is removed (it is 
 also removed if the LSP had arrived before the CSNP containing the 
 reference). When an LSPID has been held in the list for its 
 indicated remaining lifetime, it is removed from the list. When the 
 list of LSPIDs becomes empty, the timer T2 is cancelled."

Shouldn't the last sentence in above paragraph instead be:

"When the list of LSPIDs is empty, and a complete set of CSNP(s) and a
restart acknowledgement have been received over all the interfaces that
have an adjacency at this level, the timer T2 is cancelled."

Thanks,
Ravi
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: "Ravindra Sunkad" <[email-masked]>
Date: Thu, 9 Jan 2003 16:44:01 -0800

Oops. I meant "section 4.3" and not "section 4.2" in my previous email.

> -----Original Message-----
> From: Ravindra Sunkad 
> Sent: Thursday, January 09, 2003 4:41 PM
> To: [email-masked]'
> Subject: RE: [Isis-wg] Another draft-ietf-isis-restart-02 question
> 
> 
> "When the list of LSPIDs is empty, and a complete set of 
> CSNP(s) and a restart acknowledgement have been received over 
> all the interfaces that have an adjacency at this level, the 
> timer T2 is cancelled."
> 
> Thanks,
> Ravi
>

---

From: mike shand <[email-masked]>
Date: Fri, 10 Jan 2003 10:43:00 +0000

>have an adjacency at this level, the timer T2 is cancelled."

Well, strictly, yes it should.

But it would be better to say

"When the list of LSPIDs is empty, and T1 has been cancelled for all the 
interfaces that
have an adjacency at this level, the timer T2 is cancelled."

Because we may have given up on getting an ack from some adjacencies (and 
hence cancelled T1 according to the pre-penultimate paragraph of clause 4.2

         Mike