Subject: [Isis-wg] Fw: About IS-IS as PE/CE routing protocol in BGP/MPLS/VPN

From: shengcheng <[email-masked]>
Date: Mon, 02 Jun 2003 10:06:29 +0800

Dear all:
            The below are several emails of the discussion of one doubt about the draft "IS-IS as PE/CE routing protocol in BGP/MPLS/VPN".
            We wonder if the flooding of LSP accross the Sham link is necessary. According to my opinion, the flooding is not necessary, because sham link is just used to make sure  the right next-hop of the VPN-IP route of CE. As per stefano 's view, the flooding is required. But we all agree that it is difficult to flooding the LSP for IS-IS accrossthe sham link because IS-IS is not encapsulated in IP packets as OSPF. 

            Anyone are interested in this topic and can give some good suggestion ? 

            thanks in advance! 

Sheng

----- Original Message ----- 
From: "stefano previdi" <[email-masked]>
To: "shengcheng" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Thursday, May 29, 2003 9:09 PM
Subject: Re: About IS-IS as PE/CE routing protocol in BGP/MPLS/VPN

> At 12:49 PM 5/29/2003, shengcheng wrote:
> >Stefano:
> >
> >I don't think the flooding is necessary when the backdoor link fail.
> >First, the creation of sham link is just to remove the negative affect by 
> >backdoor link. when backdoor link fail, sham link is meaningless in fact.
> >Second, even we doesn't flush the lsa soon after the backdoor link fail, the 
> >right result of IS-IS spf route computation will not be affected. 
> 
> 
> I don't agree. If the backdoor link fails, then the two sites cannot 
> receive the lsp's of the other side. So whatever happens in the one 
> site will be hidden to the other. However, the sham-link will still 
> claim connectivity between the two. 
> 
> So, the consequence of this is that you have routing inconsistency 
> between sites with all the issues that are related ti it.
> 
> This is the reason why ospf does flooding over sham-link as well.
> 
> 
> >With the age of the LSA of the other site's PE and CE in one side, 
> >the database of the virtual one area (i mean "virtual" is because of sham link) 
> >may be destroied, but the route table on PE and CE will be still right . 
> >
> >Flooding over sham-link with encapsulation of isis packets into ip almost
> >can't be accepted.
> 
> 
> I know... but you don't have the choice if you want to be sure routing 
> information is consistent across sites.
> 
> Link-state protocols require that everyone get flooded with all routing 
> information. If you claim connectivity (sham-link) then you have to be 
> sure flooding will ALWAYS happen everywhere... which is not the case if 
> the bakdoor link fails.
> 
> One solution is to shutdown the sham link if the backdoor fails but in 
> order for this to be possible you have to detect such failure... not 
> easy without running additional SPFs.
> 
> s.
> 
> 
> >expect your kindly further discussion..
> >
> >regards
> >- sheng
> >
> >----- Original Message ----- 
> >From: "stefano previdi" <[email-masked]>
> >To: "shengcheng" <[email-masked]>; <[email-masked]>
> >Cc: <[email-masked]>; <[email-masked]>; <[email-masked]>
> >Sent: Thursday, May 29, 2003 3:18 PM
> >Subject: Re: About IS-IS as PE/CE routing protocol in BGP/MPLS/VPN
> >
> >
> >On Thursday 29 May 2003 04:11, shengcheng wrote:
> >> 
> >>
> >> Dear Stefano and Manav :
> >>     Thanks for your attention to our draft of ISIS as PE/CE 
> >> routing protocol in BGP/MPLS VPN.      
> >>     Unluckily, my email box doesn't work normally recently. 
> >> This is why we give such a late response. 
> >>     Your issue is really very helpful. We are trying to 
> >> deliver next version of the draft to update the existing 
> >> problem(including your issues) in the current version this week. 
> >>     Kindly wish you continue to pay attention to the draft !
> >>
> >> thanks & regards
> >> Sheng
> >
> >there is something else that need to be worked out. If the 
> >backdoor link between two sites failed, then the two sites 
> >do not receive LSPs anymore but still believe they have 
> >full connectivity through the sham-link. 
> >
> >I'm affraid we will have to specify that flooding should 
> >occur over the sham link. This complexify a bit the 
> >architecture (not to mention that flooding over sham-link 
> >implies encapsulation of isis packets into ip).
> >
> >s.
> 
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: shengcheng <[email-masked]>
Date: Mon, 02 Jun 2003 10:10:02 +0800

This is for your information.

Thanks & Regards
Sheng

----- Original Message ----- 
From: "stefano previdi" <[email-masked]>
To: "shengcheng" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Friday, May 30, 2003 4:30 PM
Subject: Re: About IS-IS as PE/CE routing protocol in BGP/MPLS/VPN

> At 05:58 AM 5/30/2003, shengcheng wrote:
> >Stefano:
> >           As you have said "So, the consequence of this is that you have routing inconsistency 
> >  between sites with all the issues that are related ti it." . What do you mean the "routing inconsistency?"
> 
> 
> whatever changes in one site will be unknown to the other 
> one. This may result in routing loops (e.g.: a prefix is 
> withdrawn from one site and advertised by another one).
> 
> sham-link is considered as a p2p link. If flooding is 
> stopped because there is no other connectivity than the 
> sham-link, then the flooding scheme is broken.
> 
> 
> >Yes the database sychronization has been destroied, but i still think the route is right in PE/CE of 
> >both side. 
> 
> 
> The PEs _may_ have correct information but not the CEs and 
> not all the other routers in both sites. CEs and sites will 
> only have local information and out-of-date information 
> about the other site.
> 
> 
> >          It is really a disaster for IS-IS to encapsulate its packet in IP format, which is the only way to 
> >flood the LSP accross the sham link in my opinion. 
> 
> 
> if you want to flood between sites you have to use IP. Note 
> that you will encap also CSNP/PSNP packets because of reliable 
> flooding (IP is just the encap).
> 
> 
> >I think your suggention about shutting down the sham 
> >link when detecting the backdoor fails is a good idea. Maybe it is the only method that deserve our 
> >further attention when we have to fufill the database synchronization of IS-IS as a link state protocol.
> 
> 
> detecting the failure of the backdoor is not trivial. the PE 
> doesn't know who is the backdoor. The only way to do so is to 
> run an additional SPF with following constraints:
> 
>         1- do not use the sham-link in the computation
>         2- check reachability of the other PE
> 
> if the other PE is found after this special SPF than it means 
> the backdoor works. If not it means that the sham-link is the 
> only way to reach the other PE. But you understand that this 
> means the PE has to run one more SPF at each network change.
> 
> So now the question is: what do we do if the backdoor link 
> fails ? If you just shutdown the sham-link, then you completely 
> lose connectivity between sites and it is not the scope of the 
> game... 
> 
> So the alternative is to _always_ redistribute sites routes 
> into BGP (even if you do flooding over sham-link) so when the 
> sham-link is shutdown you can rely on mp-bgp to propagate routes 
> between sites. This has the side effect of flooding twice the 
> routes...
> 
> s.
> 
> 
> 
> >Do you have other constructive suggestion?
> >
> >  
> >thanks&regards
> >Sheng
> >