Subject: [Isis-wg] IS-IS MT draft

From: Shankar Vemulapalli <[email-masked]>
Date: Sat, 24 Apr 2004 18:09:42 -0700 (PDT)

Hi Folks -

Looking through isis-mt draft posted @:
http://www.ietf.org/proceedings/03jul/I-D/draft-ietf-isis-wg-multi-topology-06.txt
[I believe it is under AD review - I could be wrong]

Here are some observations:
a)
In section 7:
The overload, partition and attached bits in LSP header only reflect the
status of the default topology.
vs
In Section 9:
The LSP overload bit and pseudo-node LSPs are used by all topologies during
computation.

is contradicting.

b)
In Section 11.3:
 TLV number of this TLV is 235.  It is aligned with extended IS
                                            should be IP   ^^^^^
 reachability TLV type 135 beside an additional two bytes in front.

c)
In Section 11.3: [same section]
  No attempt is made in this draft to let the M-ISIS IPv6 topology to
  understand the "normal" IPv6 prefix with TLV type 236. A network
  SHOULD only run IS-IS either with IPv6 using type 236 or with M-ISIS
  IPv6 using type 237.

should probably in Section 11.4: Multi-Topology Reachable IPv6 Prefixes TLV

Thanks,

/Shankar

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Naiming Shen <[email-masked]>
Date: Thu, 29 Apr 2004 10:00:05 -0700

Shankar,

thanks for the comment, will update in the next version.

 ] Hi Folks -
 ] 
 ] Looking through isis-mt draft posted @:
 ] http://www.ietf.org/proceedings/03jul/I-D/draft-ietf-isis-wg-multi-topology-
06.txt
 ] [I believe it is under AD review - I could be wrong]
 ] 
 ] Here are some observations:
 ] a)
 ] In section 7:
 ] The overload, partition and attached bits in LSP header only reflect the
 ] status of the default topology.
 ] vs
 ] In Section 9:
 ] The LSP overload bit and pseudo-node LSPs are used by all topologies during
 ] computation.
 ] 
 ] is contradicting.
 ] 
 ] b)
 ] In Section 11.3:
 ]  TLV number of this TLV is 235.  It is aligned with extended IS
 ]                                             should be IP   ^^^^^
 ]  reachability TLV type 135 beside an additional two bytes in front.
 ] 
 ] 
 ] c)
 ] In Section 11.3: [same section]
 ]   No attempt is made in this draft to let the M-ISIS IPv6 topology to
 ]   understand the "normal" IPv6 prefix with TLV type 236. A network
 ]   SHOULD only run IS-IS either with IPv6 using type 236 or with M-ISIS
 ]   IPv6 using type 237.
 ] 
 ] should probably in Section 11.4: Multi-Topology Reachable IPv6 Prefixes TLV
 ] 
 ] Thanks,
 ] 
 ] 
 ] /Shankar
 ] 
 ] _______________________________________________
 ] Isis-wg mailing list
 ] [email-masked]
 ] https://www1.ietf.org/mailman/listinfo/isis-wg

- Naiming