Subject: [Isis-wg] Minor comments on draft-ietf-isis-wg-mib-13.txt

From: Jeff Parker <[email-masked]>
Date: Mon, 5 Apr 2004 17:03:48 -0400

Jon -
	Since we have the isisCircLevelDesIS to define the CircID for LANs,
I see no problem restricting isisCircLevelID to P2P circuits. 
	Any issues with this?

	Your mail, and relevant portions of mib follow.  
  
- jeff parker

- Finally, isisCircLevelID.  I'd like to clarify whether this object is
only used for point to point circuits (as suggested by the reference to
ptPtCircuitID), or whether this field can be given a sensible value for a
LAN (since the CircuitID syntax doesn't give an option to return a zero
length OCTET STRING).

If the field does take a value on a LAN (with the disadvantage of making the
meaning of the field less clear), then the following text could be used.

"On a point to point circuit with a fully initialized adjacency to a peer
IS, the value of this object is the circuit ID negotiated during adjacency
initialization.  In all other cases, the value is the concatenation of the
local system ID and the one byte isisCircLevelIDOctet for this circuit.
This is the value that would be proposed for the circuit ID on a point to
point circuit, or for the LAN ID should this node be chosen as the LAN
Designated IS."

Or if the field is purely for use as the ptPtCircuitID, I suggest we change
the Circuit ID syntax to "OCTET STRING (SIZE(0|7))", and change the
description as follows:

"On a point to point circuit with a fully initialized adjacency to a peer
IS, the value of this object is the circuit ID negotiated during adjacency
initialization.  On a point to point circuit without such an adjacency, the
value is the concatenation of the local system ID and the one byte
isisCircLevelIDOctet for this circuit i.e. the value that would be proposed
for the circuit ID.

On other circuit types, the value returned is the zero length OCTET STRING."

    isisCircLevelID OBJECT-TYPE
        SYNTAX CircuitID
        MAX-ACCESS read-only
        STATUS current
        DESCRIPTION
            "The ID of the circuit allocated during initialization.
             If no value has been negotiated (either because the
             adjacency is to an End System, or because initialization
             has not yet successfully completed), this object has the
             value which would be proposed for this circuit (i.e. the
             concatenation of the local system ID and the one byte
             isisCircLevelIDOctet for this circuit."
        REFERENCE "{ISIS.aoi ptPtCircuitID (51)}"
    ::= { isisCircLevelEntry 6 }

    isisCircLevelDesIS OBJECT-TYPE
        SYNTAX CircuitID
        MAX-ACCESS read-only
        STATUS current
        DESCRIPTION
            "The ID of the LAN Designated Intermediate System
             on this circuit at this level. If, for any reason,
             this system is not partaking in the relevant
             Designated Intermediate System election process,
             then the value returned is the zero length OCTET STRING."
        REFERENCE "{ISIS.aoi l2DesignatedIntermediateSystem (75)}"
    ::= { isisCircLevelEntry 7 }

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Jonathan Harrison <[email-masked]>
Date: Wed, 7 Apr 2004 10:51:40 +0100

Jeff,

I agree.  It is clearer to have isisCircLevelID restricted to P2P circuits.

Jon

-----Original Message-----
From: Jeff Parker [mailto:[email-masked]]
Sent: 05 April 2004 22:04
To: Jonathan Harrison; Jeff Parker; [email-masked]
Subject: [Isis-wg] Minor comments on draft-ietf-isis-wg-mib-13.txt

Jon -

- jeff parker

---

From: Jonathan Harrison <[email-masked]>
Date: Wed, 7 Apr 2004 10:51:27 +0100

Jeff,

I agree that it does make sense to have these specific failures counted in
the isisCircRejAdjs.  We should still clarify the use of isisCircInitFails
though.

I think we should 

 - remove the reference to the "ISIS.aoi initialisationFailures"

 - change the description e.g. "The number of times that the underlying link
has failed."  (Possibly with an additional example?)

 - maybe even change the name to isisCircLinkFails.

What do you think?
Jon

-----Original Message-----
From: Jeff Parker [mailto:[email-masked]]
Sent: 05 April 2004 21:51
To: Jonathan Harrison; Jeff Parker; [email-masked]
Subject: [Isis-wg] Minor comments on draft-ietf-isis-wg-mib-13.txt

Jonathan -

I am accepting almost all of you helpful suggestions.  
However, this gave me pause.  I would thnk that the
two reasons you spell out would apply to isisCircRejAdjs, 
while InitFails would count link problems, such as NCP
failures on PPP.  You are probably right about the reference,
but I would argue that there are more reasons to drop adjacencies
today (non-matching IP adress, disagreements on 3-way handshake,..)
and we should put your two events in CircRejAdjs.  

- jeff parker

 - isisCircInitFails refers to "ISIS.aoi initialisationFailures", which
counts specific adjacency initialization failures due to having no version
or area address in common.  The MIB should spell this out.  For example,
"The number of times initialization of an adjacency on this circuit has
failed due to the peer having either no version or no area address in common
with the local system." 

Relevant objects below

    isisCircInitFails OBJECT-TYPE
        SYNTAX Counter32
        MAX-ACCESS read-only
        STATUS current
        DESCRIPTION
            "The number of times initialization of this circuit has
             failed."
        REFERENCE "{ISIS.aoi initialisationFailures (41)}"
    ::= { isisCircuitCounterEntry 4 }

    isisCircRejAdjs OBJECT-TYPE
        SYNTAX Counter32
        MAX-ACCESS read-only
        STATUS current
        DESCRIPTION
            "The number of times an adjacency has been rejected on
             this circuit."
        REFERENCE "{ISIS.aoi rejectedAdjacencies (42)}"
    ::= { isisCircuitCounterEntry 5 }