Subject: RE: [Isis-wg] RE: OSPF MIB support for multiple OSPF processes

From: "Daniel Joyal" <[email-masked]>
Date: Tue, 11 May 2004 17:13:50 -0400

I don't have a problem with the ISIS MIB supporting
multiple instances. Has the OAM directorate issued
any policy statements as to the preferred way to support
MIBs in virtual routers?

-Dan

> -----Original Message-----
> From: Jeff Parker [mailto:[email-masked]] 
> Sent: Tuesday, May 11, 2004 2:37 PM
> To: ISIS-WG (E-mail)
> Cc: [email-masked]'; Joyal, Daniel [BL60:NP31:EXCH]
> Subject: FW: [Isis-wg] RE: OSPF MIB support for multiple OSPF 
> processes
> 
> 
> Here is one note from my mail files: I remember more 
> discussions, but haven't stumbled across it.  It does seem to 
> come up every year or so. Periodic, with jitter applied.  
> 
> This is really more to the point that a virtual router is an 
> important concept than a statement of how best to do this.  
> 
> - jeff parker
> 
> 
> > -----Original Message-----
> > From: Jonathan Sadler [mailto:[email-masked]]
> > Sent: Tuesday, January 28, 2003 5:06 AM
> > To: Jeff Parker
> > Subject: Re: [Isis-wg] RE: OSPF MIB support for multiple OSPF
> > processes
> > 
> > 
> > Jeff -
> > 
> > I do have use for this in SONET/SDH environments --
> > specifically this index
> > allows for support of multiple logical IS-IS instances on 
> one physical
> > platform.  This is needed for:
> >  - more than one Area per physical platform
> >  - separation of IS-IS routing for the DCN from separate IS-IS
> >    routing for other layer networks (i.e. GMPLS)
> > 
> > Jeff Parker wrote:
> > 
> > >
> > > > Jeff,
> > > >
> > > >  Given the comments below, where did you get the requirement to 
> > > > explicitly support multiple IS-IS instances in the IS-IS MIB?
> > > >
> > > > -Dan
> > >
> > > Dan -
> > >         You are refering to the SysInstance index in
> > > the IS-IS MIB.  Use of this was not a requirement:
> > > it came with the original version of the MIB I inherited.
> > >
> > >         I would be interested to hear from any users
> > > that find this useful.  While it seems to offer
> > > a solution, I don't know of any other MIB that supports this, so 
> > > people will have to design an alternative anyway.
> > >
> > >         It isn't too late to rip this out if it has
> > > no utility.
> > >
> > > - jeff parker
> > >
> > > > -----Original Message-----
> > > > From: Tom Petch [mailto:[email-masked]]
> > > > Sent: Monday, January 20, 2003 1:16 PM
> > > > To: [email-masked]
> > > > Subject: Re: OSPF MIB support for multiple OSPF processes
> > > >
> > > >
> > > > Yes.
> > > > In SNMPv1, this can be done by having multiple 'agents'
> > identified by
> > > > different community names or different IP addresses, each
> > accessing a
> > > > distinct incarnation of MIB II and its subordinate branches. In 
> > > > SNMPv3, there is a more sophisticated mechanism of
> > contexts which
> > > > formalises the techniques given above.
> > > > I do not think you should ever return more than one 
> instance of a 
> > > > given object in GET or GETNEXT.
> > > >
> > > > Tom Petch
> > > > [email-masked]
> > > >
> > > > -----Original Message-----
> > > > From: Roy Jose <[email-masked]>
> > > > To: [email-masked] <[email-masked]>
> > > > Date: 20 January 2003 16:04
> > > > Subject: OSPF MIB support for multiple OSPF processes
> > > >
> > > >
> > > > >Hi,
> > > > >
> > > > >Rfc1850 doesn't talk about what to be done regarding the
> > > > retrieval(GET) of
> > > > >MIB values when multiple OSPF processes exist on a
> > router. Out first
> > > > >impression is to return details about all the processes.
> > The problem
> > > > is
> > > > >while selecting values for MIB objects like 
> > > > >ospfRouterId,ospfAreaBdrRtrStatus, ospfASBdrRtrStatus
> > etc. They may
> > > > differ
> > > > >in separate processes. The Qn is, can we really 
> support multiple
> > > > processes
> > > > >with rfc1850?
> > > > >
> > > > >Thanks,
> > > > >Roy
> > > >
> > > _______________________________________________
> > > Isis-wg mailing list
> > > [email-masked] https://www1.ietf.org/mailman/listinfo/isis-wg
> > 
> > ============================================================
> > The information contained in this message may be privileged
> > and confidential and protected from disclosure.  If the 
> > reader of this message is not the intended recipient, or an 
> > employee or agent responsible for delivering this message to 
> > the intended recipient, you are hereby notified that any 
> > reproduction, dissemination or distribution of this 
> > communication is strictly prohibited. If you have received 
> > this communication in error, please notify us immediately by 
> > replying to the message and deleting it from your computer.
> > 
> > Thank you.
> > Tellabs ============================================================
> > 
>

---

From: Christian Hopps <[email-masked]>
Date: Thu, 13 May 2004 06:27:34 -0700

I'm interested in why we *should* support multiple instances (not  
virtual routers) directly in the MIB with an index in every table.  
Currently I see no good reason for this complexity. IS-IS doesn't use  
multiple instances anywhere near as much as OSPF in the field, and the  
OSPF MIB uses the context mechanism.

I think we need a real good reason to differ from OSPF (and frankly a  
more simple MIB), otherwise we shouldn't. The only thing I've heard so  
far is OSPF has maybe hit bumps in the road in using contexts. I don't  
think thats a good enough reason, given the level of usage of multiple  
IS-IS instances, and the fact that OSPF will smooth the way for us  
here.

Chris.

On May 11, 2004, at 2:13 PM, Daniel Joyal wrote:

> X-MimeOLE: Produced By Microsoft Exchange V6.0.6487.1
> Received:  from exchangefe2.na.procket.com ([10.1.7.252]) by  
> exchange0-0.na.procket.com with Microsoft SMTPSVC(5.0.2195.6713); Thu,  
> 13 May 2004 06:09:14 -0700
> MIME-Version: 1.0
> Content-Type: text/plain;
> 	charset="iso-8859-1"
> Content-Transfer-Encoding: quoted-printable
> Received:  from miata.procket.com ([10.1.1.1]) by  
> exchangefe2.na.procket.com with Microsoft SMTPSVC(5.0.2195.6713); Thu,  
> 13 May 2004 06:09:13 -0700
> Received:  from smtp2.procket.com (smtp2.procket.com [65.174.124.37])  
> by miata.procket.com (8.12.1/8.12.1) with ESMTP id i4DD9Cd1029908;  
> Thu, 13 May 2004 06:09:12 -0700 (PDT)
> Received:  from optimus.ietf.org (datatracker.ietf.org [132.151.6.22])  
> by smtp2.procket.com (8.12.8p1/8.12.1) with ESMTP id i4DFGtAw063099;  
> Thu, 13 May 2004 08:16:56 -0700 (PDT)
> Received:  from localhost.localdomain ([127.0.0.1] helo=www1.ietf.org)  
> by optimus.ietf.org with esmtp (Exim 4.20) id 1BOFtV-00056H-Gr; Thu,  
> 13 May 2004 09:05:01 -0400
> Received:  from odin.ietf.org ([132.151.1.176] helo=ietf.org) by  
> optimus.ietf.org with esmtp (Exim 4.20) id 1BNebs-0007GU-Jm for  
> [email-masked]; Tue, 11 May 2004 17:16:20 -0400
> Received:  from ietf-mx (ietf-mx.ietf.org [132.151.6.1]) by ietf.org  
> (8.9.1a/8.9.1a) with ESMTP id RAA26354 for <[email-masked]>; Tue, 11  
> May 2004 17:16:16 -0400 (EDT)
> Received:  from ietf-mx.ietf.org ([132.151.6.1] helo=ietf-mx) by  
> ietf-mx with esmtp (Exim 4.32) id 1BNebq-0001xF-9x for  
> [email-masked]; Tue, 11 May 2004 17:16:18 -0400
> Received:  from exim by ietf-mx with spam-scanned (Exim 4.12) id  
> 1BNeaw-0001Ws-00 for [email-masked]; Tue, 11 May 2004 17:15:24 -0400
> Received:  from zcars04f.nortelnetworks.com ([47.129.242.57]) by  
> ietf-mx with esmtp (Exim 4.12) id 1BNeaE-0000wJ-00 for  
> [email-masked]; Tue, 11 May 2004 17:14:38 -0400
> Received:  from zbl6c012.us.nortel.com  
> (zbl6c012.corpeast.baynetworks.com [132.245.205.62]) by  
> zcars04f.nortelnetworks.com (Switch-2.2.6/Switch-2.2.0) with ESMTP id  
> i4BLDpH19176; Tue, 11 May 2004 17:13:52 -0400 (EDT)
> Received:  by zbl6c012.corpeast.baynetworks.com with Internet Mail  
> Service (5.5.2653.19) id <KJ4MARKM>; Tue, 11 May 2004 17:13:51 -0400
> Return-Path: <[email-masked]>
> X-Mailer: Internet Mail Service (5.5.2653.19)
> X-OriginalArrivalTime: 13 May 2004 13:09:14.0076 (UTC)  
> FILETIME=[7D1D51C0:01C438EB]
> Errors-To: [email-masked]
> X-BeenThere: [email-masked]
> X-Mailman-Version: 2.0.12
> List-Post: <mailto:[email-masked]>
> List-Id: IETF IS-IS working group <isis-wg.ietf.org>
> List-Archive:  
> <https://www1.ietf.org/mail-archive/working-groups/isis-wg/>
> X-Spam-Status: No, hits=0.5 required=5.0  
> tests=AWL,HTML_30_40,HTML_MESSAGE autolearn=no version=2.60
> X-Spam-Checker-Version: SpamAssassin 2.60 (1.212-2003-09-23-exp) on  
> ietf-mx.ietf.org
> Content-class: urn:content-classes:message
> Subject: RE: [Isis-wg] RE: OSPF MIB support for multiple OSPF processes
> Date: Tue, 11 May 2004 14:13:50 -0700
> Message-ID:  
> <[email-masked] 
> .com>
> X-MS-Has-Attach:
> X-MS-TNEF-Correlator:
> Thread-Topic: [Isis-wg] RE: OSPF MIB support for multiple OSPF  
> processes
> Thread-Index: AcQ4631ns1msUsdDQdeFUp5iJ6nRHw==
> List-Help: <mailto:[email-masked]?subject=help>
> List-Subscribe:  
> <https://www1.ietf.org/mailman/listinfo/isis-wg>,<mailto:isis-wg- 
> [email-masked]?subject=subscribe>
> List-Unsubscribe:  
> <https://www1.ietf.org/mailman/listinfo/isis-wg>,<mailto:isis-wg- 
> [email-masked]?subject=unsubscribe>
> From: "Daniel Joyal" <[email-masked]>
> Sender: <[email-masked]>
> To: "Jeff Parker" <[email-masked]>,
> 	"ISIS-WG (E-mail)" <[email-masked]>
> Cc: <[email-masked]>
>
> X-MimeOLE: Produced By Microsoft Exchange V6.0.6487.1
> Received:  from exchangefe2.na.procket.com ([10.1.7.252]) by  
> exchange0-0.na.procket.com with Microsoft SMTPSVC(5.0.2195.6713); Thu,  
> 13 May 2004 06:09:14 -0700
> MIME-Version: 1.0
> Content-Type: text/plain;
> 	charset="iso-8859-1"
> Content-Transfer-Encoding: quoted-printable
> Received:  from miata.procket.com ([10.1.1.1]) by  
> exchangefe2.na.procket.com with Microsoft SMTPSVC(5.0.2195.6713); Thu,  
> 13 May 2004 06:09:13 -0700
> Received:  from smtp2.procket.com (smtp2.procket.com [65.174.124.37])  
> by miata.procket.com (8.12.1/8.12.1) with ESMTP id i4DD9Cd1029908;  
> Thu, 13 May 2004 06:09:12 -0700 (PDT)
> Received:  from optimus.ietf.org (datatracker.ietf.org [132.151.6.22])  
> by smtp2.procket.com (8.12.8p1/8.12.1) with ESMTP id i4DFGtAw063099;  
> Thu, 13 May 2004 08:16:56 -0700 (PDT)
> Received:  from localhost.localdomain ([127.0.0.1] helo=www1.ietf.org)  
> by optimus.ietf.org with esmtp (Exim 4.20) id 1BOFtV-00056H-Gr; Thu,  
> 13 May 2004 09:05:01 -0400
> Received:  from odin.ietf.org ([132.151.1.176] helo=ietf.org) by  
> optimus.ietf.org with esmtp (Exim 4.20) id 1BNebs-0007GU-Jm for  
> [email-masked]; Tue, 11 May 2004 17:16:20 -0400
> Received:  from ietf-mx (ietf-mx.ietf.org [132.151.6.1]) by ietf.org  
> (8.9.1a/8.9.1a) with ESMTP id RAA26354 for <[email-masked]>; Tue, 11  
> May 2004 17:16:16 -0400 (EDT)
> Received:  from ietf-mx.ietf.org ([132.151.6.1] helo=ietf-mx) by  
> ietf-mx with esmtp (Exim 4.32) id 1BNebq-0001xF-9x for  
> [email-masked]; Tue, 11 May 2004 17:16:18 -0400
> Received:  from exim by ietf-mx with spam-scanned (Exim 4.12) id  
> 1BNeaw-0001Ws-00 for [email-masked]; Tue, 11 May 2004 17:15:24 -0400
> Received:  from zcars04f.nortelnetworks.com ([47.129.242.57]) by  
> ietf-mx with esmtp (Exim 4.12) id 1BNeaE-0000wJ-00 for  
> [email-masked]; Tue, 11 May 2004 17:14:38 -0400
> Received:  from zbl6c012.us.nortel.com  
> (zbl6c012.corpeast.baynetworks.com [132.245.205.62]) by  
> zcars04f.nortelnetworks.com (Switch-2.2.6/Switch-2.2.0) with ESMTP id  
> i4BLDpH19176; Tue, 11 May 2004 17:13:52 -0400 (EDT)
> Received:  by zbl6c012.corpeast.baynetworks.com with Internet Mail  
> Service (5.5.2653.19) id <KJ4MARKM>; Tue, 11 May 2004 17:13:51 -0400
> Return-Path: <[email-masked]>
> X-Mailer: Internet Mail Service (5.5.2653.19)
> X-OriginalArrivalTime: 13 May 2004 13:09:14.0076 (UTC)  
> FILETIME=[7D1D51C0:01C438EB]
> Errors-To: [email-masked]
> X-BeenThere: [email-masked]
> X-Mailman-Version: 2.0.12
> List-Post: <mailto:[email-masked]>
> List-Id: IETF IS-IS working group <isis-wg.ietf.org>
> List-Archive:  
> <https://www1.ietf.org/mail-archive/working-groups/isis-wg/>
> X-Spam-Status: No, hits=0.5 required=5.0  
> tests=AWL,HTML_30_40,HTML_MESSAGE autolearn=no version=2.60
> X-Spam-Checker-Version: SpamAssassin 2.60 (1.212-2003-09-23-exp) on  
> ietf-mx.ietf.org
> Content-class: urn:content-classes:message
> Subject: RE: [Isis-wg] RE: OSPF MIB support for multiple OSPF processes
> Date: Tue, 11 May 2004 14:13:50 -0700
> Message-ID:  
> <[email-masked] 
> .com>
> X-MS-Has-Attach:
> X-MS-TNEF-Correlator:
> Thread-Topic: [Isis-wg] RE: OSPF MIB support for multiple OSPF  
> processes
> Thread-Index: AcQ4631ns1msUsdDQdeFUp5iJ6nRHw==
> List-Help: <mailto:[email-masked]?subject=help>
> List-Subscribe:  
> <https://www1.ietf.org/mailman/listinfo/isis-wg>,<mailto:isis-wg- 
> [email-masked]?subject=subscribe>
> List-Unsubscribe:  
> <https://www1.ietf.org/mailman/listinfo/isis-wg>,<mailto:isis-wg- 
> [email-masked]?subject=unsubscribe>
> From: "Daniel Joyal" <[email-masked]>
> Sender: <[email-masked]>
> To: "Jeff Parker" <[email-masked]>,
> 	"ISIS-WG (E-mail)" <[email-masked]>
> Cc: <[email-masked]>
>

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg