Subject: Re: [Isis-wg] areaTransmitPassword/domainTransmitPassword

From: [email-masked]
Date: Thu, 29 Sep 2005 08:02:23 +0200 (CEST)

Except that ISs supporting authentication will refuse the PDU with no
password, won't they?

>I'll also point out that accepting the PDUs allows you to transition
>to a fully authenticated network in a smooth fashion.
>
>Tony

On Sep 27, 2005, at 5:05 AM, Ramalingam, Swaminathan (Swaminathan)
wrote:

> Hi-
>
> If a system is configured with no password, and L1/L2 LSP/CSNPs are
> received
> with some passwords, what should be the behaviour of processing those
> LSPs/CSNPs.
>
> I believe it should be dropped as the system is configured with no
> password
> and receiving LSPs/CSNPs with passwords. Please comment on this.
>
> But in the ISO 10589 & RFC 1195, there is no explicit mentioning of
> this. It
> might mislead some implementators to accept L1/L2 LSP/CSNPs in this
> case.
>
>
>
> Thanks,
> Swami
>
>
>
> _______________________________________________
> Isis-wg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/isis-wg
>

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Hannes Gredler <[email-masked]>
Date: Fri, 30 Sep 2005 18:45:53 +0200

as tony has pointed out that is again a matter
how friendly the implementation is to migration
scenarios .

for example in a migration scenario (non-auth -> auth)
you might not flag-day migrate all routers in a single
maintenance window ..

therefore  it might make sense to run a full authentication check
on the PDU if TLV #10 is present and do kinda
"loose" authentication check if TLV #10 is not present;

at the end of the migration period the router is configured to
"raise the shields" and both check
  "the TLV #10 present" and
  "the TLV #10 not-present" case;

/hannes

---

From: Satish Dattatri <[email-masked]>
Date: Fri, 30 Sep 2005 09:47:39 -0700 (PDT)

Please refer to D.2 of RFC1195 to see how seamless transition could
be done with Receive and Transmitt password(s). That mechanism is not
specific to simple passwords.

Satish