Subject: RE: [Isis-wg] Final WG LC draft-ietf-isis-wg-mib-23.txt (fwd)

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Wed, 12 Oct 2005 16:37:31 +0200

In rev 23 I am happy to see THis:

    IsisSystemID ::= TEXTUAL-CONVENTION
        STATUS current
        DESCRIPTION
            "A system ID."
        SYNTAX OCTET STRING (SIZE(6))

changed into this:

    IsisSystemID ::= TEXTUAL-CONVENTION
        STATUS current
        DESCRIPTION
            "The ID for an Intermediate System.  This should
             be unique within a network, and is included
             in all PDUs originated by an Intermediate System.
>            Some implementations may automatically assign
>            values and not permit an SNMP write, while
>            others may require the value to be set manually.
             The protocol does not place any meanings upon
             the bits, other than using ordering to break
             ties in electing a Designated IS on a LAN."
        REFERENCE "{ISIS.aoi systemId (119)}"
        SYNTAX OCTET STRING (SIZE(6))

But the 3 lines marked with > seem not part of the TC.
It depends on where /how the TC is used. Some may use it
for a read-only object and then those 3 lines mean nothing
or may be confusing. The 3 lines belong in a DESCRIPTION clause
where the TC is used as a SYNTAX in an OBJECT-TYPE and whihc
has possibly a MAX-ACCESS of read-write or read-create.
I am not hung up on this though.

When I see this
    IsisLinkStatePDUID ::= TEXTUAL-CONVENTION
        STATUS current
        DESCRIPTION
            "A Link State PDU Identifier."
        SYNTAX OCTET STRING (SIZE(8))

changed into:
   IsisLinkStatePDUID ::= TEXTUAL-CONVENTION
       STATUS current
       DESCRIPTION
           "A Link State PDU Identifier formed from the
            6 byte System ID, a one byte PseudoNode ID,
            and a one byte LSP fragment number."
       REFERENCE "{See section 9.8 of ISO 10589}"
       SYNTAX OCTET STRING (SIZE(8))
Then I like that. But it would have been even more helpful
if you had been more explicit on the sequence of th 6, 1 nad 1 byte.
Maybe you imply that that is the sequence, but that is not very clear.
Again, I can live with it.

When I see:
        Configured values will survive an agent reboot."
I am happy. Better/clearer might have been:
        Configured values MUST survive an agent reboot."
assuming that is what the WG wants.
I am not hung up on it. Besides, I see that Mike suggested the 
"will survive" so I should not keep nitpicking further.

Ready to go, as far as I am concerned!
Thanks Jeff!

Bert

> -----Original Message-----
> From: C. M. Heard [mailto:[email-masked]]
> Sent: Friday, October 07, 2005 21:02
> To: Wijnen, Bert (Bert)
> Subject: [Isis-wg] Final WG LC draft-ietf-isis-wg-mib-23.txt (fwd)
> 
> 
> Bert,
> 
> FYI.  It might be good to let the author & WG chairs know whether or
> not you are satisfied with this version of the MIB module.
> 
> Regards,
> 
> Mike
> 
> ---------- Forwarded message ----------
> Date: Fri, 7 Oct 2005 06:11:25 -0700
> From: Christian Hopps <[email-masked]>
> To: Jeff Parker <[email-masked]>
> Cc: ISIS WG <[email-masked]>
> Subject: [Isis-wg] Final WG LC draft-ietf-isis-wg-mib-23.txt 
> 
> This draft has been in Final Final WG LC. The only changes 
> allowed at  
> this point are changes to the changes from the previous. This  
> revision was requested by the MIB area director so the revision was  
> made. :)
> 
> Please review these changes for anything glaringly wrong as I 
> plan to  
> send this MIB to the Alex and Bill next Friday (2005/10/14). 
> I'd like  
> for this to be in the queue to become an RFC *before* the next IETF.
> 
> Chris.
> 
> On Oct 4, 2005, at 6:22 AM, Parker, Jeff wrote:
> 
> > I was remiss in not posting a note about the changes.
> >
> > I have included the diffs, but the changes were editorial, in  
> > response to a
> > request from Bert Wijnen.
> >
> >     Change Unsigned16TC to IsisUnsigned16TC and the like
> >     Beef up the Reference clauses in TCs
> >     Edits for Behaviors
> >     Describe how rest of System scalars behave after reboot
> >
> > The hope is that this version is closer to the final form.
> >
> > I did run across "Zeno's Body Shop" the other day, at the end of a  
> > scenic
> > dirt road near a popular hiking trail.  I did have a feeling of  
> > deja vu, and
> > wondered if this version of the draft is halfway there.
> >
> > - jeff parker
> >
> > ------ Forwarded Message
> >
> >
> >> Title  : Management Information Base for IS-IS
> >> Author(s) : J. Parker
> >> Filename : draft-ietf-isis-wg-mib-23.txt
> >> Pages  : 101
> >> Date  : 2005-10-3
> >>
> >
> >
> > <diffs>
> > _______________________________________________
> > Isis-wg mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/isis-wg
> >
> 
> 
> _______________________________________________
> Isis-wg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/isis-wg
> 
> 
> 

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: "Parker, Jeff" <[email-masked]>
Date: Wed, 12 Oct 2005 10:59:54 -0400

> I am not hung up on this though.

Removed

> Again, I can live with it.

            "The 8 byte Link State PDU (LSP) ID,
             consisting of the 6 byte SystemID of the
             originating IS, a one byte PseudoNode ID
             which is 0 unless the LSP represents the
             topology of a LAN, and one byte LSP
             fragment number that are issued in sequence,
             starting with 0.  Non zero PseudoNode IDs
             need to be unique to the IS, but need not
             match the IfIndex."

This probably says too much about the PseudoNode ID.  I believe it be
wordsmithed further: the byte really only needs to be unique at that
-level-.

> Ready to go, as far as I am concerned!

myrmidon:~/MIB jeff$ grep survive mib
             Configured values MUST survive an agent reboot."
             Configured values MUST survive an agent reboot."
             Configured values MUST survive an agent reboot."
             Configured values MUST survive an agent reboot."
             Configured values MUST survive an agent reboot."
             Configured values MUST survive an agent reboot."
             Configured values MUST survive an agent reboot."
             Configured values MUST survive an agent reboot."
             Configured values MUST survive an agent reboot."
             Configured values MUST survive an agent reboot."
             Configured values MUST survive an agent reboot."
             Dynamically created rows MUST survive an agent reboot."
             Dynamically learned rows do not survive an agent reboot."
             Dynamically created rows MUST survive an agent reboot.
             Dynamically created rows MUST survive an agent reboot.
             Dynamically learned rows do not survive an agent reboot."
             Configured values MUST survive an agent reboot."
             Dynamically created rows MUST survive an agent reboot."
             Configured values MUST survive an agent reboot."
             Dynamically learned rows do not survive an agent reboot."
             Dynamically learned rows do not survive an agent reboot."
             Dynamically learned rows do not survive an agent reboot."
             Dynamically learned rows do not survive an agent reboot."
             Dynamically created rows MUST survive an agent reboot."
             Dynamically created rows MUST survive an agent reboot.
             Dynamically learned rows will not survive an
             Dynamically learned rows will not survive an
 
myrmidon:~/MIB jeff$ grep survive mib | grep -v MUST
             Dynamically learned rows do not survive an agent reboot."
             Dynamically learned rows do not survive an agent reboot."
             Dynamically learned rows do not survive an agent reboot."
             Dynamically learned rows do not survive an agent reboot."
             Dynamically learned rows do not survive an agent reboot."
             Dynamically learned rows do not survive an agent reboot."
             Dynamically learned rows will not survive an
             Dynamically learned rows will not survive an

Other issues?

- jdp