Subject: RE: [Isis-wg] Computation of areas in MT-ISIS

From: "May Lu" <[email-masked]>
Date: Mon, 10 Oct 2005 11:20:34 -0500

If a MT-ISIS node runs different protocols on its interfaces, how does the node broadcast its union address in L2 LSP?

See configuration below:

       Node1(area 01, 04) ----  Node2 (area 01, 02) --- Node3 (area 02, 05)
                                        IP                               Ipv6

      All three nodes are MT-ISIS nodes. Node2 is connected to Node1 with IP protocol. Node2 and Node3 are connected with IPV6 protocol. Node2 IP union addresses should be 01, 02 and 04. Node2 Ipv6 union addresses should be 01, 02 and 05. Is this correct?

      If the union address does not consider the protocol, in the following case, there is a problem:

             Node1 (area 01)  ------ Node2 (area 01) ----- Node3 (area 01, 02)
                                        IP                              Ipv6
      All three nodes are MT-ISIS nodes. Node1 and Node2 are connected via IP protocol. Node2 and Node3 are connected via Ipv6 protocol. Node1 is a level1 only node. Node2's union addresses are 01 and 02. Node2 will set attached bit on IP protocol and Node1 will set the IP default route towards Node2. Actually Node1 and Node2 are using the same area address in IP network and Node1 shouldn't set default route to Node2.

Thanks,
- Xiaomei Lu

 -----Original Message-----
From: 	Naiming Shen [mailto:[email-masked]] 
Sent:	Saturday, October 08, 2005 12:01 AM
To:	Pudiyapura, Ajeer
Cc:	[email-masked]
Subject:	Re: [Isis-wg] Computation of areas in MT-ISIS

Pudiyapura, Ajeer said the following on 10/06/2005 11:09 AM:
> Hi.
> 
>  
> 
>   I have the following questions:
> 
>  
> 
> 1)       How is Area Address Computation (section 7.2.11 of ISO/IEC 
> 10589) done in Multi Topology IS-IS? Are they computed separately for 
> each topology?
> 

No. MT-ISIS node keeps the same system-id, areas, levels, hostname,
etc. there is no change to any of that.

thanks.
- Naiming

> 2)       If so, how is the resulting set advertised in L2 LSPs since 
> there is no mechanism to do this per topology?
> 
>  
> 
> Thanks
> 
> -Ajeer Pudiyapura
> 
>  
> 
> ============================================================
> The information contained in this message may be privileged
> and confidential and protected from disclosure. If the reader
> of this message is not the intended recipient, or an employee
> or agent responsible for delivering this message to the
> intended recipient, you are hereby notified that any reproduction,
> dissemination or distribution of this communication is strictly
> prohibited. If you have received this communication in error,
> please notify us immediately by replying to the message and
> deleting it from your computer. Thank you. Tellabs
> ============================================================
> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> Isis-wg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/isis-wg

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Naiming Shen <[email-masked]>
Date: Mon, 10 Oct 2005 11:34:06 -0700

May,

May Lu said the following on 10/10/2005 09:20 AM:
> If a MT-ISIS node runs different protocols on its interfaces, how
> does the node broadcast its union address in L2 LSP?
> 
> See configuration below:
> 
> All three nodes are MT-ISIS nodes. Node2 is connected to Node1 with
> IP protocol. Node2 and Node3 are connected with IPV6 protocol. Node2
> IP union addresses should be 01, 02 and 04. Node2 Ipv6 union
> addresses should be 01, 02 and 05. Is this correct?
> 
> Node1 (area 01)  ------ Node2 (area 01) ----- Node3 (area 01, 02) IP
> Ipv6 All three nodes are MT-ISIS nodes. Node1 and Node2 are connected
> via IP protocol. Node2 and Node3 are connected via Ipv6 protocol.
> Node1 is a level1 only node. Node2's union addresses are 01 and 02.
> Node2 will set attached bit on IP protocol and Node1 will set the IP
> default route towards Node2. Actually Node1 and Node2 are using the
> same area address in IP network and Node1 shouldn't set default route
> to Node2.
> 

But don't you already have problem even if Node3 is IP(not IPv6) ?
or do we already have problem if they are not MT-ISIS nodes?  If we
are playing with IP/IPv6, why should we assigning different areas to
those nodes ?

thanks.
- Naiming

> Thanks, - Xiaomei Lu
> 
> 
> -----Original Message----- From: 	Naiming Shen
> [mailto:[email-masked]] Sent:	Saturday, October 08, 2005 12:01 AM 
> To:	Pudiyapura, Ajeer Cc:	[email-masked] Subject:	Re: [Isis-wg]
> Computation of areas in MT-ISIS
> 
> 
> 
>>  10589) done in Multi Topology IS-IS? Are they computed separately
>> for each topology?
>> 
> 
> 
> thanks. - Naiming
>> 2)       If so, how is the resulting set advertised in L2 LSPs
>> since there is no mechanism to do this per topology?
>> 
>> 
>> 
>> Thanks
>> 
>> -Ajeer Pudiyapura
>> 
>> 
>> 
>> ============================================================ The
>> information contained in this message may be privileged and
>> confidential and protected from disclosure. If the reader of this
>> message is not the intended recipient, or an employee or agent
>> responsible for delivering this message to the intended recipient,
>> you are hereby notified that any reproduction, dissemination or
>> distribution of this communication is strictly prohibited. If you
>> have received this communication in error, please notify us
>> immediately by replying to the message and deleting it from your
>> computer. Thank you. Tellabs 
>> _______________________________________________ Isis-wg mailing
>> list [email-masked] 
> _______________________________________________ Isis-wg mailing list 
> [email-masked] https://www1.ietf.org/mailman/listinfo/isis-wg