Subject: Re: [Isis-wg] I-D ACTION:draft-ietf-isis-ipv6-te-02.txt

From: Hannes Gredler <[email-masked]>
Date: Wed, 23 Nov 2005 09:57:37 +0100

jon,

understood - a question:

for TE we only need to uniquely identify a given link, right ? -
i am wondering if the EUI64 part of the link-local adress would be
enough to unambigously identify a V6 TE link.

/hannes

Jonathan Harrison wrote:
> Hannes,
> 
> The reason this TLV is required is alluded to in section 3.2.3 of the draft.  It essentially comes down to the fact that IPv6 has link-local and global addresses, whereas IPv4 does not.
> 
> The non-TE IPv6 TLVs only provide link-local IPv6 addresses on IIH messages.  This is fine for standard IP forwarding, as the address is only used locally as the next hop address for forwarding to the peer.
> 
> When a node builds the Extended IS Reachability TLV, it may include the local and remote IPv6 addresses for the connection to the peer (in the IPv6 Interface Address sub-TLV and IPv6 Neighbor Address sub-TLV).  These IPv6 addresses are visible to remote nodes, and therefore cannot be link-local addresses.
> 
> So if a node is going to build a useful Extended IS Reachability TLV, it needs more than just an IPv6 link-local address from the neighbor - it needs an IPv6 global address too.  The IPv6 Global Interface Address TLV provides a mechanism for getting hold of this information from received IIH messages.
> 
> I hope this clarifies things.
> 
> Thanks,
> Jon
> 
> 
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Hannes Gredler
> Sent: 22 November 2005 15:51
> To: Jonathan Harrison; Jon Berger
> Cc: [email-masked]
> Subject: Re: [Isis-wg] I-D ACTION:draft-ietf-isis-ipv6-te-02.txt
> 
> 
> hi jon & jon,
> 
> i fail to understand the necessity of the
> IPv6 Global Interface Address TLV -
> 
> my train of thought is that TE for v4 is working
> fine without an indication that the neighor
> is TE capable ...
> 
> could you pls explain your rationale behind ?
> 
> /hannes
> 
> ---
> 
> 4.5  IPv6 Global Interface Address TLV
> 
>     The IPv6 Global Interface Address TLV is TLV type 233.  The TLV
>     structure is identical to that of the IPv6 Interface Address TLV
>     defined in [IPv6], but the semantics are different.  In particular,
>     the TLV is included in IIH PDUs for those interfaces using IPv6 TE
>     extensions.  The TLV contains global or site-local IPv6 addresses
>     assigned to the interface that is sending the Hello.
> 
>     The IPv6 Global Interface Address TLV is not used in LSPs.
> 
> ---
> 
> [email-masked] wrote:
> 
>>A New Internet-Draft is available from the on-line Internet-Drafts directories.
>>This draft is a work item of the IS-IS for IP Internets Working Group of the IETF.
>>
>>	Title		: IPv6 Traffic Engineering in IS-IS
>>	Author(s)	: J. Harrison, et al.
>>	Filename	: draft-ietf-isis-ipv6-te-02.txt
>>	Pages		: 10
>>	Date		: 2005-11-16
>>	
>>This document specifies a method for exchanging IPv6 Traffic
>>   Engineering information using the IS-IS routing protocol.  The
>>   described method uses three new TLVs, together with two new sub-TLVs
>>   of the Extended IS Reachability TLV.  The information distributed
>>   allows a CSPF algorithm to calculate traffic engineered routes using
>>   IPv6 addresses.
>>
>>A URL for this Internet-Draft is:
>>http://www.ietf.org/internet-drafts/draft-ietf-isis-ipv6-te-02.txt
>>
>>To remove yourself from the I-D Announcement list, send a message to 
>>[email-masked] with the word unsubscribe in the body of the message.  
>>You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
>>to change your subscription settings.
>>
>>
>>Internet-Drafts are also available by anonymous FTP. Login with the username
>>"anonymous" and a password of your e-mail address. After logging in,
>>type "cd internet-drafts" and then
>>	"get draft-ietf-isis-ipv6-te-02.txt".
>>
>>A list of Internet-Drafts directories can be found in
>>http://www.ietf.org/shadow.html 
>>or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>>
>>
>>Internet-Drafts can also be obtained by e-mail.
>>
>>Send a message to:
>>	[email-masked].
>>In the body type:
>>	"FILE /internet-drafts/draft-ietf-isis-ipv6-te-02.txt".
>>	
>>NOTE:	The mail server at ietf.org can return the document in
>>	MIME-encoded form by using the "mpack" utility.  To use this
>>	feature, insert the command "ENCODING mime" before the "FILE"
>>	command.  To decode the response(s), you will need "munpack" or
>>	a MIME-compliant mail reader.  Different MIME-compliant mail readers
>>	exhibit different behavior, especially when dealing with
>>	"multipart" MIME messages (i.e. documents which have been split
>>	up into multiple messages), so check your local documentation on
>>	how to manipulate these messages.
>>		
>>		
>>Below is the data which will enable a MIME compliant mail reader
>>implementation to automatically retrieve the ASCII version of the
>>Internet-Draft.
>>
>>
>>------------------------------------------------------------------------
>>
>>_______________________________________________
>>Isis-wg mailing list
>>[email-masked]
>>https://www1.ietf.org/mailman/listinfo/isis-wg
> 
> 
> _______________________________________________
> Isis-wg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/isis-wg

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: "Jonathan Harrison" <[email-masked]>
Date: Tue, 22 Nov 2005 16:19:47 -0000

Hannes,

Thanks,
Jon

-----Original Message-----

hi jon & jon,

/hannes

---

---