Subject: RE: [Isis-wg] Question about IS-IS Restart Signaling

From: "Sandip Devnath \(sadevnat\)" <[email-masked]>
Date: Sun, 26 Mar 2006 09:46:25 -0800

Wouldn't it cause whole forwarding to go away? Graceful restart's
requirement is to have the forwarding intact, while routing protocol
restarts (across different cards or same card).

Regards
Sandip 

-----Original Message-----
From: Parker, Jeff [mailto:[email-masked]] 
Sent: Saturday, March 25, 2006 4:40 AM
To: Les Ginsberg (ginsberg); Kandula, Ramesh; [email-masked]
Subject: RE: [Isis-wg] Question about IS-IS Restart Signaling

I would think that losing power in a building and recovering might well
give you several routers rebooting at once.  
 
- jeff parker

________________________________

From: Les Ginsberg (ginsberg) [mailto:[email-masked]]
Sent: Sat 3/25/2006 3:02 AM
To: Kandula, Ramesh; [email-masked]
Subject: RE: [Isis-wg] Question about IS-IS Restart Signaling

Hmmm...an interesting question.

I would have to say that the RFC is not explicit on this point.

>From an interoperability standpoint, I would be concerned that
implementations might not parse past the initial restart TLV and
therefore might not process a second restart TLV. This would not be
fatal as the restarting router would eventually retransmit an IIH-RR
(presumably by this time the other restarting router would have seen its
RA) - but would be suboptimal as it would delay the reestablishment of
the adjacency on the part of the restarting router. On the other hand,
it would provide a means of decreasing the total number of IIH-RAs sent
in response to the IIH-RRs in such a case.

This is, of course, a very unlikely case for two reasons:

1)It is unlikely that two routers would restart "at the same time"
2)As the requirement on sending the IIH-RA is to send it "immediately"
(with jitter on the LAN) the interval between receipt of IIH-RR from two
different routers would need to be quite small.

In the conservative spirit of being "strict in what you send" I would be
inclined to NOT include multiple restart TLVs in the same IIH. I would
recommend sending two IIHs one immediately after the other. Note that
such short bursts are already allowed in the case of LSP/CSNP
transmissions.

   Les

> -----Original Message-----
> From: Kandula, Ramesh [mailto:[email-masked]]
> Sent: Friday, March 24, 2006 11:07 PM
> To: [email-masked]'
> Subject: [Isis-wg] Question about IS-IS Restart Signaling
>
> Hi all,
>
> According to RFC 3847, if multiple routers on a broadcast network
restart
> around the same time, is the helper (receiving) router supposed to
include
> multiple instances of Restart TLVs with RA bit set (one for each
> restarting
> router) in it's hellos?
>
> thanks
> ramesh
>
> _______________________________________________
> Isis-wg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/isis-wg

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: "Parker, Jeff" <[email-masked]>
Date: Sun, 26 Mar 2006 14:27:32 -0500

I don't think this is a case we should alter the design for.
I can imagine a scenario where some routers are on a UPS, and others are not.
 
Again, this is an existence proof that the problem can happen, not something we need to engineer for.
 
- jdp

From: Sandip Devnath (sadevnat) [mailto:[email-masked]]
Sent: Sun 3/26/2006 12:46 PM
To: Parker, Jeff; Les Ginsberg (ginsberg); Kandula, Ramesh; [email-masked]
Subject: RE: [Isis-wg] Question about IS-IS Restart Signaling

Regards
Sandip

-----Original Message-----
From: Parker, Jeff [mailto:[email-masked]]
Sent: Saturday, March 25, 2006 4:40 AM
To: Les Ginsberg (ginsberg); Kandula, Ramesh; [email-masked]
Subject: RE: [Isis-wg] Question about IS-IS Restart Signaling

- jeff parker

   Les

restart
include