Subject: [Isis-wg] IP static routes

From: Paolo Puricelli <[email-masked]>
Date: Fri, 20 Apr 2007 14:05:27 +0200

Hello,

I have some questions about the distribution of IP static routes in the 
Intra Area (Level 1)
routing (see also References: <[email-masked]>).

How should be the IP static routes considered ?
As IP external routes ? or as some kind IP MESAs ?

If the Intermediate system is a Level 1 only, it should propagate the IP 
static routes in
its level 1 LSPs ? If yes, where this kind of information has to be 
placed ?
Into the External Reachability TLV field (as an extension of the 
original RFC1195) ?
or in the Internal Reachability TLV field (in the case we consider them 
as "IP MESAs") ?

If the Intermediate system is both Level 1 and Level 2, it should 
propagate the IP static
routes in its level 1 LSPs in its level 2 LSPs or in both (with up/down 
bit mechanism) ?
Again, where this kind of information has to be placed ?

Thank you in advance for your precious help

Paolo Puricelli
---------------------
Alcatel-Lucent, Italy

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Hannes Gredler <[email-masked]>
Date: Mon, 23 Apr 2007 17:17:59 +0200

> As IP external routes ? or as some kind IP MESAs ?

if local policy dictates injection of certain IPv4 routes
then most implementations inject it either using TLV130 and/or TLV135.

> or in the Internal Reachability TLV field (in the case we consider them 

see rfc2966 for details.

> Again, where this kind of information has to be placed ?

this is a matter of your local policy:
   can be L1 or L2 or both.

/hannes