Subject: Re: [Isis-wg] Context for IS-IS HMAC SHS

From: "Vishwas Manral" <[email-masked]>
Date: Tue, 17 Apr 2007 07:48:16 +0530

Hi Ran,

It is not in anyway inventing a new algorithm. We ahve forwarded you
mails from multiple cryptographers multiple times, who have clearly
said that there is no rational behind using a different constant
random number.

Yet you insist there is somebody there who has talked to you. Can you
please CC them on this thread, so that we can figure out why they used
a particular random number?

Thanks,
Vishwas

RJ Atkinson wrote:
>
> On  16 Apr 2007, at 20:01, Jack Kohn wrote:
>> Did the possibility of them being bent towards that particular
>> "mathematics" cross your mind? I would not trust my life with what
>> people, where ever they work, suggest and advise me, unless i see a
>> proof ..
>
> In one feels that way, then one might want to invent one's own
> algorithms for one's own use, since in the past some accepted
> mathematical "proofs" have turned out to be wrong -- and one
> might have the most confidence in one's own self.
>
> As noted before, there are viable active attacks on IS-IS
> that work fine without the attacker even worrying about
> attacking the mathematics.  The only thing HMAC MD5 or NIST
> SHS can do for IS-IS is prevent the really trivial "cleartext
> password sniffing" types of passive attacks.
>
> Besides, there are also other one-way hash functions
> (i.e. beyond MD5 and NIST SHS) that someone might use.
> If users wanted to use those additional algorithms,
> then one might imagine writing up an additional document
> on how to use those (e.g. RIPE-MD) with IS-IS.
>
> Yours,
>
> Ran

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: "Vishwas Manral" <[email-masked]>
Date: Tue, 17 Apr 2007 07:52:51 +0530

Hi Ran,

The list of people includes Hugo Krawczyk who is among the ones who
did the construction and analysis of HMAC.

Thanks,
Vishwas

On 4/17/07, Vishwas Manral <[email-masked]> wrote:
> >> people, where ever they work, suggest and adviFrom [email-masked] Tue Apr 17 20:19:39 2007
Date: Tue, 17 Apr 2007 07:48:16 +0530
From: "Vishwas Manral" <[email-masked]>
To: [email-masked]
Subject: Re: [Isis-wg] Context for IS-IS HMAC SHS

Hi Ran,

Thanks,
Vishwas

RJ Atkinson wrote:
> If users wanted to use thosese me, unless i see a
> >> proof ..
> >

 additional algorithms,

---

From: "Vishwas Manral" <[email-masked]>
Date: Tue, 17 Apr 2007 07:52:51 +0530

Hi Ran,

Thanks,
Vishwas