Subject: [Isis-wg] Pseudonode reduction

From: "Thomas, Matthew R" <[email-masked]>
Date: Wed, 12 Mar 2008 13:33:51 -0000

Hi Les,

Sorry for the late response. We were going down a repetitive path for a moment there. We can talk offline, but there is little to say as we simply just differ on how we view the issue. I understand your perspective though for sure.

Anyway.. I think that we all agree that we have more processing power becoming available. I personally believe that we really do have quite a bucket of 'performance' to spend here, but "How do we spend that power?" Frittering it away doesn't seem like a particularly frugal thing to do. We may need it in the future. How we spend it will result in how scalable we become in time.  I certainly am concerned about reducing 50% increases of course! however small they may appear from a distance. I have learned that issues can get larger when they approach.

Our proposal is really a VERY small but important one. It simply gives IS-IS the chance to remove the effect of Pseudonodes if it requires it. 

The 'manual version' is a great solution also (P2P over IGP), but it requires configuration. Also it is absolutely NOT suitable for TRILL because you begin migration with a multitude of bridges and manually configuring them into new pairs?

IS-IS would be in a stronger position to be able to be applied to new link state requirements?? As an aside another small upside to this draft would be some clarification on the ability? to place TLV's in IS-IS hellos. This could perhaps be useful for other protocols that may follow, but lets try not to discuss 'n' in a valuable timeslot if it can be avoided??..

MT
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/isis-wg

---

From: stefano previdi <[email-masked]>
Date: Wed, 12 Mar 2008 14:41:11 +0100

> From: "Thomas, Matthew R" <[email-masked]>
> 
> Hi Les,
> 
> Sorry for the late response. We were going down a repetitive path for a moment
> there. We can talk offline, but there is little to say as we simply just
> differ on how we view the issue. I understand your perspective though for
> sure.
> 
> Anyway.. I think that we all agree that we have more processing power becoming
> available. I personally believe that we really do have quite a bucket of
> 'performance' to spend here, but "How do we spend that power?" Frittering it
> away doesn't seem like a particularly frugal thing to do. We may need it in
> the future. How we spend it will result in how scalable we become in time.  I
> certainly am concerned about reducing 50% increases of course! however small
> they may appear from a distance. I have learned that issues can get larger
> when they approach.
> 
> Our proposal is really a VERY small but important one. It simply gives IS-IS
> the chance to remove the effect of Pseudonodes if it requires it.

it would be interesting to see some numbers/measurements illustrating what
you state as "pseudonode effect" in real topologies.

s.

> The 'manual version' is a great solution also (P2P over IGP), but it requires
> configuration. Also it is absolutely NOT suitable for TRILL because you begin
> migration with a multitude of bridges and manually configuring them into new
> pairs?
> 
> IS-IS would be in a stronger position to be able to be applied to new link
> state requirements?? As an aside another small upside to this draft would be
> some clarification on the ability? to place TLV's in IS-IS hellos. This could
> perhaps be useful for other protocols that may follow, but lets try not to
> discuss 'n' in a valuable timeslot if it can be avoided??..
> 
>  
> 
> MT

---

From: "Thomas, Matthew R" <[email-masked]>
Date: Wed, 12 Mar 2008 13:50:58 -0000

Absolutely Stefano,
 
I am will contact ofline, I would appreciate your views especially
 
MT

________________________________

From: stefano previdi [mailto:[email-masked]]
Sent: Wed 12/03/2008 13:41
To: Thomas, Matthew R; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [Isis-wg] Pseudonode reduction

s.

---

From: "Thomas, Matthew R" <[email-masked]>
Date: Thu, 20 Mar 2008 10:36:28 -0000

Hi Hannes,

Yes currently section 4.5 doesn't really seem to prevent a pair of P2P routers establishing adjacency parallel to an adjacent pair of LAN routers? They would then discard discordant packets and advertise the same network in two places in the graph.

The problem is that we may end up correcting the error scoping of this document but never quite achieve our goal :o)

Matthew

From: Hannes Gredler [mailto:[email-masked]]
Sent: Wed 19/03/2008 22:54
To: Thomas, Matthew R
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Isis-wg] Pseudonode avoidance

| Our proposal is really a VERY small but important one.
| It simply gives IS-IS the chance to remove the effect
| of Pseudonodes if it requires it.
|   
| The 'manual version' is a great solution also (P2P over IGP),
| but it requires configuration. Also it is absolutely NOT suitable for
| TRILL because you begin migration with a multitude of bridges and manually
| configuring them into new pairs?

hi thomas,

i am not entirely convinced that you need protocol extensions for what
you are after.

what about if a TRILL speaker:

1. would start by default in p2p mode, and
2. once it discovers that there is more than one neighbor on the LAN,
   teardown the p2p adjacency and restart and stay in lan mode.

perhaps some rewording/clarification of draft-ietf-isis-igp-p2p-over-lan-06
section 4.5 needs to be done(read: do not blindly discard LAN IIHs when
in p2p mode, but restart the adjacency in LAN mode after receiving N * IIHs
from different neighbors (i mean different than the one you already have an
adjacency with), but in principle the above should work.

to make the state machinery not too complex, a TRILL speaker must stay
in LAN mode (after a p2p -> lan transition) until manually cleared.

that way you automatically save PSN-IDs b/c yo only allocate one where
it really is needed.

/hannes