Subject: [Isis-wg] Clarification Needed on Section 2.2.2 of draft-ietf-isis-layer2-02.txt

From: Kuntal <[email-masked]>
Date: Thu, 25 Feb 2010 14:48:57 +0530

Hi,

I have seen in draft-ietf-isis-layer2-02.txt that the format of Group MAC
address sub-TLV and Group IPv6 address sub-TLV contain the following format
at the beginning of the respective sub-TLV:

Type: 1 byte
Length: 1 byte
Topology-Id/Nickname-id: 2 bytes
Confidence: 1 byte
Rest of the Sub-TLV

On the other hand Group IP sub-TLV as described in section 2.2.2 of this
drafts shows the following format at the beginning of the respective
sub-TLV:

 Type: 1 byte
Length: 1 byte
Confidence: 1 byte
Topology-Id/Nickname-id: 2 bytes
Rest of the Sub-TLV

What would be the actual encoding format for Group Address's sub-TLV?

Regards,
Kuntal

---

From: Ayan Banerjee <[email-masked]>
Date: Thu, 25 Feb 2010 01:33:44 -0800

Kuntal,

This was a typo, we will fix this up in the next rev of the draft, all of
them should have the format.
          Type: 1 byte
          Rest of the Sub-TLV

Thanks,
Ayan

On 2/25/10 1:18 AM, "Kuntal" <[email-masked]> wrote:

> address sub-TLV and Group IPv6 address sub-TLV contain the following format at
> the beginning of the respective sub-TLV:
>  
> Type: 1 byte
> Length: 1 byte
> drafts shows the following format at the beginning of the respective sub-TLV:
>  
> Type: 1 byte
> Length: 1 byte
> Confidence: 1 byte
> _______________________________________________
> Isis-wg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/isis-wg