Subject: Re: [Isis-wg] Clarification Needed on Section 2.2.2 of draft-ietf-isis-layer2-02.txt

From: Donald Eastlake <[email-masked]>
Date: Wed, 3 Mar 2010 11:00:08 -0500

In this and other sub-TLVs the contents of the
"Topology-Id/Nickname-id" field is presumably either a topology,
represented by a topology-id, or an RBridge or distribution tree,
represented by a nickname. "nickname-id" should be globally replaced
by "nickname" in this document.

Thanks,
Donald

On Thu, Feb 25, 2010 at 4:33 AM, Ayan Banerjee <[email-masked]> wrote:
> Kuntal,
>
> This was a typo, we will fix this up in the next rev of the draft, all of
> them should have the format.
>           Type: 1 byte
>
> Length: 1 byte
> Topology-Id/Nickname-id: 2 bytes
> Confidence: 1 byte
>
>          Rest of the Sub-TLV
>
> Thanks,
> Ayan
>
>
>
> On 2/25/10 1:18 AM, "Kuntal" <[email-masked]> wrote:
>
> Hi,
>
> I have seen in draft-ietf-isis-layer2-02.txt that the format of Group MAC
> address sub-TLV and Group IPv6 address sub-TLV contain the following format
> at the beginning of the respective sub-TLV:
>
> Type: 1 byte
> Length: 1 byte
> Topology-Id/Nickname-id: 2 bytes
> Confidence: 1 byte
> Rest of the Sub-TLV
>
> On the other hand Group IP sub-TLV as described in section 2.2.2 of this
> drafts shows the following format at the beginning of the respective
> sub-TLV:
>
> Type: 1 byte
> Length: 1 byte
> Confidence: 1 byte
> Topology-Id/Nickname-id: 2 bytes
> Rest of the Sub-TLV
>
> What would be the actual encoding format for Group Address's sub-TLV?
>
>
> Regards,
> Kuntal
>
> ________________________________
> _______________________________________________
> Isis-wg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/isis-wg
>

---

From: Ayan Banerjee <[email-masked]>
Date: Wed, 03 Mar 2010 13:16:03 -0800

Donald,

The next version will have the change.

Thanks,
Ayan