Subject: [Isis-wg] draft-wei-isis-tlv-03 (Purge Originator Id)

From: <[email-masked]>
Date: Tue, 20 Apr 2010 10:56:14 +0200

Hi Fang, Yue, Zhenqiang, Tony, Jie, all,

As the goal is to help the troubleshooting, and specifically to locate the source IS, what about also adding the dynamic hostname of the purge originator in addition to the system ID? (cf existing TLV type 137)

Thanks,
Regards,
Bruno

---

From: Jie Dong <[email-masked]>
Date: Tue, 20 Apr 2010 17:57:56 +0800

Hi Bruno and all,

Hostname would be helpful for network management and operation, thus rfc5301
defined the mechanism of dynamic hostname exchange. 

On the other hand, if ISs already have the mapping from System ID to
hostname, IMO it may be optional for purge packet to carry this information.

Best regards,
Jie

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of 
> [email-masked]
> Sent: Tuesday, April 20, 2010 4:56 PM
> To: [email-masked]; [email-masked]; 
> [email-masked]
> Subject: [Isis-wg] draft-wei-isis-tlv-03 (Purge Originator Id)
> 
> As the goal is to help the troubleshooting, and specifically 
> to locate the source IS, what about also adding the dynamic 
> hostname of the purge originator in addition to the system 
> ID? (cf existing TLV type 137)
> 
> Thanks,
> Regards,
> Bruno
> 
> _______________________________________________
> Isis-wg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/isis-wg

---

From: <[email-masked]>
Date: Tue, 20 Apr 2010 12:25:40 +0200

Hi Zhenqiang,

> Basiclly, I think this makes sense. I just want to know whether hostname
> is widely used in the field network to identify IS,

As far as we are concerned, yes this is widely implemented and used. 

> and the impact on implementation.
> Comments from other operators and verdors are welcome.

Thanks,
Best regards,
Bruno
 
> Best Regards,
> ________________________________
> 
> Zhenqiang Li
> 13911635816
> Department of Network Technology
> China Mobile Research Institute
> 2010-04-20
> ________________________________
> 
> 发件人： [email-masked]
> 发送时间： 2010-04-20 17:08:29
> 收件人： [email-masked]; [email-masked];
> [email-masked]
> 抄送：
> 主题： draft-wei-isis-tlv-03 (Purge Originator Id)
> 
> As the goal is to help the troubleshooting, and specifically to locate the
> source IS, what about also adding the dynamic hostname of the purge
> originator in addition to the system ID? (cf existing TLV type 137)
> 
> Thanks,
> Regards,
> Bruno

---

From: <[email-masked]>
Date: Tue, 20 Apr 2010 12:18:13 +0200

Hi Jie, all

> Hostname would be helpful for network management and operation, thus
> rfc5301 defined the mechanism of dynamic hostname exchange.
>  

Some monitoring systems passively record ISIS messages. Indeed, they
could record the System ID - hostname mapping from previous LSP, then
use this database to enhance the purge originator info. But it seems it
would be easier for them to have the name embedded in the purge message.
Not to mention for tools such as wireshark (and most probably for logs
and debugging tools)

Obviously, the decision to add the hostname is up to you and the WG.
IMHO, I see benefits (at least the above) and fail to see any cost. Do
you see any drawback?

Best regards,
Bruno

---

From: Jie Dong <[email-masked]>
Date: Wed, 21 Apr 2010 09:44:04 +0800

Hi Bruno, all

I have no objections if there are some benefits of adding the hostname. 

Best regards,
Jie

> From: [email-masked] 
> [mailto:[email-masked]] 
> Sent: Tuesday, April 20, 2010 6:18 PM
> To: [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]
> Subject: RE: [Isis-wg] draft-wei-isis-tlv-03 (Purge Originator Id)
> 
> Hi Jie, all
> 
> Some monitoring systems passively record ISIS messages. 
> Indeed, they could record the System ID - hostname mapping 
> from previous LSP, then use this database to enhance the 
> purge originator info. But it seems it would be easier for 
> them to have the name embedded in the purge message.
> Not to mention for tools such as wireshark (and most probably 
> for logs and debugging tools)
> 
> IMHO, I see benefits (at least the above) and fail to see any 
> cost. Do you see any drawback?
> 
> Best regards,
> Bruno 
>  
> > 
> > Best regards,
> > Jie
> > 
> > 
> > > As the goal is to help the troubleshooting, and specifically to 
> > > locate the source IS, what about also adding the dynamic 
> hostname of 
> > > the purge originator in addition to the system ID? (cf 
> existing TLV 
> > > type 137)
> > >
> > > Thanks,
> > > Regards,
> > > Bruno
> > >

---

From: Tony Li <[email-masked]>
Date: Wed, 21 Apr 2010 14:20:05 -0700

It sounds like there is general agreement that this would be useful.

I'll volunteer to make the document changes if someone would be so kind as
to send me the current XML source.

Thanks,
Tony