Subject: Re: [Isis-wg] IETF-77 isis-wg meeting minutes posted. (Christian Hopps)

From: [email-masked]
Date: Tue, 6 Apr 2010 12:09:55 +0800

Thanks Chris & Dave,

For draft-li-isis-error-lsp-processing-03, I think it's better to mention following point in the minute.
Generating correct chesksum for all kinds of LSPs including zero remaining lifetime LSP is helpful to increase the IS's compatibility.

Best Regards,
--------------------------------------------------------------------------------

Zhenqiang Li
13911635816
Department of Network Technology
China Mobile Research Institute
2010-04-06

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Mon, 5 Apr 2010 22:05:02 -0700

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of [email-masked]
> Sent: Monday, April 05, 2010 9:10 PM
> To: [email-masked]
> Subject: Re: [Isis-wg] IETF-77 isis-wg meeting minutes posted.
> (ChristianHopps)
> 
> 
> Thanks Chris & Dave,
> 
> Generating correct chesksum for all kinds of LSPs including zero
> remaining lifetime LSP is helpful to increase the IS's compatibility.

This point was made in the presentation - which itself is available
online. The contents of the presentations are therefore not intended to
be captured in the minutes - but rather the minutes are intended to
capture what was said during the meeting in the discussion of the
presentations.

Responding to your statement as a continuation of your argument in favor
of the draft, I do not agree with this point. What is needed to
"increase compatibility" is for all implementations to follow the
existing normative statements in the specification - not to invent some
new normative behavior - which requiring checksum calculation on a zero
remaining lifetime LSP would be. This is the substance of a number of
responses made during the meeting i.e. the only change necessary is for
the implementations which are non-conformant to be fixed.

   Les

> Best Regards,
-----------------------------------------------------------------------
> ---------
> _______________________________________________
> Isis-wg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/isis-wg

---

From: Jie Dong <[email-masked]>
Date: Tue, 06 Apr 2010 14:37:33 +0800

Hi Les,

IMO, the intention of this draft is to recommend routers to be strict on
what they advertise and be generous on what they receive, and in this way
the network can be more interoperable and fault-tolerant.

I agree that non-conformant implementations should be fixed as long as they
are found out, but making correct implementations more robust may also be
helpful to operators and their network.

Best regards,
Jie

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Les Ginsberg (ginsberg)
> Sent: Tuesday, April 06, 2010 1:05 PM
> To: [email-masked]; [email-masked]
> Subject: Re: [Isis-wg] IETF-77 isis-wg meeting minutes 
> posted. (ChristianHopps)
> 
> This point was made in the presentation - which itself is 
> available online. The contents of the presentations are 
> therefore not intended to be captured in the minutes - but 
> rather the minutes are intended to capture what was said 
> during the meeting in the discussion of the presentations.
> 
> Responding to your statement as a continuation of your 
> argument in favor of the draft, I do not agree with this 
> point. What is needed to "increase compatibility" is for all 
> implementations to follow the existing normative statements 
> in the specification - not to invent some new normative 
> behavior - which requiring checksum calculation on a zero 
> remaining lifetime LSP would be. This is the substance of a 
> number of responses made during the meeting i.e. the only 
> change necessary is for the implementations which are 
> non-conformant to be fixed.
> 
>    Les
> 
> > 
> > Best Regards,
> >