Subject: [Isis-wg] Suggested Path forward for Layer2-isis

From: David Ward <[email-masked]>
Date: Wed, 12 May 2010 18:54:01 -0700

All -

Chris and I have chatted and we believe it is time to split up the layer2-isis document. It's clear that there is significant non-overlap between 802.1aq extensions, TRILL and OTV.  We propose that not only do we split the three technologies but, following the advice of the ADs create a fourth doc that is the "glue" doc and one that contains the "overlapping" TLVs and some significant normative text. Each technology doc will also need corresponding normative text to describe how the TLVs, subTLVs and PDUs (as appropriate) are used and impact on the protocol state machinery, adjacency formation, etc.  The suggested split is described along the definition of the TLVs, PDUs in the existing -05 version of the draft.  Three docs will automatically become WG documents: IEEE 802.1aq extesions, TRILL extensions and the Common doc. OTV extensions will become an individual submission and may be brought to the ISIS WG for acceptance pending clarification of OTV technology standardization at the IETF. Also there has been recent discussion of collapsing or eliminating PDUs from the TRILL portion of the specification. We'll work through those items independently. Each technology is not dependent on the other(s) for standardization or progression.

Doc 1: Baseline document – will be an introduction document for carrying L2 TLVs and will have all TLVs and PDUs that are common to at least *two* IETF/WG approved technologies. 
Doc 2: IEEE technology scoped document – TLVs that are marked “I” in the table.
Doc 3: TRILL technology scoped document – TLVs that are marked “T” in the table. 
Doc 4: OTV technology scoped document – TLVs that are marked “O” in the table. 

Based on the above and the current –05 version, we expect the following TLVs and PDUs in the various documents. The normative text would explicitly describe where/how the TLVs/PDUs are used. It would be a normative spec for all the technologies.

Doc1 (Common): 
MAC-RI TLV                                  (141) 
MT-Port-Cap-TLV                        (143) 

Doc2 (IEEE): 
PortCap.BaseVLANID                  sub-TLV   5 
PortCap.SPBDigest                      sub-TLV   6 
MT-Capability-TLV                        (144)   
MT-Cap.SPB Instance                  sub-TLV  1 
MT-Cap.Opaque Algorithm         sub-TLV  2  
MT-Cap.Service Id.                       sub-TLV  3 
MT-Cap.SPBV-MAC-ADDR        sub-TLV  4
EXT-IS.SPB Link Metric               sub-TLV  5 
MT-EXT-IS.SPB LinkMetric         sub-TLV  5

Doc 3 (TRILL): 
PortCap.VLAN and Flags            sub-TLV  1  
PortCap.Enabled-VLANs            sub-TLV  2  
PortCap.AppointedFwrdrs          sub-TLV  3  
PortCap.HBHOPT                         sub-TLV  4
CAPABILITY.Trill-Version            sub-TLV  5
CAPABILITY.Nickname               sub-TLV  6   
CAPABILITY.Tree                         sub-TLV  7   
CAPABILITY.Tree Id                     sub-TLV  8  
CAPABILITY.TreeUseRootId      sub-TLV  9 
CAPABILITY.Int-VLANs               sub-TLV 10  
CAPABILITY.VLAN-Groups        sub-TLV 11  
CAPABILITY.ITEOPT                   sub-TLV 12  
CAPABILITY.VMAP                      sub-TLV 13
TRILL-Nieghbor TLV                    (145)    
EXT-IS.MTU                                   sub-TLV  6
GADDR-TLV                                  (142)  
GADDR-TLV.GMAC-ADDR        sub-TLV  1 
GADDR-TLV.GMAC-IP                sub-TLV  2 
GADDR-TLV.GMAC-IPV6           sub-TLV  3 
TRILL-HELLO 		                PDU
MTU 			                        PDU  
MGroup 			                        PDU
MGROUP-CSNP 	                        PDU
MGRUP-PSNP 		                PDU
NOTE: If the TRILL folks decide NOT to use the MGROUP related PDUs, they would move to the OTV document. 

Doc 4(OTV): 
PortCap.SiteIdentifier                   sub-TLV 250  
PortCap.SiteGroupIP                   sub-TLV 251  
PortCap.SiteGroupIPv6               sub-TLV 252 
PortCap.AdjServerIP                    sub-TLV 253 
PortCap.AdjServerIPv6               sub-TLV 254
Group Mem Active Source TLV (146)  
GMAS-TLV.GMAS-MAC             sub-TLV  1   
GMAS-TLV.GMAS-IP                  sub-TLV  2  
GMAS-TLV.GMAS-IPV6             sub-TLV  3

Also, we'll need agreement on authorship of the four drafts. Here is the suggestion:

802.1.aq = Don, Peter
TRILL = Donald, Dino, Radia, Russ, DWard
OTV = Ayan, others?
Arch = Ayan, DWard

Please flame, comment, ask questions, etc.  We'll still follow the process for a thorough review and implementation/interoperability report for each of the technologies but, now they will progress independently.

Thanks

-DWard, CHopps

---

From: David Ward <[email-masked]>
Date: Thu, 20 May 2010 11:09:37 -0700

All -

We will go forward with the split. The WG will be discussing and progressing the base, TRILL and IEEE drafts independently. 

Thanks

-DWard, CHopps