Subject: [Isis-wg] Fwd: Re: Last Call: draft-ietf-isis-bfd-tlv (IS-IS BFD EnabledTLV) to Proposed Standard

From: Stewart Bryant <[email-masked]>
Date: Fri, 03 Sep 2010 20:19:00 +0100

This LC comment only appeared on the main IETF list

Please will the authors address this issue

-------- Original Message --------
Subject: 	Re: [Isis-wg] Last Call: draft-ietf-isis-bfd-tlv (IS-IS BFD
EnabledTLV) to Proposed Standard
Date: 	Mon, 26 Jul 2010 17:04:40 +0800
From: 	lan7801 <[email-masked]>
To: 	ietf <[email-masked]>
CC: 	iesg <[email-masked]>

Hi,
I have some comments about this draft.
section 3.2. Adjacency Establishment and Maintenance

    Whenever ISIS_BFD_REQUIRED is TRUE the following extensions to the
    rules for adjacency establishment and maintenance MUST apply:
    o ISIS_NEIGHBOR_USEABLE MUST be TRUE before the adjacency can
    transition from INIT to UP state

This rule assumes that both the BFD and IS-IS configurations are correct
and they work well. But This isn't the way all
the time.
AS we know that the establishment of the BFD session is bootstraped by
IS-IS,If the BFD enabled interface have two or
more address, which address should be used to create the BFD session ?
If the two addresses of the BFD session are not on
the same subnet,the BFD session will fail ,and the IS-IS adjacency can
never be ceated.That is a risk.
Cisco router encodes the primary ip address of the inteface in IS-IS
hello's ip interface address(es) TLV, however,Juniper
router encodes all addresses of the interface in ip interface
address(es) TLV,How about the other router ?
To resove this problem,this draft should specify which address should be
used .The choosed address may be included in the
BFD enabled TLV.
To avoid confusion,it is better to specify that the IS-IS must triggere
BFD session establishment before the adjacency is in UP state.
There is another scenario we must consider. When the state of IS-IS
adjacency is UP and the administrator trys to configure BFD or modify
BFD configuration, IS-IS should discard the first BFD session failure
,IS-IS can trust BFD session state only after
BFD session has informed IS-IS a BFD session success.
------------------------------------------------------------------------
Jiaxing Lan
2010-07-25
------------------------------------------------------------------------
*发件人：* The IESG
*发送时间：* 2010-07-13 02:42:14
*收件人：* IETF-Announce
*抄送：* isis-wg
*主题：* [Isis-wg] Last Call: draft-ietf-isis-bfd-tlv (IS-IS BFD
EnabledTLV) to Proposed Standard
The IESG has received a request from the IS-IS for IP Internets WG (isis)
to consider the following document:
- 'IS-IS BFD Enabled TLV '
<draft-ietf-isis-bfd-tlv-02.txt> as a Proposed Standard
The IESG plans to make a decision in the next few weeks, and solicits
final comments on this action. Please send substantive comments to the
[email-masked] mailing lists by 2010-07-26. Exceptionally,
comments may be sent to [email-masked] instead. In either case, please
retain the beginning of the Subject line to allow automated sorting.
The file can be obtained via
http://www.ietf.org/internet-drafts/draft-ietf-isis-bfd-tlv-02.txt
IESG discussion can be tracked via
https://datatracker.ietf.org/public/pidtracker.cgi?command=view_id&dTag=17118&rfc_flag=0
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/isis-wg

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Wed, 22 Sep 2010 09:51:09 -0700

(Stewart - thanx for calling this to our attention)

Jiaxing -

Sorry for the delayed response, but as you did not copy the IS-IS WG your post was not seen.
Responses inline.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Stewart Bryant (stbryant)
> Sent: Friday, September 03, 2010 12:19 PM
> To: isis-wg
> Subject: [Isis-wg] Fwd: Re: Last Call: draft-ietf-isis-bfd-tlv (IS-IS
> BFD EnabledTLV) to Proposed Standard
> 
> From: 	lan7801 <[email-masked]> <mailto:[email-masked]>
> 
> To: 	ietf <[email-masked]> <mailto:[email-masked]>
> CC: 	iesg <[email-masked]> <mailto:[email-masked]>
> 
> 
> Hi,
>    This rule assumes that both the BFD and IS-IS configurations are
> correct and they  work well.  But This isn't  the way all
> the time.
>    AS we know that the establishment  of the BFD session is bootstraped
> by IS-IS,If the BFD enabled interface have two or
>  To resove this problem,this draft should specify which address should
> be used .The choosed address may be included in the
> BFD enabled TLV.

I am reluctant to add this option to the TLV. Local configuration is required to specify which IP address should be used in cases where multiple addresses are configured on the interface. If there is a mismatch between what is configured on two neighbors then having the advertisement will not help us insure that matching subnets are used - so it seems that we have not made life any easier/better by adding this information in the TLV.

>  To avoid confusion,it is better to specify that the IS-IS must
> triggere BFD session establishment before the adjacency is in UP state.
>

The point of the draft is to REQUIRE that the BFD session be UP before the IS-IS adjacency transitions to UP - but only when it is known that BFD is enabled on both neighbors. This avoids failure to bring up an adjacency simply because of mismatched configurations (i.e. one IS has BFD support and the other does not).
 
>  BFD session has informed IS-IS a BFD session success.

This point is addressed in Section 4 of the draft.

   Les

> 
> 
> 
> 
> 
> ________________________________
> 
> Jiaxing Lan
> 2010-07-25
> ________________________________
> 
> 发件人： The IESG
> 发送时间： 2010-07-13 02:42:14
> 收件人： IETF-Announce
> 抄送： isis-wg
> 主题： [Isis-wg] Last Call: draft-ietf-isis-bfd-tlv (IS-IS BFD