Subject: Re: [Isis-wg] WG LC draft-ietf-isis-purge-tlv-03.txt

From: Tony Li <[email-masked]>
Date: Wed, 1 Sep 2010 20:41:06 -0700

Hi all,

Thanks everyone for your comments on this draft.  This sparked a great deal of discussion and refinement.  I've submitted draft-isis-purge-tlv-04.txt and draft-li-reg-purge-01.txt to reflect all of those comments.

Links:
http://www.ietf.org/internet-drafts/draft-ietf-isis-purge-tlv-04.txt
http://www.ietf.org/internet-drafts/draft-li-reg-purge-01.txt

Any further clarifications, questions or comments?

Thanks,
Tony

On Aug 12, 2010, at 9:00 AM, David Ward wrote:

> Dear WG -
> 
> 	We'd like to start a WG LC on this draft:
> 
> http://www.ietf.org/id/draft-ietf-isis-purge-tlv-03.txt
> 
> Please reply to the WG list and authors with any clarifications, questions or comments. The comment period will end 2010.08.27 at 1700 PDT.
> 
> Thanks
> 
> -DWard, CHopps

---

From: Tony Li <[email-masked]>
Date: Wed, 15 Sep 2010 19:23:26 -0700

Hi all,

It's been two weeks and I've received no comments.  

I'd like to request a) that we do a(nother) WG last call on draft-ietf-isis-purge-tlv-04 and b) that we accept draft-li-reg-purge-01 as a WG document.

Thanks all,
Tony

On Sep 1, 2010, at 8:41 PM, Tony Li wrote:

> _______________________________________________
> Isis-wg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/isis-wg

---

From: Shane Amante <[email-masked]>
Date: Wed, 15 Sep 2010 22:12:38 -0600

Tony,

> I'd like to request a) that we do a(nother) WG last call on draft-ietf-isis-purge-tlv-04 and b) that we accept draft-li-reg-purge-01 as a WG document.

Apologies for not responding earlier.

Re: draft-ietf-isis-purge-tlv-03
1)  I support this document proceeding to publication as an RFC; however, I have a few questions/clarifications that might be helpful to explain or clear up prior to that.
2)  In Section 4, it is mentioned that the Dynamic Hostname TLV can be included in purges.  When an IS is inserting two System ID's into the Purge TLV (first, of the IS that inserted the Purge TLV and, second, of the IS that the purge was received from), presumably the Dynamic Hostname TLV would only include the former (the IS that inserted the Purge TLV), correct?  Or, is it permitted for this IS that's inserting two System ID's to insert two Dynamic Hostname TLV's, (assuming the Dynamic Hostname of the IS that purge was first recv'd from was available)?
3)  In Section 5, there appears to be a placeholder in there that says "NEW TEXT:".  Should those two words be stricken?
4)  In Section 6, why is there an RFC Editor Note to remove this section?  Shouldn't this section stay "as is"?

Re: draft-li-reg-purge-01
1)  I support adoption of this doc as a WG doc.
2)  draft-ietf-isis-purge-tlv states that it's acceptable for the Dynamic Hostname TLV to be included in Purges.  Thus, shouldn't draft-li-reg-purge specify, in IANA Considerations, that the Purge Column should be augmented to also include TLV 137, "Dynamic Name"?  Or, perhaps it would be cleaner if in the IANA Considerations of draft-ietf-isis-purge-tlv stated that TLV 137 also have the Purge column say "y", since Dynamic Hostname TLV is mentioned in this draft and isn't talked about at all in draft-li-reg-purge?

Thanks,

-shane

---

From: Tony Li <[email-masked]>
Date: Thu, 16 Sep 2010 09:04:05 -0700

Hi Shane,

Thanks for your comments.

> 2)  In Section 4, it is mentioned that the Dynamic Hostname TLV can be included in purges.  When an IS is inserting two System ID's into the Purge TLV (first, of the IS that inserted the Purge TLV…

The intent was that it was only the local hostname that would be inserted.  I'll add some clarifying text.

> 3)  In Section 5, there appears to be a placeholder in there that says "NEW TEXT:".  Should those two words be stricken?

<blush>  Whoops.  Yes, text processing error on my part.  </blush>

> 4)  In Section 6, why is there an RFC Editor Note to remove this section?  Shouldn't this section stay "as is"?

My understanding is that IANA requests are supposed to be removed.  If I'm out of sync here, I'm happy for it to stay.

> 2)  draft-ietf-isis-purge-tlv states that it's acceptable for the Dynamic Hostname TLV to be included in Purges.  Thus, shouldn't draft-li-reg-purge specify, in IANA Considerations, that the Purge…

?

Section 4, para 2:
   The 'Purge' column should initially contain a 'y' for TLV type 10
   (Authentication) and for TLV type 137 (Dynamic hostname).  All other
   entries in this column should have an 'n'.  Other additions to this
   registry should explicitly specify their value for this column.

Tony

---

From: Shane Amante <[email-masked]>
Date: Thu, 16 Sep 2010 19:44:02 -0600

Hi Tony,

> The intent was that it was only the local hostname that would be inserted.  I'll add some clarifying text.

Sounds good.

[--snip--]

> My understanding is that IANA requests are supposed to be removed.  If I'm out of sync here, I'm happy for it to stay.

By way of precedent I could cite a small handful of (random) IS-IS RFC's with IANA Considerations:
http://tools.ietf.org/html/rfc5305#section-5
http://tools.ietf.org/html/rfc5310#section-6
http://tools.ietf.org/html/rfc5304#section-4
http://tools.ietf.org/html/rfc5308
... thus, I'd recommend it stays in.  However, I'll defer to the co-chairs judgement if you're still unsure/uncomfortable.

>   registry should explicitly specify their value for this column.

My turn to blush.  Looks good.  :-)

-shane