Subject: Re: [Isis-wg] operational problem might be solved by somehowextending current IS-IS

From: [email-masked]
Date: Mon, 20 Sep 2010 20:03:26 +0200

> 
> 
> That's not yet clear to me.  If an IS doesn't support the reverse metric TLV, then it will compute different SPF results than an IS that does.  That seems like it is guaranteed to create forwarding loops.
> 
> Please feel free to convince me otherwise.  Mathematical proofs preferred.  ;-)
> 
> Tony
> 
> 
> 
> 
> _______________________________________________
> Isis-wg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/isis-wg

I dont really see it will create loops in the LAN case, at most the traffic will continue to hit the node who requested reverse metric if there are some node do not execute the SPF "correctly" , meaning ignores non-zero metric. The former 
should still have a route if it is connected to the network using other links. In any cases i assume the DIS will advertise the SAME metric the requesting node have asked for in both directions.

Guan

---

From: "Chen, Jay (Jay)" <[email-masked]>
Date: Mon, 20 Sep 2010 13:57:38 -0500

> Please feel free to convince me otherwise.  Mathematical proofs 

I dont really see it will create loops in the LAN case, at most the traffic will continue to hit the node who requested reverse metric if there are some node do not execute the SPF "correctly" , meaning ignores non-zero metric. The former should still have a route if it is connected to the network using other links. In any cases i assume the DIS will advertise the SAME metric the requesting node have asked for in both directions.

Guan

If the single SPF per level can be relaxed, a SPF as before which assumes zero metric and a SPF including non-zero metric TLVs. Then comparing the two sets of results, if it results in loop, ignore otherwise it should be good to use. If there are good cases, it does not matter that not all IS participate in the non-zero metric, because the result is as good as if there is a only single spf. The question is (or prove) whether it will always lead to loop or never (alwary then no use, never, then a single spf is sufficient, otherwise two SPF provide useful cases)? 

Jay

---

From: Peter Ashwood-Smith <[email-masked]>
Date: Tue, 21 Sep 2010 16:51:09 -0400

We have not made much use of the SPB-ISIS email list since most of the work
has been IEEE focussed but I just posted there a request to start a
discussion on interop testing, so its probably a good use for that list and
if you wish to discuss please join that list and/or ensure your email
address is correct.

Cheers,

Peter