Subject: [Isis-wg] Automatic setting of systemID and/or systemID collision detection

From: Stewart Bryant <[email-masked]>
Date: Fri, 19 Aug 2011 19:30:09 +0100

There  have been a number of emails on this list regarding
the automatic setting of ISIS systemIDs that have diverted
from the technical discussion by making unpleasant personal
comments.

I would like to set those to one side and properly understand
whether there is any need for us to develop such a technology
in the working group. Therefore the question to the working
group is whether we need a working group document describing
one or more of the following:

a) Automatically set the ISIS systemID in the absence of
an 8802 address

b) Automatically detect an ISIS systemID collision
A
c) In the event a systemID collision negotiate a new
systemID.

- Stewart

---

From: Tony Li <[email-masked]>
Date: Fri, 19 Aug 2011 12:27:46 -0700

> c) In the event a systemID collision negotiate a new

IMHO, 802 now has sufficiently pervaded the world that even (a) is an exception that should be handled manually.

Regards,
Tony

---

From: Radia Perlman <[email-masked]>
Date: Fri, 19 Aug 2011 13:31:47 -0700

Stewart, when you asked me to review the document, I explicitly said
that those 3 goals of the document are useful.

I believe that it's great to have 100% reliable manual configuration,
but that the protocol should handle things properly in situations
where someone has a network that they don't want to be doing a lot of
manual configuration for, or where people make mistakes.

Conceivably, the document might add an option that instead of choosing
a new ID when detecting conflict, it should just refuse to operate, I
could imagine situations in which people might prefer one behavior or
the other.

Radia

On Fri, Aug 19, 2011 at 11:30 AM, Stewart Bryant <[email-masked]> wrote:
> _______________________________________________
> Isis-wg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/isis-wg
>