Subject: [Isis-wg] [Technical Errata Reported] RFC6329 (3503)

From: RFC Errata System <[email-masked]>
Date: Thu, 28 Feb 2013 04:18:23 -0800 (PST)

The following errata report has been submitted for RFC6329,
"IS-IS Extensions Supporting IEEE 802.1aq Shortest Path Bridging".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=6329&eid=3503

--------------------------------------
Type: Technical
Reported by: Jan De Backer <[email-masked]>

Section: 4.4

Original Text
-------------
   o  I-SID is the 24-bit I-Component Service ID advertised in the SPBM
      Service Identifier TLV.  It occupies the lower 24 bits of the SPBM
      multicast DA.  The I-SID value 0xfff is reserved for SPBM control
      traffic (refer to the default I-SID in [802.1aq]).

Corrected Text
--------------
   o  I-SID is the 24-bit I-Component Service ID advertised in the SPBM
      Service Identifier TLV.  It occupies the lower 24 bits of the SPBM
      multicast DA.  The I-SID value 0xff is reserved for SPBM control
      traffic (refer to the default I-SID in [802.1aq]).

Notes
-----

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC6329 (draft-ietf-isis-ieee-aq-05)
--------------------------------------
Title               : IS-IS Extensions Supporting IEEE 802.1aq Shortest Path Bridging
Publication Date    : April 2012
Author(s)           : D. Fedyk, Ed., P. Ashwood-Smith, Ed., D. Allan, A. Bragg, P. Unbehagen
Category            : PROPOSED STANDARD
Source              : IS-IS for IP Internets
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 28 Feb 2013 14:27:30 -0000

Hi Jan,

You didn't enter any notes commenting on your proposed change.
As far as I can see, you have s/0xfff/0xff/ with no other changes.

Now, it seems to me that the I-SID is 24 bits and 0xff is 16 bits.
You may be wanting this to read 0x0ff or you may have mistaken the length of the
field.

I'd welcome your explanation, and the thoughts of the WG.

A

> -----Original Message-----
> From: RFC Errata System [mailto:[email-masked]]
> Sent: 28 February 2013 12:18
> To: [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: [Technical Errata Reported] RFC6329 (3503)
> 
> 
> Author(s)           : D. Fedyk, Ed., P. Ashwood-Smith, Ed., D. Allan, A.
Bragg, P.
> Unbehagen

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 28 Feb 2013 15:10:05 -0000

Ah yes, now we have established that I can't count...

Your reference seems unambiguous.
I have a preference for clearly indicating the zeros, even if that is slightly
overkill.

Anyone else have thoughts?

Adrian

> From: Jan DeBacker [mailto:[email-masked]]
> Sent: 28 February 2013 14:52
> To: [email-masked]
> Cc: [email-masked]
> Subject: RE: [Technical Errata Reported] RFC6329 (3503)
> 
> Hi Adrian,
> 
> Actually, 0xff is 8 bits ;)
> 
> In 802.1aq (Clause 28)it is stated:
> "A default I-SID (I-SID 0x0000ff) maps to all SPT bridges operating in SPBM
mode
> allowing a
> default broadcast and group address capability for ISIS-SPB."
> 
> But in Table 9.3 (Clause 9.7) the SPBM Default I-SID is represented as just
'FF'.
> 
> Do you think the value of the default I-SID should also indicate the I-SID
field
> length? If that's the case then '0x0000ff' should be used. Otherwise '0xff'
should
> do.
> Cheers,
> Jan
> From: Adrian Farrel [mailto:[email-masked]]
> Sent: Thursday, February 28, 2013 15:28
> To: Jan DeBacker
> Cc: [email-masked]
> Subject: RE: [Technical Errata Reported] RFC6329 (3503)
> 
> Hi Jan,
> 
> You may be wanting this to read 0x0ff or you may have mistaken the length of
> the field.
> 
> > The following errata report has been submitted for RFC6329, "IS-IS
> > Extensions Supporting IEEE 802.1aq Shortest Path Bridging".
> >
> > use "Reply All" to discuss whether it should be verified or rejected.
> > When a decision is reached, the verifying party (IESG) can log in to
> > change the status and edit the report, if necessary.
> >

---

From: Jan DeBacker <[email-masked]>
Date: Thu, 28 Feb 2013 14:51:58 +0000

Hi Adrian,

In 802.1aq (Clause 28)it is stated:  
"A default I-SID (I-SID 0x0000ff) maps to all SPT bridges operating in SPBM mode allowing a
default broadcast and group address capability for ISIS-SPB."

But in Table 9.3 (Clause 9.7) the SPBM Default I-SID is represented as just 'FF'.

Do you think the value of the default I-SID should also indicate the I-SID field length? If that's the case then '0x0000ff' should be used. Otherwise '0xff' should do.

Cheers,
Jan

-----Original Message-----
From: Adrian Farrel [mailto:[email-masked]] 
Sent: Thursday, February 28, 2013 15:28
To: Jan DeBacker
Cc: [email-masked]
Subject: RE: [Technical Errata Reported] RFC6329 (3503)

Hi Jan,

Now, it seems to me that the I-SID is 24 bits and 0xff is 16 bits.
You may be wanting this to read 0x0ff or you may have mistaken the length of the field.

A

Bragg, P.

---

From: "Fedyk, Donald (Don)" <[email-masked]>
Date: Thu, 28 Feb 2013 16:32:03 +0000

Hi 

The correct value is 255 decimal and 0x0000ff is consistent with the 24 bit value as defined in IEEE.

Thank you
Don 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Jan DeBacker
Sent: Thursday, February 28, 2013 9:52 AM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Isis-wg] [Technical Errata Reported] RFC6329 (3503)

Hi Adrian,

In 802.1aq (Clause 28)it is stated:  
"A default I-SID (I-SID 0x0000ff) maps to all SPT bridges operating in SPBM mode allowing a default broadcast and group address capability for ISIS-SPB."

Cheers,
Jan

-----Original Message-----
From: Adrian Farrel [mailto:[email-masked]]
Sent: Thursday, February 28, 2013 15:28
To: Jan DeBacker
Cc: [email-masked]
Subject: RE: [Technical Errata Reported] RFC6329 (3503)

Hi Jan,

A

Bragg, P.
> Source              : IS-IS for IP Internets

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/isis-wg