Subject: [Isis-wg] ISIS LSP fragmentation

From: Abhishek Verma <[email-masked]>
Date: Fri, 14 Jun 2013 22:49:04 +0530

Hi,

In ISIS routing protocol, the maximum size of a single LSP, as specified by
ISO 10589, is1492 bytes. If a router cannot fit all of its TLVs into this
maximum length, it produces a multipart LSP. The first part will have an
LSP number of 0x00, the second 0x01, the third 0x02, and so on.

When a router has to break its LSP into multiple parts,  will it break one
TLV into 2 parts? That is some information of a TLV is contained in the
first part and other information of the previous TLV is contained in the
next part.

Regards,

Abhishek

---

From: Tony Li <[email-masked]>
Date: Fri, 14 Jun 2013 10:27:12 -0700

> In ISIS routing protocol, the maximum size of a single LSP, as specified by ISO 10589, is1492 bytes. If a router cannot fit all of its TLVs into this maximum length, it produces a multipart LSP. The first part will have an LSP number of 0x00, the second 0x01, the third 0x02, and so on.
> 
> When a router has to break its LSP into multiple parts,  will it break one TLV into 2 parts? That is some information of a TLV is contained in the first part and other information of the previous TLV is contained in the next part.  

Welcome to the WG.  This list is primarily intended for standards making discussions, not for educational purposes.

That said, no, splitting a TLV would get hairy.  TLVs are atomic and should always appear in their entirety in a single fragment.

Tony