Subject: [Isis-wg] Reg: draft-ietf-isis-reverse-metric-03

From: Vijay Kumar Vasantha <[email-masked]>
Date: Thu, 13 Jun 2013 01:18:25 -0600

Hi,

While reading draft-ietf-isis-reverse-metric-03 I got the following query, could someone please clarify it.

-          Could the link to DIS be made link of last resort on a LAN.

For example consider a topology where three routers A, B & C are connected on a LAN, where A is DIS.

A----------A'-----------B
                    |
                    |
                    |
                   C

If administrator wishes to remove the bi-directional traffic for node A, then configuring reverse-metric on A will,

-          Make the cost from A to A' high.

-          Not affect the cost from A' to A in pseudo-node LSP.

So the traffic from non-DIS nodes could still reach DIS on this LAN.

Perhaps one of the ways to address it would be,
Upon administrator enabling reverse-metric on a LAN,

-          If the node is a DIS on the LAN then DIS could increase the cost to itself in the pseudonode LSP.

Thanks,
Vijay

---

From: Shane Amante <[email-masked]>
Date: Fri, 14 Jun 2013 13:26:22 -0600

Hi Vijay,

Please see below.

On Jun 13, 2013, at 1:18 AM, Vijay Kumar Vasantha <[email-masked]> wrote:
> A----------A’-----------B
>                     |
>                     |
>                     |
>                    C

I take it A' represents the pseudo-node?

> -          Make the cost from A to A’ high.
> -          Not affect the cost from A’ to A in pseudo-node LSP.

The latter bullet is incorrect for the scenario you describe.  The DIS should increase the cost in the pseudo-node LSP (A') back to A, at the same time.  But, before you answer, please see the next response.

> -          If the node is a DIS on the LAN then DIS could increase the cost to itself in the pseudonode LSP.

Actually, I believe the comment/question you have is actually more applicable to a related draft:
http://tools.ietf.org/html/draft-ietf-isis-oper-enhance-03

In particular, you may wish to review Section 3, "Pseudonodes with Non-zero Metrics", of the aforementioned draft, which describes where the DIS, itself, is altering the metric in the Pseudo-node LSP to achieve the effect you describe.

Anyway, let me know if the above addresses you question or not.

Thanks,

-shane

> Thanks,
> Vijay
>  
>  
>  
>  
> _______________________________________________
> Isis-wg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/isis-wg

---

From: Naiming Shen <[email-masked]>
Date: Fri, 14 Jun 2013 15:02:51 -0700

Hi Vijay,

please see inline.

> -          Not affect the cost from A’ to A in pseudo-node LSP.

No, as Shane mentioned, this 'reverse metric' is in the direction of A' to A, assume
if you want to change the default behavior which is metric of zero.
Basically you have metric from two sides, from any node to A', and from A' to any node.
If you change metric from a node to A', that's the normal ISIS behavior on LAN today, which
controls the traffic outbound to the LAN towards all the other nodes; This draft allows to
to change the metric from A' to any node on the LAN, which controls the inbound traffic
into that node. In your case, if you what to increase the inbound metric to A, then
this draft allows you to set A' to A metric.

> So the traffic from non-DIS nodes could still reach DIS on this LAN.

the above change does not change the traffic between B to C, or from C to B, or outbound
traffic from A to B or C.

> -          If the node is a DIS on the LAN then DIS could increase the cost to itself in the pseudonode LSP.

That is intention of the draft. It allows any node on the LAN to use IIH packet to request
the DIS (could be itself) to raise/change the 'reverse metric' towards the requesting node.

Regards,
- Naiming

---

From: Vijay Kumar Vasantha <[email-masked]>
Date: Sat, 15 Jun 2013 09:39:28 -0600

Hi,

Thanks Shane & Naiming for explaining and pointing out to the related draft 'draft-ietf-isis-oper-enhance-03'.
Yes, the sec 3 of this related draft addresses my question.

Thanks,
Vijay

From: Shane Amante [mailto:[email-masked]]
Sent: Saturday, June 15, 2013 12:56 AM
To: Vijay Kumar Vasantha
Cc: [email-masked]
Subject: Re: [Isis-wg] Reg: draft-ietf-isis-reverse-metric-03

Hi Vijay,

Please see below.

On Jun 13, 2013, at 1:18 AM, Vijay Kumar Vasantha <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Thanks,

-shane

Thanks,
Vijay

_______________________________________________
Isis-wg mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/isis-wg