Subject: [Isis-wg] Comment on draft-ginsberg-isis-udl-01

From: Donald Eastlake <[email-masked]>
Date: Tue, 6 Aug 2013 12:12:07 -0400

Using the terminology of the draft, while IS-R can see BFD Enabled
TLVs in IIHs from IS-T, IS-R cannot provide this indication to IS-T.
So I believe a sub-TLV should be specified for the UDL TLV to convey
this information.

Thanks,
Donald
=============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Mon, 12 Aug 2013 06:27:02 +0000

Donald -

Apologies for the delayed reply.

Although BFD can certainly be used on a UDL it is necessary that multi-hop BFD be used as IS-R cannot reach IS-T directly. If the return path from IS-R to IS-T traverses another UDL it is possible that IP/IPv6 reachability to IS-T would require the UDL adjacency(s) on the return path to be up in order for the BFD session to be up. If RFC 6213 was being employed on all UDL links this could introduce a circular dependency which would prevent the UDL adjacencies from coming up.

I am therefore not convinced that RFC 6213 can be used safely in such deployments.

You have raised a good point and I agree that the draft should be updated to discuss this issue - but at the moment I don't think simply adding a new sub-TLV as you suggested would be correct.

   Les

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Donald Eastlake
> Sent: Tuesday, August 06, 2013 9:12 AM
> To: isis mailing list
> Subject: [Isis-wg] Comment on draft-ginsberg-isis-udl-01
> 
> _______________________________________________
> Isis-wg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/isis-wg

---

From: Donald Eastlake <[email-masked]>
Date: Mon, 12 Aug 2013 22:43:24 -0400

Hi Les,

> Although BFD can certainly be used on a UDL it is necessary that multi-hop BFD be used as IS-R cannot reach IS-T directly. If the return path from IS-R to IS-T traverses another UDL it is possible…

That is an interesting point I hadn't thought of.

Thanks,
Donald