Subject: [Isis-wg] Request comments on ISIS Autoconf draft

From: "Liubing (Leo)" <[email-masked]>
Date: Thu, 24 Oct 2013 03:28:30 +0000

Hi, Dear All

I have submitted a new draft regarding ISIS auto-configuration:
http://tools.ietf.org/html/draft-liu-isis-auto-conf-00

The draft is just on the very initial stage. And I'm very willing to hear your opinions:
1. Do you think the ISIS-Autoconf is a valuable feature worth to be developed?
2. Technical comments are also appreciated much.
3. Any other comments you'd like to post

Many thanks and best regards to you all.
Bing

---

From: Mikael Abrahamsson <[email-masked]>
Date: Thu, 24 Oct 2013 06:25:10 +0200 (CEST)

> 1. Do you think the ISIS-Autoconf is a valuable feature worth to be developed?

I support the rationale of having isis autoconf.

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: Hannes Gredler <[email-masked]>
Date: Fri, 25 Oct 2013 10:29:38 +0200

hi,

nice work so far - you should add procedures to detect sysID duplicates,
like e.g. zeroconf does;

/hannes

On Thu, Oct 24, 2013 at 03:28:30AM +0000, Liubing (Leo) wrote:
| Hi, Dear All
| 
| I have submitted a new draft regarding ISIS auto-configuration:
| http://tools.ietf.org/html/draft-liu-isis-auto-conf-00
| 
| The draft is just on the very initial stage. And I'm very willing to hear your opinions:
| 1. Do you think the ISIS-Autoconf is a valuable feature worth to be developed?
| 2. Technical comments are also appreciated much.
| 3. Any other comments you'd like to post
| 
| Many thanks and best regards to you all.
| Bing
| _______________________________________________
| Isis-wg mailing list
| [email-masked]
| https://www.ietf.org/mailman/listinfo/isis-wg
| 
|

---

From: "Liubing (Leo)" <[email-masked]>
Date: Fri, 25 Oct 2013 09:18:04 +0000

Hi, Hannes

Thanks for your positive feedback and the technical comment. I'll continue working on it.

Best regards,
Bing

> -----Original Message-----
> From: Hannes Gredler [mailto:[email-masked]]
> Sent: Friday, October 25, 2013 4:30 PM
> To: Liubing (Leo)
> Cc: [email-masked]
> Subject: Re: [Isis-wg] Request comments on ISIS Autoconf draft
> 
> hi,
>

---

From: "Liubing (Leo)" <[email-masked]>
Date: Fri, 25 Oct 2013 09:20:57 +0000

Hi, Mikael

Thanks for your support. Hope we could work out a useful feature.

Best regards,
Bing

> From: Mikael Abrahamsson [mailto:[email-masked]]
> Sent: Thursday, October 24, 2013 12:25 PM
> To: Liubing (Leo)
> Cc: [email-masked]

---

From: Qin Wu <[email-masked]>
Date: Fri, 25 Oct 2013 09:29:46 +0000

Good start, I am wondering how ISIS Autoconf is different from OSPF Autoconf?

Regards!
-Qin
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Liubing (Leo)
Sent: Thursday, October 24, 2013 11:29 AM
To: [email-masked]
Subject: [Isis-wg] Request comments on ISIS Autoconf draft

Hi, Dear All

Many thanks and best regards to you all.
Bing
_______________________________________________
Isis-wg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/isis-wg

---

From: "Liubing (Leo)" <[email-masked]>
Date: Fri, 25 Oct 2013 09:41:14 +0000

Hi, Qin

> From: Qin Wu
> Sent: Friday, October 25, 2013 5:30 PM
> To: Liubing (Leo); [email-masked]
> Subject: RE: Request comments on ISIS Autoconf draft
> 

[Bing] I think the rationale is similar, since they have similar design/functions.
One big difference I could tell is regarding the adjacency formation. OSPF requires strict HelloInterval/DeadInterval matching among routers, if not, the adjacencies could not be formed.
But ISIS does not. However, the intervals in ISIS should also be within a proper range. I might need to add some considerations on it.

Best regards,
Bing

---

From: Qin Wu <[email-masked]>
Date: Fri, 25 Oct 2013 09:43:47 +0000

Thanks for your clarification, more analysis and digging into it will be great.

Regards!
-Qin
-----Original Message-----
From: Liubing (Leo) 
Sent: Friday, October 25, 2013 5:41 PM
To: Qin Wu; [email-masked]
Subject: RE: Request comments on ISIS Autoconf draft

Hi, Qin

Best regards,
Bing

---

From: "Liubing (Leo)" <[email-masked]>
Date: Fri, 25 Oct 2013 09:47:14 +0000

> Thanks for your clarification, more analysis and digging into it will be great.
Sure. I'll continue on it.
Thanks for your comments.

B.R.
Bing