Subject: [Isis-wg] 答复: [OSPF] Inconsistency between OSPF extention and IS-IS extension for segment routing

From: Xuxiaohu <[email-masked]>
Date: Fri, 8 Nov 2013 00:23:39 +0000

Hi Peter,

________________________________________
发件人: Peter Psenak [[email-masked]]
发送时间: 2013年11月8日 7:45
收件人: Xuxiaohu
抄送: [email-masked]; [email-masked]
主题: Re: [OSPF] Inconsistency between OSPF extention and IS-IS extension for segment routing

Xiaohu,

please see inline:

On 11/7/13 14:51 , Xuxiaohu wrote:
> Hi co-authors of the above two drafts,
>
> OSPF extension draft proposes to use Extended Prefix Opaque LSA to carry SR-related attributes. Since the Extended Prefix Opaque LSA does not advertise reachability of the prefix, but only its attributes, the prefixes contained within those LSAs for building IP routing table (e.g., Router LSAs) can be aggregated when crossing area boundaries while the Extended Prefix Opaque LSAs containing prefix SIDs can be intactly propagated across area boudaries. The final effect is much similar to the mechanism defined in RFC5283.
>
> In contract, IS-IS extension draft proposes to reuse those Extended IP Reachability TLVs which are used for building IP routing table to carry SR-related attributes. Although this choice has the benefit of propagating less LSAs, it loses the capability of aggregating routes when acrossing level boudaries. Furthermore, it requires the L1/L2 routers much be SR-capable.

if you aggregate on area/L1L2 boundary, SIDs/labels for individual
prefixes that are covered by the aggregate are useless in the area to
which you aggregate - there will be no FIB entries for these individual
prefixes in such area. So if you aggregate, there is no need to
propagate SIDs/labels for aggregated prefixes.

[Xiaohu] "In the multi-area/level
   scenario where route summary between areas/levels is required, the IP
   longest-match algorithm SHOULD be used by SR-capable routers when
   processing label bindings advertised by the mapping server" For more details, please read the Introduction section of http://tools.ietf.org/html/draft-xu-rtgwg-global-label-adv-00

Best regards,
Xiaohu

"

thanks,
Peter

>
> Although these two drafts are proposing extensions to two different IGPs, IMHO, it would better to provide similar capabilities if possible, especially advoid destroying the existing capabilities of these two IGPs,  e.g., inter-area/level route aggregation capability.
>
> To Peter Psenak,
>
> I don't agree with your argrment that the reason that IS-IS extension draft made that choice is because there is no choice for IS-IS. In fact, you can use the signalling mechanism for Label Request which has been proposed in draft-xu-rtgwg-global-label-adv-00. That's to say, you can use separate Extended IP Reachability TLVs other than those for IP reachability advertisement to carry SR-related attibutes. Since the former TLVs are intened for advertising label bindings other than building IP routing table, the Metric field of these TLVs is set to a value larger than MAX_PATH_METRIC (i.e., 0xFE000000). It's a normal approach for IS-IS. Of course, if SR is just used within a single level, it's good to use the existing approach proposed in the IS-IS extension draft.
>
> Best regards,
> Xiaohu
> _______________________________________________
> OSPF mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ospf
>

---

From: Peter Psenak <[email-masked]>
Date: Thu, 07 Nov 2013 16:39:12 -0800

Xiaohu,

> Hi Peter,
]
>     processing label bindings advertised by the mapping server" For more details, please read the Introduction section of http://tools.ietf.org/html/draft-xu-rtgwg-global-label-adv-00

I don't understand. If you summarize, then only the summary prefix will
be visible in the backbone (and remote areas) and installed in the FIB
on all routers in these areas.

Where would you apply 'longest-match algorithm' when you only see the
single summary? How would you use the SID/label for prefixes that are
covered by the summary?

thanks,
Peter

---

From: Xuxiaohu <[email-masked]>
Date: Fri, 8 Nov 2013 01:28:40 +0000

Hi Peter,

The 'longest-match algorithm' for LIB installation has been proposed by RFC5283.

Best regards,
Xiaohu

________________________________________
发件人: Peter Psenak [[email-masked]]
发送时间: 2013年11月8日 8:39
收件人: Xuxiaohu
抄送: [email-masked]; [email-masked]
主题: Re: 答复: [OSPF] Inconsistency between OSPF extention and IS-IS extension for segment routing

Xiaohu,

]

thanks,
Peter

---

From: Xuxiaohu <[email-masked]>
Date: Fri, 8 Nov 2013 01:47:33 +0000

> To Peter Psenak,
>
> I don't agree with your argrment that the reason that IS-IS extension draft made that choice is because there is no choice for IS-IS.

i second that opinion - the only extensible container for IP prefixes are the
extended IP reach TLVs.

[Xiaohu] Yes, you should still use the Extended IP reachability TLVs to carry SR-related attributes. Howover, you can use "separate" Extended IP reachability TLVs other than those Extended IP reachability TLVs for building IP routing table to advertise label bindings. Since the former TLVs are just intended for label distribution, rather than IP reachability advertisement, the Metric field of these TLVs is set to a value larger than MAX_PATH_METRIC (i.e., 0xFE000000). In this way, the former TLVs now play the similar role of the OSPF Extended Prefix Opaque LSAs. 

Best regards,
Xiaohu

---

From: Peter Psenak <[email-masked]>
Date: Fri, 08 Nov 2013 11:56:19 -0800

Xiaohu,

there is no LDP in the SR network, so RFC5283 is not applicable.

thanks,
Peter

---

From: Xuxiaohu <[email-masked]>
Date: Fri, 8 Nov 2013 20:04:45 +0000

Hi Peter,

Sure. However, why not borrow the idea of longest-matching algorithm proposed in that RFC to SR?

BR,
Xiaohu

________________________________________
发件人: [email-masked] [[email-masked]] 代表 Peter Psenak [[email-masked]]
发送时间: 2013年11月9日 3:56
收件人: Xuxiaohu
抄送: [email-masked]; [email-masked]
主题: Re: [Isis-wg] 答复: 答复: [OSPF] Inconsistency between OSPF extention and IS-IS extension for segment routing

Xiaohu,

thanks,
Peter

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/isis-wg

---

From: Peter Psenak <[email-masked]>
Date: Fri, 08 Nov 2013 12:37:20 -0800

Xiaohu,

OSPF SR draft clearly states that newly defined Extended Prefix Opaque
LSAs do not contribute to the prefix reachability. What you are asking
for is to negate that and install forwarding entries based on what is in
the EP-LSA, without prefix being advertised in any regular LSA. Once you
start to do that you will end up with all sorts of problems. I would
like to keep the current definition in place.

thanks,
Peter

---

From: Xuxiaohu <[email-masked]>
Date: Fri, 8 Nov 2013 20:50:02 +0000

Hi Peter,

You misunderstood what I have said. On the contrary, the OSPF extension draft looks fine to me. It's the ISIS extension draft that I believed should follow the similar approach defined in the OSPF extension draft.

Best regards,
Xiaohu

________________________________________
发件人: Peter Psenak [[email-masked]]
发送时间: 2013年11月9日 4:37
收件人: Xuxiaohu
抄送: [email-masked]; [email-masked]
主题: Re: [Isis-wg] 答复:  答复: 答复: [OSPF] Inconsistency between OSPF extention and IS-IS extension for segment routing

Xiaohu,

thanks,
Peter

---

From: Peter Psenak <[email-masked]>
Date: Fri, 08 Nov 2013 12:58:43 -0800

Xiaohu,

I understand what you started this thread with.

What I'm trying to say is that even if OSPF separates the advertisement
of prefix and prefix SID/label, you should not be using the SID/label
advertisement without the actual prefix reachability advertisement.

thanks,
Peter

---

From: Xuxiaohu <[email-masked]>
Date: Fri, 8 Nov 2013 21:07:16 +0000

Peter,

In my understanding, the OSPF EP LSAs containing SID/label bindings just play the role of label distribution protocols. Since LDP can support the longest-matching algorithm for LFIB installation, why OSPF EP LSAs could not support that capability?

BR
Xiaohu

________________________________________
发件人: Peter Psenak [[email-masked]]
发送时间: 2013年11月9日 4:58
收件人: Xuxiaohu
抄送: [email-masked]; [email-masked]
主题: Re: 答复: [Isis-wg] 答复:  答复: 答复: [OSPF] Inconsistency between OSPF extention and IS-IS extension for segment routing

Xiaohu,

thanks,
Peter

---

From: Peter Psenak <[email-masked]>
Date: Fri, 08 Nov 2013 13:14:28 -0800

Xiaohu,

> In my understanding, the OSPF EP LSAs containing SID/label bindings just play the role of label distribution protocols. Since LDP can support the longest-matching algorithm for LFIB installation, w…

because we do not want OSPF EP LSAs to do what you want to use it for.

thanks,
Peter