Subject: [Isis-wg] Upcoming IETF Last Call on draft-ietf-mpls-extended-admin-group

From: Loa Andersson <[email-masked]>
Date: Wed, 02 Apr 2014 11:11:02 +0200

OSPF, ISIS and CCAMP working groups,
(mpls wg cc'ed)

The MPLS working group have requested that 
draft-ietf-mpls-extended-admin-group is published as a Standard Tracks RFC.

The document is through the AD review; as part of the review we have
agreed that we'd like to point out to the OSPF, ISIS and CCAMP working
groups, that any comments should be sent as responses to the upcoming
IETF Last call (the document is in what we hope will be a very
quick and minor update).

/Loa
for the mpls wg co-chairs

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Wed, 2 Apr 2014 14:52:18 +0000

Loa -

In reading Section 2.3.1 the text seems contradictory:

<snip>
If a node advertises both AG and EAG then the first 32 bits of the
   EAG MUST be identical to the advertised AG.  If a receiving node
   notices that the AG differs from the first 32 bits of the EAG, it
   SHOULD use the AG as the first 32 bits of the EAG, and SHOULD
   indicate this mismatch to the operator.

   If the AG and EAG advertised for a link differ, the EAG MUST take
   priority.
<end snip>

The first quoted paragraph says when there is a conflict "AG SHOULD be used".

The second quoted paragraph says when there is a conflict "EAG MUST take priority".

Which preference is intended??

I would think that AG MUST take priority in such cases - otherwise you will have inconsistency between legacy nodes and nodes which support EAG.

I would also note that conflict could be avoided entirely if you defined the EAG to be used only for additional (beyond the currently supported 32 groups) rather than as a superset of AG. This would also eliminate the need to advertise both AG and EAG solely as a transition strategy. Was this option considered and if so why was it rejected? (Apologies if this was discussed on mpls list - I do not routinely follow that list.)

   Les

> -----Original Message-----
> From: Isis-wg [mailto:[email-masked]] On Behalf Of Loa Andersson
> Sent: Wednesday, April 02, 2014 2:11 AM
> To: [email-masked]; [email-masked]; [email-masked]
> Cc: [email-masked]; Adrian Farrel; VIGOUREUX, MARTIN (MARTIN); draft-ietf-
> [email-masked]
> Subject: [Isis-wg] Upcoming IETF Last Call on draft-ietf-mpls-extended-admin-
> group
> 
> _______________________________________________
> Isis-wg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/isis-wg

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Wed, 2 Apr 2014 15:38:02 +0000

(Resending w corrected OSPF/CCAMP WG addresses)

Loa -

<snip>

   Les