Subject: Re: [Isis-wg] draft-ietf-isis-segment-routing-extensions-02

From: Hannes Gredler <[email-masked]>
Date: Fri, 6 Jun 2014 13:02:17 +0200

hi stefano,

+ISIS-WG as this is now a WG-item.

a comment n the 'V' flag -
what is IMO missing is the clarification when and when not to use the 'V' flag.
i.e. for which particular data plane -

to play devils advocate:
  as generic as the draft is right now,
  the V-flag may be abused for prefix-SIDs on a MPLS data plane
  as an attempt to-reintroduce the notion of global labels,
  which as you may know i do reject.

may i ask you to add some clarifying notes that V-flag=1 applies only for the
Prefix SIDs assuming IPv6-SR dataplane.

furthermore i am not really sure what the V-flag shall mean for Adjacency-SIDs.
(the adjacency-SID always has been a label and never an index).

thanks,

/hannes

On Jun 6, 2014, at 10:47 AM, Stefano Previdi (sprevidi) wrote:

> Co-authors,
> 
> this is the latest version we are ready to submit. It contains the different 
> updates we've discussed in the past weeks.
> 
> . Addition of flags in prefix-sid and adj-sid subtlv. We added E, V and L flags. 
>  At some point we removed the R flag but is now back.
> . use of prefix-sid-tlv for mapping server
> . fixed typo's and inconsistencies
> 
> Bruno and others already sent comments that I have tryed to address (e.g.: I 
> moved the SID/Label SubTLV section after PrefixSID and Adj-SID sections.
> 
> Thanks for letting me know any comment.
> 
> s.
> 
> 
> <draft-ietf-isis-segment-routing-extensions-01.txt>

---

From: "Stefano Previdi (sprevidi)" <[email-masked]>
Date: Fri, 6 Jun 2014 12:05:21 +0000

> +ISIS-WG as this is now a WG-item.

sure. I usually try to have, at least, agreement with co-authors 
before presenting the change to the WG and ask for consensus but 
this way is fine for me too.

> i.e. for which particular data plane -

indeed, we could add some clarification such as:

. V (value flag): is set when the SID is a label value (i.e.: not an index).
  The V flag is set when:
    . SID carries MPLS labels (i.e.: not indexes)
    . SID carries IPv6 addresses
  
. L (local flag): is set when the SID has local significance (local means 
  router/node context). It applies to both MPLS and IPv6 dataplanes:
  . MPLS: prefix-SID being global, the L flag is unset
          adj-SID being local, the L flag is set
  . IPv6: Adj-SID can be eithr local or global. When used with a globally 
          unique ipv6 address, the L flag is unset.

This, I believe reflects what you and me agreed a ouple of weeks ago, right ?

>  which as you may know i do reject.

there are maybe use-cases out there where a prefix would be better 
advertised with a global label. Also, at some point in the future 
we may want to support global labels without having to go through 
a complete re-spin of the drafts, so adding a bit to govern the 
significance of a sid is a good thing to have.

> Prefix SIDs assuming IPv6-SR dataplane.

Well, I'd prefer to stick with what the co-authors already agreed 
to propose at the WG so anyone, feel free to express your opinion.

> (the adjacency-SID always has been a label and never an index).

at some point, one may want to have a global index for adj-sid's

s.

> _______________________________________________
> Isis-wg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/isis-wg