Subject: [Isis-wg] comments on draft-litkowski-isis-yang-isis-cfg-01

From: "Wunan (Eric)" <[email-masked]>
Date: Tue, 22 Jul 2014 19:26:22 +0000

Hi Stephane,

Some comments below. Please check.

1. +--rw isis

Should be a list here with a key like [name] or [local-id] here?

2. +--rw nsap-address in isis-cfg container,

"nsap-address" is used here but "system-id" is used isis-state. Suggest to use same one.

And one isis can have at least three NSAP since area address can be different.

3. +--rw ipv4-router-id?

    +--rw ipv6-router-id?

Not sure the use here.

4. Missing vrf association ?

5. Missing nsf ?

6. Missing traffic engineering ?

7. Missing Timer related cfg ?

8. Missing redistribution related cfg ?

9. Multi-topology should allow to configure more besides ipv4-uni, ipv6-uni, ipv4-multi, ipv6-multi

These are commonly used configuration which should not be omitted.

10. isis route configuration and operation should be included in isis-cfg and isis-state ?

11. interfaces and TE state should be included in isis-state

---

From: <[email-masked]>
Date: Tue, 22 Jul 2014 20:03:21 +0000

Hi,

Thanks for your comment.
It seems that your are IOS CLI familiar :)
As I pointed to OSPF wg meeting, Yang datamodel does not require to be a CLI mirror.

Inline answers ...

From: Wunan (Eric) [mailto:[email-masked]]
Sent: Tuesday, July 22, 2014 15:26
To: LITKOWSKI Stephane SCE/IBNF; [email-masked]
Cc: Lizhenbin; Yangang
Subject: comments on draft-litkowski-isis-yang-isis-cfg-01

Hi Stephane,

1. +--rw isis

[SLI] The name of the protocol instance comes from the "routing-protocol* [name]" container in core routing model.

[SLI] NSAP address type is AREA+SYSTEMID+NSEL while system-id type is only systemid that's why I needed two types.

I agree that we may extend to multiple area ... this is just a first shot , so some parts are missing ...

3. +--rw ipv4-router-id?

    +--rw ipv6-router-id?

Not sure the use here.

[SLI] Definition of address of TLV134 and 140

[SLI] No the protocol definition is within a routing-instance in the core datamodel .

5. Missing nsf ?

[SLI] NSF is cisco :( you may  refer to GR or NSR stuffs ? HA features are not there yet.

[SLI] Only wide metrics are there , but not traffic-eng. I was wondering if TE should be part of a separate datamodel (using augmentation) and so can be used for both OSPF and ISIS protocols ... point to discuss ...

[SLI] Some timers are there ... some may be missing. Which timer are your referering to ?

[SLI] Route-filters are part of the core data model. But maybe we need to augment stuffs ... I did not look at it yet.

[SLI] Please provide more details on what you want.

[SLI] Don't understand the comment ...

[SLI] Interface state is not there yet ... for TE, it must be part of the TE modeling discussion ...

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Wunan (Eric)" <[email-masked]>
Date: Wed, 23 Jul 2014 18:04:28 +0000

Hi Stephane,

Have to say you are also familiar with IOS CLI too. ( Alright we need to stop doing advertisement here:) )

And it is correct YANG need not to be CLI mirror but it needs to contain its counterpart for fulfilling YANG's configuration objective.

Please check responses below.

Regards

Eric

________________________________
发件人: [email-masked] [[email-masked]]
发送时间: 2014年7月23日 4:03
收件人: Wunan (Eric); [email-masked]
抄送: Lizhenbin; Yangang
主题: RE: comments on draft-litkowski-isis-yang-isis-cfg-01

Hi,

Thanks for your comment.

Inline answers …

Hi Stephane,

1. +--rw isis

[SLI] The name of the protocol instance comes from the “routing-protocol* [name]” container in core routing model.

[SLI] NSAP address type is AREA+SYSTEMID+NSEL while system-id type is only systemid that’s why I needed two types.

I agree that we may extend to multiple area … this is just a first shot , so some parts are missing …

3. +--rw ipv4-router-id?

    +--rw ipv6-router-id?

Not sure the use here.

5. Missing nsf ?

[Eric] GR. Sorry for that face here.

[SLI] Only wide metrics are there , but not traffic-eng. I was wondering if TE should be part of a separate datamodel (using augmentation) and so can be used for both OSPF and ISIS protocols … point to discuss …

[Eric] Agree to be a separate model. That's will be better.

[SLI] Some timers are there … some may be missing. Which timer are your referering to ?

[Eric] For example, spf delay timer.

[SLI] Route-filters are part of the core data model. But maybe we need to augment stuffs … I did not look at it yet.

[Eric] Multi-topology for non-standard ones. This model should allow this.

[SLI] Don’t understand the comment …

[Eric] Does isis model need to expand the route attributes from core model?
            How about adding state and rpc operation for isis route ?

[SLI] Interface state is not there yet … for TE, it must be part of the TE modeling discussion …

---

From: Hannes Gredler <[email-masked]>
Date: Mon, 28 Jul 2014 17:38:55 +0200

hi eric, stephane,

On Wed, Jul 23, 2014 at 06:04:28PM +0000, Wunan (Eric) wrote:
[ ... ]
|    6. Missing traffic engineering ?
| 
| 
| 
|    [SLI] Only wide metrics are there , but not traffic-eng. I was wondering
|    if TE should be part of a separate datamodel (using augmentation) and so
|    can be used for both OSPF and ISIS protocols ¡ point to discuss ¡
| 
|    [Eric] Agree to be a separate model. That's will be better.

hmm can we first collect some TE related atrributes that apply both to
OSPF and IS_IS before making that call ?

[ ... ]
|    8. Missing redistribution related cfg ?
| 
| 
| 
|    [SLI] Route-filters are part of the core data model. But maybe we need to
|    augment stuffs ¡ I did not look at it yet.
 
that one might get hairy pretty soon ... as some vendors define
their leak policy as prefix, lists and some others call into
execution of a policy language.

|    9. Multi-topology should allow to configure more besides ipv4-uni,
|    ipv6-uni, ipv4-multi, ipv6-multi
| 
|    These are commonly used configuration which should not be omitted.
| 
| 
| 
|    [SLI] Please provide more details on what you want.
| 
|    [Eric] Multi-topology for non-standard ones. This model should allow this.

do you have a use-case for this ? - any document that you can refer to ?

/hannes

---

From: <[email-masked]>
Date: Tue, 29 Jul 2014 08:04:54 +0000

Hi Hannes,

> hmm can we first collect some TE related atrributes that apply both to OSPF and IS_IS before making that call ?

Based on the last discussions we had at IETF, the best solution would be to have TE attributes directly in the ISIS model in a similar way as OSPF rather than trying to define a common augmented model. I think this discussion is similar to the "superset" IGP Link State model where we did not want to go into ...

> that one might get hairy pretty soon ... as some vendors define their leak policy as prefix, lists and some others call into execution of a policy language.

Right, the issue with policy is more global rather than just an ISIS issue ... it's not really my priority for now ...

Stephane

-----Original Message-----
From: Hannes Gredler [mailto:[email-masked]] 
Sent: Monday, July 28, 2014 17:39
To: Wunan (Eric)
Cc: LITKOWSKI Stephane SCE/IBNF; [email-masked]
Subject: Re: [Isis-wg] comments on draft-litkowski-isis-yang-isis-cfg-01

hi eric, stephane,

|    can be used for both OSPF and ISIS protocols    point to discuss   

hmm can we first collect some TE related atrributes that apply both to OSPF and IS_IS before making that call ?

[ ... ]
|    8. Missing redistribution related cfg ?
| 
| 
| 
|    [SLI] Route-filters are part of the core data model. But maybe we need to
|    augment stuffs    I did not look at it yet.
 
that one might get hairy pretty soon ... as some vendors define their leak policy as prefix, lists and some others call into execution of a policy language.

/hannes

---

From: Alia Atlas <[email-masked]>
Date: Tue, 29 Jul 2014 15:41:48 -0400

Hi Stephane,

On Tue, Jul 29, 2014 at 4:04 AM, <[email-masked]> wrote:

> Based on the last discussions we had at IETF, the best solution would be
> to have TE attributes directly in the ISIS model in a similar way as OSPF
> rather than trying to define a common augmented model. I think this
> discussion is similar to the "superset" IGP Link State model where we did
> not want to go into ...

Is there a reason not to look for common groups of information where we
can?  I wouldn't necessarily go for augmenting but for a common group that
both ISIS and OSPF could include.

You might also look at draft-clemm-i2rs-yang-network-topo-00 .

Alia

>  > that one might get hairy pretty soon ... as some vendors define their
> leak policy as prefix, lists and some others call into execution of a
> policy language.
>
> Right, the issue with policy is more global rather than just an ISIS issue
> ... it's not really my priority for now ...
>
>
> Stephane
>
>
> that one might get hairy pretty soon ... as some vendors define their leak
> policy as prefix, lists and some others call into execution of a policy
> language.
>
>
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez
> recu ce message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration,
> This message and its attachments may contain confidential or privileged
> information that may be protected by law;
> _______________________________________________
> Isis-wg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/isis-wg
>

---

From: Chris Bowers <[email-masked]>
Date: Tue, 29 Jul 2014 20:37:37 +0000

Stephane,

I agree with Alia that we should find the common information between ISIS and OSPF were it exists.

As a concrete example, maximum link bandwidth, maximum reservable bandwidth, and unreserved bandwidth refer to the same information independent of whether it is carried via ISIS, OSPF, or BGP-LS.  It doesn’t seem that we should be create three parallel data models to describe the same information three times.

Chris

From: Isis-wg [mailto:[email-masked]] On Behalf Of Alia Atlas
Sent: Tuesday, July 29, 2014 3:42 PM
To: Stephane Litkowski
Cc: Hannes Gredler; Wunan (Eric); [email-masked]
Subject: Re: [Isis-wg] comments on draft-litkowski-isis-yang-isis-cfg-01

Hi Stephane,
On Tue, Jul 29, 2014 at 4:04 AM, <[email-masked]<mailto:[email-masked]>> wrote:
Hi Hannes,

Is there a reason not to look for common groups of information where we can?  I wouldn't necessarily go for augmenting but for a common group that both ISIS and OSPF could include.

Alia

Stephane

-----Original Message-----
From: Hannes Gredler [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Monday, July 28, 2014 17:39
To: Wunan (Eric)
Cc: LITKOWSKI Stephane SCE/IBNF; [email-masked]<mailto:[email-masked]>
Subject: Re: [Isis-wg] comments on draft-litkowski-isis-yang-isis-cfg-01

hi eric, stephane,

[ ... ]

/hannes

[email-masked]<mailto:[email-masked]>

---

From: <[email-masked]>
Date: Wed, 30 Jul 2014 11:14:32 +0000

Hi, (adding Derek & Jeffrey)

I agree that from a theorical point of view that would be great.
By experience, it’s really hard to find the good tradeoff in term of dependencies of components, and define where we should stop in term of trying to aggregate things.
We had this discussion last week with Derek, Jeffrey, Hannes, Les and Lada, and even if there was an interest raised during the discussion for a “superset” IGP LS model (common modeling topology, …), there was also some complexity that might be introduced : so we decided at least for the moment to work on parallel and flat models.

I think at this point of the model definition this is still the good approach. Let’s finish this work, and as OSPF and ISIS model are maintained by the same core set of people, alignment will be guaranteed. When models will be almost finished, we will be able to decide if some superset models or common augmentations can be used to simplify future extensions.

Thoughts ?

From: Chris Bowers [mailto:[email-masked]]
Sent: Tuesday, July 29, 2014 22:38
To: Alia Atlas; LITKOWSKI Stephane SCE/IBNF
Cc: Hannes Gredler; Wunan (Eric); [email-masked]
Subject: RE: [Isis-wg] comments on draft-litkowski-isis-yang-isis-cfg-01

Stephane,

Chris

From: Isis-wg [mailto:[email-masked]] On Behalf Of Alia Atlas
Sent: Tuesday, July 29, 2014 3:42 PM
To: Stephane Litkowski
Cc: Hannes Gredler; Wunan (Eric); [email-masked]<mailto:[email-masked]>
Subject: Re: [Isis-wg] comments on draft-litkowski-isis-yang-isis-cfg-01

Hi Stephane,

Alia

Stephane

-----Original Message-----
From: Hannes Gredler [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Monday, July 28, 2014 17:39
To: Wunan (Eric)
Cc: LITKOWSKI Stephane SCE/IBNF; [email-masked]<mailto:[email-masked]>
Subject: Re: [Isis-wg] comments on draft-litkowski-isis-yang-isis-cfg-01

hi eric, stephane,

[ ... ]

/hannes

---

From: "Osborne, Eric" <[email-masked]>
Date: Wed, 30 Jul 2014 11:30:27 +0000

I’m jumping into this kinda late, so forgive me.  And of course I missed the conversation in Toronto so I’m not sure what the strong argument was for progressing this as what sounds like three separate implementations.

“Let’s finish this work, and as OSPF and ISIS model are maintained by the same core set of people, alignment will be guaranteed.”

Not to be a naysayer, but I’m skeptical that ‘guarantee’ will actually work without some teeth behind it.  Is there a framework doc or something that says “one of the goals of any model is to reuse parts from other models”, or maybe something scoped to just link-state routing or TE that says “you MUST reuse what is common”?  Without that, I’m afraid ‘guarantee’ will turn into ‘well, we tried but we gave up’.

That said, perhaps a path to homogeny is to work on three separate models in order to see what can be reused; make the three models throwaway work, at least as far as TE goes.  Does that work?

eric

From: Isis-wg [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, July 30, 2014 7:15 AM
To: Chris Bowers; Alia Atlas; Derek Man-Kit Yeung (myeung) ([email-masked]); Jeffrey (Zhaohui) Zhang ([email-masked])
Cc: Hannes Gredler; Wunan (Eric); [email-masked]
Subject: Re: [Isis-wg] comments on draft-litkowski-isis-yang-isis-cfg-01

Thoughts ?

Stephane,

Chris

Hi Stephane,

Alia

Stephane

-----Original Message-----
From: Hannes Gredler [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Monday, July 28, 2014 17:39
To: Wunan (Eric)
Cc: LITKOWSKI Stephane SCE/IBNF; [email-masked]<mailto:[email-masked]>
Subject: Re: [Isis-wg] comments on draft-litkowski-isis-yang-isis-cfg-01

hi eric, stephane,

[ ... ]

/hannes

Thank you.

---

From: "Osborne, Eric" <[email-masked]>
Date: Wed, 30 Jul 2014 13:52:43 +0000

[trimmed to get under size limit]

I just skimmed rfc6087 and it didn’t talk about this sort of thing.  I think it might be nice for netmod to do (I’ll start a separate thread over there).  It’s not because I want to be pedantic about TE models.  If YANG takes off and we don’t have some guidelines that strongly recommend reuse, we’ll end up with a very wide, flat model space with minute differences between models.

eric

From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, July 30, 2014 9:45 AM
To: Osborne, Eric; Chris Bowers; Alia Atlas; Derek Man-Kit Yeung (myeung) ([email-masked]); Jeffrey (Zhaohui) Zhang ([email-masked])
Cc: Hannes Gredler; Wunan (Eric); [email-masked]; Ladislav Lhotka ([email-masked])
Subject: RE: [Isis-wg] comments on draft-litkowski-isis-yang-isis-cfg-01

“one of the goals of any model is to reuse parts from other models”

Ø  I’m not aware of any sort of design model for the routing part … expect that it must be aligned with the core routing model. Maybe some Yang doctor’s have another view …

Yang model definition is just starting … it’s time to define such constraint if it does not exist

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Wed, 30 Jul 2014 12:47:18 +0000

Stephane,

My impression of that discussion about using a common node/group for IGPs to augment/use was not about some things that are really homogeneous.

We did not discuss TE stuff (perhaps except the fact that it was missing). It may be possible to define a common TE node/group under rt:routing-protocols for OSPF/ISIS/BGP-LS to augment/use.

Jeffrey

To: Chris Bowers; Alia Atlas; Derek Man-Kit Yeung (myeung) ([email-masked]); Jeffrey (Zhaohui) Zhang

Thoughts ?

Stephane,

Chris

Hi Stephane,

Alia

Stephane

-----Original Message-----
From: Hannes Gredler [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Monday, July 28, 2014 17:39
To: Wunan (Eric)
Cc: LITKOWSKI Stephane SCE/IBNF; [email-masked]<mailto:[email-masked]>
Subject: Re: [Isis-wg] comments on draft-litkowski-isis-yang-isis-cfg-01

hi eric, stephane,

[ ... ]

/hannes

Thank you.

---

From: <[email-masked]>
Date: Wed, 30 Jul 2014 13:34:47 +0000

We did not talk explicitly about TE stuffs but more general parameters that are common to both IGP and that may be part of a superset IGP model.

I’m still open to have something hierarchical or using augmentations for common parameters but we need to agree on the scope.

From: Jeffrey (Zhaohui) Zhang [mailto:[email-masked]]
Sent: Wednesday, July 30, 2014 14:47
To: LITKOWSKI Stephane SCE/IBNF; Chris Bowers; Alia Atlas; Derek Man-Kit Yeung (myeung) ([email-masked])
Cc: Hannes Gredler; Wunan (Eric); [email-masked]
Subject: RE: [Isis-wg] comments on draft-litkowski-isis-yang-isis-cfg-01

Stephane,

Jeffrey

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Wednesday, July 30, 2014 7:15 AM
To: Chris Bowers; Alia Atlas; Derek Man-Kit Yeung (myeung) ([email-masked]<mailto:[email-masked]>); Jeffrey (Zhaohui) Zhang
Cc: Hannes Gredler; Wunan (Eric); [email-masked]<mailto:[email-masked]>
Subject: RE: [Isis-wg] comments on draft-litkowski-isis-yang-isis-cfg-01

Thoughts ?

Stephane,

Chris

Hi Stephane,

Alia

Stephane

-----Original Message-----
From: Hannes Gredler [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Monday, July 28, 2014 17:39
To: Wunan (Eric)
Cc: LITKOWSKI Stephane SCE/IBNF; [email-masked]<mailto:[email-masked]>
Subject: Re: [Isis-wg] comments on draft-litkowski-isis-yang-isis-cfg-01

hi eric, stephane,

[ ... ]

/hannes

Thank you.

---

From: <[email-masked]>
Date: Wed, 30 Jul 2014 13:45:00 +0000

From: Osborne, Eric [mailto:[email-masked]]
Sent: Wednesday, July 30, 2014 13:30
To: LITKOWSKI Stephane SCE/IBNF; Chris Bowers; Alia Atlas; Derek Man-Kit Yeung (myeung) ([email-masked]); Jeffrey (Zhaohui) Zhang ([email-masked])
Cc: Hannes Gredler; Wunan (Eric); [email-masked]
Subject: RE: [Isis-wg] comments on draft-litkowski-isis-yang-isis-cfg-01

eric

From: Isis-wg [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Wednesday, July 30, 2014 7:15 AM
To: Chris Bowers; Alia Atlas; Derek Man-Kit Yeung (myeung) ([email-masked]<mailto:[email-masked]>); Jeffrey (Zhaohui) Zhang ([email-masked]<mailto:[email-masked]>)
Cc: Hannes Gredler; Wunan (Eric); [email-masked]<mailto:[email-masked]>
Subject: Re: [Isis-wg] comments on draft-litkowski-isis-yang-isis-cfg-01

Thoughts ?

Stephane,

Chris

Hi Stephane,

Alia

Stephane

-----Original Message-----
From: Hannes Gredler [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Monday, July 28, 2014 17:39
To: Wunan (Eric)
Cc: LITKOWSKI Stephane SCE/IBNF; [email-masked]<mailto:[email-masked]>
Subject: Re: [Isis-wg] comments on draft-litkowski-isis-yang-isis-cfg-01

hi eric, stephane,

[ ... ]

/hannes

Thank you.