Subject: Re: [Isis-wg] Gen-art LC review draft-ietf-isis-tlv-codepoints-00

From: Jari Arkko <[email-masked]>
Date: Thu, 7 Aug 2014 13:21:37 +1200

Thank you very much for your review, Robert.

>>>>> 
>>>>> Thanks for assembling such a clearly written document.
>>>>> 
>>>>> The shepherd writeup should have discussed _why_ this document is
>>>>> intended for Proposed Standard.
>>>>> There is no protocol definition here, and nothing to progress on the
>>>>> standards ladder. This is, instead,
>>>>> primarily defining process. Why isn't this being progressed as a BCP?
>>>> The document does two things:
>>>> 
>>>> 1)It updates some registries for sub-TLVs defined at
>>> http://www.iana.org/assignments/isis-tlv-codepoints/isis-tlv-
>>> codepoints.xhtml
>>>> As these changes are modifying the format (not the content) of registries
>>> used by a number of standards track RFCs it needs to be a standards track
>>> document.
>>> I don't believe that follows. A BCP could update these documents as well.
>> The registries define the codepoints which are sent on the wire by IS-IS implementations. This is absolutely essential for interoperability. I fail to follow your reasoning that a change to such a registry falls into the BCP bucket.
>> 
>> That said, I don't really care about the category - my goal in writing this draft is to satisfy the process requirements to get what amount to editorial changes to the registry done. In this matter I am happy to follow the recommendations from IANA/IESG, Gen-ART, etc. So let's not argue - rather please build consensus with your peers in IANA/IESG as well as the ADs and I will happily agree so long as it accomplishes the original goal.
> Yes - the IESG can steer this at this point.

With regards to the document-as-ps issue, I think we can observe that new or changed IANA considerations have been done under various document classifications. I personally can not get worked over whether this is a BCP or a PS, albeit, as Pete notes, "Slightly weird to have this be Standards Track.”. I think having the texts clarified as Adrian suggested in his Discuss is probably the most worthwhile thing we can do here.

jari

---

From: Jari Arkko <[email-masked]>
Date: Thu, 7 Aug 2014 13:24:08 +1200

(Resending due to incorrect e-mail address - please respond to this instead.)

jari