Subject: [Isis-wg] draft-psarkar-isis-node-admin-tag-02 WG acceptance

From: Hannes Gredler <[email-masked]>
Date: Mon, 29 Sep 2014 11:00:43 +0200

fellow ISIS-WG,

The authors have requested ISIS-WG draft-psarkar-isis-node-admin-tag-02
as a working group document.

note there has been already a decent level of discussion around applicability and use
on the OSPF-WG mailing list. please see:

  http://www.ietf.org/mail-archive/web/ospf/current/maillist.html
  grep for 'WG adoption of draft-hegde-ospf-node-admin-tag'

please state support/no-support.

thanks,

hannes & chris

---

From: <[email-masked]>
Date: Mon, 29 Sep 2014 12:56:56 +0000

Hi Hannes, all

I support adoption of draft-psarkar-isis-node-admin-tag-02.

This is useful for network operator to express policy based on node capabilities/performance/roles (e.g. PE/P/ASBR/BNG, access/aggregation/POP/Core, odd/even.).
In particular I support uses cases 2, 3 and TE/explicit routing policy (a la CSPF excluding "even" or "ASBR" nodes, in particular in the SPRING context).

Thanks,
Bruno

> From Hannes  Gredler  Sent: Monday, September 29, 2014 11:01 AM
> fellow ISIS-WG,
> 
> note there has been already a decent level of discussion around applicability
> and use on the OSPF-WG mailing list. please see:
> 
> _______________________________________________
> Isis-wg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/isis-wg

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Mon, 29 Sep 2014 16:24:47 +0000

I support making this a WG document - but I have the same concern which I previously expressed regarding the companion OSPF document i.e. a much more complete discussion regarding the tradeoffs between using node tags vs capability identifiers needs to be included .

As Hannes has referenced there has been a lively discussion of this point on the OSPF-WG list - all of which I think is applicable to the IS-IS draft. It would be good if any discussion of that issue in the future was copied to both lists.

Also, I would prefer that the Applications content which is found in Section 5 of http://www.ietf.org/id/draft-hegde-ospf-node-admin-tag-02.txt be repeated in the IS-IS draft rather than referenced.

   Les

> -----Original Message-----
> From: Isis-wg [mailto:[email-masked]] On Behalf Of Hannes
> Gredler
> Sent: Monday, September 29, 2014 2:01 AM
> To: [email-masked] list
> Cc: [email-masked]; Christian Hopps
> Subject: [Isis-wg] draft-psarkar-isis-node-admin-tag-02 WG acceptance
> 
> fellow ISIS-WG,
>

---

From: Uma Chunduri <[email-masked]>
Date: Mon, 29 Sep 2014 17:43:22 +0000

Support.

Application of node tags can be very interesting and could be creative to exercise different operator policies.

One small comment- 
IMO, granularity of the tag per topology/AF can be useful in MT deployments. Authors may  think over on this.

--
Uma C.

-----Original Message-----
From: Isis-wg [mailto:[email-masked]] On Behalf Of Hannes Gredler
Sent: Monday, September 29, 2014 2:01 AM
To: [email-masked] list
Cc: [email-masked]; Christian Hopps
Subject: [Isis-wg] draft-psarkar-isis-node-admin-tag-02 WG acceptance

fellow ISIS-WG,

note there has been already a decent level of discussion around applicability and use on the OSPF-WG mailing list. please see:

thanks,

hannes & chris

---

From: Dhruv Dhody <[email-masked]>
Date: Tue, 30 Sep 2014 07:18:15 +0530

Hi All,

Support moving this work along.

Similar to the ospf draft[1], I have following comment...

Explicit text should be added for -
- Minimum one tag must be present in the 'Per-node Admin Tag' sub-TLV
- What happens if the implementation does not know the Interpretation
of the tag value
- No IANA registry is required to store the meaning or interpretation
of.the tag values.
- Backward compatibility behavior  - unknown sub-TLV

Nits
- Remove reference from abstract for [ISO10589],[RFC1195]
- space between 'of' and 'the' is missing in "...grouping ofthe nodes
in an IS-IS domain..."
- expand LFA,TE, on first use

Regards,
Dhruv

[1] http://www.ietf.org/mail-archive/web/ospf/current/msg07118.html