Subject: Re: [Isis-wg] draft-psarkar-isis-node-admin-tag-02 WG acceptance

From: Pushpasis Sarkar <[email-masked]>
Date: Wed, 1 Oct 2014 16:22:09 +0000

Hi Les,

Thanks for the support. Please find few comments inline.

Regards,
-Pushpasis

On 9/29/14, 9:54 PM, "Les Ginsberg (ginsberg)" <[email-masked]> wrote:

>I support making this a WG document - but I have the same concern which I
>previously expressed regarding the companion OSPF document i.e. a much
>more complete discussion regarding the tradeoffs between using node tags
>vs capability identifiers needs to be included .
[PS] IMO, defining capabilities will restrict the usage of node-admin-tags
to a finite number of use cases (as there can be only finite number of
capability definitions). We would not prefer to do that. We would prefer
the operators to use the node-admin-tags in as many number of use cases as
they want to. This way a node can be part of as many groups as the number
of values a 32-bit unsigned integer can generate. And the same
node-admin-tag value can be used for identifying groups by different
operators with different purpose in their own networks.

>
>As Hannes has referenced there has been a lively discussion of this point
>on the OSPF-WG list - all of which I think is applicable to the IS-IS
>draft. It would be good if any discussion of that issue in the future was
>copied to both lists.
>
>Also, I would prefer that the Applications content which is found in
>Section 5 of 
>http://www.ietf.org/id/draft-hegde-ospf-node-admin-tag-02.txt be repeated
>in the IS-IS draft rather than referenced.
[PS] IMO, it does not make sense to duplicate text from the OSPF draft.
But then I am speaking more from a software developers perspective :)

>
>   Les
>
>
>> -----Original Message-----
>> From: Isis-wg [mailto:[email-masked]] On Behalf Of Hannes
>> Gredler
>> Sent: Monday, September 29, 2014 2:01 AM
>> To: [email-masked] list
>> Cc: [email-masked]; Christian Hopps
>> Subject: [Isis-wg] draft-psarkar-isis-node-admin-tag-02 WG acceptance
>> 
>> fellow ISIS-WG,
>> 
>> The authors have requested ISIS-WG draft-psarkar-isis-node-admin-tag-02
>> as a working group document.
>> 
>> note there has been already a decent level of discussion around
>> applicability and use
>> on the OSPF-WG mailing list. please see:
>> 
>>   http://www.ietf.org/mail-archive/web/ospf/current/maillist.html
>>   grep for 'WG adoption of draft-hegde-ospf-node-admin-tag'
>> 
>> please state support/no-support.
>> 
>> thanks,
>> 
>> hannes & chris
>> 
>> _______________________________________________
>> Isis-wg mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/isis-wg

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Wed, 1 Oct 2014 17:39:11 +0000

Pushpasis -

I am not suggesting that there should be a limit to how many use cases evolve for node admin tags. I am saying with the introduction of node admin tags there are now two ways for a new capability to be advertised. There needs to be guidance as to when it is appropriate to use node admin tags and when it is appropriate to use Router Capabilities. Remaining silent on this subject means that whenever some new use case is proposed we will have to have this discussion over and over again and we will have no guidelines to provide consistency. Unless you intend to eliminate ALL new uses of Router Capability I think this is an issue which cannot be ignored.

There have been some suggestions put forward in the discussion of the companion OSPF draft which may serve as a starting point. I do think this is something that future versions of the draft MUST address.

   Les

> From: Pushpasis Sarkar [mailto:[email-masked]]
> Sent: Wednesday, October 01, 2014 9:22 AM
> To: Les Ginsberg (ginsberg); Hannes Gredler; [email-masked] list
> Subject: Re: [Isis-wg] draft-psarkar-isis-node-admin-tag-02 WG acceptance
> 
> Hi Les,
>

---

From: <[email-masked]>
Date: Thu, 2 Oct 2014 13:56:14 +0000

Hi Les,

I agree with your point that there could be a side effect of using tags to handle router capabilities even if the purpose is not this one for sure.
Node tags are only defining node administrative property and not any node capability related to an ISIS feature. 
It might be useful to add such precision in the draft.

Brgds,

Stephane

-----Original Message-----
From: Isis-wg [mailto:[email-masked]] On Behalf Of Les Ginsberg (ginsberg)
Sent: Wednesday, October 01, 2014 19:39
To: Pushpasis Sarkar; Hannes Gredler; [email-masked] list
Cc: [email-masked]; Christian Hopps
Subject: Re: [Isis-wg] draft-psarkar-isis-node-admin-tag-02 WG acceptance

Pushpasis -

   Les

> >I support making this a WG document - but I have the same concern 
> >which I previously expressed regarding the companion OSPF document 
> >i.e. a much more complete discussion regarding the tradeoffs between 
> >using node
> tags
> [PS] IMO, defining capabilities will restrict the usage of 
> node-admin-tags to a finite number of use cases (as there can be only 
> finite number of capability definitions). We would not prefer to do 
> that. We would prefer the operators to use the node-admin-tags in as 
> many number of use cases as they want to. This way a node can be part 
> of as many groups as the number of values a 32-bit unsigned integer 
> can generate. And the same node-admin-tag value can be used for 
> identifying groups by different operators with different purpose in 
> their own networks.
> 
> >
> >As Hannes has referenced there has been a lively discussion of this 
> >point on the OSPF-WG list - all of which I think is applicable to the 
> >IS-IS draft. It would be good if any discussion of that issue in the 
> >future was copied to both lists.
> >
> >> The authors have requested ISIS-WG 
> >> draft-psarkar-isis-node-admin-tag-
> 02
> >> applicability and use on the OSPF-WG mailing list. please see:
> >>

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Shraddha Hegde <[email-masked]>
Date: Wed, 1 Oct 2014 17:55:03 +0000

Hi Les,

In OSPF WG, majority opinion was to use Router capability for well known applications and keep the node-admin tag generic which does not need
Any IANA registry. 

Both ISIS and OSPF drafts can be updated to capture this information explicitly.

Rgds
Shraddha

-----Original Message-----
From: Les Ginsberg (ginsberg) [mailto:[email-masked]] 
Sent: Wednesday, October 01, 2014 11:09 PM
To: Pushpasis Sarkar; Hannes Gredler; [email-masked] list
Cc: [email-masked]; Christian Hopps
Subject: RE: [Isis-wg] draft-psarkar-isis-node-admin-tag-02 WG acceptance

Pushpasis -

   Les

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 3 Oct 2014 16:35:31 +0000

Hi Shraddha, 
I think this is good option. 
Thanks,
Acee