Subject: [Isis-wg] FW: New Version Notification for draft-ginsberg-isis-prefix-attributes-00.txt

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Mon, 6 Oct 2014 23:46:13 +0000

This draft should be of interest to the WG.

   Les

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, October 06, 2014 4:45 PM
To: Stefano Previdi (sprevidi); Bruno Decraene; Clarence Filsfils; Les Ginsberg (ginsberg); Bruno Decraene; Stephane Litkowski; Clarence Filsfils; Stefano Previdi (sprevidi); Les Ginsberg (ginsberg); Stephane Litkowski
Subject: New Version Notification for draft-ginsberg-isis-prefix-attributes-00.txt

A new version of I-D, draft-ginsberg-isis-prefix-attributes-00.txt
has been successfully submitted by Les Ginsberg and posted to the
IETF repository.

Name:		draft-ginsberg-isis-prefix-attributes
Revision:	00
Title:		IS-IS Prefix Attributes for Extended IP and IPv6 Reachability
Document date:	2014-10-06
Group:		Individual Submission
Pages:		7
URL:            http://www.ietf.org/internet-drafts/draft-ginsberg-isis-prefix-attributes-00.txt
Status:         https://datatracker.ietf.org/doc/draft-ginsberg-isis-prefix-attributes/
Htmlized:       http://tools.ietf.org/html/draft-ginsberg-isis-prefix-attributes-00

Abstract:
   This document introduces new sub-TLVs to support advertisement of
   prefix attribute flags and the source router id of the router which
   originated a prefix advertisement.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Uma Chunduri <[email-masked]>
Date: Tue, 7 Oct 2014 02:34:22 +0000

Dear Les and Authors,

Did a quick review and it's a very useful draft. Thx.

I see some of the flags are from SR IS-IS extensions, specifically for prefix-SID (right?) and 
I like generalization of these to 135/235/236/237.

Though we can use ADJ SID for a tunnel terminating on a particular interface  (in some existing RSVP scenarios),
relaxing N flag for indicating interface address could  be very useful (non-loopbacks basically).

--
Uma C.

-----Original Message-----
From: Isis-wg [mailto:[email-masked]] On Behalf Of Les Ginsberg (ginsberg)
Sent: Monday, October 06, 2014 4:46 PM
To: [email-masked]
Subject: [Isis-wg] FW: New Version Notification for draft-ginsberg-isis-prefix-attributes-00.txt

   Les

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, October 06, 2014 4:45 PM
To: Stefano Previdi (sprevidi); Bruno Decraene; Clarence Filsfils; Les Ginsberg (ginsberg); Bruno Decraene; Stephane Litkowski; Clarence Filsfils; Stefano Previdi (sprevidi); Les Ginsberg (ginsberg); Stephane Litkowski
Subject: New Version Notification for draft-ginsberg-isis-prefix-attributes-00.txt

Abstract:

The IETF Secretariat

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/isis-wg

---

From: Xuxiaohu <[email-masked]>
Date: Wed, 8 Oct 2014 08:07:46 +0000

Hi Les,

I have read this draft and felt that the description of the use cases is not much clear. For instance, it said "There are existing use cases in which knowing additional attributes of a prefix is useful.  For example, it is useful to know whether an advertised prefix is directly connected to the advertising router or not.  In the case of [SR] knowing whether a prefix is directly connected or not determines what action should be taken as regards processing of labels associated with an incoming packet..."  Would you please further point to the exact place of the referenced SR draft (draft-ietf-isis-segment-routing-extensions-02) where it said that it's useful to know whether an advertised prefix is directly connected to the advertising router or not. Similarly, it would be better if you could give a more concrete use case where it is useful to know the source of a prefix advertisement when the advertisement has been leaked to another level. 

Best regards,
Xiaohu

> Sent: Tuesday, October 07, 2014 7:46 AM
> To: [email-masked]
> Subject: [Isis-wg] FW: New Version Notification for
> draft-ginsberg-isis-prefix-attributes-00.txt
> 
> To: Stefano Previdi (sprevidi); Bruno Decraene; Clarence Filsfils; Les Ginsberg
> (ginsberg); Bruno Decraene; Stephane Litkowski; Clarence Filsfils; Stefano
> Previdi (sprevidi); Les Ginsberg (ginsberg); Stephane Litkowski
> URL:
> http://www.ietf.org/internet-drafts/draft-ginsberg-isis-prefix-attributes-00.txt
> Status:
> https://datatracker.ietf.org/doc/draft-ginsberg-isis-prefix-attributes/
> Htmlized:
> http://tools.ietf.org/html/draft-ginsberg-isis-prefix-attributes-00
> 
> 
> Abstract:

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Thu, 9 Oct 2014 13:50:37 +0000

Xiaohu -

Please read the description of the P-flag in Sections 2.1 and 2.1.1 of http://www.ietf.org/id/draft-ietf-isis-segment-routing-extensions-02.txt

   Les

> From: Xuxiaohu [mailto:[email-masked]]
> Sent: Wednesday, October 08, 2014 1:08 AM
> To: Les Ginsberg (ginsberg); [email-masked]
> Subject: RE: New Version Notification for draft-ginsberg-isis-prefix-
> attributes-00.txt
> 
> Hi Les,
> 
> I have read this draft and felt that the description of the use cases is not
> much clear. For instance, it said "There are existing use cases in which
> knowing additional attributes of a prefix is useful.  For example, it is useful
> to know whether an advertised prefix is directly connected to the
> advertising router or not.  In the case of [SR] knowing whether a prefix is
> directly connected or not determines what action should be taken as
> regards processing of labels associated with an incoming packet..."  Would
> you please further point to the exact place of the referenced SR draft (draft-
> ietf-isis-segment-routing-extensions-02) where it said that it's useful to
> know whether an advertised prefix is directly connected to the advertising
> router or not. Similarly, it would be better if you could give a more concrete
> use case where it is useful to know the source of a prefix advertisement
> when the advertisement has been leaked to another level.
> 
> Best regards,
> Xiaohu
> 
> 
> 
> > From: Isis-wg [mailto:[email-masked]] On Behalf Of Les
> Ginsberg
> > (ginsberg)

---

From: Xuxiaohu <[email-masked]>
Date: Sat, 11 Oct 2014 03:45:27 +0000

Hi Les,

If I understand the P-flag correctly, it is specific to those sub-TLVs which is used for label/index advertisements, rather than to the reachability TLVs. As for how to determine whether a given node is a penultimate hop, it has been well addressed by the routable IP address sub-TLVs as defined in (https://tools.ietf.org/html/draft-xu-isis-routable-ip-address-01). Don't you think so?

Best regards,
Xiaohu

> From: Les Ginsberg (ginsberg) [mailto:[email-masked]]
> Sent: Thursday, October 09, 2014 9:51 PM
> To: Xuxiaohu; [email-masked]
> Subject: RE: New Version Notification for
> Please read the description of the P-flag in Sections 2.1 and 2.1.1 of
> http://www.ietf.org/id/draft-ietf-isis-segment-routing-extensions-02.txt

> > I have read this draft and felt that the description of the use cases
> > is not much clear. For instance, it said "There are existing use cases
> > in which knowing additional attributes of a prefix is useful.  For
> > example, it is useful to know whether an advertised prefix is directly
> > connected to the advertising router or not.  In the case of [SR]
> > knowing whether a prefix is directly connected or not determines what
> > action should be taken as regards processing of labels associated with
> > an incoming packet..."  Would you please further point to the exact
> > place of the referenced SR draft (draft-
> > ietf-isis-segment-routing-extensions-02) where it said that it's
> > useful to know whether an advertised prefix is directly connected to
> > the advertising router or not. Similarly, it would be better if you
> > could give a more concrete use case where it is useful to know the
> > source of a prefix advertisement when the advertisement has been leaked to
> another level.
> >
> > Best regards,
> > Xiaohu
> >
> >
> >
> > > To: Stefano Previdi (sprevidi); Bruno Decraene; Clarence Filsfils;
> > > Les
> > Ginsberg
> > > (ginsberg); Bruno Decraene; Stephane Litkowski; Clarence Filsfils;
> > > Stefano Previdi (sprevidi); Les Ginsberg (ginsberg); Stephane
> > > Litkowski
> > > Subject: New Version Notification for
> > > http://www.ietf.org/internet-drafts/draft-ginsberg-isis-prefix-attri
> > > butes-
> > 00.txt
> > > Status:

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Sun, 12 Oct 2014 20:32:33 +0000

Xiaohu -

You asked

"Would you please further point to the exact
> > > the advertising router or not"

I believe that question has been answered.

Using the functionality defined in the prefix-attributes draft note the following:

  o If the N flag is set and the R and X flags are NOT set then the advertisement is for a directly connected address local to the advertising router - there is no need to also include the source Router ID - which allows a more efficient encoding in these cases. 
  o In cases where the prefix has been leaked from one level to another, the presence of the source Router ID is also required. 
  o The use of Reachability TLVs to carry this information also allows topology specific node addresses to be advertised if desired.
  o Once prefix attribute support has been deployed there is no need for the P-flag - this can be deprecated.

It is true that draft-xu-isis-routable-ip-address-01 defines another way to advertise the source of a directly connected advertisement, but it is not as flexible nor as efficient in its encoding (in some cases) as the definition in the prefix-attributes draft. 

   Les

> Sent: Friday, October 10, 2014 8:45 PM
> If I understand the P-flag correctly, it is specific to those sub-TLVs which is
> used for label/index advertisements, rather than to the reachability TLVs.
> As for how to determine whether a given node is a penultimate hop, it has
> been well addressed by the routable IP address sub-TLVs as defined in
> (https://tools.ietf.org/html/draft-xu-isis-routable-ip-address-01). Don't you
> think so?
> 
> Best regards,
> Xiaohu
>