Subject: [Isis-wg] WG Draft QA review of draft-ginsberg-isis-route-preference-00.txt

From: Mike Shand <[email-masked]>
Date: Fri, 03 Oct 2014 15:48:29 +0100

Hello,

I have been selected as the Routing Directorate QA reviewer for 
draft-ginsberg-isis-route-preference-00.txt

The Routing Directorate QA reviews are intended to be a support to 
improve the quality of RTG Area documents as they pass through the IETF 
process. This is the QA review at the time of wg document adoption poll.

    Summary

This document serves a useful purpose in clarifying the existing 
confusion, and potential interoperability issues, caused by the 
piecemeal introduction over a period of time, with varying degrees of 
rigour, of various uses for route preferences. As such it seems a good 
candidate for adoption as a WG document.

My slight concern is how we manage the process of ensuring that people 
referencing RFC5302, 5 and 8 are correctly directed to this document and 
understand where this document overrides requirements in the earlier 
documents and where it merely clarifies,  given the mixture of 
clarifications and correction that it contains.

    Comments

 From a technical point of view I find the document ready to be adopted 
as a working group document.

I'm wondering whether a tabular form of presentation might be easier to 
assimilate than the rather verbose and repetitive textual descriptions.

e.g.

type | L1/L2 LSP | TLV |up/down bit | Extern bit | comments

L1 intra-area routes | 236/237 | L1 | 0 | 0 | These IPv6 prefixes are directly connected to the advertising router.

    Major Issues

No major issues found.

    Minor Issues

Route preferences. Does it need to be specified that the route 
preferences are listed in order of most preferred first, just to be 
absolutely clear?

    Nits

There is inconsistency between the use of "zero" and "0" and between 
"one" and "1".

Is there a reason why the external bit is spelled with an upper case X 
as  eXternal?

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Fri, 3 Oct 2014 22:16:06 +0000

Mike -

Thanx for the review.
Please see my replies inline.

From: Mike Shand [mailto:[email-masked]]
Sent: Friday, October 03, 2014 7:48 AM
To: [email-masked]; [email-masked]; Les Ginsberg (ginsberg); [email-masked]; Stefano Previdi (sprevidi)
Subject: WG Draft QA review of draft-ginsberg-isis-route-preference-00.txt

Hello,

I have been selected as the Routing Directorate QA reviewer for draft-ginsberg-isis-route-preference-00.txt

The Routing Directorate QA reviews are intended to be a support to improve the quality of RTG Area documents as they pass through the IETF process. This is the QA review at the time of wg document adoption poll.

Summary

This document serves a useful purpose in clarifying the existing confusion, and potential interoperability issues, caused by the piecemeal introduction over a period of time, with varying degrees of rigour, of various uses for route preferences. As such it seems a good candidate for adoption as a WG document.

My slight concern is how we manage the process of ensuring that people referencing RFC5302, 5 and 8 are correctly directed to this document and understand where this document overrides requirements in the earlier documents and where it merely clarifies,  given the mixture of clarifications and correction that it contains.

LES: In regards to RFC 5308, this document does correct RFC 5308 so I assume that RFC 5308 Datatracker page would be modifed to say "Updated by route-preference-RFC".

In regards to RFC 5302/5305 we are only clarifying - so "Updated by..." may be a bit misleading. Don't know if there is an option such as "Clarified by..." - so perhaps we can use "Updated by..." and then when folks actually read the route-preference-RFC they will know that it is only a clarification.

Comments

>From a technical point of view I find the document ready to be adopted as a working group document.

I'm wondering whether a tabular form of presentation might be easier to assimilate than the rather verbose and repetitive textual descriptions.

e.g.

LES: The current format follows the format in RFC 5302. This is done for a couple of reasons:

1)It is easier to compare the two documents.

2)I personally feel that RFC 5302 is well written - handling a complex subject with clarity and consistency.

What you suggest could be done but it is not obvious to me whether this would be an improvement or simply a different style. If it is not an improvement then I would prefer to be consistent w RFC 5302. But I would encourage comments from the WG on this point - if there is consensus that the format you suggest is an improvement then we would have a good reason to change the it.

Major Issues

No major issues found.

Minor Issues

Route preferences. Does it need to be specified that the route preferences are listed in order of most preferred first, just to be absolutely clear?

LES: Actually they are not (though it is close :)). For example, L2->L2 inter-area routes are listed last, but they are not the least preferred route type.

Sections 3.3/3.4 are the normative sections on order of preference. I would not want folks to infer a normative behavior from the order of entries in Sections 3.1/3.2 - but we can certainly modify the order in those sections to follow the order of preference if you think it aids clarity.

Nits

There is inconsistency between the use of "zero" and "0" and between "one" and "1".

LES: OK - will fix.

Is there a reason why the external bit is spelled with an upper case X as  eXternal?

LES: Because I didn't want you to miss the "X"? :)

You don't like it??? Happy to change it.

   Les