Subject: Re: [Isis-wg] draft-psarkar-isis-node-admin-tag-02 WG acceptance

From: Pushpasis Sarkar <[email-masked]>
Date: Wed, 1 Oct 2014 15:50:29 +0000

Hi Dhruv,

Thanks a lot for the comments (and off-course for the comments). Will
definitely take care of in the next version. Just wanted clarify the
following pointŠ 

"- What happens if the implementation does not know the Interpretation
of the tag value²

We the co-authors will not like to associate any sort of interpretation
with the 32-bit unsigned integer used as the tag. We would like the
operators to use it to any means they would like to (just like
route-tags). Hence there will be no need for IANA registry allocation for
the same. 

I will add these explicit texts in the next version.

Thanks
-Pushpasis 

On 9/30/14, 7:18 AM, "Dhruv Dhody" <[email-masked]> wrote:

>Hi All,
>
>Support moving this work along.
>
>Similar to the ospf draft[1], I have following comment...
>
>Explicit text should be added for -
>- Minimum one tag must be present in the 'Per-node Admin Tag' sub-TLV
>- What happens if the implementation does not know the Interpretation
>of the tag value
>- No IANA registry is required to store the meaning or interpretation
>of.the tag values.
>- Backward compatibility behavior  - unknown sub-TLV
>
>Nits
>- Remove reference from abstract for [ISO10589],[RFC1195]
>- space between 'of' and 'the' is missing in "...grouping ofthe nodes
>in an IS-IS domain..."
>- expand LFA,TE, on first use
>
>Regards,
>Dhruv
>
>[1] http://www.ietf.org/mail-archive/web/ospf/current/msg07118.html
>
>On Mon, Sep 29, 2014 at 2:30 PM, Hannes Gredler <[email-masked]>
>wrote:
>> fellow ISIS-WG,
>>
>> The authors have requested ISIS-WG draft-psarkar-isis-node-admin-tag-02
>> as a working group document.
>>
>> note there has been already a decent level of discussion around
>>applicability and use
>> on the OSPF-WG mailing list. please see:
>>
>>   http://www.ietf.org/mail-archive/web/ospf/current/maillist.html
>>   grep for 'WG adoption of draft-hegde-ospf-node-admin-tag'
>>
>> please state support/no-support.
>>
>> thanks,
>>
>> hannes & chris
>>
>> _______________________________________________
>> Isis-wg mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/isis-wg

---

From: Dhruv Dhody <[email-masked]>
Date: Thu, 2 Oct 2014 10:19:15 +0530

Hi Pushpasis,

> route-tags). Hence there will be no need for IANA registry allocation for

As noted in my mail, I agree with that!
But my intention with top statement was to add text which suggest the
'behavior' - when a node doesn't know what the received tag means?
With "do whatever implementation wants" as a viable option :)

Dhruv