Subject: Re: [Isis-wg] [OSPF] New Version Notification for draft-liang-ospf-flowspec-extensions-01.txt

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Thu, 9 Oct 2014 05:15:14 +0000

Adding the IS-IS WG since there is an equivalent draft for IS-IS submitted by the same authors.

"IF" this were something the respective WGs decide the protocol should support, then running a separate instance of the protocol so that the flowspec  advertisements can be isolated from the primary function of the IGP (routing) would be the right way to implement it - and this is precisely what GENINFO/MI (RFC 6823/6822) were defined to address. OSPF Transport instance would be the analogous mechanism for OSPF.

But the first question is whether this is something the IGPs should support at all. As Acee has indicated this was proposed previously in OSPF and there was little interest. In the case of IS-IS there is even less reason to consider it since IS-IS is NOT deployed as a PE-CE protocol.

   Les

> -----Original Message-----
> From: OSPF [mailto:[email-masked]] On Behalf Of Acee Lindem
> (acee)
> Sent: Wednesday, October 08, 2014 9:36 AM
> To: Peter Psenak (ppsenak)
> Cc: [email-masked]
> Subject: Re: [OSPF] New Version Notification for draft-liang-ospf-flowspec-
> extensions-01.txt
> 
> Hi Peter, et al,
> I’ve also seen many OSPF PE-CE deployments as well. One question is
> whether the CE is under the administrative control of the provider or the
> customer?
> Note that this was proposed at least once before -
> http://www.ietf.org/archive/id/draft-shrivastava-ospf-flow-spec-01.txt bit
> it didn’t gain momentum.
> 
> With respect to Hannes’ comment, Les Ginsberg said he sees this as a
> candidate for the ISIS Generic Information instance (RFC 6823). We could do
> the same and push it to the OSPF transport instance which has also lost
> momentum as a draft.
> 
> We’ve heard from one provider (Eric) who doesn’t think this is useful - any
> other input?
> 
> One thing I hope is that no sees this a generic flow-spec distribution
> mechanism for SDN. The reason being that you really need per peer
> granularity of advertisement and policy, e.g. BGP.
> 
> Thanks,
> Acee
> 
> On Oct 8, 2014, at 12:16 PM, Peter Psenak <[email-masked]> wrote:
> 
> > Hi Eric,
> >
> > there are definitely deployments using OSPF as PE-CE. It's typically used
> for enterprise customers, that use OSPF as their IGP and use L3 VPN service
> to interconnect their sites.
> >
> > thanks,
> > Peter
> >
> > On 10/8/14 17:45 , Osborne, Eric wrote:
> >> I'm not sure this has much value.  The vast majority of dynamic PE-CE is
> done with BGP; the little bit that isn't BGP is, in my experience, RIP.  I don't
> think I've seen many (any?) OSPF PE-CE deployments.
> >>
> >>
> >>
> >>
> >> eric
> >>
> >> -----Original Message-----
> >> From: OSPF [mailto:[email-masked]] On Behalf Of Youjianjie
> >> Sent: Tuesday, October 07, 2014 10:11 PM
> >> To: [email-masked]
> >> Subject: [OSPF] 转发: New Version Notification for draft-liang-ospf-
> flowspec-extensions-01.txt
> >>
> >> Hi all,
> >>
> >> This document discusses the use cases that OSPF is used to distribute
> FlowSpec routes. This document also defines a new OSPF FlowSpec Opaque
> Link State Advertisement (LSA) encoding format.
> >> Your comments are appreciated.
> >>
> >> Best Regards,
> >> Jianjie
> >>
> >> -----邮件原件-----
> >> 发件人: [email-masked] [mailto:[email-masked]]
> >> 发送时间: 2014年9月28日 10:32
> >> 收件人: Youjianjie; Youjianjie; liuweihang; liuweihang
> >> 主题: New Version Notification for draft-liang-ospf-flowspec-
> extensions-01.txt
> >>
> >>
> >> A new version of I-D, draft-liang-ospf-flowspec-extensions-01.txt
> >> has been successfully submitted by Jianjie You and posted to the IETF
> repository.
> >>
> >> Name:		draft-liang-ospf-flowspec-extensions
> >> Revision:	01
> >> Title:		OSPF Extensions for Flow Specification
> >> Document date:	2014-09-27
> >> Group:		Individual Submission
> >> Pages:		11
> >> URL:            http://www.ietf.org/internet-drafts/draft-liang-ospf-
> flowspec-extensions-01.txt
> >> Status:         https://datatracker.ietf.org/doc/draft-liang-ospf-flowspec-
> extensions/
> >> Htmlized:       http://tools.ietf.org/html/draft-liang-ospf-flowspec-
> extensions-01
> >> Diff:           http://www.ietf.org/rfcdiff?url2=draft-liang-ospf-flowspec-
> extensions-01
> >>
> >> Abstract:
> >>    This document discusses the use cases why OSPF (Open Shortest Path
> >>    First) distributing flow specification (FlowSpec) routes is
> >>    necessary.  This document also defines a new OSPF FlowSpec Opaque
> >>    Link State Advertisement (LSA) encoding format that can be used to
> >>    distribute FlowSpec routes.
> >>
> >>    For the network only deploying IGP (Interior Gateway Protocol) (e.g.
> >>    OSPF), it is expected to extend IGP to distribute FlowSpec routes.
> >>    One advantage is to mitigate the impacts of Denial-of-Service (DoS)
> >>    attacks.
> >>
> >>
> >>
> >>
> >>
> >> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at tools.ietf.org.
> >>
> >> The IETF Secretariat
> >>
> >> _______________________________________________
> >> OSPF mailing list
> >> [email-masked]
> >> https://www.ietf.org/mailman/listinfo/ospf
> >> _______________________________________________
> >> OSPF mailing list
> >> [email-masked]
> >> https://www.ietf.org/mailman/listinfo/ospf
> >>
> >
> > _______________________________________________
> > OSPF mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/ospf
> 
> _______________________________________________
> OSPF mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ospf

---

From: Pushpasis Sarkar <[email-masked]>
Date: Thu, 9 Oct 2014 09:31:29 +0000

+1 

The only case of ISIS as PE-CE known so far to me is the ISOVPN
deployments. Don’t see how this proposal add any considerable value.

On 10/9/14, 10:45 AM, "Les Ginsberg (ginsberg)" <[email-masked]> wrote:

>"IF" this were something the respective WGs decide the protocol should
>support, then running a separate instance of the protocol so that the
>flowspec  advertisements can be isolated from the primary function of the
>IGP (routing) would be the right way to implement it - and this is
>precisely what GENINFO/MI (RFC 6823/6822) were defined to address. OSPF
>Transport instance would be the analogous mechanism for OSPF.
>
>But the first question is whether this is something the IGPs should
>support at all. As Acee has indicated this was proposed previously in
>OSPF and there was little interest. In the case of IS-IS there is even
>less reason to consider it since IS-IS is NOT deployed as a PE-CE
>protocol.
>
>   Les
>
>
>> >> Status:      
>>https://datatracker.ietf.org/doc/draft-liang-ospf-flowspec-
>> extensions/
>> >> Diff:        
>>http://www.ietf.org/rfcdiff?url2=draft-liang-ospf-flowspec-
>> extensions-01
>> >>
>> >> Abstract:
>Isis-wg mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/isis-wg